I always forget about __init__.py
[plnode-utils.git] / plnode-utils-lxc.spec
1 %define name plnode-utils
2 %define version 0.2
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: Python utilities for a PlanetLab node
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Libraries
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: bwlimit
22
23 %description
24 This python package provides utilities like bwlimit, used in various places on a PlanetLab node, nodemanager and mom among others. It aims at cleaning up the packaging scheme, as bwlimit used to ship with util-vserver-pl, but is relevant in the lxc variant as well.
25
26 %prep
27 %setup -q
28
29 %build
30 # xxx fixme
31 # this is where we chose which flavour of bwlimit gets shipped
32 cp plnode/bwlimit_lxc.py plnode/bwlimit.py
33 python setup.py build
34
35 %install
36 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %{python_sitelib}/*
43 %{_bindir}
44
45 %changelog