1 Summary: OpenCloud core services
6 Group: Development/Tools
7 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
10 requires: postgresql-server
11 requires: python-psycopg2
13 requires: graphviz-devel
14 requires: graphviz-python
15 requires: libxslt-devel
19 requires: python-httplib2
33 pip-python install django==1.7
34 pip-python install djangorestframework
35 pip-python install markdown # Markdown support for the browseable API.
36 pip-python install pyyaml # YAML content-type support.
37 pip-python install django-filter # Filtering support
38 pip-python install lxml # XML manipulation library
39 pip-python install netaddr # IP Addr library
40 pip-python install pytz
41 pip-python install django-timezones
42 pip-python install requests
43 pip-python install django-crispy-forms
44 pip-python install django-geoposition
45 pip-python install django-extensions
46 pip-python install django-suit
47 pip-python install django-evolution
48 pip-python install django-bitfield
49 pip-python install django-ipware
50 pip-python install django-encrypted-fields
51 pip-python install python-keyczar
52 pip-python install python-keystoneclient
53 pip-python install python-novaclient
54 pip-python install python-neutronclient
55 pip-python install python-glanceclient
58 easy_install django_evolution
59 easy_install python_gflags
60 easy_install google_api_python_client
62 if [ ! -f /usr/lib/python2.7/site-packages/suit/static/suit/js/jquery-1.9.1.min.js ]; then
63 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
66 if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
67 rm -f /usr/share/GeoIP/GeoLiteCity.*
68 wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
69 gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
72 if [ "$1" == 2 ] ; then
73 if [[ -e /opt/planetstack/scripts/opencloud ]]; then
74 echo "UPGRADE - saving current state"
75 /opt/planetstack/scripts/opencloud dumpdata
82 install -d %{buildroot}/opt/planetstack
83 install -d %{buildroot}/etc/init.d
88 # don't copy symbolic links (they are handled in %post)
89 rsync -rptgoD ./planetstack %{buildroot}/opt/.
90 cp observer-initscript %{buildroot}/etc/init.d/plstackobserver
92 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
93 echo /etc/init.d/plstackobserver >> %{_tmppath}/tmp-filelist
95 # remove config files from the file list (see %config below)
96 cat > %{_tmppath}/config-files << "EOF"
97 /opt/planetstack/plstackapi_config
98 /opt/planetstack/deployment_auth.py
101 sort %{_tmppath}/tmp-filelist > %{_tmppath}/tmp-filelist.sorted
102 sort %{_tmppath}/config-files > %{_tmppath}/config-files.sorted
103 comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tmppath}/tmp-filelist
105 cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
107 # Clone ansible with latest openstack modules
108 git clone --recursive git://github.com/ansible/ansible.git /opt/ansible
109 mkdir -p /etc/ansible
110 echo > /etc/ansible/hosts << "EOF"
118 %files -f %{_tmppath}/tmp-filelist
119 %defattr(-,root,root,-)
120 %config /opt/planetstack/plstackapi_config
121 %config /opt/planetstack/deployment_auth.py
124 ln -s ec2_observer /opt/planetstack/observer
125 ln -s config-opencloud.py /opt/planetstack/syndicate_observer/syndicatelib_config/config.py
127 if [ ! -e /opt/planetstack/public_keys ]; then
129 scripts/opencloud genkeys
132 if [ "$1" == 1 ] ; then
133 echo "NEW INSTALL - initializing database"
134 /opt/planetstack/scripts/opencloud initdb
136 # scripts/opencloud will choose evolve or migrate depending on django version
137 echo "UPGRADE - doing evolution/migration"
138 /opt/planetstack/scripts/opencloud evolvedb
142 /opt/planetstack/scripts/opencloud runserver
145 if [ "$1" = 0 ] ; then
146 echo "UNINSTALL - destroying planetstack"
147 rm -rf /opt/planetstack
151 * Sat Feb 22 2014 Siobhan Tully 1.0.0