added openstack dependencies for the observer
[plstackapi.git] / opencloud.spec
1 Summary: OpenCloud core services
2 Name: opencloud
3 Version: 1.0.27
4 Release: 3
5 License: GPL+
6 Group: Development/Tools
7 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9 requires: postgresql
10 requires: postgresql-server
11 requires: python-psycopg2
12 requires: graphviz
13 requires: graphviz-devel
14 requires: graphviz-python
15 requires: libxslt-devel
16 requires: python-pip
17 requires: tar
18 requires: gcc
19 requires: python-httplib2
20 requires: GeoIP
21 requires: wget
22
23 %description
24 %{summary}
25
26 %prep
27 %setup -q
28
29 %build
30 # Empty section.
31
32 %pre
33 pip-python install django==1.7
34 pip-python install djangorestframework
35 pip-python install markdown  # Markdown support for the browseable API.
36 pip-python install pyyaml    # YAML content-type support.
37 pip-python install django-filter  # Filtering support
38 pip-python install lxml  # XML manipulation library
39 pip-python install netaddr # IP Addr library
40 pip-python install pytz
41 pip-python install django-timezones
42 pip-python install requests
43 pip-python install django-crispy-forms
44 pip-python install django-geoposition
45 pip-python install django-extensions
46 pip-python install django-suit
47 pip-python install django-evolution
48 pip-python install django-bitfield
49 pip-python install django-ipware
50 pip-python install django-encrypted-fields
51 pip-python install python-keyczar
52 pip-python install python-keystoneclient
53 pip-python install python-novaclient
54 pip-python install python-neutronclient 
55 pip-python install python-glanceclient
56
57
58 easy_install django_evolution
59 easy_install python_gflags
60 easy_install google_api_python_client
61
62 if [ ! -f /usr/lib/python2.7/site-packages/suit/static/suit/js/jquery-1.9.1.min.js ]; then
63     wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
64 fi
65
66 if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
67    rm -f /usr/share/GeoIP/GeoLiteCity.*
68    wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
69    gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
70 fi
71
72 if [ "$1" == 2 ] ; then
73     if [[ -e /opt/planetstack/scripts/opencloud ]]; then
74         echo "UPGRADE - saving current state"
75         /opt/planetstack/scripts/opencloud dumpdata
76     fi
77 fi
78
79 %install
80 rm -rf %{buildroot}
81 mkdir -p  %{buildroot}
82 install -d %{buildroot}/opt/planetstack
83 install -d %{buildroot}/etc/init.d
84
85 # in builddir
86
87
88 # don't copy symbolic links (they are handled in %post)
89 rsync -rptgoD ./planetstack %{buildroot}/opt/.  
90 cp observer-initscript %{buildroot}/etc/init.d/plstackobserver
91
92 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
93 echo /etc/init.d/plstackobserver >> %{_tmppath}/tmp-filelist
94
95 # remove config files from the file list (see %config below)
96 cat > %{_tmppath}/config-files << "EOF"
97 /opt/planetstack/plstackapi_config
98 /opt/planetstack/deployment_auth.py
99 EOF
100
101 sort %{_tmppath}/tmp-filelist > %{_tmppath}/tmp-filelist.sorted
102 sort %{_tmppath}/config-files > %{_tmppath}/config-files.sorted
103 comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tmppath}/tmp-filelist
104
105 cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
106
107 %clean
108 rm -rf %{buildroot}
109
110 %files -f %{_tmppath}/tmp-filelist
111 %defattr(-,root,root,-)
112 %config /opt/planetstack/plstackapi_config
113 %config /opt/planetstack/deployment_auth.py
114
115 %post
116 ln -s ec2_observer /opt/planetstack/observer
117 ln -s config-opencloud.py /opt/planetstack/syndicate_observer/syndicatelib_config/config.py
118
119 if [ ! -e /opt/planetstack/public_keys ]; then
120     cd /opt/planetstack
121     scripts/opencloud genkeys
122 fi
123
124 if [ "$1" == 1 ] ; then
125     echo "NEW INSTALL - initializing database"
126     /opt/planetstack/scripts/opencloud initdb
127 else
128     # scripts/opencloud will choose evolve or migrate depending on django version
129     echo "UPGRADE - doing evolution/migration"
130     /opt/planetstack/scripts/opencloud evolvedb
131 fi
132
133 # start the server
134 /opt/planetstack/scripts/opencloud runserver
135
136 %preun
137 if [ "$1" = 0 ] ; then
138     echo "UNINSTALL - destroying planetstack"
139     rm -rf /opt/planetstack
140 fi
141
142 %changelog
143 * Sat Feb 22 2014  Siobhan Tully  1.0.0
144 - First Build
145