install dependencies for analyics, install newer jquery, bump version number
[plstackapi.git] / opencloud.spec
1 Summary: OpenCloud core services
2 Name: opencloud
3 Version: 1.0.2
4 Release: 1
5 License: GPL+
6 Group: Development/Tools
7 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9 requires: postgresql
10 requires: postgresql-server
11 requires: python-psycopg2
12 requires: graphviz
13 requires: graphviz-devel
14 requires: graphviz-python
15 requires: libxslt-devel
16 requires: python-pip
17 requires: tar
18 requires: gcc
19 requires: python-httplib2
20
21 %description
22 %{summary}
23
24 %prep
25 %setup -q
26
27 %build
28 # Empty section.
29
30 %pre
31 pip-python install django==1.5
32 pip-python install djangorestframework
33 pip-python install markdown  # Markdown support for the browseable API.
34 pip-python install pyyaml    # YAML content-type support.
35 pip-python install django-filter  # Filtering support
36 pip-python install lxml  # XML manipulation library
37 pip-python install netaddr # IP Addr library
38 pip-python install pytz
39 pip-python install django-timezones
40 pip-python install requests
41 pip-python install django-crispy-forms
42 pip-python install django-geoposition
43 pip-python install django-extensions
44 pip-python install django-suit
45 pip-python install django-evolution
46 pip-python install django-bitfield
47
48 easy_install django_evolution
49 easy_install python_gflags
50 easy_install google_api_python_client
51
52 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
53
54 %install
55 rm -rf %{buildroot}
56 mkdir -p  %{buildroot}
57 install -d %{buildroot}/opt/planetstack
58
59 # in builddir
60 cp -rp /opt/plstackapi/planetstack %{buildroot}/opt/.
61
62 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g"  > %{_tmppath}/tmp-filelist
63
64 %clean
65 rm -rf %{buildroot}
66
67 %files -f %{_tmppath}/tmp-filelist
68 %defattr(-,root,root,-)
69
70 %post
71 /opt/planetstack/scripts/opencloud initdb
72
73 %preun
74 rm -rf /opt/planetstack
75
76 %changelog
77 * Sat Feb 22 2014  Siobhan Tully  1.0.0
78 - First Build
79