Added requirements for using django encrypted fields
[plstackapi.git] / opencloud.spec
1 Summary: OpenCloud core services
2 Name: opencloud
3 Version: 1.0.23
4 Release: 0
5 License: GPL+
6 Group: Development/Tools
7 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9 requires: postgresql
10 requires: postgresql-server
11 requires: python-psycopg2
12 requires: graphviz
13 requires: graphviz-devel
14 requires: graphviz-python
15 requires: libxslt-devel
16 requires: python-pip
17 requires: tar
18 requires: gcc
19 requires: python-httplib2
20 requires: GeoIP
21 requires: python-keyczar
22
23 %description
24 %{summary}
25
26 %prep
27 %setup -q
28
29 %build
30 # Empty section.
31
32 %pre
33 #pip-python install django==1.5
34 pip-python install djangorestframework
35 pip-python install markdown  # Markdown support for the browseable API.
36 pip-python install pyyaml    # YAML content-type support.
37 pip-python install django-filter  # Filtering support
38 pip-python install lxml  # XML manipulation library
39 pip-python install netaddr # IP Addr library
40 pip-python install pytz
41 pip-python install django-timezones
42 pip-python install requests
43 pip-python install django-crispy-forms
44 pip-python install django-geoposition
45 pip-python install django-extensions
46 pip-python install django-suit
47 pip-python install django-evolution
48 pip-python install django-bitfield
49 pip-python install django-ipware
50 pip-python install django-encrypted-fields
51
52 easy_install django_evolution
53 easy_install python_gflags
54 easy_install google_api_python_client
55
56 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
57
58 if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
59    rm -f /usr/share/GeoIP/GeoLiteCity.*
60    wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
61    gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
62 fi
63
64 if [ "$1" == 2 ] ; then
65     if [[ -e /opt/planetstack/scripts/opencloud ]]; then
66         echo "UPGRADE - saving current state"
67         /opt/planetstack/scripts/opencloud dumpdata
68     fi
69 fi
70
71 %install
72 rm -rf %{buildroot}
73 mkdir -p  %{buildroot}
74 install -d %{buildroot}/opt/planetstack
75 install -d %{buildroot}/etc/init.d
76
77 # in builddir
78
79
80 # don't copy symbolic links (they are handled in %post)
81 rsync -rptgoD ./planetstack %{buildroot}/opt/.  
82 cp observer-initscript %{buildroot}/etc/init.d/plstackobserver
83
84 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
85 echo /etc/init.d/plstackobserver >> %{_tmppath}/tmp-filelist
86
87 # remove config files from the file list (see %config below)
88 cat > %{_tmppath}/config-files << "EOF"
89 /opt/planetstack/plstackapi_config
90 /opt/planetstack/deployment_auth.py
91 EOF
92
93 sort %{_tmppath}/tmp-filelist > %{_tmppath}/tmp-filelist.sorted
94 sort %{_tmppath}/config-files > %{_tmppath}/config-files.sorted
95 comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tmppath}/tmp-filelist
96
97 cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
98
99 %clean
100 rm -rf %{buildroot}
101
102 %files -f %{_tmppath}/tmp-filelist
103 %defattr(-,root,root,-)
104 %config /opt/planetstack/plstackapi_config
105 %config /opt/planetstack/deployment_auth.py
106
107 %post
108 ln -s ec2_observer /opt/planetstack/observer
109 ln -s config-opencloud.py /opt/planetstack/syndicate_observer/syndicatelib_config/config.py
110
111 if [ "$1" == 1 ] ; then
112     echo "NEW INSTALL - initializing database"
113     /opt/planetstack/scripts/opencloud initdb
114 else
115     echo "UPGRADE - doing evolution"
116     /opt/planetstack/scripts/opencloud evolvedb
117 fi
118 # start the server
119 /opt/planetstack/scripts/opencloud runserver
120
121 %preun
122 if [ "$1" = 0 ] ; then
123     echo "UNINSTALL - destroying planetstack"
124     rm -rf /opt/planetstack
125 fi
126
127 %changelog
128 * Sat Feb 22 2014  Siobhan Tully  1.0.0
129 - First Build
130