bump version number; add install-keys makefile action
[plstackapi.git] / opencloud.spec
1 Summary: OpenCloud core services
2 Name: opencloud
3 Version: 1.0.10
4 Release: 3
5 License: GPL+
6 Group: Development/Tools
7 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9 requires: postgresql
10 requires: postgresql-server
11 requires: python-psycopg2
12 requires: graphviz
13 requires: graphviz-devel
14 requires: graphviz-python
15 requires: libxslt-devel
16 requires: python-pip
17 requires: tar
18 requires: gcc
19 requires: python-httplib2
20 requires: GeoIP
21
22 %description
23 %{summary}
24
25 %prep
26 %setup -q
27
28 %build
29 # Empty section.
30
31 %pre
32 pip-python install django==1.5
33 pip-python install djangorestframework
34 pip-python install markdown  # Markdown support for the browseable API.
35 pip-python install pyyaml    # YAML content-type support.
36 pip-python install django-filter  # Filtering support
37 pip-python install lxml  # XML manipulation library
38 pip-python install netaddr # IP Addr library
39 pip-python install pytz
40 pip-python install django-timezones
41 pip-python install requests
42 pip-python install django-crispy-forms
43 pip-python install django-geoposition
44 pip-python install django-extensions
45 pip-python install django-suit
46 pip-python install django-evolution
47 pip-python install django-bitfield
48 pip-python install django-ipware
49
50 easy_install django_evolution
51 easy_install python_gflags
52 easy_install google_api_python_client
53
54 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
55
56 if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
57    rm -f /usr/share/GeoIP/GeoLiteCity.*
58    wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
59    gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
60 fi
61
62 if [ "$1" == 2 ] ; then
63     echo "UPGRADE - saving current state"
64     /opt/planetstack/scripts/opencloud dumpdata
65 fi
66
67 %install
68 rm -rf %{buildroot}
69 mkdir -p  %{buildroot}
70 install -d %{buildroot}/opt/planetstack
71
72 # in builddir
73 cp -rp ./planetstack %{buildroot}/opt/.
74
75 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g"  > %{_tmppath}/tmp-filelist
76
77 %clean
78 rm -rf %{buildroot}
79
80 %files -f %{_tmppath}/tmp-filelist
81 %defattr(-,root,root,-)
82
83 %post
84 if [ "$1" == 1 ] ; then
85     echo "NEW INSTALL - initializing database"
86     /opt/planetstack/scripts/opencloud initdb
87 else
88     echo "UPGRADE - doing evolution"
89     /opt/planetstack/scripts/opencloud evolvedb
90 fi
91 # start the server
92 /opt/planetstack/scripts/opencloud runserver
93
94 %preun
95 if [ "$1" = 0 ] ; then
96     echo "UNINSTALL - destroying planetstack"
97     rm -rf /opt/planetstack
98 fi
99
100 %changelog
101 * Sat Feb 22 2014  Siobhan Tully  1.0.0
102 - First Build
103