Added specfile
[procprotect.git] / procprotect.spec
1 %define url $URL$
2
3 %define name procprotect
4 %define version 0.1
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Vendor: PlanetLab
10 Packager: PlanetLab Central <support@planet-lab.org>
11 Distribution: PlanetLab %{plrelease}
12 URL: %(echo %{url} | cut -d ' ' -f 2)
13
14 Summary: Proc fs acls
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Kernel
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21 Source0: procprotect-%{version}.tar.gz
22
23 %description
24 ACLs for protecting entries in the proc filesystem.
25
26 %prep 
27 %setup -q
28
29 %build
30 make -C /lib/modules/`ls /lib/modules | head -1`/build M=$PWD modules
31
32 %install
33 mkdir -p $RPM_BUILD_ROOT/lib/modules/`ls /lib/modules | head -1`/kernel/net/procprotect
34 cp procprotect.ko $RPM_BUILD_ROOT/lib/modules/`ls /lib/modules | head -1`/kernel/net/procprotect
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 /lib
41
42 %post
43
44 %postun
45
46 %changelog