Tagging module pyplnet - pyplnet-4.2-4
[pyplnet.git] / pyplnet.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name pyplnet
7 %define version 4.2
8 %define taglevel 4
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
13
14 Summary: PlanetLab Network Configuration library
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: python >= 2.4
29 BuildRequires: python, python-devel
30 BuildArch: noarch
31
32 %description
33 pyplnet is used to write the network configuration files based on the
34 configuration data recorded at PLC.
35
36 %prep
37 %setup -q
38
39 %build
40 python setup.py build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
45 chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
46 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
47 ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(-,root,root,-)
54 %{_bindir}/plnet
55 %{python_sitelib}/*
56
57 %changelog
58 * Wed Apr 15 2009 Marc Fiuczynski <mef@cs.princeton.edu> - pyplnet-4.2-4
59 - - reimplementation of the ModProbe class to be more robust in parsing
60 - modprobe/blacklist files.
61 - - blacklist get/set methods
62 - - supports "include" modprobe command
63
64 * Tue Feb 24 2009 Marc Fiuczynski <mef@cs.princeton.edu> - pyplnet-4.2-3
65 - BUGFIX: the "program" argument needs to go with the the m.output() method.
66 - The bug is that the m.input() method does not take two args and python
67 - will raise an exception to indicate this.  However, the m.input()
68 - method was wrapped in a
69 - try:
70 - m.input(a,b)
71 - except:
72 - pass
73 - which masked this error.  The mainly visible side effect is that the
74 - specific modprobe.conf file is not parsed and so any previously
75 - written aliases and options are lost.
76
77 * Mon Dec 15 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.2-2
78 - Work on PLCs running in Linux-VServer guests or other environments where /sys
79 - isn't mounted.
80
81 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.2-1
82 - Rewrite sioc in Python.
83 - Add a plnet symlink to make it easier to run the script via plcsh.
84 - Set DNS servers/gateway for static configurations.
85 - Work with an empty tree.
86 - Use tempfile for temporary files.
87
88 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.2-1
89 - initial release