Setting tag pyplnet-4.3-12
[pyplnet.git] / pyplnet.spec
1 %define name pyplnet
2 %define version 4.3
3 %define taglevel 12
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Summary: PlanetLab Network Configuration library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Requires: python >= 2.4
24 BuildRequires: python, python-devel
25 BuildArch: noarch
26
27 %description
28 pyplnet is used to write the network configuration files based on the
29 configuration data recorded at PLC.
30
31 %prep
32 %setup -q
33
34 %build
35 python setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
40 chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
41 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
42 ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(-,root,root,-)
49 %{_bindir}/plnet
50 %{python_sitelib}/*
51
52 %changelog
53 * Thu Apr 26 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-12
54
55 * Sun Sep 25 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-11
56 - turn off verbose/debug messages
57 - pyplnet-4.3-10 was broken because of that
58
59 * Wed Sep 21 2011 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-10
60 - Enable creation of bridged interfaces
61
62 * Tue Feb 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-9
63 - protect shell vars definition in ifcfg files with ""
64 - tweaks in numbering rules
65
66 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-8
67 - no semantic change - just fixed specfile for git URL
68
69 * Thu Dec 09 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - pyplnet-4.3-7
70 - Secondary interface fixes and features.
71
72 * Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
73 - aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
74
75 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
76 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
77 - this code can handle both..
78
79 * Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
80 - alias without a mac address: fix runtime error while issuing warning
81
82 * Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
83 - this patch addresses mlab and other multi-interface node confgurations where
84 - the generated boot image and network config files are mis-named.
85
86 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
87 - handle wireless settings back again
88
89 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
90 - fixes for 4.3
91
92 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
93 - initial release