Don't whine about comments in modprobe.conf.
[pyplnet.git] / pyplnet.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name pyplnet
7 %define version 4.3
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
13
14 Summary: PlanetLab Network Configuration library
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: python >= 2.4
29 BuildRequires: python, python-devel
30
31 %description
32 pyplnet is used to write the network configuration files based on the
33 configuration data recorded at PLC.
34
35 %prep
36 %setup -q
37
38 %build
39 python setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
44 chmod +x %{python_sitearch}/plnet.py
45 ln -s %{python_sitearch}/plnet.py %{_bindir}/plnet
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 %{_bindir}/plnet
53 %{python_sitearch}/*
54
55 %changelog
56 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
57 - initial release