Use source based routing if secondary interfaces specify different gateway.
[pyplnet.git] / pyplnet.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name pyplnet
7 %define version 4.3
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
13
14 Summary: PlanetLab Network Configuration library
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: python >= 2.4
29 BuildRequires: python, python-devel
30 BuildArch: noarch
31
32 %description
33 pyplnet is used to write the network configuration files based on the
34 configuration data recorded at PLC.
35
36 %prep
37 %setup -q
38
39 %build
40 python setup.py build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
45 chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
46 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
47 ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(-,root,root,-)
54 %{_bindir}/plnet
55 %{python_sitelib}/*
56
57 %changelog
58 * Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
59 - aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
60
61 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
62 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
63 - this code can handle both..
64
65 * Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
66 - alias without a mac address: fix runtime error while issuing warning
67
68 * Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
69 - this patch addresses mlab and other multi-interface node confgurations where
70 - the generated boot image and network config files are mis-named.
71
72 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
73 - handle wireless settings back again
74
75 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
76 - fixes for 4.3
77
78 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
79 - initial release