Setting tag pyplnet-7.0-0
[pyplnet.git] / pyplnet.spec
1 %define name pyplnet
2 %define version 7.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Network Configuration library
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Requires: python3
22 BuildRequires: python3, python3-devel
23 BuildArch: noarch
24
25 %description
26 pyplnet is used to write the network configuration files based on the
27 configuration data recorded at PLC.
28
29 %prep
30 %setup -q
31
32 %build
33 python3 setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 python3 setup.py install --skip-build --root "$RPM_BUILD_ROOT"
38 chmod +x $RPM_BUILD_ROOT/%{python3_sitelib}/plnet.py
39 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
40 ln -s %{python3_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root,-)
47 %{_bindir}/plnet
48 %{python3_sitelib}/*
49
50 %changelog
51 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - pyplnet-7.0-0
52 - based on python3
53 - remove 'NM_CONTROLLED=no' from ifcfg file, as we now rely on NetworkManager
54 - cleaned up old code related to 'nodenetworks', oly use 'interfaces' instead
55
56 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-19
57 - always set NM_CONTROLLED=no in ifcfg files
58 - more modern python
59
60 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-18
61 - IPv6 changes from Thomas Dreibholz
62
63 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-17
64 - Added tags for configuring OvS interfaces
65
66 * Thu Jan 03 2013 Scott Baker <smbaker@gmail.com> - pyplnet-4.3-16
67 - verify ovs is running before setting up ovs bridge
68
69 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-15
70 - Add support for bridging using Open vSwitch
71
72 * Wed May 02 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-14
73 - Fix stupid bug
74
75 * Mon Apr 30 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-13
76 - Support for VLAN interfaces
77
78 * Thu Apr 26 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-12
79
80 * Sun Sep 25 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-11
81 - turn off verbose/debug messages
82 - pyplnet-4.3-10 was broken because of that
83
84 * Wed Sep 21 2011 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-10
85 - Enable creation of bridged interfaces
86
87 * Tue Feb 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-9
88 - protect shell vars definition in ifcfg files with ""
89 - tweaks in numbering rules
90
91 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-8
92 - no semantic change - just fixed specfile for git URL
93
94 * Thu Dec 09 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - pyplnet-4.3-7
95 - Secondary interface fixes and features.
96
97 * Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
98 - aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
99
100 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
101 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
102 - this code can handle both..
103
104 * Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
105 - alias without a mac address: fix runtime error while issuing warning
106
107 * Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
108 - this patch addresses mlab and other multi-interface node confgurations where
109 - the generated boot image and network config files are mis-named.
110
111 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
112 - handle wireless settings back again
113
114 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
115 - fixes for 4.3
116
117 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
118 - initial release