install keyconvert to /usr/bin
[sfa.git] / geniwrapper.spec
1 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
2
3 %define name sfa
4 %define version 0.8
5 %define taglevel 2
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
10
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Source0: %{name}-%{version}.tar.bz2
15 License: GPL
16 Group: Applications/System
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %(echo %{url} | cut -d ' ' -f 2)
23
24 BuildRequires: make
25 Requires: python
26 Requires: pyOpenSSL >= 0.7
27 Requires: m2crypto
28
29 Summary: the SFA python libraries
30 Group: Applications/System
31
32 %package plc
33 Summary: the SFA wrapper arounf MyPLC
34 Group: Applications/System
35 Requires: sfa
36
37 %package client
38 Summary: the SFA experimenter-side CLI
39 Group: Applications/System
40 Requires: sfa
41
42 %description
43 This package provides the python libraries that the SFA implementation requires
44
45 %description plc
46 Geniwrapper implements the SFA interface which serves as a layer
47 between the existing PlanetLab interfaces and the SFA API.
48
49 %description client
50 This package provides the client side of the SFA API, in particular
51 sfi.py, together with other utilities.
52
53 %prep
54 %setup -q
55
56 %build
57 make
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 make install DESTDIR="$RPM_BUILD_ROOT"
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %{python_sitelib}/*
68 /usr/bin/keyconvert
69 /var/www/html/wsdl/sfa.wsdl
70
71 %files plc
72 %defattr(-,root,root)
73 %config (noreplace) /etc/sfa/sfa_config
74 %config (noreplace) /etc/sfa/aggregates.xml
75 %config (noreplace) /etc/sfa/registries.xml
76 /etc/init.d/sfa
77 %{_bindir}/sfa-config-tty
78 %{_bindir}/sfa-import-plc.py*
79 %{_bindir}/sfa-server.py*
80
81 %files client
82 %config (noreplace) /etc/sfa/sfi_config
83 %{_bindir}/sfi.py*
84 %{_bindir}/getNodes.py*
85 %{_bindir}/getRecord.py*
86 %{_bindir}/setRecord.py*
87 %{_bindir}/genidump.py*
88
89 %pre plc
90 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
91
92 %post plc
93 chkconfig --add sfa
94
95 %changelog
96 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
97 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
98 - config variables in sfa_config now start with SFA_ and not GENI_
99 - config.py can be loaded even with no config present
100
101 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
102 - first step for cleanup and reorganization
103 - mass-renaming from geni to sfa (some are still needed)
104 - sfa/trust implements the security architecture
105
106 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
107 - snapshot for reproducible builds
108
109 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
110 - snapshot for the convenience of alpha users
111
112 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
113 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
114
115 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
116 - ongoing work - snapshot for 4.3-rc9
117
118 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
119 - various fixes
120
121 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
122 - bugfixes - still a work in progress
123
124 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
125 - initial package
126
127
128 %define module_current_branch 0.2