added --extractgids, --dumpparents
[sfa.git] / geniwrapper.spec
1
2 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
3
4 %define name geniwrapper
5 %define version 0.2
6 %define taglevel 3
7
8 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
9 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
10
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Source0: %{name}-%{version}.tar.bz2
15 License: GPL
16 Group: Applications/System
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %(echo %{url} | cut -d ' ' -f 2)
23
24 BuildRequires: make
25 Requires: python
26 Requires: pyOpenSSL >= 0.7
27 Requires: m2crypto
28
29
30 Summary: Geniwrapper
31 Group: Applications/System
32
33 %description
34 Geniwrapper description...
35
36 %prep
37 %setup -q
38
39 %build
40 make
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 make install DESTDIR="$RPM_BUILD_ROOT"
45
46 # hack to add installed files to the package
47 python -c "print '\n'.join(['%s*'%i.strip() for i in open('GENI_INSTALLED_FILES').readlines() if not i.strip().endswith('.pyc')])" |uniq > GENI_INSTALLED_FILES.all
48
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files -f GENI_INSTALLED_FILES.all
54 %defattr(-,root,root)
55 /usr/share/keyconvert
56
57 %post
58 chmod 0744 /etc/init.d/geniwrapper
59
60 %changelog
61 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
62 - various fixes
63
64 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
65 - bugfixes - still a work in progress
66
67 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
68 - initial package
69