use consistent name sfi_config, like plc_config and geni_config (oops, unsaved changes)
[sfa.git] / geniwrapper.spec
1
2 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
3
4 %define name geniwrapper
5 %define version 0.8
6 %define taglevel 0
7
8 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
9 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
10
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Source0: %{name}-%{version}.tar.bz2
15 License: GPL
16 Group: Applications/System
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %(echo %{url} | cut -d ' ' -f 2)
23
24 BuildRequires: make
25 Requires: python
26 Requires: pyOpenSSL >= 0.7
27 Requires: m2crypto
28
29
30 Summary: Geniwrapper
31 Group: Applications/System
32
33 %description
34 Geniwrapper description...
35
36 %prep
37 %setup -q
38
39 %build
40 make
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 make install DESTDIR="$RPM_BUILD_ROOT"
45
46 # hack to add installed files to the package
47 python -c "print '\n'.join(['%s*'%i.strip() for i in open('GENI_INSTALLED_FILES').readlines() if not i.strip().endswith('.pyc')])" |uniq > GENI_INSTALLED_FILES.all
48
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files -f GENI_INSTALLED_FILES.all
54 %defattr(-,root,root)
55 /usr/share/keyconvert
56 %config (noreplace) /etc/geni/geni_config
57 %config (noreplace) /etc/geni/sfi_config
58 %config (noreplace) /etc/geni/aggregates.xml
59 %config (noreplace) /etc/geni/registries.xml
60
61 %post
62 chmod 0744 /etc/init.d/geniwrapper
63
64 %changelog
65 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
66 - snapshot for reproducible builds
67
68 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
69 - snapshot for the convenience of alpha users
70
71 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
72 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
73
74 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
75 - ongoing work - snapshot for 4.3-rc9
76
77 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
78 - various fixes
79
80 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
81 - bugfixes - still a work in progress
82
83 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
84 - initial package
85
86
87 %define module_current_branch 0.2