if the slice is renewed in the local aggregate, we have to make corresponding change...
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 6
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36 Requires: python-ZSI
37 Requires: python-psycopg2
38
39 # python 2.5 has uuid module added, for python 2.4 we still need it
40 %define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
41 %if has_uuid
42 %else
43 Requires: python-uuid
44 %endif
45
46 %package plc
47 Summary: the SFA wrapper arounf MyPLC
48 Group: Applications/System
49 Requires: sfa
50
51 %package client
52 Summary: the SFA experimenter-side CLI
53 Group: Applications/System
54 Requires: sfa
55
56 %package sfatables
57 Summary: sfatables policy tool for SFA
58 Group: Applications/System
59 Requires: sfa
60
61 %description
62 This package provides the python libraries that the SFA implementation requires
63
64 %description plc
65 Geniwrapper implements the SFA interface which serves as a layer
66 between the existing PlanetLab interfaces and the SFA API.
67
68 %description client
69 This package provides the client side of the SFA API, in particular
70 sfi.py, together with other utilities.
71
72 %description sfatables
73 sfatables is a tool for defining access and admission control policies
74 in an SFA network, in much the same way as iptables is for ip
75 networks. This is the command line interface to manage sfatables
76
77 %prep
78 %setup -q
79
80 %build
81 make
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 make install DESTDIR="$RPM_BUILD_ROOT"
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 # sfa and sfatables depend each other.
92 /etc/sfatables/*
93 %{python_sitelib}/*
94 /usr/bin/keyconvert
95 /var/www/html/wsdl/*.wsdl
96
97
98 %files plc
99 %defattr(-,root,root)
100 %config (noreplace) /etc/sfa/sfa_config
101 %config (noreplace) /etc/sfa/aggregates.xml
102 %config (noreplace) /etc/sfa/registries.xml
103 /etc/init.d/sfa
104 %{_bindir}/sfa-config-tty
105 %{_bindir}/sfa-import-plc.py*
106 %{_bindir}/sfa-clean-peer-records.py*
107 %{_bindir}/sfa-nuke-plc.py*
108 %{_bindir}/sfa-server.py*
109
110 %files client
111 %config (noreplace) /etc/sfa/sfi_config
112 %{_bindir}/sfi.py*
113 %{_bindir}/getNodes.py*
114 %{_bindir}/getRecord.py*
115 %{_bindir}/setRecord.py*
116 %{_bindir}/genidump.py*
117
118 %files sfatables
119 %{_bindir}/sfatables
120
121 %pre plc
122 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
123
124 %post plc
125 chkconfig --add sfa
126
127 %changelog
128 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
129 - This tag includes:
130 - - Sfatables
131 - - Preliminary version of hash based authentication
132 - - Initial code for Component Manager
133 - - Authority structure is moved to /var/lib/sfa/
134 - - some bug-fixes
135
136 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
137 - Create_slice and get_resources methods are connected to sfatables.
138 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
139
140 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
141 - Bug fix on update and remove_peer_object methods
142 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
143
144 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
145 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
146
147 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
148 - compatibility with RefreshPeer
149 - incremental mechanism for importing PLC records into SFA tables
150 - unified single database (still inside the underlying PLC db postgresql server)
151 - includes/improves call traceability and logging features
152 - several bug fixes
153
154 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
155 - added libxslt-python dependency
156
157 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
158 - unified single SFA database in the PLC-DB
159 - upcalls from  PLCAPI to SFA methods
160 - SFA call traceability and logging features
161 - many bug fixes
162 - includes first/rough version of sfatables for policy implementation
163
164 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
165 - snapshot after the GEC5 demo
166 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
167
168 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
169 - snapshot july 15 - has gone through superficial manual testing
170 - hopefully a good basis for gec5 demo
171 - multi-dir sfi client tested as well
172
173 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
174 - rename geniwrapper.spec into sfa.spec
175
176 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
177 - clean up in xmlrpc/soap, --protocol option to chose between both
178 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
179 - hopefully more helpful context in case of crashes when importing
180 - bugfixes for using only /etc/sfa for site-dep files
181 - bugfixes in wsdl generation
182
183 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
184 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
185 - config variables in sfa_config now start with SFA_ and not GENI_
186 - config.py can be loaded even with no config present
187
188 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
189 - first step for cleanup and reorganization
190 - mass-renaming from geni to sfa (some are still needed)
191 - sfa/trust implements the security architecture
192
193 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
194 - snapshot for reproducible builds
195
196 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
197 - snapshot for the convenience of alpha users
198
199 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
200 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
201
202 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
203 - ongoing work - snapshot for 4.3-rc9
204
205 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
206 - various fixes
207
208 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
209 - bugfixes - still a work in progress
210
211 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
212 - initial package
213
214
215 %define module_current_branch 0.2