fix typo
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 8
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 /etc/sfa/credential.rng
135 /etc/sfa/top.rng
136 /etc/sfa/protogeni-rspec-common.rng
137 %{_bindir}/sfa-config-tty
138 %{_bindir}/sfa-import-plc.py*
139 %{_bindir}/sfa-clean-peer-records.py*
140 %{_bindir}/sfa-nuke-plc.py*
141 %{_bindir}/gen-sfa-cm-config.py*
142 %{_bindir}/sfa-ca.py*
143
144 %files client
145 %config (noreplace) /etc/sfa/sfi_config
146 %{_bindir}/sfi*
147 %{_bindir}/getNodes.py*
148 %{_bindir}/getRecord.py*
149 %{_bindir}/setRecord.py*
150 %{_bindir}/sfadump.py*
151
152 %files sfatables
153 %{_bindir}/sfatables
154
155 %files tests
156 %{_datadir}/sfa/tests
157
158 ### sfa-plc installs the 'sfa' service
159 %post plc
160 chkconfig --add sfa
161
162 %preun plc
163 if [ "$1" = 0 ] ; then
164   /sbin/service sfa stop || :
165   /sbin/chkconfig --del sfa || :
166 fi
167
168 %postun plc
169 [ "$1" -ge "1" ] && service sfa restart
170
171 ### sfa-cm installs the 'sfa-cm' service
172 %post cm
173 chkconfig --add sfa-cm
174
175 %preun cm
176 if [ "$1" = 0 ] ; then
177    /sbin/service sfa-cm stop || :
178    /sbin/chkconfig --del sfa-cm || :
179 fi
180
181 %postun cm
182 [ "$1" -ge "1" ] && service sfa-cm restart
183
184
185 %changelog
186 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
187 - fix registry credential regeneration and handle expiration
188 - support for setting slice tags (min_role=user)
189 - client can display its own version: sfi.py version --local
190 - GetVersion to provide urn in addition to hrn
191 - more code uses plxrn vs previous helper functions
192 - import replaces '+' in email addresses with '_'
193
194 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
195 - fix GetVersion code_tag and add code_url
196
197 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
198 - extend GetVersion towards minimum federation introspection, and expose local tag
199
200 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
201 - fixed some legacy issues (list vs List)
202 - deprecated sfa.util.namespace for xrn and plxrn
203 - unit tests ship as the sfa-tests rpm
204
205 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
206 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
207 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
208 - hrn-urn translations tweaked
209 - fixed 'service sfa status'
210 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
211 - started to repair sfadump - although not usable yet
212 - trust objects now have dump_string method that dump() actually prints
213 - unit tests under review
214 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
215 - binaries now support -v or -vv to increase loglevel
216 - trashed obsolete sfa.util.client
217
218 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
219 - various bugfixes and cleanup, improved/harmonized logging
220
221 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
222 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
223   to avoid returning a PLCAPI exception that might confuse users.
224 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
225 - fix build errors.  
226
227 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
228 - (Architecture) Credential format changed to match ProtoGENI xml format
229 - (Architecture) All interfaces export a new set of methods that are compatible
230    with the ProtoGeni Aggregate spec. These new methods are considered a 
231    replacement  for the pervious methods exported by the interfaces. All 
232    previous methods are still exported and work as normal, but they are 
233    considered deprecated and will not be supported in future releases.  
234 - (Architecture) SFI has been updated to use the new interface methods.
235 - (Architecture) Changed keyconvet implementation from c to python.
236 - (Architecture) Slice Manager now attempts looks for a delegated credential
237   provided by the client before using its own server credential.
238 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
239   This cache now exists only in memory and is cleared when service is restarted
240   or cache lifetime is exceeded.  
241 - (Performance) SliceManager sends request to Aggregates in parallel instead 
242   of sequentially.
243 - (Bug fix) SFA tickets now support the new rspec format.
244 - (Bug fix) SFI only uses cahced credential if they aren't expired.
245 - (Bug fix) Cerdential delegation modified to work with new credential format.
246 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
247   Aggregate instead of relaying through the Slice Manager.
248 - (Enhancement) Simplified caching. Accociated a global cache instance with
249   the api handler on every new server request, making it easier to access the 
250   cache and use in more general ways.     
251
252 %changelog
253 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
254 - fix registry credential regeneration and handle expiration
255 - support for setting slice tags (min_role=user)
256 - client can display its own version: sfi.py version --local
257 - GetVersion to provide urn in addition to hrn
258 - more code uses plxrn vs previous helper functions
259 - import replaces '+' in email addresses with '_'
260
261 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
262 - fix GetVersion code_tag and add code_url
263
264 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
265 - extend GetVersion towards minimum federation introspection, and expose local tag
266
267 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
268 - fixed some legacy issues (list vs List)
269 - deprecated sfa.util.namespace for xrn and plxrn
270 - unit tests ship as the sfa-tests rpm
271
272 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
273 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
274 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
275 - hrn-urn translations tweaked
276 - fixed 'service sfa status'
277 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
278 - started to repair sfadump - although not usable yet
279 - trust objects now have dump_string method that dump() actually prints
280 - unit tests under review
281 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
282 - binaries now support -v or -vv to increase loglevel
283 - trashed obsolete sfa.util.client
284
285 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
286 - various bugfixes and cleanup, improved/harmonized logging
287
288 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
289 - SfaServer now uses a pool of threads to handle requests concurrently
290 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
291 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
292 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
293 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
294 - Component manager does not install gid files if slice already has them  
295 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
296 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
297 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
298      
299 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
300 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
301 - - sfa-config-tty now has the same features like plc-config-tty
302 - - Contains code to support both urn and hrn
303 - - Cleaned up request_hash related stuff
304 - - SM, AM and Registry code is organized under respective managers
305 - - Site and Slice synchronization across federated aggregates
306 - - Script to generate sfa_component_config
307
308 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
309 - sfa-config-tty now has the same features like plc-config-tty
310 - Contains code to support both urn and hrn
311 - Cleaned up request_hash related stuff
312 - SM, AM and Registry code is organized under respective managers
313 - Slice synchronization across federated aggregates
314 - some bugs are fixed
315
316 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
317 - checkpoint with fewer mentions of geni
318
319 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
320 - checkpointing
321 - this is believed to pass the tests; among other things:
322 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
323
324 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
325 - This tag includes:
326 - - Sfatables
327 - - Preliminary version of hash based authentication
328 - - Initial code for Component Manager
329 - - Authority structure is moved to /var/lib/sfa/
330 - - some bug-fixes
331
332 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
333 - Create_slice and get_resources methods are connected to sfatables.
334 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
335
336 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
337 - Bug fix on update and remove_peer_object methods
338 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
339
340 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
341 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
342
343 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
344 - compatibility with RefreshPeer
345 - incremental mechanism for importing PLC records into SFA tables
346 - unified single database (still inside the underlying PLC db postgresql server)
347 - includes/improves call traceability and logging features
348 - several bug fixes
349
350 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
351 - added libxslt-python dependency
352
353 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
354 - unified single SFA database in the PLC-DB
355 - upcalls from  PLCAPI to SFA methods
356 - SFA call traceability and logging features
357 - many bug fixes
358 - includes first/rough version of sfatables for policy implementation
359
360 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
361 - snapshot after the GEC5 demo
362 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
363
364 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
365 - snapshot july 15 - has gone through superficial manual testing
366 - hopefully a good basis for gec5 demo
367 - multi-dir sfi client tested as well
368
369 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
370 - rename geniwrapper.spec into sfa.spec
371
372 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
373 - clean up in xmlrpc/soap, --protocol option to chose between both
374 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
375 - hopefully more helpful context in case of crashes when importing
376 - bugfixes for using only /etc/sfa for site-dep files
377 - bugfixes in wsdl generation
378
379 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
380 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
381 - config variables in sfa_config now start with SFA_ and not GENI_
382 - config.py can be loaded even with no config present
383
384 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
385 - first step for cleanup and reorganization
386 - mass-renaming from geni to sfa (some are still needed)
387 - sfa/trust implements the security architecture
388
389 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
390 - snapshot for reproducible builds
391
392 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
393 - snapshot for the convenience of alpha users
394
395 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
396 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
397
398 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
399 - ongoing work - snapshot for 4.3-rc9
400
401 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
402 - various fixes
403
404 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
405 - bugfixes - still a work in progress
406
407 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
408 - initial package
409
410
411 %define module_current_branch 0.2