Setting tag sfa-1.0-8
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 8
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 %{_bindir}/sfa-config-tty
135 %{_bindir}/sfa-import-plc.py*
136 %{_bindir}/sfa-clean-peer-records.py*
137 %{_bindir}/sfa-nuke-plc.py*
138 %{_bindir}/gen-sfa-cm-config.py*
139 %{_bindir}/sfa-ca.py*
140
141 %files client
142 %config (noreplace) /etc/sfa/sfi_config
143 %{_bindir}/sfi*
144 %{_bindir}/getNodes.py*
145 %{_bindir}/getRecord.py*
146 %{_bindir}/setRecord.py*
147 %{_bindir}/sfadump.py*
148
149 %files sfatables
150 %{_bindir}/sfatables
151
152 %files tests
153 %{_datadir}/sfa/tests
154
155 ### sfa-plc installs the 'sfa' service
156 %post plc
157 chkconfig --add sfa
158
159 %preun plc
160 if [ "$1" = 0 ] ; then
161   /sbin/service sfa stop || :
162   /sbin/chkconfig --del sfa || :
163 fi
164
165 %postun plc
166 [ "$1" -ge "1" ] && service sfa restart
167
168 ### sfa-cm installs the 'sfa-cm' service
169 %post cm
170 chkconfig --add sfa-cm
171
172 %preun cm
173 if [ "$1" = 0 ] ; then
174    /sbin/service sfa-cm stop || :
175    /sbin/chkconfig --del sfa-cm || :
176 fi
177
178 %postun cm
179 [ "$1" -ge "1" ] && service sfa-cm restart
180
181
182 %changelog
183 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
184 - fix registry credential regeneration and handle expiration
185 - support for setting slice tags (min_role=user)
186 - client can display its own version: sfi.py version --local
187 - GetVersion to provide urn in addition to hrn
188 - more code uses plxrn vs previous helper functions
189 - import replaces '+' in email addresses with '_'
190
191 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
192 - fix GetVersion code_tag and add code_url
193
194 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
195 - extend GetVersion towards minimum federation introspection, and expose local tag
196
197 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
198 - fixed some legacy issues (list vs List)
199 - deprecated sfa.util.namespace for xrn and plxrn
200 - unit tests ship as the sfa-tests rpm
201
202 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
203 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
204 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
205 - hrn-urn translations tweaked
206 - fixed 'service sfa status'
207 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
208 - started to repair sfadump - although not usable yet
209 - trust objects now have dump_string method that dump() actually prints
210 - unit tests under review
211 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
212 - binaries now support -v or -vv to increase loglevel
213 - trashed obsolete sfa.util.client
214
215 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
216 - various bugfixes and cleanup, improved/harmonized logging
217
218 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
219 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
220   to avoid returning a PLCAPI exception that might confuse users.
221 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
222 - fix build errors.  
223
224 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
225 - (Architecture) Credential format changed to match ProtoGENI xml format
226 - (Architecture) All interfaces export a new set of methods that are compatible
227    with the ProtoGeni Aggregate spec. These new methods are considered a 
228    replacement  for the pervious methods exported by the interfaces. All 
229    previous methods are still exported and work as normal, but they are 
230    considered deprecated and will not be supported in future releases.  
231 - (Architecture) SFI has been updated to use the new interface methods.
232 - (Architecture) Changed keyconvet implementation from c to python.
233 - (Architecture) Slice Manager now attempts looks for a delegated credential
234   provided by the client before using its own server credential.
235 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
236   This cache now exists only in memory and is cleared when service is restarted
237   or cache lifetime is exceeded.  
238 - (Performance) SliceManager sends request to Aggregates in parallel instead 
239   of sequentially.
240 - (Bug fix) SFA tickets now support the new rspec format.
241 - (Bug fix) SFI only uses cahced credential if they aren't expired.
242 - (Bug fix) Cerdential delegation modified to work with new credential format.
243 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
244   Aggregate instead of relaying through the Slice Manager.
245 - (Enhancement) Simplified caching. Accociated a global cache instance with
246   the api handler on every new server request, making it easier to access the 
247   cache and use in more general ways.     
248
249 %changelog
250 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
251 - fix registry credential regeneration and handle expiration
252 - support for setting slice tags (min_role=user)
253 - client can display its own version: sfi.py version --local
254 - GetVersion to provide urn in addition to hrn
255 - more code uses plxrn vs previous helper functions
256 - import replaces '+' in email addresses with '_'
257
258 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
259 - fix GetVersion code_tag and add code_url
260
261 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
262 - extend GetVersion towards minimum federation introspection, and expose local tag
263
264 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
265 - fixed some legacy issues (list vs List)
266 - deprecated sfa.util.namespace for xrn and plxrn
267 - unit tests ship as the sfa-tests rpm
268
269 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
270 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
271 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
272 - hrn-urn translations tweaked
273 - fixed 'service sfa status'
274 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
275 - started to repair sfadump - although not usable yet
276 - trust objects now have dump_string method that dump() actually prints
277 - unit tests under review
278 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
279 - binaries now support -v or -vv to increase loglevel
280 - trashed obsolete sfa.util.client
281
282 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
283 - various bugfixes and cleanup, improved/harmonized logging
284
285 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
286 - SfaServer now uses a pool of threads to handle requests concurrently
287 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
288 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
289 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
290 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
291 - Component manager does not install gid files if slice already has them  
292 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
293 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
294 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
295      
296 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
297 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
298 - - sfa-config-tty now has the same features like plc-config-tty
299 - - Contains code to support both urn and hrn
300 - - Cleaned up request_hash related stuff
301 - - SM, AM and Registry code is organized under respective managers
302 - - Site and Slice synchronization across federated aggregates
303 - - Script to generate sfa_component_config
304
305 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
306 - sfa-config-tty now has the same features like plc-config-tty
307 - Contains code to support both urn and hrn
308 - Cleaned up request_hash related stuff
309 - SM, AM and Registry code is organized under respective managers
310 - Slice synchronization across federated aggregates
311 - some bugs are fixed
312
313 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
314 - checkpoint with fewer mentions of geni
315
316 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
317 - checkpointing
318 - this is believed to pass the tests; among other things:
319 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
320
321 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
322 - This tag includes:
323 - - Sfatables
324 - - Preliminary version of hash based authentication
325 - - Initial code for Component Manager
326 - - Authority structure is moved to /var/lib/sfa/
327 - - some bug-fixes
328
329 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
330 - Create_slice and get_resources methods are connected to sfatables.
331 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
332
333 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
334 - Bug fix on update and remove_peer_object methods
335 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
336
337 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
338 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
339
340 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
341 - compatibility with RefreshPeer
342 - incremental mechanism for importing PLC records into SFA tables
343 - unified single database (still inside the underlying PLC db postgresql server)
344 - includes/improves call traceability and logging features
345 - several bug fixes
346
347 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
348 - added libxslt-python dependency
349
350 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
351 - unified single SFA database in the PLC-DB
352 - upcalls from  PLCAPI to SFA methods
353 - SFA call traceability and logging features
354 - many bug fixes
355 - includes first/rough version of sfatables for policy implementation
356
357 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
358 - snapshot after the GEC5 demo
359 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
360
361 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
362 - snapshot july 15 - has gone through superficial manual testing
363 - hopefully a good basis for gec5 demo
364 - multi-dir sfi client tested as well
365
366 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
367 - rename geniwrapper.spec into sfa.spec
368
369 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
370 - clean up in xmlrpc/soap, --protocol option to chose between both
371 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
372 - hopefully more helpful context in case of crashes when importing
373 - bugfixes for using only /etc/sfa for site-dep files
374 - bugfixes in wsdl generation
375
376 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
377 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
378 - config variables in sfa_config now start with SFA_ and not GENI_
379 - config.py can be loaded even with no config present
380
381 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
382 - first step for cleanup and reorganization
383 - mass-renaming from geni to sfa (some are still needed)
384 - sfa/trust implements the security architecture
385
386 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
387 - snapshot for reproducible builds
388
389 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
390 - snapshot for the convenience of alpha users
391
392 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
393 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
394
395 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
396 - ongoing work - snapshot for 4.3-rc9
397
398 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
399 - various fixes
400
401 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
402 - bugfixes - still a work in progress
403
404 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
405 - initial package
406
407
408 %define module_current_branch 0.2