update
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 10
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37
38 # python 2.5 has uuid module added, for python 2.4 we still need it.
39 # we can't really check for if we can load uuid as a python module,
40 # it'll be installed by "devel.pkgs". we have the epel repository so
41 # python-uuid will be provided. but we can test for the python
42 # version.
43 %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
44 %if %has_py24
45 Requires: python-uuid
46 %endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC's NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %description
74 This package provides the python libraries that the SFA implementation requires
75
76 %description cm
77 This package implements the SFA interface which serves as a layer
78 between the existing PlanetLab NodeManager interfaces and the SFA API.
79  
80 %description plc
81 This package implements the SFA interface which serves as a layer
82 between the existing PlanetLab interfaces and the SFA API.
83
84 %description client
85 This package provides the client side of the SFA API, in particular
86 sfi.py, together with other utilities.
87
88 %description sfatables
89 sfatables is a tool for defining access and admission control policies
90 in an SFA network, in much the same way as iptables is for ip
91 networks. This is the command line interface to manage sfatables
92
93 %prep
94 %setup -q
95
96 %build
97 make
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 make install DESTDIR="$RPM_BUILD_ROOT"
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 # sfa and sfatables depend each other.
108 %{_bindir}/sfa-server.py*
109 /etc/sfatables/*
110 %{python_sitelib}/*
111 /usr/bin/keyconvert
112 /var/www/html/wsdl/*.wsdl
113
114 %files cm
115 /etc/init.d/sfa-cm
116 %{_bindir}/sfa_component_setup.py*
117 # cron jobs here 
118
119 %files plc
120 %defattr(-,root,root)
121 %config /etc/sfa/default_config.xml
122 %config (noreplace) /etc/sfa/aggregates.xml
123 %config (noreplace) /etc/sfa/registries.xml
124 /etc/init.d/sfa
125 %{_bindir}/sfa-config-tty
126 %{_bindir}/sfa-import-plc.py*
127 %{_bindir}/sfa-clean-peer-records.py*
128 %{_bindir}/sfa-nuke-plc.py*
129 %{_bindir}/gen-sfa-cm-config.py*
130
131 %files client
132 %config (noreplace) /etc/sfa/sfi_config
133 %{_bindir}/sfi.py*
134 %{_bindir}/getNodes.py*
135 %{_bindir}/getRecord.py*
136 %{_bindir}/setRecord.py*
137 %{_bindir}/sfadump.py*
138
139 %files sfatables
140 %{_bindir}/sfatables
141
142 %pre plc
143 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
144
145 %pre cm
146 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
147
148 %post plc
149 chkconfig --add sfa
150
151 %post cm
152 chkconfig --add sfa-cm
153 %changelog
154 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
155 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
156 - - sfa-config-tty now has the same features like plc-config-tty
157 - - Contains code to support both urn and hrn
158 - - Cleaned up request_hash related stuff
159 - - SM, AM and Registry code is organized under respective managers
160 - - Site and Slice synchronization across federated aggregates
161 - - Script to generate sfa_component_config
162
163 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
164 - sfa-config-tty now has the same features like plc-config-tty
165 - Contains code to support both urn and hrn
166 - Cleaned up request_hash related stuff
167 - SM, AM and Registry code is organized under respective managers
168 - Slice synchronization across federated aggregates
169 - some bugs are fixed
170
171 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
172 - checkpoint with fewer mentions of geni
173
174 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
175 - checkpointing
176 - this is believed to pass the tests; among other things:
177 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
178
179 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
180 - This tag includes:
181 - - Sfatables
182 - - Preliminary version of hash based authentication
183 - - Initial code for Component Manager
184 - - Authority structure is moved to /var/lib/sfa/
185 - - some bug-fixes
186
187 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
188 - Create_slice and get_resources methods are connected to sfatables.
189 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
190
191 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
192 - Bug fix on update and remove_peer_object methods
193 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
194
195 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
196 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
197
198 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
199 - compatibility with RefreshPeer
200 - incremental mechanism for importing PLC records into SFA tables
201 - unified single database (still inside the underlying PLC db postgresql server)
202 - includes/improves call traceability and logging features
203 - several bug fixes
204
205 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
206 - added libxslt-python dependency
207
208 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
209 - unified single SFA database in the PLC-DB
210 - upcalls from  PLCAPI to SFA methods
211 - SFA call traceability and logging features
212 - many bug fixes
213 - includes first/rough version of sfatables for policy implementation
214
215 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
216 - snapshot after the GEC5 demo
217 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
218
219 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
220 - snapshot july 15 - has gone through superficial manual testing
221 - hopefully a good basis for gec5 demo
222 - multi-dir sfi client tested as well
223
224 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
225 - rename geniwrapper.spec into sfa.spec
226
227 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
228 - clean up in xmlrpc/soap, --protocol option to chose between both
229 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
230 - hopefully more helpful context in case of crashes when importing
231 - bugfixes for using only /etc/sfa for site-dep files
232 - bugfixes in wsdl generation
233
234 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
235 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
236 - config variables in sfa_config now start with SFA_ and not GENI_
237 - config.py can be loaded even with no config present
238
239 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
240 - first step for cleanup and reorganization
241 - mass-renaming from geni to sfa (some are still needed)
242 - sfa/trust implements the security architecture
243
244 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
245 - snapshot for reproducible builds
246
247 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
248 - snapshot for the convenience of alpha users
249
250 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
251 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
252
253 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
254 - ongoing work - snapshot for 4.3-rc9
255
256 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
257 - various fixes
258
259 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
260 - bugfixes - still a work in progress
261
262 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
263 - initial package
264
265
266 %define module_current_branch 0.2