installing gen-sfa-cm-config.py
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 9
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python
32 Requires: pyOpenSSL >= 0.7
33 Requires: m2crypto
34 Requires: libxslt-python
35 Requires: python-ZSI
36 Requires: python-psycopg2
37 Requires: myplc-config
38
39 # python 2.5 has uuid module added, for python 2.4 we still need it
40 %define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
41 %if has_uuid
42 %else
43 Requires: python-uuid
44 %endif
45
46 %package plc
47 Summary: the SFA wrapper arounf MyPLC
48 Group: Applications/System
49 Requires: sfa
50
51 %package client
52 Summary: the SFA experimenter-side CLI
53 Group: Applications/System
54 Requires: sfa
55
56 %package sfatables
57 Summary: sfatables policy tool for SFA
58 Group: Applications/System
59 Requires: sfa
60
61 %description
62 This package provides the python libraries that the SFA implementation requires
63
64 %description plc
65 This package implements the SFA interface which serves as a layer
66 between the existing PlanetLab interfaces and the SFA API.
67
68 %description client
69 This package provides the client side of the SFA API, in particular
70 sfi.py, together with other utilities.
71
72 %description sfatables
73 sfatables is a tool for defining access and admission control policies
74 in an SFA network, in much the same way as iptables is for ip
75 networks. This is the command line interface to manage sfatables
76
77 %prep
78 %setup -q
79
80 %build
81 make
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 make install DESTDIR="$RPM_BUILD_ROOT"
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 # sfa and sfatables depend each other.
92 /etc/sfatables/*
93 %{python_sitelib}/*
94 /usr/bin/keyconvert
95 /var/www/html/wsdl/*.wsdl
96
97
98 %files plc
99 %defattr(-,root,root)
100 %config /etc/sfa/default_config.xml
101 %config (noreplace) /etc/sfa/aggregates.xml
102 %config (noreplace) /etc/sfa/registries.xml
103 /etc/init.d/sfa
104 %{_bindir}/sfa-config-tty
105 %{_bindir}/sfa-import-plc.py*
106 %{_bindir}/sfa-clean-peer-records.py*
107 %{_bindir}/sfa-nuke-plc.py*
108 %{_bindir}/sfa-server.py*
109 %{_bindir}/gen-sfa-cm-config.py*
110
111 %files client
112 %config (noreplace) /etc/sfa/sfi_config
113 %{_bindir}/sfi.py*
114 %{_bindir}/getNodes.py*
115 %{_bindir}/getRecord.py*
116 %{_bindir}/setRecord.py*
117 %{_bindir}/sfadump.py*
118
119 %files sfatables
120 %{_bindir}/sfatables
121
122 %pre plc
123 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
124
125 %post plc
126 chkconfig --add sfa
127
128 %changelog
129 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
130 - sfa-config-tty now has the same features like plc-config-tty
131 - Contains code to support both urn and hrn
132 - Cleaned up request_hash related stuff
133 - SM, AM and Registry code is organized under respective managers
134 - Slice synchronization across federated aggregates
135 - some bugs are fixed
136
137 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
138 - checkpoint with fewer mentions of geni
139
140 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
141 - checkpointing
142 - this is believed to pass the tests; among other things:
143 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
144
145 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
146 - This tag includes:
147 - - Sfatables
148 - - Preliminary version of hash based authentication
149 - - Initial code for Component Manager
150 - - Authority structure is moved to /var/lib/sfa/
151 - - some bug-fixes
152
153 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
154 - Create_slice and get_resources methods are connected to sfatables.
155 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
156
157 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
158 - Bug fix on update and remove_peer_object methods
159 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
160
161 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
162 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
163
164 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
165 - compatibility with RefreshPeer
166 - incremental mechanism for importing PLC records into SFA tables
167 - unified single database (still inside the underlying PLC db postgresql server)
168 - includes/improves call traceability and logging features
169 - several bug fixes
170
171 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
172 - added libxslt-python dependency
173
174 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
175 - unified single SFA database in the PLC-DB
176 - upcalls from  PLCAPI to SFA methods
177 - SFA call traceability and logging features
178 - many bug fixes
179 - includes first/rough version of sfatables for policy implementation
180
181 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
182 - snapshot after the GEC5 demo
183 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
184
185 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
186 - snapshot july 15 - has gone through superficial manual testing
187 - hopefully a good basis for gec5 demo
188 - multi-dir sfi client tested as well
189
190 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
191 - rename geniwrapper.spec into sfa.spec
192
193 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
194 - clean up in xmlrpc/soap, --protocol option to chose between both
195 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
196 - hopefully more helpful context in case of crashes when importing
197 - bugfixes for using only /etc/sfa for site-dep files
198 - bugfixes in wsdl generation
199
200 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
201 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
202 - config variables in sfa_config now start with SFA_ and not GENI_
203 - config.py can be loaded even with no config present
204
205 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
206 - first step for cleanup and reorganization
207 - mass-renaming from geni to sfa (some are still needed)
208 - sfa/trust implements the security architecture
209
210 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
211 - snapshot for reproducible builds
212
213 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
214 - snapshot for the convenience of alpha users
215
216 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
217 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
218
219 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
220 - ongoing work - snapshot for 4.3-rc9
221
222 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
223 - various fixes
224
225 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
226 - bugfixes - still a work in progress
227
228 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
229 - initial package
230
231
232 %define module_current_branch 0.2