Setting tag sfa-1.0-3
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 1.0
9 %define taglevel 3
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: xmlsec1-openssl-devel
34 Requires: libxslt-python
35 Requires: python-ZSI
36 # xmlbuilder depends on  lxml
37 Requires: python-lxml
38 Requires: python-setuptools
39 Requires: python-dateutil
40  
41 # python 2.5 has uuid module added, for python 2.4 we still need it.
42 # we can't really check for if we can load uuid as a python module,
43 # it'll be installed by "devel.pkgs". we have the epel repository so
44 # python-uuid will be provided. but we can test for the python
45 # version.
46 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
47 # %if %has_py24
48 #
49 # this also didn't work very well. I'll just check for distroname - baris
50 #%if %{distroname} == "centos5"
51 #Requires: python-uuid
52 #%endif
53
54 %package cm
55 Summary: the SFA wrapper around MyPLC's NodeManager
56 Group: Applications/System
57 Requires: sfa
58 Requires: pyOpenSSL >= 0.6
59
60 %package plc
61 Summary: the SFA wrapper arounf MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65 Requires: myplc-config
66 Requires: pyOpenSSL >= 0.7
67
68 %package client
69 Summary: the SFA experimenter-side CLI
70 Group: Applications/System
71 Requires: sfa
72 Requires: pyOpenSSL >= 0.7
73
74 %package sfatables
75 Summary: sfatables policy tool for SFA
76 Group: Applications/System
77 Requires: sfa
78
79 %description
80 This package provides the python libraries that the SFA implementation requires
81
82 %description cm
83 This package implements the SFA interface which serves as a layer
84 between the existing PlanetLab NodeManager interfaces and the SFA API.
85  
86 %description plc
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab interfaces and the SFA API.
89
90 %description client
91 This package provides the client side of the SFA API, in particular
92 sfi.py, together with other utilities.
93
94 %description sfatables
95 sfatables is a tool for defining access and admission control policies
96 in an SFA network, in much the same way as iptables is for ip
97 networks. This is the command line interface to manage sfatables
98
99 %prep
100 %setup -q
101
102 %build
103 make
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 make install DESTDIR="$RPM_BUILD_ROOT"
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 # sfa and sfatables depend each other.
114 %{_bindir}/sfa-server.py*
115 /etc/sfatables/*
116 %{python_sitelib}/*
117 %{_bindir}/keyconvert.py*
118 /var/www/html/wsdl/*.wsdl
119
120 %files cm
121 /etc/init.d/sfa-cm
122 %{_bindir}/sfa_component_setup.py*
123 # cron jobs here 
124
125 %files plc
126 %defattr(-,root,root)
127 %config /etc/sfa/default_config.xml
128 %config (noreplace) /etc/sfa/aggregates.xml
129 %config (noreplace) /etc/sfa/registries.xml
130 /etc/init.d/sfa
131 /etc/sfa/pl.rng
132 %{_bindir}/sfa-config-tty
133 %{_bindir}/sfa-import-plc.py*
134 %{_bindir}/sfa-clean-peer-records.py*
135 %{_bindir}/sfa-nuke-plc.py*
136 %{_bindir}/gen-sfa-cm-config.py*
137 %{_bindir}/sfa-ca.py*
138
139 %files client
140 %config (noreplace) /etc/sfa/sfi_config
141 %{_bindir}/sfi*
142 %{_bindir}/getNodes.py*
143 %{_bindir}/getRecord.py*
144 %{_bindir}/setRecord.py*
145 %{_bindir}/sfadump.py*
146
147 %files sfatables
148 %{_bindir}/sfatables
149
150 ### sfa-plc installs the 'sfa' service
151 %post plc
152 chkconfig --add sfa
153
154 %preun plc
155 if [ "$1" = 0 ] ; then
156   /sbin/service sfa stop || :
157   /sbin/chkconfig --del sfa || :
158 fi
159
160 %postun plc
161 [ "$1" -ge "1" ] && service sfa restart
162
163 ### sfa-cm installs the 'sfa-cm' service
164 %post cm
165 chkconfig --add sfa-cm
166
167 %preun cm
168 if [ "$1" = 0 ] ; then
169    /sbin/service sfa-cm stop || :
170    /sbin/chkconfig --del sfa-cm || :
171 fi
172
173 %postun cm
174 [ "$1" -ge "1" ] && service sfa-cm restart
175
176
177 %changelog
178 * Wed Oct 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-1.0-3
179 - various cleanups.
180 - tagging the commit before merge.
181
182 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
183 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
184 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
185 - hrn-urn translations tweaked
186 - fixed 'service sfa status'
187 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
188 - started to repair sfadump - although not usable yet
189 - trust objects now have dump_string method that dump() actually prints
190 - unit tests under review
191 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
192 - binaries now support -v or -vv to increase loglevel
193 - trashed obsolete sfa.util.client
194
195 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
196 - various bugfixes and cleanup, improved/harmonized logging
197
198 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
199 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
200   to avoid returning a PLCAPI exception that might confuse users.
201 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
202 - fix build errors.  
203
204 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
205 - (Architecture) Credential format changed to match ProtoGENI xml format
206 - (Architecture) All interfaces export a new set of methods that are compatible
207    with the ProtoGeni Aggregate spec. These new methods are considered a 
208    replacement  for the pervious methods exported by the interfaces. All 
209    previous methods are still exported and work as normal, but they are 
210    considered deprecated and will not be supported in future releases.  
211 - (Architecture) SFI has been updated to use the new interface methods.
212 - (Architecture) Changed keyconvet implementation from c to python.
213 - (Architecture) Slice Manager now attempts looks for a delegated credential
214   provided by the client before using its own server credential.
215 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
216   This cache now exists only in memory and is cleared when service is restarted
217   or cache lifetime is exceeded.  
218 - (Performance) SliceManager sends request to Aggregates in parallel instead 
219   of sequentially.
220 - (Bug fix) SFA tickets now support the new rspec format.
221 - (Bug fix) SFI only uses cahced credential if they aren't expired.
222 - (Bug fix) Cerdential delegation modified to work with new credential format.
223 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
224   Aggregate instead of relaying through the Slice Manager.
225 - (Enhancement) Simplified caching. Accociated a global cache instance with
226   the api handler on every new server request, making it easier to access the 
227   cache and use in more general ways.     
228
229 %changelog
230 * Wed Oct 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-1.0-3
231 - various cleanups.
232 - tagging the commit before merge.
233
234 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
235 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
236 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
237 - hrn-urn translations tweaked
238 - fixed 'service sfa status'
239 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
240 - started to repair sfadump - although not usable yet
241 - trust objects now have dump_string method that dump() actually prints
242 - unit tests under review
243 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
244 - binaries now support -v or -vv to increase loglevel
245 - trashed obsolete sfa.util.client
246
247 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
248 - various bugfixes and cleanup, improved/harmonized logging
249
250 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
251 - SfaServer now uses a pool of threads to handle requests concurrently
252 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
253 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
254 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
255 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
256 - Component manager does not install gid files if slice already has them  
257 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
258 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
259 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
260      
261 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
262 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
263 - - sfa-config-tty now has the same features like plc-config-tty
264 - - Contains code to support both urn and hrn
265 - - Cleaned up request_hash related stuff
266 - - SM, AM and Registry code is organized under respective managers
267 - - Site and Slice synchronization across federated aggregates
268 - - Script to generate sfa_component_config
269
270 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
271 - sfa-config-tty now has the same features like plc-config-tty
272 - Contains code to support both urn and hrn
273 - Cleaned up request_hash related stuff
274 - SM, AM and Registry code is organized under respective managers
275 - Slice synchronization across federated aggregates
276 - some bugs are fixed
277
278 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
279 - checkpoint with fewer mentions of geni
280
281 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
282 - checkpointing
283 - this is believed to pass the tests; among other things:
284 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
285
286 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
287 - This tag includes:
288 - - Sfatables
289 - - Preliminary version of hash based authentication
290 - - Initial code for Component Manager
291 - - Authority structure is moved to /var/lib/sfa/
292 - - some bug-fixes
293
294 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
295 - Create_slice and get_resources methods are connected to sfatables.
296 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
297
298 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
299 - Bug fix on update and remove_peer_object methods
300 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
301
302 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
303 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
304
305 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
306 - compatibility with RefreshPeer
307 - incremental mechanism for importing PLC records into SFA tables
308 - unified single database (still inside the underlying PLC db postgresql server)
309 - includes/improves call traceability and logging features
310 - several bug fixes
311
312 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
313 - added libxslt-python dependency
314
315 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
316 - unified single SFA database in the PLC-DB
317 - upcalls from  PLCAPI to SFA methods
318 - SFA call traceability and logging features
319 - many bug fixes
320 - includes first/rough version of sfatables for policy implementation
321
322 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
323 - snapshot after the GEC5 demo
324 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
325
326 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
327 - snapshot july 15 - has gone through superficial manual testing
328 - hopefully a good basis for gec5 demo
329 - multi-dir sfi client tested as well
330
331 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
332 - rename geniwrapper.spec into sfa.spec
333
334 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
335 - clean up in xmlrpc/soap, --protocol option to chose between both
336 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
337 - hopefully more helpful context in case of crashes when importing
338 - bugfixes for using only /etc/sfa for site-dep files
339 - bugfixes in wsdl generation
340
341 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
342 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
343 - config variables in sfa_config now start with SFA_ and not GENI_
344 - config.py can be loaded even with no config present
345
346 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
347 - first step for cleanup and reorganization
348 - mass-renaming from geni to sfa (some are still needed)
349 - sfa/trust implements the security architecture
350
351 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
352 - snapshot for reproducible builds
353
354 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
355 - snapshot for the convenience of alpha users
356
357 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
358 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
359
360 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
361 - ongoing work - snapshot for 4.3-rc9
362
363 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
364 - various fixes
365
366 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
367 - bugfixes - still a work in progress
368
369 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
370 - initial package
371
372
373 %define module_current_branch 0.2