Removed some debuggin print statements.
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 5
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36
37 # python 2.5 has uuid module added, for python 2.4 we still need it
38 %define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
39 %if has_uuid
40 %else
41 Requires: python-uuid
42 %endif
43
44 %package plc
45 Summary: the SFA wrapper arounf MyPLC
46 Group: Applications/System
47 Requires: sfa
48
49 %package client
50 Summary: the SFA experimenter-side CLI
51 Group: Applications/System
52 Requires: sfa
53
54 %package sfatables
55 Summary: sfatables policy tool for SFA
56 Group: Applications/System
57 Requires: sfa
58
59 %description
60 This package provides the python libraries that the SFA implementation requires
61
62 %description plc
63 Geniwrapper implements the SFA interface which serves as a layer
64 between the existing PlanetLab interfaces and the SFA API.
65
66 %description client
67 This package provides the client side of the SFA API, in particular
68 sfi.py, together with other utilities.
69
70 %description sfatables
71 sfatables is a tool for defining access and admission control policies
72 in an SFA network, in much the same way as iptables is for ip
73 networks. This is the command line interface to manage sfatables
74
75 %prep
76 %setup -q
77
78 %build
79 make
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 make install DESTDIR="$RPM_BUILD_ROOT"
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 # sfa and sfatables depend each other.
90 /etc/sfatables/*
91 %{python_sitelib}/*
92 /usr/bin/keyconvert
93 /var/www/html/wsdl/*.wsdl
94
95
96 %files plc
97 %defattr(-,root,root)
98 %config (noreplace) /etc/sfa/sfa_config
99 %config (noreplace) /etc/sfa/aggregates.xml
100 %config (noreplace) /etc/sfa/registries.xml
101 /etc/init.d/sfa
102 %{_bindir}/sfa-config-tty
103 %{_bindir}/sfa-import-plc.py*
104 %{_bindir}/sfa-clean-peer-records.py*
105 %{_bindir}/sfa-nuke-plc.py*
106 %{_bindir}/sfa-server.py*
107
108 %files client
109 %config (noreplace) /etc/sfa/sfi_config
110 %{_bindir}/sfi.py*
111 %{_bindir}/getNodes.py*
112 %{_bindir}/getRecord.py*
113 %{_bindir}/setRecord.py*
114 %{_bindir}/genidump.py*
115
116 %files sfatables
117 %{_bindir}/sfatables
118
119 %pre plc
120 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
121
122 %post plc
123 chkconfig --add sfa
124
125 %changelog
126 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
127 - Create_slice and get_resources methods are connected to sfatables.
128 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
129
130 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
131 - Bug fix on update and remove_peer_object methods
132 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
133
134 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
135 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
136
137 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
138 - compatibility with RefreshPeer
139 - incremental mechanism for importing PLC records into SFA tables
140 - unified single database (still inside the underlying PLC db postgresql server)
141 - includes/improves call traceability and logging features
142 - several bug fixes
143
144 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
145 - added libxslt-python dependency
146
147 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
148 - unified single SFA database in the PLC-DB
149 - upcalls from  PLCAPI to SFA methods
150 - SFA call traceability and logging features
151 - many bug fixes
152 - includes first/rough version of sfatables for policy implementation
153
154 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
155 - snapshot after the GEC5 demo
156 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
157
158 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
159 - snapshot july 15 - has gone through superficial manual testing
160 - hopefully a good basis for gec5 demo
161 - multi-dir sfi client tested as well
162
163 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
164 - rename geniwrapper.spec into sfa.spec
165
166 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
167 - clean up in xmlrpc/soap, --protocol option to chose between both
168 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
169 - hopefully more helpful context in case of crashes when importing
170 - bugfixes for using only /etc/sfa for site-dep files
171 - bugfixes in wsdl generation
172
173 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
174 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
175 - config variables in sfa_config now start with SFA_ and not GENI_
176 - config.py can be loaded even with no config present
177
178 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
179 - first step for cleanup and reorganization
180 - mass-renaming from geni to sfa (some are still needed)
181 - sfa/trust implements the security architecture
182
183 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
184 - snapshot for reproducible builds
185
186 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
187 - snapshot for the convenience of alpha users
188
189 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
190 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
191
192 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
193 - ongoing work - snapshot for 4.3-rc9
194
195 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
196 - various fixes
197
198 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
199 - bugfixes - still a work in progress
200
201 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
202 - initial package
203
204
205 %define module_current_branch 0.2