first attempt to split sfa package into
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 23
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package dummy
83 Summary: the SFA layer around a Dummy Testbed 
84 Group: Applications/System
85 Requires: sfa
86
87 %package sfatables
88 Summary: sfatables policy tool for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %package xmlbuilder
93 Summary: third-party xmlbuilder tool
94 Group: Applications/System
95 Provides: python-xmlbuilder
96
97 %package tests
98 Summary: unit tests suite for SFA
99 Group: Applications/System
100 Requires: sfa-common
101
102 %description
103 This package provides the python libraries for the PlanetLab implementation of SFA
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description plc
110 This package implements the SFA interface which serves as a layer
111 between the existing PlanetLab interfaces and the SFA API.
112
113 %description flashpolicy
114 This package provides support for adobe flash client applications.  
115
116 %description federica
117 The SFA driver for FEDERICA.
118
119 %description nitos
120 The SFA driver for NITOS.
121
122 %description dummy
123 The SFA driver for a Dummy Testbed.
124
125 %description sfatables
126 sfatables is a tool for defining access and admission control policies
127 in an SFA network, in much the same way as iptables is for ip
128 networks. This is the command line interface to manage sfatables
129
130 %description xmlbuilder
131 This package contains the xmlbuilder python library, packaged for
132 convenience as it is not supported by fedora
133
134 %description tests
135 Provides some binary unit tests in /usr/share/sfa/tests
136
137 %prep
138 %setup -q
139
140 %build
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 /etc/init.d/sfa
152 %{_bindir}/sfa-start.py*
153 %{_bindir}/sfaadmin.py*
154 %{_bindir}/sfaadmin
155 %{_bindir}/keyconvert.py*
156 %{_bindir}/sfa-config-tty
157 %{_bindir}/sfa-config
158 %config /etc/sfa/default_config.xml
159 %config (noreplace) /etc/sfa/aggregates.xml
160 %config (noreplace) /etc/sfa/registries.xml
161 /usr/share/sfa/migrations
162 /usr/share/sfa/examples
163 /var/www/html/wsdl/*.wsdl
164
165 %files common
166 %{python_sitelib}/sfa/__init__.py*
167 %{python_sitelib}/sfa/trust
168 %{python_sitelib}/sfa/storage
169 %{python_sitelib}/sfa/util
170 %{python_sitelib}/sfa/server
171 %{python_sitelib}/sfa/methods
172 %{python_sitelib}/sfa/generic
173 %{python_sitelib}/sfa/managers
174 %{python_sitelib}/sfa/importer
175 %{python_sitelib}/sfa/rspecs
176 %{python_sitelib}/sfa/client
177
178 %files client
179 %config (noreplace) /etc/sfa/sfi_config
180 %{_bindir}/sfi*.py*
181 %{_bindir}/sfi
182 %{_bindir}/get*.py*
183 %{_bindir}/setRecord.py*
184 %{_bindir}/sfascan.py*
185 %{_bindir}/sfascan
186 %{_bindir}/sfadump.py*
187
188 %files plc
189 %defattr(-,root,root)
190 %{python_sitelib}/sfa/planetlab
191 %{python_sitelib}/sfa/openstack
192 /etc/sfa/pl.rng
193 /etc/sfa/credential.xsd
194 /etc/sfa/top.xsd
195 /etc/sfa/sig.xsd
196 /etc/sfa/xml.xsd
197 /etc/sfa/protogeni-rspec-common.xsd
198 /etc/sfa/topology
199
200 %files flashpolicy
201 %{_bindir}/sfa_flashpolicy.py*
202 /etc/sfa/sfa_flashpolicy_config.xml
203
204 %files federica
205 %{python_sitelib}/sfa/federica
206
207 %files nitos
208 %{python_sitelib}/sfa/nitos
209
210 %files dummy
211 %{python_sitelib}/sfa/dummy
212
213 %files sfatables
214 /etc/sfatables/*
215 %{_bindir}/sfatables
216 %{python_sitelib}/sfatables
217
218 %files xmlbuilder
219 %{python_sitelib}/xmlbuilder
220
221 %files tests
222 %{_datadir}/sfa/tests
223
224 ### sfa installs the 'sfa' service
225 %post 
226 chkconfig --add sfa
227
228 %preun 
229 if [ "$1" = 0 ] ; then
230   /sbin/service sfa stop || :
231   /sbin/chkconfig --del sfa || :
232 fi
233
234 %postun
235 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
236
237 #### sfa-cm installs the 'sfa-cm' service
238 #%post cm
239 #chkconfig --add sfa-cm
240 #
241 #%preun cm
242 #if [ "$1" = 0 ] ; then
243 #   /sbin/service sfa-cm stop || :
244 #   /sbin/chkconfig --del sfa-cm || :
245 #fi
246 #
247 #%postun cm
248 #[ "$1" -ge "1" ] && service sfa-cm restart || :
249
250 %changelog
251 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
252 - minor fix in registry
253 - fix for sfi gid, use clientbootstrap
254 - support for debians and ubuntus (packaging and initscript)
255 - deprecated cm package altogether
256 - pl flavour, minor fix for tags
257 - various fixes for the dummy flavour
258
259 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
260 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
261 - tweaks in nitos importer
262 - improvements to sfaadmin check-gid
263
264 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
265 - PL importer: minor fixes for corner cases
266 - PL importer: also handles last_updated more accurately
267 - sfi update can be used to select a key among several in PL
268 - sfi add/update usage message fixes (no more record)
269 - new feature sfaadmin registry check_gid [-a]
270
271 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
272 - fix 2 major bugs in PL importer
273 - esp. wrt GID management against PLC key
274
275 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
276 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
277
278 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
279 - support fordelegation in sfaclientlib
280 - sfi delegate fixed
281 - other delegation-related sfi option trashed
282 - new config (based on ini format)
283 - new dummy driver and related package
284 - pl importer has more explicit error messages
285 - credential dump shows expiration
286
287 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
288 - bugfix in forwarding Resolve requests
289 - various fixes in the nitos driver wrt keys and users
290
291 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
292 - various tweaks for the nitos driver
293
294 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
295 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
296 - deeper cleanup of the data-dependencies between SFA and the testbed
297 - in particular, sfi create issues Resolve(details=False)
298 - for that purpose, Resolve exposes reg-* keys for SFA builtins
299 - which in turn allows sfi list to show PIs, slice members and keys
300 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
301 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
302
303 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
304 - configurable data-dir (/var/lib/sfa)
305 - no more dependent on myplc-config
306 - some support for hrns with _ instead of \.
307 - fix for PL importing in presence of gpg keys
308 - DeleteSliver returns True instead of 1 in case of success
309 - Various improvements on the openstack/nova side
310 - new package sfa-nitos
311
312 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
313 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
314 - sfi to remove expired credentials
315
316 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
317 - Update Openstack driver to support Essex release/
318 - Fix authority xrn bug.
319   
320
321 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
322 - review packaging - site-packages/planetlab now come with sfa-plc
323 - new package sfa-federica
324 - clientbin moved one step upwards
325
326 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
327 - fix bug in sfi update()
328
329 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
330 - fix broken sfa.util.xrn class for lowercase
331
332 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
333 - new 'void' generic_flavour for running in registry-only mode
334 - first shot at refactoring importers - probably needs more work
335 - openstack: various enhancements
336 - sfi interface to registry not based on xml files anymore
337 - sfi show sorts result on record key
338 - bugfix in sfa update on users with a pl-backed registry
339
340 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
341 - renamed sfa/plc into sfa/planetlab
342 - plxrn moved in sfa/planetlab as well
343 - bugfix for sfaadmin reg update --pi <>
344
345 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
346 - native data model now has a authority x user (PI) relationship
347 - no call to 'augment_records_with_testbed_info' for GetCredential
348 - which means, registry can now be used without an underlying testbed
349 - reviewed code about relationships b/w objects and related in pl driver
350 - reviewed PL import wrt roles and pis
351 - removed mentions to is_enabled in driver
352 - small changes in update_relation* in driver interface
353 - sfaadmin: can create authorities and attach pi users to them
354 - sfaadmin: categories can be abbreviated
355 - sfi list and sfaadmin list have a new -r/--recursive option
356 - this means that List now supports an (optional) 'options' argument
357 - sfi config can display config vars
358 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
359
360 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
361 - make sync now supports vserver or lxc.
362 - Added slice expiration and login info to SliverStatus response. 
363 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
364   the 'component_name' attribute.
365 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
366   
367 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
368 - Introduced new administrative command line script, sfaadmin.py. Removed various single
369  purpose scripts and migrated their functionality into sfaadmin.py.
370 - Refactored Registry import scripts.
371 - Removed SQLAlchemy dependency from sfi.py.
372 - Fixed bugs in sfi.py
373 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
374
375 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
376 - slice x researcher rel. in database,
377 - plimporter to maintain that, as well as user.email, and more robust
378 - ongoing draft for sfaadmin tool
379 - support for a federica driver
380 - support for a nova/euca driver
381 - no more sfa-clean-peer-records script
382
383 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
384 - registry database has user's keys and mail (known as v0 for migrate)
385 - pl importer properly maintains user's keys and mail
386 - pl driver now to handle 'role' when adding person record (exp.)
387 - first draft of federica driver with config section
388 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
389 - plus, from master as of tag merged-in-sfa-2.1-2:
390 - disk_image revisited
391 - new nova_shell nova_driver & various tweaks for openstack
392
393 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
394 - uses sqlalchemy and related migrate
395 - thorough migration and upgrade scheme
396 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
397 - trashed dbinfo stuff in auth hierarchy
398 - data model still has little more than plain records
399 - checkpoint tag, not yet intended for release
400
401 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
402 - client: added -R --raw sfi cmdline option that displays raw server response.
403 - client: request GENI RSpec by default. 
404 - server: remove database dependencies from sfa.server.sfaapi.
405 - server: increased default credential lifetime to 31 days.
406 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
407 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
408 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
409  
410 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
411 - bugfix: 'geni_api' should be in the top level struct, not the code struct
412 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
413           output returned by the Aggregate Manager.
414 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
415 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
416 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
417           there is extra whitespace in the schemaLocation field.
418 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
419           advertisement rspecs.
420 - bugfix: <login> RSpec element should contain the 'username' attribute.
421 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
422  
423 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
424 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
425   exit when it encountered a user with an invalid public key.
426 - server: imporved logging in sfa-import-plc.py
427  
428 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
429 - bugfix: Fixed appending public keys in CreateSliver
430 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
431 - client: -c --current option allows users to request the current/uncached rspec.
432 - server: Added 'geni_api_versions' field to GetVersion() output.
433 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
434    
435 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
436 - bugfix: sfi was not sending call_id with ListResources to v2 servers
437 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
438 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
439
440 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
441 - client: sfi -a / -p deprecated (use -s instead)
442 - client: sfi cleaned up
443 - client: sfi has backward support for APIv1 aggregates again
444 - server: only APIv2 is supported and should be rather strict
445 - server: settings for turning on/off caching in sm or am
446 - server: plc-dependant code has moved from aggregate to pldriver
447 - server: driver interface extended accordingly
448
449 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
450 - screwed up previous tag
451
452 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
453 - client side revisited with a bootstrap library
454 - client side has a new source layout
455 - various (nasty) bug fixes wrt options and call_id
456
457 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
458 - various fixes in rspecs for sfav1&slice tags
459 - uses 'geni_rspec_version' and not just 'rspec_version'
460 - example flavour for the max testbed
461 - embryo for an sfa client library
462 - topology.py moved into plc
463 - sql: table is named records; record_types are enforced
464 - sql: table creation cleaned up
465
466 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
467 - cleaned up all references to SFA_*_TYPE in config
468 - enable cache at the aggregate by default
469 - registry now uses the driver in a sensible way (see managers/driver.py)
470 - slice manager supports sfav1/pgv2 neighbours
471 - get_key renamed into get_key_from_incoming_ip
472 - new sfa.storage module for record/table and all db-related stuff
473 - db schema in sfa.storage.sfa.sql
474 - init.d and cron.d move one step up
475 - cleaned up rspec/ directory
476 - add deps to pyopenssl and myplc-config
477 - start support for new API (return value)
478 - plc.remoteshell removed, use plshell instead
479 - plshell uses a 'capability' auth method whenever possible
480 - various tweaks in rspec elements
481 - made dependency on sfatables softer
482
483 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
484 - sfa should now be started *before* the initial import
485 - sfa to use its own database (default sfa) - can run without myplc
486 - server calls support optional 'options'
487 - client sends options in argument when needed
488 - fix infinite getattr recursion in elements/element.py
489 - error codes in line with geni
490
491 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
492 - fixed links and attributes in rspecs
493 - minor cleanup in the API methods, and more consistent names in manager methods
494
495 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
496 - ongoing refoactoring towards more genericity
497 - passes tests again although known issues remain with attributes/tags
498
499 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
500 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
501 - improvements in the pgv2 rspecs
502 - driver separated from api
503 - code starts moving around where it belongs
504 - sfascan caches getversion across invokations
505 - vini topology extracted as a config file
506
507 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
508 - first support for protogeni rspecs is working
509 - vini no longer needs a specific manager
510 - refactoring underway towards more flexible/generic architecture
511
512 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
513 - Unicode-friendliness for user names with accents/special chars.
514 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
515 - CreaetSliver no longer fails for users that have a capital letter in their URN.
516 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
517 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
518 - Fix bugs and missing imports     
519  
520
521 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
522 - new method record.get_field for sface
523
524 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
525 - new option -c to sfa-nuke-plc.py
526 - CreateSliver fixed for admin-only slice tags
527
528 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
529 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
530 - Fixed holes in certificate verification logic.
531 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
532 - Added 'boot_state' as an attribute of the node element in SFA rspec.
533 - Non authority certificates are marked as CA:FALSE.
534
535 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
536 - fix typo in sfa-1.0-31 tag.
537 - added CreateGid() Registry interface method.
538
539 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
540 - fix typo in sfa-1.0-30 tag
541
542 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
543 - Declare namespace and schema location in the credential.
544 - Fix bug that prevetend connections from timing out.
545 - Fix slice delegation.
546 - Add statistics to slicemaanger listresources/createsliver rspec.
547 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
548   of days a user can extend their slice expiration.
549 - CA certs are only issued to objects of type authority
550    
551 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
552 - tag 1.0-28 was broken due to typo in the changelog
553 - new class sfa/util/httpsProtocol.py that supports timeouts
554
555 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
556 - Resolved issue that caused sfa hold onto idle db connections.
557 - Fix bug that caused the registry to use the wrong type of credential.
558 - Support authority+sm type.
559 - Fix rspec merging bugs.
560 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
561 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
562  planetlab hosted initscripts using the <planetlab:initscript> tag  
563 - Can now handle extraneous whitespace in the rspec without failing.   
564  
565 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
566 - ProtoGENI v2 RSpec updates.
567 - Convert expiration timestamps with timezone info in credentials to utc.
568 - Fixed redundant logging issue. 
569 - Improved SliceManager and SFI client logging.
570 - Support aggregates that don't support the optional 'call_id' argument. 
571 - Only call get_trusted_certs() at aggreage interfaces that support the call.
572 - CreateSliver() now handles MyPLC slice attributes/tags.
573 - Cache now supports persistence.
574 - Hide whitelisted nodes.
575
576 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
577 - fixed issues with sup authority signing
578 - fixed bugs in remove_slivers and SliverStatus
579
580 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
581 - fix typo that prevented aggregates from operating properly
582
583 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
584 - load trusted certs into ssl context prior to handshake
585 - client's logfile lives in ~/.sfi/sfi.log
586
587 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
588 - includes a change on passphrases that was intended in 1.0-22
589
590 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
591 - Added support for ProtoGENI RSpec v2
592  
593 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
594 - stable sfascan
595 - fix in initscript, *ENABLED tags in config now taken into account
596
597 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
598 - some commits had not been pushed in tag 19
599
600 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
601 - GetVersion should now report full URLs with path
602 - scansfa has nicer output and new syntax (entry URLs as args and not options)
603 - dos2unix'ed flash policy pill
604
605 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
606 - fix packaging again for f8
607
608 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
609 - fix packaging (apparently broken in 1.0-16)
610 - first working version of sfascan
611 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
612 - deprecated the sfa_geni_aggregate config category
613
614 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
615 - Fix build problem
616 - First version of SFA scanner
617
618 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
619 - Add support for Flash clients using flashpolicy
620 - Fix problems with tag handling in RSpec
621
622 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
623 - Modifications to the Eucalyptus Aggregate Manager
624 - Fixes for VINI RSpec
625 - Fix tag handling for PL RSpec
626 - Fix XML Schema ordering for <urn> element
627
628 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
629 - just set x509 version to 2
630
631 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
632 - added urn to the node area in rspecs
633 - conversion to urn now exports fqdn
634 - sfa-import-plc.py now creates a unique registry record for each SFA interface
635
636 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
637 - undo broken attempt for python-2.7
638
639 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
640 - SMs avoid duplicates for when call graph has dags;
641 - just based on network's name, when a duplicate occurs, one is just dropped
642 - does not try to merge/aggregate 2 networks
643 - also reviewed logging with the hope to fix the sfa startup msg:
644 - TypeError: not all arguments converted during string formatting
645
646 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
647 - verify credentials against xsd schema
648 - Fix SM to SM communication
649 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
650 - new setting session_key_path
651
652 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
653 - fix registry credential regeneration and handle expiration
654 - support for setting slice tags (min_role=user)
655 - client can display its own version: sfi.py version --local
656 - GetVersion to provide urn in addition to hrn
657 - more code uses plxrn vs previous helper functions
658 - import replaces '+' in email addresses with '_'
659
660 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
661 - fix GetVersion code_tag and add code_url
662
663 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
664 - extend GetVersion towards minimum federation introspection, and expose local tag
665
666 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
667 - fixed some legacy issues (list vs List)
668 - deprecated sfa.util.namespace for xrn and plxrn
669 - unit tests ship as the sfa-tests rpm
670
671 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
672 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
673 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
674 - hrn-urn translations tweaked
675 - fixed 'service sfa status'
676 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
677 - started to repair sfadump - although not usable yet
678 - trust objects now have dump_string method that dump() actually prints
679 - unit tests under review
680 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
681 - binaries now support -v or -vv to increase loglevel
682 - trashed obsolete sfa.util.client
683
684 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
685 - various bugfixes and cleanup, improved/harmonized logging
686
687 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
688 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
689   to avoid returning a PLCAPI exception that might confuse users.
690 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
691 - fix build errors.  
692
693 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
694 - (Architecture) Credential format changed to match ProtoGENI xml format
695 - (Architecture) All interfaces export a new set of methods that are compatible
696    with the ProtoGeni Aggregate spec. These new methods are considered a 
697    replacement  for the pervious methods exported by the interfaces. All 
698    previous methods are still exported and work as normal, but they are 
699    considered deprecated and will not be supported in future releases.  
700 - (Architecture) SFI has been updated to use the new interface methods.
701 - (Architecture) Changed keyconvet implementation from c to python.
702 - (Architecture) Slice Manager now attempts looks for a delegated credential
703   provided by the client before using its own server credential.
704 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
705   This cache now exists only in memory and is cleared when service is restarted
706   or cache lifetime is exceeded.  
707 - (Performance) SliceManager sends request to Aggregates in parallel instead 
708   of sequentially.
709 - (Bug fix) SFA tickets now support the new rspec format.
710 - (Bug fix) SFI only uses cahced credential if they aren't expired.
711 - (Bug fix) Cerdential delegation modified to work with new credential format.
712 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
713   Aggregate instead of relaying through the Slice Manager.
714 - (Enhancement) Simplified caching. Accociated a global cache instance with
715   the api handler on every new server request, making it easier to access the 
716   cache and use in more general ways.     
717
718 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
719 - SfaServer now uses a pool of threads to handle requests concurrently
720 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
721 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
722 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
723 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
724 - Component manager does not install gid files if slice already has them  
725 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
726 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
727 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
728      
729 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
730 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
731 - - sfa-config-tty now has the same features like plc-config-tty
732 - - Contains code to support both urn and hrn
733 - - Cleaned up request_hash related stuff
734 - - SM, AM and Registry code is organized under respective managers
735 - - Site and Slice synchronization across federated aggregates
736 - - Script to generate sfa_component_config
737
738 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
739 - sfa-config-tty now has the same features like plc-config-tty
740 - Contains code to support both urn and hrn
741 - Cleaned up request_hash related stuff
742 - SM, AM and Registry code is organized under respective managers
743 - Slice synchronization across federated aggregates
744 - some bugs are fixed
745
746 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
747 - checkpoint with fewer mentions of geni
748
749 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
750 - checkpointing
751 - this is believed to pass the tests; among other things:
752 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
753
754 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
755 - This tag includes:
756 - - Sfatables
757 - - Preliminary version of hash based authentication
758 - - Initial code for Component Manager
759 - - Authority structure is moved to /var/lib/sfa/
760 - - some bug-fixes
761
762 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
763 - Create_slice and get_resources methods are connected to sfatables.
764 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
765
766 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
767 - Bug fix on update and remove_peer_object methods
768 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
769
770 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
771 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
772
773 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
774 - compatibility with RefreshPeer
775 - incremental mechanism for importing PLC records into SFA tables
776 - unified single database (still inside the underlying PLC db postgresql server)
777 - includes/improves call traceability and logging features
778 - several bug fixes
779
780 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
781 - added libxslt-python dependency
782
783 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
784 - unified single SFA database in the PLC-DB
785 - upcalls from  PLCAPI to SFA methods
786 - SFA call traceability and logging features
787 - many bug fixes
788 - includes first/rough version of sfatables for policy implementation
789
790 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
791 - snapshot after the GEC5 demo
792 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
793
794 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
795 - snapshot july 15 - has gone through superficial manual testing
796 - hopefully a good basis for gec5 demo
797 - multi-dir sfi client tested as well
798
799 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
800 - rename geniwrapper.spec into sfa.spec
801
802 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
803 - clean up in xmlrpc/soap, --protocol option to chose between both
804 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
805 - hopefully more helpful context in case of crashes when importing
806 - bugfixes for using only /etc/sfa for site-dep files
807 - bugfixes in wsdl generation
808
809 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
810 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
811 - config variables in sfa_config now start with SFA_ and not GENI_
812 - config.py can be loaded even with no config present
813
814 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
815 - first step for cleanup and reorganization
816 - mass-renaming from geni to sfa (some are still needed)
817 - sfa/trust implements the security architecture
818
819 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
820 - snapshot for reproducible builds
821
822 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
823 - snapshot for the convenience of alpha users
824
825 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
826 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
827
828 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
829 - ongoing work - snapshot for 4.3-rc9
830
831 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
832 - various fixes
833
834 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
835 - bugfixes - still a work in progress
836
837 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
838 - initial package
839
840
841 %define module_current_branch 0.2