in the case of an SM-SM federation, this check will avoid looping of get_resources...
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 6
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36 Requires: python-ZSI
37
38 # python 2.5 has uuid module added, for python 2.4 we still need it
39 %define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
40 %if has_uuid
41 %else
42 Requires: python-uuid
43 %endif
44
45 %package plc
46 Summary: the SFA wrapper arounf MyPLC
47 Group: Applications/System
48 Requires: sfa
49
50 %package client
51 Summary: the SFA experimenter-side CLI
52 Group: Applications/System
53 Requires: sfa
54
55 %package sfatables
56 Summary: sfatables policy tool for SFA
57 Group: Applications/System
58 Requires: sfa
59
60 %description
61 This package provides the python libraries that the SFA implementation requires
62
63 %description plc
64 Geniwrapper implements the SFA interface which serves as a layer
65 between the existing PlanetLab interfaces and the SFA API.
66
67 %description client
68 This package provides the client side of the SFA API, in particular
69 sfi.py, together with other utilities.
70
71 %description sfatables
72 sfatables is a tool for defining access and admission control policies
73 in an SFA network, in much the same way as iptables is for ip
74 networks. This is the command line interface to manage sfatables
75
76 %prep
77 %setup -q
78
79 %build
80 make
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 make install DESTDIR="$RPM_BUILD_ROOT"
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 # sfa and sfatables depend each other.
91 /etc/sfatables/*
92 %{python_sitelib}/*
93 /usr/bin/keyconvert
94 /var/www/html/wsdl/*.wsdl
95
96
97 %files plc
98 %defattr(-,root,root)
99 %config (noreplace) /etc/sfa/sfa_config
100 %config (noreplace) /etc/sfa/aggregates.xml
101 %config (noreplace) /etc/sfa/registries.xml
102 /etc/init.d/sfa
103 %{_bindir}/sfa-config-tty
104 %{_bindir}/sfa-import-plc.py*
105 %{_bindir}/sfa-clean-peer-records.py*
106 %{_bindir}/sfa-nuke-plc.py*
107 %{_bindir}/sfa-server.py*
108
109 %files client
110 %config (noreplace) /etc/sfa/sfi_config
111 %{_bindir}/sfi.py*
112 %{_bindir}/getNodes.py*
113 %{_bindir}/getRecord.py*
114 %{_bindir}/setRecord.py*
115 %{_bindir}/genidump.py*
116
117 %files sfatables
118 %{_bindir}/sfatables
119
120 %pre plc
121 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
122
123 %post plc
124 chkconfig --add sfa
125
126 %changelog
127 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
128 - This tag includes:
129 - - Sfatables
130 - - Preliminary version of hash based authentication
131 - - Initial code for Component Manager
132 - - Authority structure is moved to /var/lib/sfa/
133 - - some bug-fixes
134
135 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
136 - Create_slice and get_resources methods are connected to sfatables.
137 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
138
139 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
140 - Bug fix on update and remove_peer_object methods
141 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
142
143 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
144 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
145
146 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
147 - compatibility with RefreshPeer
148 - incremental mechanism for importing PLC records into SFA tables
149 - unified single database (still inside the underlying PLC db postgresql server)
150 - includes/improves call traceability and logging features
151 - several bug fixes
152
153 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
154 - added libxslt-python dependency
155
156 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
157 - unified single SFA database in the PLC-DB
158 - upcalls from  PLCAPI to SFA methods
159 - SFA call traceability and logging features
160 - many bug fixes
161 - includes first/rough version of sfatables for policy implementation
162
163 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
164 - snapshot after the GEC5 demo
165 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
166
167 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
168 - snapshot july 15 - has gone through superficial manual testing
169 - hopefully a good basis for gec5 demo
170 - multi-dir sfi client tested as well
171
172 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
173 - rename geniwrapper.spec into sfa.spec
174
175 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
176 - clean up in xmlrpc/soap, --protocol option to chose between both
177 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
178 - hopefully more helpful context in case of crashes when importing
179 - bugfixes for using only /etc/sfa for site-dep files
180 - bugfixes in wsdl generation
181
182 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
183 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
184 - config variables in sfa_config now start with SFA_ and not GENI_
185 - config.py can be loaded even with no config present
186
187 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
188 - first step for cleanup and reorganization
189 - mass-renaming from geni to sfa (some are still needed)
190 - sfa/trust implements the security architecture
191
192 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
193 - snapshot for reproducible builds
194
195 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
196 - snapshot for the convenience of alpha users
197
198 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
199 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
200
201 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
202 - ongoing work - snapshot for 4.3-rc9
203
204 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
205 - various fixes
206
207 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
208 - bugfixes - still a work in progress
209
210 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
211 - initial package
212
213
214 %define module_current_branch 0.2