small changes to creds/gid
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 11
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38
39 # python 2.5 has uuid module added, for python 2.4 we still need it.
40 # we can't really check for if we can load uuid as a python module,
41 # it'll be installed by "devel.pkgs". we have the epel repository so
42 # python-uuid will be provided. but we can test for the python
43 # version.
44 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
45 # %if %has_py24
46 #
47 # this also didn't work very well. I'll just check for distroname - baris
48 %if %{distroname} == "centos5"
49 Requires: python-uuid
50 %endif
51
52 %package cm
53 Summary: the SFA wrapper around MyPLC's NodeManager
54 Group: Applications/System
55 Requires: sfa
56 Requires: pyOpenSSL >= 0.6
57
58 %package plc
59 Summary: the SFA wrapper arounf MyPLC
60 Group: Applications/System
61 Requires: sfa
62 Requires: python-psycopg2
63 Requires: myplc-config
64 Requires: pyOpenSSL >= 0.7
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %description
78 This package provides the python libraries that the SFA implementation requires
79
80 %description cm
81 This package implements the SFA interface which serves as a layer
82 between the existing PlanetLab NodeManager interfaces and the SFA API.
83  
84 %description plc
85 This package implements the SFA interface which serves as a layer
86 between the existing PlanetLab interfaces and the SFA API.
87
88 %description client
89 This package provides the client side of the SFA API, in particular
90 sfi.py, together with other utilities.
91
92 %description sfatables
93 sfatables is a tool for defining access and admission control policies
94 in an SFA network, in much the same way as iptables is for ip
95 networks. This is the command line interface to manage sfatables
96
97 %prep
98 %setup -q
99
100 %build
101 make
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 make install DESTDIR="$RPM_BUILD_ROOT"
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 # sfa and sfatables depend each other.
112 %{_bindir}/sfa-server.py*
113 /etc/sfatables/*
114 %{python_sitelib}/*
115 /usr/bin/keyconvert
116 /var/www/html/wsdl/*.wsdl
117
118 %files cm
119 /etc/init.d/sfa-cm
120 %{_bindir}/sfa_component_setup.py*
121 # cron jobs here 
122
123 %files plc
124 %defattr(-,root,root)
125 %config /etc/sfa/default_config.xml
126 %config (noreplace) /etc/sfa/aggregates.xml
127 %config (noreplace) /etc/sfa/registries.xml
128 /etc/init.d/sfa
129 %{_bindir}/sfa-config-tty
130 %{_bindir}/sfa-import-plc.py*
131 %{_bindir}/sfa-clean-peer-records.py*
132 %{_bindir}/sfa-nuke-plc.py*
133 %{_bindir}/gen-sfa-cm-config.py*
134
135 %files client
136 %config (noreplace) /etc/sfa/sfi_config
137 %{_bindir}/sfi.py*
138 %{_bindir}/getNodes.py*
139 %{_bindir}/getRecord.py*
140 %{_bindir}/setRecord.py*
141 %{_bindir}/sfadump.py*
142
143 %files sfatables
144 %{_bindir}/sfatables
145
146 %pre plc
147 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
148
149 %pre cm
150 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
151
152 %post plc
153 chkconfig --add sfa
154
155 %post cm
156 chkconfig --add sfa-cm
157 %changelog
158 * Thu Apr 08 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
159 - SfaServer now uses a pool of threads to handle requests concurrently
160 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
161 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
162 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
163 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
164 - Component manager does not install gid files if slice already has them  
165  
166 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
167 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
168 - - sfa-config-tty now has the same features like plc-config-tty
169 - - Contains code to support both urn and hrn
170 - - Cleaned up request_hash related stuff
171 - - SM, AM and Registry code is organized under respective managers
172 - - Site and Slice synchronization across federated aggregates
173 - - Script to generate sfa_component_config
174
175 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
176 - sfa-config-tty now has the same features like plc-config-tty
177 - Contains code to support both urn and hrn
178 - Cleaned up request_hash related stuff
179 - SM, AM and Registry code is organized under respective managers
180 - Slice synchronization across federated aggregates
181 - some bugs are fixed
182
183 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
184 - checkpoint with fewer mentions of geni
185
186 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
187 - checkpointing
188 - this is believed to pass the tests; among other things:
189 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
190
191 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
192 - This tag includes:
193 - - Sfatables
194 - - Preliminary version of hash based authentication
195 - - Initial code for Component Manager
196 - - Authority structure is moved to /var/lib/sfa/
197 - - some bug-fixes
198
199 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
200 - Create_slice and get_resources methods are connected to sfatables.
201 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
202
203 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
204 - Bug fix on update and remove_peer_object methods
205 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
206
207 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
208 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
209
210 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
211 - compatibility with RefreshPeer
212 - incremental mechanism for importing PLC records into SFA tables
213 - unified single database (still inside the underlying PLC db postgresql server)
214 - includes/improves call traceability and logging features
215 - several bug fixes
216
217 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
218 - added libxslt-python dependency
219
220 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
221 - unified single SFA database in the PLC-DB
222 - upcalls from  PLCAPI to SFA methods
223 - SFA call traceability and logging features
224 - many bug fixes
225 - includes first/rough version of sfatables for policy implementation
226
227 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
228 - snapshot after the GEC5 demo
229 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
230
231 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
232 - snapshot july 15 - has gone through superficial manual testing
233 - hopefully a good basis for gec5 demo
234 - multi-dir sfi client tested as well
235
236 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
237 - rename geniwrapper.spec into sfa.spec
238
239 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
240 - clean up in xmlrpc/soap, --protocol option to chose between both
241 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
242 - hopefully more helpful context in case of crashes when importing
243 - bugfixes for using only /etc/sfa for site-dep files
244 - bugfixes in wsdl generation
245
246 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
247 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
248 - config variables in sfa_config now start with SFA_ and not GENI_
249 - config.py can be loaded even with no config present
250
251 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
252 - first step for cleanup and reorganization
253 - mass-renaming from geni to sfa (some are still needed)
254 - sfa/trust implements the security architecture
255
256 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
257 - snapshot for reproducible builds
258
259 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
260 - snapshot for the convenience of alpha users
261
262 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
263 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
264
265 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
266 - ongoing work - snapshot for 4.3-rc9
267
268 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
269 - various fixes
270
271 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
272 - bugfixes - still a work in progress
273
274 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
275 - initial package
276
277
278 %define module_current_branch 0.2