Merge remote-tracking branch 'origin/master'
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package flashpolicy
66 Summary: SFA support for flash clients
67 Group: Applications/System
68 Requires: sfa
69
70 %package client
71 Summary: the SFA experimenter-side CLI
72 Group: Applications/System
73 Requires: sfa
74 Requires: pyOpenSSL >= 0.7
75
76 %package plc
77 Summary: the SFA layer around MyPLC
78 Group: Applications/System
79 Requires: sfa
80
81 %package cm
82 Summary: the SFA layer around MyPLC NodeManager
83 Group: Applications/System
84 Requires: sfa
85 Requires: pyOpenSSL >= 0.6
86
87 %package federica
88 Summary: the SFA layer around Federica
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa
106
107 %description
108 This package provides the python libraries for the PlanetLab implementation of SFA
109
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112
113 %description client
114 This package provides the client side of the SFA API, in particular
115 sfi.py, together with other utilities.
116
117 %description plc
118 This package implements the SFA interface which serves as a layer
119 between the existing PlanetLab interfaces and the SFA API.
120
121 %description cm
122 This package implements the SFA interface which serves as a layer
123 between the existing PlanetLab NodeManager interfaces and the SFA API.
124
125 %description federica
126 The SFA driver for FEDERICA.
127
128 %description sfatables
129 sfatables is a tool for defining access and admission control policies
130 in an SFA network, in much the same way as iptables is for ip
131 networks. This is the command line interface to manage sfatables
132
133 %description xmlbuilder
134 This package contains the xmlbuilder python library, packaged for
135 convenience as it is not supported by fedora
136
137 %description tests
138 Provides some binary unit tests in /usr/share/sfa/tests
139
140 %prep
141 %setup -q
142
143 %build
144 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %{python_sitelib}/sfa/__init__.py*
155 %{python_sitelib}/sfa/trust
156 %{python_sitelib}/sfa/storage
157 %{python_sitelib}/sfa/util
158 %{python_sitelib}/sfa/server
159 %{python_sitelib}/sfa/methods
160 %{python_sitelib}/sfa/generic
161 %{python_sitelib}/sfa/managers
162 %{python_sitelib}/sfa/importer
163 %{python_sitelib}/sfa/rspecs
164 %{python_sitelib}/sfa/client
165 /etc/init.d/sfa
166 %{_bindir}/sfa-start.py*
167 %{_bindir}/sfaadmin.py*
168 %{_bindir}/sfaadmin
169 %{_bindir}/keyconvert.py*
170 %{_bindir}/sfa-config-tty
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 /usr/share/sfa/migrations
175 /usr/share/sfa/examples
176 /var/www/html/wsdl/*.wsdl
177
178 %files flashpolicy
179 %{_bindir}/sfa_flashpolicy.py*
180 /etc/sfa/sfa_flashpolicy_config.xml
181
182 %files client
183 %config (noreplace) /etc/sfa/sfi_config
184 %{python_sitelib}/sfa/clientbin
185 %{_bindir}/sfi*.py*
186 %{_bindir}/sfi
187 %{_bindir}/get*.py*
188 %{_bindir}/setRecord.py*
189 %{_bindir}/sfascan.py*
190 %{_bindir}/sfascan
191 %{_bindir}/sfadump.py*
192
193 %files plc
194 %defattr(-,root,root)
195 %{python_sitelib}/sfa/planetlab
196 %{python_sitelib}/sfa/openstack
197 /etc/sfa/pl.rng
198 /etc/sfa/credential.xsd
199 /etc/sfa/top.xsd
200 /etc/sfa/sig.xsd
201 /etc/sfa/xml.xsd
202 /etc/sfa/protogeni-rspec-common.xsd
203 /etc/sfa/topology
204 %{_bindir}/gen-sfa-cm-config.py*
205
206 %files cm
207 /etc/init.d/sfa-cm
208 %{_bindir}/sfa_component_setup.py*
209 # cron jobs here 
210
211 %files federica
212 %{python_sitelib}/sfa/federica
213
214 %files sfatables
215 /etc/sfatables/*
216 %{_bindir}/sfatables
217 %{python_sitelib}/sfatables
218
219 %files xmlbuilder
220 %{python_sitelib}/xmlbuilder
221
222 %files tests
223 %{_datadir}/sfa/tests
224
225 ### sfa installs the 'sfa' service
226 %post 
227 chkconfig --add sfa
228
229 %preun 
230 if [ "$1" = 0 ] ; then
231   /sbin/service sfa stop || :
232   /sbin/chkconfig --del sfa || :
233 fi
234
235 %postun
236 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
237
238 ### sfa-cm installs the 'sfa-cm' service
239 %post cm
240 chkconfig --add sfa-cm
241
242 %preun cm
243 if [ "$1" = 0 ] ; then
244    /sbin/service sfa-cm stop || :
245    /sbin/chkconfig --del sfa-cm || :
246 fi
247
248 %postun cm
249 [ "$1" -ge "1" ] && service sfa-cm restart || :
250
251 %changelog
252 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
253 - fix bug in sfi update()
254
255 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
256 - fix broken sfa.util.xrn class for lowercase
257
258 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
259 - new 'void' generic_flavour for running in registry-only mode
260 - first shot at refactoring importers - probably needs more work
261 - openstack: various enhancements
262 - sfi interface to registry not based on xml files anymore
263 - sfi show sorts result on record key
264 - bugfix in sfa update on users with a pl-backed registry
265
266 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
267 - renamed sfa/plc into sfa/planetlab
268 - plxrn moved in sfa/planetlab as well
269 - bugfix for sfaadmin reg update --pi <>
270
271 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
272 - native data model now has a authority x user (PI) relationship
273 - no call to 'augment_records_with_testbed_info' for GetCredential
274 - which means, registry can now be used without an underlying testbed
275 - reviewed code about relationships b/w objects and related in pl driver
276 - reviewed PL import wrt roles and pis
277 - removed mentions to is_enabled in driver
278 - small changes in update_relation* in driver interface
279 - sfaadmin: can create authorities and attach pi users to them
280 - sfaadmin: categories can be abbreviated
281 - sfi list and sfaadmin list have a new -r/--recursive option
282 - this means that List now supports an (optional) 'options' argument
283 - sfi config can display config vars
284 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
285
286 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
287 - make sync now supports vserver or lxc.
288 - Added slice expiration and login info to SliverStatus response. 
289 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
290   the 'component_name' attribute.
291 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
292   
293 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
294 - Introduced new administrative command line script, sfaadmin.py. Removed various single
295  purpose scripts and migrated their functionality into sfaadmin.py.
296 - Refactored Registry import scripts.
297 - Removed SQLAlchemy dependency from sfi.py.
298 - Fixed bugs in sfi.py
299 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
300
301 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
302 - slice x researcher rel. in database,
303 - plimporter to maintain that, as well as user.email, and more robust
304 - ongoing draft for sfaadmin tool
305 - support for a federica driver
306 - support for a nova/euca driver
307 - no more sfa-clean-peer-records script
308
309 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
310 - registry database has user's keys and mail (known as v0 for migrate)
311 - pl importer properly maintains user's keys and mail
312 - pl driver now to handle 'role' when adding person record (exp.)
313 - first draft of federica driver with config section
314 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
315 - plus, from master as of tag merged-in-sfa-2.1-2:
316 - disk_image revisited
317 - new nova_shell nova_driver & various tweaks for openstack
318
319 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
320 - uses sqlalchemy and related migrate
321 - thorough migration and upgrade scheme
322 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
323 - trashed dbinfo stuff in auth hierarchy
324 - data model still has little more than plain records
325 - checkpoint tag, not yet intended for release
326
327 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
328 - client: added -R --raw sfi cmdline option that displays raw server response.
329 - client: request GENI RSpec by default. 
330 - server: remove database dependencies from sfa.server.sfaapi.
331 - server: increased default credential lifetime to 31 days.
332 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
333 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
334 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
335  
336 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
337 - bugfix: 'geni_api' should be in the top level struct, not the code struct
338 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
339           output returned by the Aggregate Manager.
340 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
341 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
342 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
343           there is extra whitespace in the schemaLocation field.
344 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
345           advertisement rspecs.
346 - bugfix: <login> RSpec element should contain the 'username' attribute.
347 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
348  
349 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
350 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
351   exit when it encountered a user with an invalid public key.
352 - server: imporved logging in sfa-import-plc.py
353  
354 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
355 - bugfix: Fixed appending public keys in CreateSliver
356 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
357 - client: -c --current option allows users to request the current/uncached rspec.
358 - server: Added 'geni_api_versions' field to GetVersion() output.
359 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
360    
361 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
362 - bugfix: sfi was not sending call_id with ListResources to v2 servers
363 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
364 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
365
366 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
367 - client: sfi -a / -p deprecated (use -s instead)
368 - client: sfi cleaned up
369 - client: sfi has backward support for APIv1 aggregates again
370 - server: only APIv2 is supported and should be rather strict
371 - server: settings for turning on/off caching in sm or am
372 - server: plc-dependant code has moved from aggregate to pldriver
373 - server: driver interface extended accordingly
374
375 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
376 - screwed up previous tag
377
378 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
379 - client side revisited with a bootstrap library
380 - client side has a new source layout
381 - various (nasty) bug fixes wrt options and call_id
382
383 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
384 - various fixes in rspecs for sfav1&slice tags
385 - uses 'geni_rspec_version' and not just 'rspec_version'
386 - example flavour for the max testbed
387 - embryo for an sfa client library
388 - topology.py moved into plc
389 - sql: table is named records; record_types are enforced
390 - sql: table creation cleaned up
391
392 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
393 - cleaned up all references to SFA_*_TYPE in config
394 - enable cache at the aggregate by default
395 - registry now uses the driver in a sensible way (see managers/driver.py)
396 - slice manager supports sfav1/pgv2 neighbours
397 - get_key renamed into get_key_from_incoming_ip
398 - new sfa.storage module for record/table and all db-related stuff
399 - db schema in sfa.storage.sfa.sql
400 - init.d and cron.d move one step up
401 - cleaned up rspec/ directory
402 - add deps to pyopenssl and myplc-config
403 - start support for new API (return value)
404 - plc.remoteshell removed, use plshell instead
405 - plshell uses a 'capability' auth method whenever possible
406 - various tweaks in rspec elements
407 - made dependency on sfatables softer
408
409 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
410 - sfa should now be started *before* the initial import
411 - sfa to use its own database (default sfa) - can run without myplc
412 - server calls support optional 'options'
413 - client sends options in argument when needed
414 - fix infinite getattr recursion in elements/element.py
415 - error codes in line with geni
416
417 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
418 - fixed links and attributes in rspecs
419 - minor cleanup in the API methods, and more consistent names in manager methods
420
421 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
422 - ongoing refoactoring towards more genericity
423 - passes tests again although known issues remain with attributes/tags
424
425 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
426 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
427 - improvements in the pgv2 rspecs
428 - driver separated from api
429 - code starts moving around where it belongs
430 - sfascan caches getversion across invokations
431 - vini topology extracted as a config file
432
433 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
434 - first support for protogeni rspecs is working
435 - vini no longer needs a specific manager
436 - refactoring underway towards more flexible/generic architecture
437
438 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
439 - Unicode-friendliness for user names with accents/special chars.
440 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
441 - CreaetSliver no longer fails for users that have a capital letter in their URN.
442 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
443 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
444 - Fix bugs and missing imports     
445  
446
447 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
448 - new method record.get_field for sface
449
450 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
451 - new option -c to sfa-nuke-plc.py
452 - CreateSliver fixed for admin-only slice tags
453
454 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
455 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
456 - Fixed holes in certificate verification logic.
457 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
458 - Added 'boot_state' as an attribute of the node element in SFA rspec.
459 - Non authority certificates are marked as CA:FALSE.
460
461 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
462 - fix typo in sfa-1.0-31 tag.
463 - added CreateGid() Registry interface method.
464
465 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
466 - fix typo in sfa-1.0-30 tag
467
468 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
469 - Declare namespace and schema location in the credential.
470 - Fix bug that prevetend connections from timing out.
471 - Fix slice delegation.
472 - Add statistics to slicemaanger listresources/createsliver rspec.
473 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
474   of days a user can extend their slice expiration.
475 - CA certs are only issued to objects of type authority
476    
477 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
478 - tag 1.0-28 was broken due to typo in the changelog
479 - new class sfa/util/httpsProtocol.py that supports timeouts
480
481 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
482 - Resolved issue that caused sfa hold onto idle db connections.
483 - Fix bug that caused the registry to use the wrong type of credential.
484 - Support authority+sm type.
485 - Fix rspec merging bugs.
486 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
487 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
488  planetlab hosted initscripts using the <planetlab:initscript> tag  
489 - Can now handle extraneous whitespace in the rspec without failing.   
490  
491 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
492 - ProtoGENI v2 RSpec updates.
493 - Convert expiration timestamps with timezone info in credentials to utc.
494 - Fixed redundant logging issue. 
495 - Improved SliceManager and SFI client logging.
496 - Support aggregates that don't support the optional 'call_id' argument. 
497 - Only call get_trusted_certs() at aggreage interfaces that support the call.
498 - CreateSliver() now handles MyPLC slice attributes/tags.
499 - Cache now supports persistence.
500 - Hide whitelisted nodes.
501
502 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
503 - fixed issues with sup authority signing
504 - fixed bugs in remove_slivers and SliverStatus
505
506 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
507 - fix typo that prevented aggregates from operating properly
508
509 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
510 - load trusted certs into ssl context prior to handshake
511 - client's logfile lives in ~/.sfi/sfi.log
512
513 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
514 - includes a change on passphrases that was intended in 1.0-22
515
516 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
517 - Added support for ProtoGENI RSpec v2
518  
519 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
520 - stable sfascan
521 - fix in initscript, *ENABLED tags in config now taken into account
522
523 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
524 - some commits had not been pushed in tag 19
525
526 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
527 - GetVersion should now report full URLs with path
528 - scansfa has nicer output and new syntax (entry URLs as args and not options)
529 - dos2unix'ed flash policy pill
530
531 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
532 - fix packaging again for f8
533
534 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
535 - fix packaging (apparently broken in 1.0-16)
536 - first working version of sfascan
537 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
538 - deprecated the sfa_geni_aggregate config category
539
540 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
541 - Fix build problem
542 - First version of SFA scanner
543
544 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
545 - Add support for Flash clients using flashpolicy
546 - Fix problems with tag handling in RSpec
547
548 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
549 - Modifications to the Eucalyptus Aggregate Manager
550 - Fixes for VINI RSpec
551 - Fix tag handling for PL RSpec
552 - Fix XML Schema ordering for <urn> element
553
554 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
555 - just set x509 version to 2
556
557 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
558 - added urn to the node area in rspecs
559 - conversion to urn now exports fqdn
560 - sfa-import-plc.py now creates a unique registry record for each SFA interface
561
562 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
563 - undo broken attempt for python-2.7
564
565 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
566 - SMs avoid duplicates for when call graph has dags;
567 - just based on network's name, when a duplicate occurs, one is just dropped
568 - does not try to merge/aggregate 2 networks
569 - also reviewed logging with the hope to fix the sfa startup msg:
570 - TypeError: not all arguments converted during string formatting
571
572 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
573 - verify credentials against xsd schema
574 - Fix SM to SM communication
575 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
576 - new setting session_key_path
577
578 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
579 - fix registry credential regeneration and handle expiration
580 - support for setting slice tags (min_role=user)
581 - client can display its own version: sfi.py version --local
582 - GetVersion to provide urn in addition to hrn
583 - more code uses plxrn vs previous helper functions
584 - import replaces '+' in email addresses with '_'
585
586 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
587 - fix GetVersion code_tag and add code_url
588
589 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
590 - extend GetVersion towards minimum federation introspection, and expose local tag
591
592 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
593 - fixed some legacy issues (list vs List)
594 - deprecated sfa.util.namespace for xrn and plxrn
595 - unit tests ship as the sfa-tests rpm
596
597 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
598 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
599 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
600 - hrn-urn translations tweaked
601 - fixed 'service sfa status'
602 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
603 - started to repair sfadump - although not usable yet
604 - trust objects now have dump_string method that dump() actually prints
605 - unit tests under review
606 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
607 - binaries now support -v or -vv to increase loglevel
608 - trashed obsolete sfa.util.client
609
610 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
611 - various bugfixes and cleanup, improved/harmonized logging
612
613 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
614 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
615   to avoid returning a PLCAPI exception that might confuse users.
616 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
617 - fix build errors.  
618
619 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
620 - (Architecture) Credential format changed to match ProtoGENI xml format
621 - (Architecture) All interfaces export a new set of methods that are compatible
622    with the ProtoGeni Aggregate spec. These new methods are considered a 
623    replacement  for the pervious methods exported by the interfaces. All 
624    previous methods are still exported and work as normal, but they are 
625    considered deprecated and will not be supported in future releases.  
626 - (Architecture) SFI has been updated to use the new interface methods.
627 - (Architecture) Changed keyconvet implementation from c to python.
628 - (Architecture) Slice Manager now attempts looks for a delegated credential
629   provided by the client before using its own server credential.
630 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
631   This cache now exists only in memory and is cleared when service is restarted
632   or cache lifetime is exceeded.  
633 - (Performance) SliceManager sends request to Aggregates in parallel instead 
634   of sequentially.
635 - (Bug fix) SFA tickets now support the new rspec format.
636 - (Bug fix) SFI only uses cahced credential if they aren't expired.
637 - (Bug fix) Cerdential delegation modified to work with new credential format.
638 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
639   Aggregate instead of relaying through the Slice Manager.
640 - (Enhancement) Simplified caching. Accociated a global cache instance with
641   the api handler on every new server request, making it easier to access the 
642   cache and use in more general ways.     
643
644 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
645 - SfaServer now uses a pool of threads to handle requests concurrently
646 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
647 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
648 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
649 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
650 - Component manager does not install gid files if slice already has them  
651 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
652 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
653 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
654      
655 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
656 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
657 - - sfa-config-tty now has the same features like plc-config-tty
658 - - Contains code to support both urn and hrn
659 - - Cleaned up request_hash related stuff
660 - - SM, AM and Registry code is organized under respective managers
661 - - Site and Slice synchronization across federated aggregates
662 - - Script to generate sfa_component_config
663
664 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
665 - sfa-config-tty now has the same features like plc-config-tty
666 - Contains code to support both urn and hrn
667 - Cleaned up request_hash related stuff
668 - SM, AM and Registry code is organized under respective managers
669 - Slice synchronization across federated aggregates
670 - some bugs are fixed
671
672 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
673 - checkpoint with fewer mentions of geni
674
675 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
676 - checkpointing
677 - this is believed to pass the tests; among other things:
678 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
679
680 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
681 - This tag includes:
682 - - Sfatables
683 - - Preliminary version of hash based authentication
684 - - Initial code for Component Manager
685 - - Authority structure is moved to /var/lib/sfa/
686 - - some bug-fixes
687
688 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
689 - Create_slice and get_resources methods are connected to sfatables.
690 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
691
692 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
693 - Bug fix on update and remove_peer_object methods
694 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
695
696 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
697 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
698
699 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
700 - compatibility with RefreshPeer
701 - incremental mechanism for importing PLC records into SFA tables
702 - unified single database (still inside the underlying PLC db postgresql server)
703 - includes/improves call traceability and logging features
704 - several bug fixes
705
706 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
707 - added libxslt-python dependency
708
709 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
710 - unified single SFA database in the PLC-DB
711 - upcalls from  PLCAPI to SFA methods
712 - SFA call traceability and logging features
713 - many bug fixes
714 - includes first/rough version of sfatables for policy implementation
715
716 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
717 - snapshot after the GEC5 demo
718 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
719
720 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
721 - snapshot july 15 - has gone through superficial manual testing
722 - hopefully a good basis for gec5 demo
723 - multi-dir sfi client tested as well
724
725 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
726 - rename geniwrapper.spec into sfa.spec
727
728 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
729 - clean up in xmlrpc/soap, --protocol option to chose between both
730 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
731 - hopefully more helpful context in case of crashes when importing
732 - bugfixes for using only /etc/sfa for site-dep files
733 - bugfixes in wsdl generation
734
735 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
736 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
737 - config variables in sfa_config now start with SFA_ and not GENI_
738 - config.py can be loaded even with no config present
739
740 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
741 - first step for cleanup and reorganization
742 - mass-renaming from geni to sfa (some are still needed)
743 - sfa/trust implements the security architecture
744
745 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
746 - snapshot for reproducible builds
747
748 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
749 - snapshot for the convenience of alpha users
750
751 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
752 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
753
754 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
755 - ongoing work - snapshot for 4.3-rc9
756
757 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
758 - various fixes
759
760 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
761 - bugfixes - still a work in progress
762
763 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
764 - initial package
765
766
767 %define module_current_branch 0.2