merge master again (2.0-10 changelog only)
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/keyconvert.py*
152 %{_bindir}/sfa-config-tty
153 %config /etc/sfa/default_config.xml
154 %config (noreplace) /etc/sfa/aggregates.xml
155 %config (noreplace) /etc/sfa/registries.xml
156 /usr/share/sfa/migrations
157 /usr/share/sfa/examples
158 /var/www/html/wsdl/*.wsdl
159
160 %files plc
161 %defattr(-,root,root)
162 /etc/sfa/pl.rng
163 /etc/sfa/credential.xsd
164 /etc/sfa/top.xsd
165 /etc/sfa/sig.xsd
166 /etc/sfa/xml.xsd
167 /etc/sfa/protogeni-rspec-common.xsd
168 /etc/sfa/topology
169 %{_bindir}/sfa-import-plc.py*
170 %{_bindir}/sfa-nuke-plc.py*
171 %{_bindir}/sfa-clean-peer-records.py*
172 %{_bindir}/gen-sfa-cm-config.py*
173 %{_bindir}/sfa-ca.py*
174
175 %files client
176 %config (noreplace) /etc/sfa/sfi_config
177 %{_bindir}/sfi*.py*
178 %{_bindir}/sfi
179 %{_bindir}/get*.py*
180 %{_bindir}/setRecord.py*
181 %{_bindir}/sfascan.py*
182 %{_bindir}/sfascan
183 %{_bindir}/sfadump.py*
184
185 %files sfatables
186 /etc/sfatables/*
187 %{_bindir}/sfatables
188 %{python_sitelib}/sfatables
189
190 %files cm
191 /etc/init.d/sfa-cm
192 %{_bindir}/sfa_component_setup.py*
193 # cron jobs here 
194
195 %files flashpolicy
196 %{_bindir}/sfa_flashpolicy.py*
197 /etc/sfa/sfa_flashpolicy_config.xml
198
199 %files xmlbuilder
200 %{python_sitelib}/xmlbuilder
201
202 %files tests
203 %{_datadir}/sfa/tests
204
205 ### sfa installs the 'sfa' service
206 %post 
207 chkconfig --add sfa
208
209 %preun 
210 if [ "$1" = 0 ] ; then
211   /sbin/service sfa stop || :
212   /sbin/chkconfig --del sfa || :
213 fi
214
215 %postun
216 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
217
218 ### sfa-cm installs the 'sfa-cm' service
219 %post cm
220 chkconfig --add sfa-cm
221
222 %preun cm
223 if [ "$1" = 0 ] ; then
224    /sbin/service sfa-cm stop || :
225    /sbin/chkconfig --del sfa-cm || :
226 fi
227
228 %postun cm
229 [ "$1" -ge "1" ] && service sfa-cm restart || :
230
231 %changelog
232 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
233 - client: added -R --raw sfi cmdline option that displays raw server response.
234 - client: request GENI RSpec by default. 
235 - server: remove database dependencies from sfa.server.sfaapi.
236 - server: increased default credential lifetime to 31 days.
237 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
238 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
239 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
240  
241 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
242 - bugfix: 'geni_api' should be in the top level struct, not the code struct
243 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
244           output returned by the Aggregate Manager.
245 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
246 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
247 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
248           there is extra whitespace in the schemaLocation field.
249 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
250           advertisement rspecs.
251 - bugfix: <login> RSpec element should contain the 'username' attribute.
252 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
253  
254 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
255 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
256   exit when it encountered a user with an invalid public key.
257 - server: imporved logging in sfa-import-plc.py
258  
259 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
260 - bugfix: Fixed appending public keys in CreateSliver
261 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
262 - client: -c --current option allows users to request the current/uncached rspec.
263 - server: Added 'geni_api_versions' field to GetVersion() output.
264 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
265    
266 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
267 - bugfix: sfi was not sending call_id with ListResources to v2 servers
268 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
269 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
270
271 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
272 - client: sfi -a / -p deprecated (use -s instead)
273 - client: sfi cleaned up
274 - client: sfi has backward support for APIv1 aggregates again
275 - server: only APIv2 is supported and should be rather strict
276 - server: settings for turning on/off caching in sm or am
277 - server: plc-dependant code has moved from aggregate to pldriver
278 - server: driver interface extended accordingly
279
280 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
281 - screwed up previous tag
282
283 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
284 - client side revisited with a bootstrap library
285 - client side has a new source layout
286 - various (nasty) bug fixes wrt options and call_id
287
288 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
289 - various fixes in rspecs for sfav1&slice tags
290 - uses 'geni_rspec_version' and not just 'rspec_version'
291 - example flavour for the max testbed
292 - embryo for an sfa client library
293 - topology.py moved into plc
294 - sql: table is named records; record_types are enforced
295 - sql: table creation cleaned up
296
297 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
298 - cleaned up all references to SFA_*_TYPE in config
299 - enable cache at the aggregate by default
300 - registry now uses the driver in a sensible way (see managers/driver.py)
301 - slice manager supports sfav1/pgv2 neighbours
302 - get_key renamed into get_key_from_incoming_ip
303 - new sfa.storage module for record/table and all db-related stuff
304 - db schema in sfa.storage.sfa.sql
305 - init.d and cron.d move one step up
306 - cleaned up rspec/ directory
307 - add deps to pyopenssl and myplc-config
308 - start support for new API (return value)
309 - plc.remoteshell removed, use plshell instead
310 - plshell uses a 'capability' auth method whenever possible
311 - various tweaks in rspec elements
312 - made dependency on sfatables softer
313
314 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
315 - sfa should now be started *before* the initial import
316 - sfa to use its own database (default sfa) - can run without myplc
317 - server calls support optional 'options'
318 - client sends options in argument when needed
319 - fix infinite getattr recursion in elements/element.py
320 - error codes in line with geni
321
322 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
323 - fixed links and attributes in rspecs
324 - minor cleanup in the API methods, and more consistent names in manager methods
325
326 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
327 - ongoing refoactoring towards more genericity
328 - passes tests again although known issues remain with attributes/tags
329
330 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
331 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
332 - improvements in the pgv2 rspecs
333 - driver separated from api
334 - code starts moving around where it belongs
335 - sfascan caches getversion across invokations
336 - vini topology extracted as a config file
337
338 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
339 - first support for protogeni rspecs is working
340 - vini no longer needs a specific manager
341 - refactoring underway towards more flexible/generic architecture
342
343 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
344 - Unicode-friendliness for user names with accents/special chars.
345 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
346 - CreaetSliver no longer fails for users that have a capital letter in their URN.
347 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
348 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
349 - Fix bugs and missing imports     
350  
351
352 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
353 - new method record.get_field for sface
354
355 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
356 - new option -c to sfa-nuke-plc.py
357 - CreateSliver fixed for admin-only slice tags
358
359 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
360 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
361 - Fixed holes in certificate verification logic.
362 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
363 - Added 'boot_state' as an attribute of the node element in SFA rspec.
364 - Non authority certificates are marked as CA:FALSE.
365
366 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
367 - fix typo in sfa-1.0-31 tag.
368 - added CreateGid() Registry interface method.
369
370 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
371 - fix typo in sfa-1.0-30 tag
372
373 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
374 - Declare namespace and schema location in the credential.
375 - Fix bug that prevetend connections from timing out.
376 - Fix slice delegation.
377 - Add statistics to slicemaanger listresources/createsliver rspec.
378 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
379   of days a user can extend their slice expiration.
380 - CA certs are only issued to objects of type authority
381    
382 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
383 - tag 1.0-28 was broken due to typo in the changelog
384 - new class sfa/util/httpsProtocol.py that supports timeouts
385
386 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
387 - Resolved issue that caused sfa hold onto idle db connections.
388 - Fix bug that caused the registry to use the wrong type of credential.
389 - Support authority+sm type.
390 - Fix rspec merging bugs.
391 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
392 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
393  planetlab hosted initscripts using the <planetlab:initscript> tag  
394 - Can now handle extraneous whitespace in the rspec without failing.   
395  
396 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
397 - ProtoGENI v2 RSpec updates.
398 - Convert expiration timestamps with timezone info in credentials to utc.
399 - Fixed redundant logging issue. 
400 - Improved SliceManager and SFI client logging.
401 - Support aggregates that don't support the optional 'call_id' argument. 
402 - Only call get_trusted_certs() at aggreage interfaces that support the call.
403 - CreateSliver() now handles MyPLC slice attributes/tags.
404 - Cache now supports persistence.
405 - Hide whitelisted nodes.
406
407 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
408 - fixed issues with sup authority signing
409 - fixed bugs in remove_slivers and SliverStatus
410
411 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
412 - fix typo that prevented aggregates from operating properly
413
414 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
415 - load trusted certs into ssl context prior to handshake
416 - client's logfile lives in ~/.sfi/sfi.log
417
418 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
419 - includes a change on passphrases that was intended in 1.0-22
420
421 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
422 - Added support for ProtoGENI RSpec v2
423  
424 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
425 - stable sfascan
426 - fix in initscript, *ENABLED tags in config now taken into account
427
428 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
429 - some commits had not been pushed in tag 19
430
431 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
432 - GetVersion should now report full URLs with path
433 - scansfa has nicer output and new syntax (entry URLs as args and not options)
434 - dos2unix'ed flash policy pill
435
436 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
437 - fix packaging again for f8
438
439 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
440 - fix packaging (apparently broken in 1.0-16)
441 - first working version of sfascan
442 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
443 - deprecated the sfa_geni_aggregate config category
444
445 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
446 - Fix build problem
447 - First version of SFA scanner
448
449 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
450 - Add support for Flash clients using flashpolicy
451 - Fix problems with tag handling in RSpec
452
453 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
454 - Modifications to the Eucalyptus Aggregate Manager
455 - Fixes for VINI RSpec
456 - Fix tag handling for PL RSpec
457 - Fix XML Schema ordering for <urn> element
458
459 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
460 - just set x509 version to 2
461
462 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
463 - added urn to the node area in rspecs
464 - conversion to urn now exports fqdn
465 - sfa-import-plc.py now creates a unique registry record for each SFA interface
466
467 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
468 - undo broken attempt for python-2.7
469
470 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
471 - SMs avoid duplicates for when call graph has dags;
472 - just based on network's name, when a duplicate occurs, one is just dropped
473 - does not try to merge/aggregate 2 networks
474 - also reviewed logging with the hope to fix the sfa startup msg:
475 - TypeError: not all arguments converted during string formatting
476
477 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
478 - verify credentials against xsd schema
479 - Fix SM to SM communication
480 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
481 - new setting session_key_path
482
483 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
484 - fix registry credential regeneration and handle expiration
485 - support for setting slice tags (min_role=user)
486 - client can display its own version: sfi.py version --local
487 - GetVersion to provide urn in addition to hrn
488 - more code uses plxrn vs previous helper functions
489 - import replaces '+' in email addresses with '_'
490
491 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
492 - fix GetVersion code_tag and add code_url
493
494 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
495 - extend GetVersion towards minimum federation introspection, and expose local tag
496
497 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
498 - fixed some legacy issues (list vs List)
499 - deprecated sfa.util.namespace for xrn and plxrn
500 - unit tests ship as the sfa-tests rpm
501
502 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
503 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
504 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
505 - hrn-urn translations tweaked
506 - fixed 'service sfa status'
507 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
508 - started to repair sfadump - although not usable yet
509 - trust objects now have dump_string method that dump() actually prints
510 - unit tests under review
511 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
512 - binaries now support -v or -vv to increase loglevel
513 - trashed obsolete sfa.util.client
514
515 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
516 - various bugfixes and cleanup, improved/harmonized logging
517
518 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
519 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
520   to avoid returning a PLCAPI exception that might confuse users.
521 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
522 - fix build errors.  
523
524 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
525 - (Architecture) Credential format changed to match ProtoGENI xml format
526 - (Architecture) All interfaces export a new set of methods that are compatible
527    with the ProtoGeni Aggregate spec. These new methods are considered a 
528    replacement  for the pervious methods exported by the interfaces. All 
529    previous methods are still exported and work as normal, but they are 
530    considered deprecated and will not be supported in future releases.  
531 - (Architecture) SFI has been updated to use the new interface methods.
532 - (Architecture) Changed keyconvet implementation from c to python.
533 - (Architecture) Slice Manager now attempts looks for a delegated credential
534   provided by the client before using its own server credential.
535 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
536   This cache now exists only in memory and is cleared when service is restarted
537   or cache lifetime is exceeded.  
538 - (Performance) SliceManager sends request to Aggregates in parallel instead 
539   of sequentially.
540 - (Bug fix) SFA tickets now support the new rspec format.
541 - (Bug fix) SFI only uses cahced credential if they aren't expired.
542 - (Bug fix) Cerdential delegation modified to work with new credential format.
543 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
544   Aggregate instead of relaying through the Slice Manager.
545 - (Enhancement) Simplified caching. Accociated a global cache instance with
546   the api handler on every new server request, making it easier to access the 
547   cache and use in more general ways.     
548
549 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
550 - SfaServer now uses a pool of threads to handle requests concurrently
551 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
552 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
553 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
554 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
555 - Component manager does not install gid files if slice already has them  
556 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
557 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
558 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
559      
560 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
561 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
562 - - sfa-config-tty now has the same features like plc-config-tty
563 - - Contains code to support both urn and hrn
564 - - Cleaned up request_hash related stuff
565 - - SM, AM and Registry code is organized under respective managers
566 - - Site and Slice synchronization across federated aggregates
567 - - Script to generate sfa_component_config
568
569 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
570 - sfa-config-tty now has the same features like plc-config-tty
571 - Contains code to support both urn and hrn
572 - Cleaned up request_hash related stuff
573 - SM, AM and Registry code is organized under respective managers
574 - Slice synchronization across federated aggregates
575 - some bugs are fixed
576
577 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
578 - checkpoint with fewer mentions of geni
579
580 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
581 - checkpointing
582 - this is believed to pass the tests; among other things:
583 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
584
585 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
586 - This tag includes:
587 - - Sfatables
588 - - Preliminary version of hash based authentication
589 - - Initial code for Component Manager
590 - - Authority structure is moved to /var/lib/sfa/
591 - - some bug-fixes
592
593 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
594 - Create_slice and get_resources methods are connected to sfatables.
595 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
596
597 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
598 - Bug fix on update and remove_peer_object methods
599 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
600
601 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
602 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
603
604 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
605 - compatibility with RefreshPeer
606 - incremental mechanism for importing PLC records into SFA tables
607 - unified single database (still inside the underlying PLC db postgresql server)
608 - includes/improves call traceability and logging features
609 - several bug fixes
610
611 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
612 - added libxslt-python dependency
613
614 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
615 - unified single SFA database in the PLC-DB
616 - upcalls from  PLCAPI to SFA methods
617 - SFA call traceability and logging features
618 - many bug fixes
619 - includes first/rough version of sfatables for policy implementation
620
621 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
622 - snapshot after the GEC5 demo
623 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
624
625 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
626 - snapshot july 15 - has gone through superficial manual testing
627 - hopefully a good basis for gec5 demo
628 - multi-dir sfi client tested as well
629
630 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
631 - rename geniwrapper.spec into sfa.spec
632
633 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
634 - clean up in xmlrpc/soap, --protocol option to chose between both
635 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
636 - hopefully more helpful context in case of crashes when importing
637 - bugfixes for using only /etc/sfa for site-dep files
638 - bugfixes in wsdl generation
639
640 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
641 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
642 - config variables in sfa_config now start with SFA_ and not GENI_
643 - config.py can be loaded even with no config present
644
645 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
646 - first step for cleanup and reorganization
647 - mass-renaming from geni to sfa (some are still needed)
648 - sfa/trust implements the security architecture
649
650 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
651 - snapshot for reproducible builds
652
653 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
654 - snapshot for the convenience of alpha users
655
656 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
657 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
658
659 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
660 - ongoing work - snapshot for 4.3-rc9
661
662 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
663 - various fixes
664
665 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
666 - bugfixes - still a work in progress
667
668 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
669 - initial package
670
671
672 %define module_current_branch 0.2