validate credential against RelaxNG schema
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 8
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 /etc/sfa/credential.rng
135 %{_bindir}/sfa-config-tty
136 %{_bindir}/sfa-import-plc.py*
137 %{_bindir}/sfa-clean-peer-records.py*
138 %{_bindir}/sfa-nuke-plc.py*
139 %{_bindir}/gen-sfa-cm-config.py*
140 %{_bindir}/sfa-ca.py*
141
142 %files client
143 %config (noreplace) /etc/sfa/sfi_config
144 %{_bindir}/sfi*
145 %{_bindir}/getNodes.py*
146 %{_bindir}/getRecord.py*
147 %{_bindir}/setRecord.py*
148 %{_bindir}/sfadump.py*
149
150 %files sfatables
151 %{_bindir}/sfatables
152
153 %files tests
154 %{_datadir}/sfa/tests
155
156 ### sfa-plc installs the 'sfa' service
157 %post plc
158 chkconfig --add sfa
159
160 %preun plc
161 if [ "$1" = 0 ] ; then
162   /sbin/service sfa stop || :
163   /sbin/chkconfig --del sfa || :
164 fi
165
166 %postun plc
167 [ "$1" -ge "1" ] && service sfa restart
168
169 ### sfa-cm installs the 'sfa-cm' service
170 %post cm
171 chkconfig --add sfa-cm
172
173 %preun cm
174 if [ "$1" = 0 ] ; then
175    /sbin/service sfa-cm stop || :
176    /sbin/chkconfig --del sfa-cm || :
177 fi
178
179 %postun cm
180 [ "$1" -ge "1" ] && service sfa-cm restart
181
182
183 %changelog
184 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
185 - fix registry credential regeneration and handle expiration
186 - support for setting slice tags (min_role=user)
187 - client can display its own version: sfi.py version --local
188 - GetVersion to provide urn in addition to hrn
189 - more code uses plxrn vs previous helper functions
190 - import replaces '+' in email addresses with '_'
191
192 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
193 - fix GetVersion code_tag and add code_url
194
195 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
196 - extend GetVersion towards minimum federation introspection, and expose local tag
197
198 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
199 - fixed some legacy issues (list vs List)
200 - deprecated sfa.util.namespace for xrn and plxrn
201 - unit tests ship as the sfa-tests rpm
202
203 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
204 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
205 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
206 - hrn-urn translations tweaked
207 - fixed 'service sfa status'
208 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
209 - started to repair sfadump - although not usable yet
210 - trust objects now have dump_string method that dump() actually prints
211 - unit tests under review
212 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
213 - binaries now support -v or -vv to increase loglevel
214 - trashed obsolete sfa.util.client
215
216 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
217 - various bugfixes and cleanup, improved/harmonized logging
218
219 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
220 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
221   to avoid returning a PLCAPI exception that might confuse users.
222 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
223 - fix build errors.  
224
225 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
226 - (Architecture) Credential format changed to match ProtoGENI xml format
227 - (Architecture) All interfaces export a new set of methods that are compatible
228    with the ProtoGeni Aggregate spec. These new methods are considered a 
229    replacement  for the pervious methods exported by the interfaces. All 
230    previous methods are still exported and work as normal, but they are 
231    considered deprecated and will not be supported in future releases.  
232 - (Architecture) SFI has been updated to use the new interface methods.
233 - (Architecture) Changed keyconvet implementation from c to python.
234 - (Architecture) Slice Manager now attempts looks for a delegated credential
235   provided by the client before using its own server credential.
236 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
237   This cache now exists only in memory and is cleared when service is restarted
238   or cache lifetime is exceeded.  
239 - (Performance) SliceManager sends request to Aggregates in parallel instead 
240   of sequentially.
241 - (Bug fix) SFA tickets now support the new rspec format.
242 - (Bug fix) SFI only uses cahced credential if they aren't expired.
243 - (Bug fix) Cerdential delegation modified to work with new credential format.
244 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
245   Aggregate instead of relaying through the Slice Manager.
246 - (Enhancement) Simplified caching. Accociated a global cache instance with
247   the api handler on every new server request, making it easier to access the 
248   cache and use in more general ways.     
249
250 %changelog
251 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
252 - fix registry credential regeneration and handle expiration
253 - support for setting slice tags (min_role=user)
254 - client can display its own version: sfi.py version --local
255 - GetVersion to provide urn in addition to hrn
256 - more code uses plxrn vs previous helper functions
257 - import replaces '+' in email addresses with '_'
258
259 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
260 - fix GetVersion code_tag and add code_url
261
262 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
263 - extend GetVersion towards minimum federation introspection, and expose local tag
264
265 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
266 - fixed some legacy issues (list vs List)
267 - deprecated sfa.util.namespace for xrn and plxrn
268 - unit tests ship as the sfa-tests rpm
269
270 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
271 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
272 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
273 - hrn-urn translations tweaked
274 - fixed 'service sfa status'
275 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
276 - started to repair sfadump - although not usable yet
277 - trust objects now have dump_string method that dump() actually prints
278 - unit tests under review
279 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
280 - binaries now support -v or -vv to increase loglevel
281 - trashed obsolete sfa.util.client
282
283 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
284 - various bugfixes and cleanup, improved/harmonized logging
285
286 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
287 - SfaServer now uses a pool of threads to handle requests concurrently
288 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
289 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
290 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
291 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
292 - Component manager does not install gid files if slice already has them  
293 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
294 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
295 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
296      
297 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
298 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
299 - - sfa-config-tty now has the same features like plc-config-tty
300 - - Contains code to support both urn and hrn
301 - - Cleaned up request_hash related stuff
302 - - SM, AM and Registry code is organized under respective managers
303 - - Site and Slice synchronization across federated aggregates
304 - - Script to generate sfa_component_config
305
306 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
307 - sfa-config-tty now has the same features like plc-config-tty
308 - Contains code to support both urn and hrn
309 - Cleaned up request_hash related stuff
310 - SM, AM and Registry code is organized under respective managers
311 - Slice synchronization across federated aggregates
312 - some bugs are fixed
313
314 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
315 - checkpoint with fewer mentions of geni
316
317 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
318 - checkpointing
319 - this is believed to pass the tests; among other things:
320 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
321
322 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
323 - This tag includes:
324 - - Sfatables
325 - - Preliminary version of hash based authentication
326 - - Initial code for Component Manager
327 - - Authority structure is moved to /var/lib/sfa/
328 - - some bug-fixes
329
330 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
331 - Create_slice and get_resources methods are connected to sfatables.
332 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
333
334 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
335 - Bug fix on update and remove_peer_object methods
336 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
337
338 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
339 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
340
341 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
342 - compatibility with RefreshPeer
343 - incremental mechanism for importing PLC records into SFA tables
344 - unified single database (still inside the underlying PLC db postgresql server)
345 - includes/improves call traceability and logging features
346 - several bug fixes
347
348 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
349 - added libxslt-python dependency
350
351 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
352 - unified single SFA database in the PLC-DB
353 - upcalls from  PLCAPI to SFA methods
354 - SFA call traceability and logging features
355 - many bug fixes
356 - includes first/rough version of sfatables for policy implementation
357
358 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
359 - snapshot after the GEC5 demo
360 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
361
362 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
363 - snapshot july 15 - has gone through superficial manual testing
364 - hopefully a good basis for gec5 demo
365 - multi-dir sfi client tested as well
366
367 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
368 - rename geniwrapper.spec into sfa.spec
369
370 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
371 - clean up in xmlrpc/soap, --protocol option to chose between both
372 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
373 - hopefully more helpful context in case of crashes when importing
374 - bugfixes for using only /etc/sfa for site-dep files
375 - bugfixes in wsdl generation
376
377 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
378 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
379 - config variables in sfa_config now start with SFA_ and not GENI_
380 - config.py can be loaded even with no config present
381
382 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
383 - first step for cleanup and reorganization
384 - mass-renaming from geni to sfa (some are still needed)
385 - sfa/trust implements the security architecture
386
387 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
388 - snapshot for reproducible builds
389
390 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
391 - snapshot for the convenience of alpha users
392
393 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
394 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
395
396 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
397 - ongoing work - snapshot for 4.3-rc9
398
399 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
400 - various fixes
401
402 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
403 - bugfixes - still a work in progress
404
405 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
406 - initial package
407
408
409 %define module_current_branch 0.2