install sfatables
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 2
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36
37 # python 2.5 has uuid module added, for python 2.4 we still need it 
38 %define uuid_missing %(`python -c "import uuid" 2> /dev/null ; echo $?`)
39 %if uuid_missing
40 Requires: python-uuid
41 %endif
42
43 %package plc
44 Summary: the SFA wrapper arounf MyPLC
45 Group: Applications/System
46 Requires: sfa
47
48 %package client
49 Summary: the SFA experimenter-side CLI
50 Group: Applications/System
51 Requires: sfa
52
53 %package sfatables
54 Summary: sfatables policy tool for SFA
55 Group: Applications/System
56 Requires: sfa
57
58 %description
59 This package provides the python libraries that the SFA implementation requires
60
61 %description plc
62 Geniwrapper implements the SFA interface which serves as a layer
63 between the existing PlanetLab interfaces and the SFA API.
64
65 %description client
66 This package provides the client side of the SFA API, in particular
67 sfi.py, together with other utilities.
68
69 %description sfatables
70 sfatables is a tool for defining access and admission control policies
71 in an SFA network, in much the same way as iptables is for ip
72 networks.
73
74 %prep
75 %setup -q
76
77 %build
78 make
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 make install DESTDIR="$RPM_BUILD_ROOT"
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %{python_sitelib}/*
89 /usr/bin/keyconvert
90 /var/www/html/wsdl/*.wsdl
91
92 %files plc
93 %defattr(-,root,root)
94 %config (noreplace) /etc/sfa/sfa_config
95 %config (noreplace) /etc/sfa/aggregates.xml
96 %config (noreplace) /etc/sfa/registries.xml
97 /etc/init.d/sfa
98 %{_bindir}/sfa-config-tty
99 %{_bindir}/sfa-import-plc.py*
100 %{_bindir}/sfa-nuke-plc.py*
101 %{_bindir}/sfa-server.py*
102
103 %files client
104 %config (noreplace) /etc/sfa/sfi_config
105 %{_bindir}/sfi.py*
106 %{_bindir}/getNodes.py*
107 %{_bindir}/getRecord.py*
108 %{_bindir}/setRecord.py*
109 %{_bindir}/genidump.py*
110
111 %files sfatables
112 /etc/sfatables/*
113 %{_bindir}/sfatables
114 %{python_sitelib}/sfatables/*
115
116 %pre plc
117 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
118
119 %post plc
120 chkconfig --add sfa
121
122 %changelog
123 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
124 - compatibility with RefreshPeer
125 - incremental mechanism for importing PLC records into SFA tables
126 - unified single database (still inside the underlying PLC db postgresql server)
127 - includes/improves call traceability and logging features
128 - several bug fixes
129
130 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
131 - added libxslt-python dependency
132
133 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
134 - unified single SFA database in the PLC-DB
135 - upcalls from  PLCAPI to SFA methods
136 - SFA call traceability and logging features
137 - many bug fixes
138 - includes first/rough version of sfatables for policy implementation
139
140 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
141 - snapshot after the GEC5 demo
142 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
143
144 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
145 - snapshot july 15 - has gone through superficial manual testing
146 - hopefully a good basis for gec5 demo
147 - multi-dir sfi client tested as well
148
149 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
150 - rename geniwrapper.spec into sfa.spec
151
152 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
153 - clean up in xmlrpc/soap, --protocol option to chose between both
154 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
155 - hopefully more helpful context in case of crashes when importing
156 - bugfixes for using only /etc/sfa for site-dep files
157 - bugfixes in wsdl generation
158
159 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
160 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
161 - config variables in sfa_config now start with SFA_ and not GENI_
162 - config.py can be loaded even with no config present
163
164 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
165 - first step for cleanup and reorganization
166 - mass-renaming from geni to sfa (some are still needed)
167 - sfa/trust implements the security architecture
168
169 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
170 - snapshot for reproducible builds
171
172 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
173 - snapshot for the convenience of alpha users
174
175 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
176 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
177
178 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
179 - ongoing work - snapshot for 4.3-rc9
180
181 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
182 - various fixes
183
184 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
185 - bugfixes - still a work in progress
186
187 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
188 - initial package
189
190
191 %define module_current_branch 0.2