move init.d and cron.d one step up in the source tree
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 # sfa and sfatables depend on each other.
134 %{python_sitelib}/sfa
135 %{python_sitelib}/xmlbuilder
136 /etc/init.d/sfa
137 %{_bindir}/sfa-start.py*
138 %{_bindir}/keyconvert.py*
139 %{_bindir}/sfa-config-tty
140 %config /etc/sfa/default_config.xml
141 %config (noreplace) /etc/sfa/aggregates.xml
142 %config (noreplace) /etc/sfa/registries.xml
143 /var/www/html/wsdl/*.wsdl
144
145 %files plc
146 %defattr(-,root,root)
147 /etc/sfa/pl.rng
148 /etc/sfa/credential.xsd
149 /etc/sfa/top.xsd
150 /etc/sfa/sig.xsd
151 /etc/sfa/xml.xsd
152 /etc/sfa/protogeni-rspec-common.xsd
153 /etc/sfa/topology
154 %{_bindir}/sfa-import-plc.py*
155 %{_bindir}/sfa-nuke-plc.py*
156 %{_bindir}/sfa-clean-peer-records.py*
157 %{_bindir}/gen-sfa-cm-config.py*
158 %{_bindir}/sfa-ca.py*
159
160 %files client
161 %config (noreplace) /etc/sfa/sfi_config
162 %{_bindir}/sfi*
163 %{_bindir}/getNodes.py*
164 %{_bindir}/getRecord.py*
165 %{_bindir}/setRecord.py*
166 %{_bindir}/sfadump.py*
167
168 %files sfatables
169 /etc/sfatables/*
170 %{_bindir}/sfatables
171 %{python_sitelib}/sfatables
172
173 %files cm
174 /etc/init.d/sfa-cm
175 %{_bindir}/sfa_component_setup.py*
176 # cron jobs here 
177
178 %files flashpolicy
179 %{_bindir}/sfa_flashpolicy.py*
180 /etc/sfa/sfa_flashpolicy_config.xml
181
182 %files tests
183 %{_datadir}/sfa/tests
184
185 ### sfa-plc installs the 'sfa' service
186 %post plc
187 chkconfig --add sfa
188
189 %preun plc
190 if [ "$1" = 0 ] ; then
191   /sbin/service sfa stop || :
192   /sbin/chkconfig --del sfa || :
193 fi
194
195 %postun plc
196 [ "$1" -ge "1" ] && service sfa restart
197
198 ### sfa-cm installs the 'sfa-cm' service
199 %post cm
200 chkconfig --add sfa-cm
201
202 %preun cm
203 if [ "$1" = 0 ] ; then
204    /sbin/service sfa-cm stop || :
205    /sbin/chkconfig --del sfa-cm || :
206 fi
207
208 %postun cm
209 [ "$1" -ge "1" ] && service sfa-cm restart || :
210
211 %changelog
212 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
213 - sfa should now be started *before* the initial import
214 - sfa to use its own database (default sfa) - can run without myplc
215 - server calls support optional 'options'
216 - client sends options in argument when needed
217 - fix infinite getattr recursion in elements/element.py
218 - error codes in line with geni
219
220 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
221 - fixed links and attributes in rspecs
222 - minor cleanup in the API methods, and more consistent names in manager methods
223
224 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
225 - ongoing refoactoring towards more genericity
226 - passes tests again although known issues remain with attributes/tags
227
228 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
229 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
230 - improvements in the pgv2 rspecs
231 - driver separated from api
232 - code starts moving around where it belongs
233 - sfascan caches getversion across invokations
234 - vini topology extracted as a config file
235
236 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
237 - first support for protogeni rspecs is working
238 - vini no longer needs a specific manager
239 - refactoring underway towards more flexible/generic architecture
240
241 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
242 - Unicode-friendliness for user names with accents/special chars.
243 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
244 - CreaetSliver no longer fails for users that have a capital letter in their URN.
245 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
246 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
247 - Fix bugs and missing imports     
248  
249
250 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
251 - new method record.get_field for sface
252
253 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
254 - new option -c to sfa-nuke-plc.py
255 - CreateSliver fixed for admin-only slice tags
256
257 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
258 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
259 - Fixed holes in certificate verification logic.
260 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
261 - Added 'boot_state' as an attribute of the node element in SFA rspec.
262 - Non authority certificates are marked as CA:FALSE.
263
264 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
265 - fix typo in sfa-1.0-31 tag.
266 - added CreateGid() Registry interface method.
267
268 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
269 - fix typo in sfa-1.0-30 tag
270
271 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
272 - Declare namespace and schema location in the credential.
273 - Fix bug that prevetend connections from timing out.
274 - Fix slice delegation.
275 - Add statistics to slicemaanger listresources/createsliver rspec.
276 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
277   of days a user can extend their slice expiration.
278 - CA certs are only issued to objects of type authority
279    
280 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
281 - tag 1.0-28 was broken due to typo in the changelog
282 - new class sfa/util/httpsProtocol.py that supports timeouts
283
284 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
285 - Resolved issue that caused sfa hold onto idle db connections.
286 - Fix bug that caused the registry to use the wrong type of credential.
287 - Support authority+sm type.
288 - Fix rspec merging bugs.
289 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
290 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
291  planetlab hosted initscripts using the <planetlab:initscript> tag  
292 - Can now handle extraneous whitespace in the rspec without failing.   
293  
294 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
295 - ProtoGENI v2 RSpec updates.
296 - Convert expiration timestamps with timezone info in credentials to utc.
297 - Fixed redundant logging issue. 
298 - Improved SliceManager and SFI client logging.
299 - Support aggregates that don't support the optional 'call_id' argument. 
300 - Only call get_trusted_certs() at aggreage interfaces that support the call.
301 - CreateSliver() now handles MyPLC slice attributes/tags.
302 - Cache now supports persistence.
303 - Hide whitelisted nodes.
304
305 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
306 - fixed issues with sup authority signing
307 - fixed bugs in remove_slivers and SliverStatus
308
309 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
310 - fix typo that prevented aggregates from operating properly
311
312 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
313 - load trusted certs into ssl context prior to handshake
314 - client's logfile lives in ~/.sfi/sfi.log
315
316 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
317 - includes a change on passphrases that was intended in 1.0-22
318
319 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
320 - Added support for ProtoGENI RSpec v2
321  
322 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
323 - stable sfascan
324 - fix in initscript, *ENABLED tags in config now taken into account
325
326 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
327 - some commits had not been pushed in tag 19
328
329 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
330 - GetVersion should now report full URLs with path
331 - scansfa has nicer output and new syntax (entry URLs as args and not options)
332 - dos2unix'ed flash policy pill
333
334 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
335 - fix packaging again for f8
336
337 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
338 - fix packaging (apparently broken in 1.0-16)
339 - first working version of sfascan
340 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
341 - deprecated the sfa_geni_aggregate config category
342
343 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
344 - Fix build problem
345 - First version of SFA scanner
346
347 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
348 - Add support for Flash clients using flashpolicy
349 - Fix problems with tag handling in RSpec
350
351 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
352 - Modifications to the Eucalyptus Aggregate Manager
353 - Fixes for VINI RSpec
354 - Fix tag handling for PL RSpec
355 - Fix XML Schema ordering for <urn> element
356
357 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
358 - just set x509 version to 2
359
360 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
361 - added urn to the node area in rspecs
362 - conversion to urn now exports fqdn
363 - sfa-import-plc.py now creates a unique registry record for each SFA interface
364
365 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
366 - undo broken attempt for python-2.7
367
368 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
369 - SMs avoid duplicates for when call graph has dags;
370 - just based on network's name, when a duplicate occurs, one is just dropped
371 - does not try to merge/aggregate 2 networks
372 - also reviewed logging with the hope to fix the sfa startup msg:
373 - TypeError: not all arguments converted during string formatting
374
375 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
376 - verify credentials against xsd schema
377 - Fix SM to SM communication
378 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
379 - new setting session_key_path
380
381 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
382 - fix registry credential regeneration and handle expiration
383 - support for setting slice tags (min_role=user)
384 - client can display its own version: sfi.py version --local
385 - GetVersion to provide urn in addition to hrn
386 - more code uses plxrn vs previous helper functions
387 - import replaces '+' in email addresses with '_'
388
389 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
390 - fix GetVersion code_tag and add code_url
391
392 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
393 - extend GetVersion towards minimum federation introspection, and expose local tag
394
395 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
396 - fixed some legacy issues (list vs List)
397 - deprecated sfa.util.namespace for xrn and plxrn
398 - unit tests ship as the sfa-tests rpm
399
400 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
401 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
402 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
403 - hrn-urn translations tweaked
404 - fixed 'service sfa status'
405 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
406 - started to repair sfadump - although not usable yet
407 - trust objects now have dump_string method that dump() actually prints
408 - unit tests under review
409 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
410 - binaries now support -v or -vv to increase loglevel
411 - trashed obsolete sfa.util.client
412
413 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
414 - various bugfixes and cleanup, improved/harmonized logging
415
416 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
417 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
418   to avoid returning a PLCAPI exception that might confuse users.
419 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
420 - fix build errors.  
421
422 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
423 - (Architecture) Credential format changed to match ProtoGENI xml format
424 - (Architecture) All interfaces export a new set of methods that are compatible
425    with the ProtoGeni Aggregate spec. These new methods are considered a 
426    replacement  for the pervious methods exported by the interfaces. All 
427    previous methods are still exported and work as normal, but they are 
428    considered deprecated and will not be supported in future releases.  
429 - (Architecture) SFI has been updated to use the new interface methods.
430 - (Architecture) Changed keyconvet implementation from c to python.
431 - (Architecture) Slice Manager now attempts looks for a delegated credential
432   provided by the client before using its own server credential.
433 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
434   This cache now exists only in memory and is cleared when service is restarted
435   or cache lifetime is exceeded.  
436 - (Performance) SliceManager sends request to Aggregates in parallel instead 
437   of sequentially.
438 - (Bug fix) SFA tickets now support the new rspec format.
439 - (Bug fix) SFI only uses cahced credential if they aren't expired.
440 - (Bug fix) Cerdential delegation modified to work with new credential format.
441 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
442   Aggregate instead of relaying through the Slice Manager.
443 - (Enhancement) Simplified caching. Accociated a global cache instance with
444   the api handler on every new server request, making it easier to access the 
445   cache and use in more general ways.     
446
447 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
448 - SfaServer now uses a pool of threads to handle requests concurrently
449 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
450 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
451 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
452 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
453 - Component manager does not install gid files if slice already has them  
454 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
455 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
456 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
457      
458 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
459 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
460 - - sfa-config-tty now has the same features like plc-config-tty
461 - - Contains code to support both urn and hrn
462 - - Cleaned up request_hash related stuff
463 - - SM, AM and Registry code is organized under respective managers
464 - - Site and Slice synchronization across federated aggregates
465 - - Script to generate sfa_component_config
466
467 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
468 - sfa-config-tty now has the same features like plc-config-tty
469 - Contains code to support both urn and hrn
470 - Cleaned up request_hash related stuff
471 - SM, AM and Registry code is organized under respective managers
472 - Slice synchronization across federated aggregates
473 - some bugs are fixed
474
475 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
476 - checkpoint with fewer mentions of geni
477
478 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
479 - checkpointing
480 - this is believed to pass the tests; among other things:
481 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
482
483 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
484 - This tag includes:
485 - - Sfatables
486 - - Preliminary version of hash based authentication
487 - - Initial code for Component Manager
488 - - Authority structure is moved to /var/lib/sfa/
489 - - some bug-fixes
490
491 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
492 - Create_slice and get_resources methods are connected to sfatables.
493 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
494
495 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
496 - Bug fix on update and remove_peer_object methods
497 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
498
499 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
500 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
501
502 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
503 - compatibility with RefreshPeer
504 - incremental mechanism for importing PLC records into SFA tables
505 - unified single database (still inside the underlying PLC db postgresql server)
506 - includes/improves call traceability and logging features
507 - several bug fixes
508
509 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
510 - added libxslt-python dependency
511
512 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
513 - unified single SFA database in the PLC-DB
514 - upcalls from  PLCAPI to SFA methods
515 - SFA call traceability and logging features
516 - many bug fixes
517 - includes first/rough version of sfatables for policy implementation
518
519 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
520 - snapshot after the GEC5 demo
521 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
522
523 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
524 - snapshot july 15 - has gone through superficial manual testing
525 - hopefully a good basis for gec5 demo
526 - multi-dir sfi client tested as well
527
528 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
529 - rename geniwrapper.spec into sfa.spec
530
531 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
532 - clean up in xmlrpc/soap, --protocol option to chose between both
533 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
534 - hopefully more helpful context in case of crashes when importing
535 - bugfixes for using only /etc/sfa for site-dep files
536 - bugfixes in wsdl generation
537
538 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
539 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
540 - config variables in sfa_config now start with SFA_ and not GENI_
541 - config.py can be loaded even with no config present
542
543 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
544 - first step for cleanup and reorganization
545 - mass-renaming from geni to sfa (some are still needed)
546 - sfa/trust implements the security architecture
547
548 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
549 - snapshot for reproducible builds
550
551 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
552 - snapshot for the convenience of alpha users
553
554 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
555 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
556
557 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
558 - ongoing work - snapshot for 4.3-rc9
559
560 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
561 - various fixes
562
563 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
564 - bugfixes - still a work in progress
565
566 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
567 - initial package
568
569
570 %define module_current_branch 0.2