Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package flashpolicy
66 Summary: SFA support for flash clients
67 Group: Applications/System
68 Requires: sfa
69
70 %package client
71 Summary: the SFA experimenter-side CLI
72 Group: Applications/System
73 Requires: sfa
74 Requires: pyOpenSSL >= 0.7
75
76 %package plc
77 Summary: the SFA layer around MyPLC
78 Group: Applications/System
79 Requires: sfa
80
81 %package cm
82 Summary: the SFA layer around MyPLC NodeManager
83 Group: Applications/System
84 Requires: sfa
85 Requires: pyOpenSSL >= 0.6
86
87 %package federica
88 Summary: the SFA layer around Federica
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa
106
107 %description
108 This package provides the python libraries for the PlanetLab implementation of SFA
109
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112
113 %description client
114 This package provides the client side of the SFA API, in particular
115 sfi.py, together with other utilities.
116
117 %description plc
118 This package implements the SFA interface which serves as a layer
119 between the existing PlanetLab interfaces and the SFA API.
120
121 %description cm
122 This package implements the SFA interface which serves as a layer
123 between the existing PlanetLab NodeManager interfaces and the SFA API.
124
125 %description federica
126 The SFA driver for FEDERICA.
127
128 %description sfatables
129 sfatables is a tool for defining access and admission control policies
130 in an SFA network, in much the same way as iptables is for ip
131 networks. This is the command line interface to manage sfatables
132
133 %description xmlbuilder
134 This package contains the xmlbuilder python library, packaged for
135 convenience as it is not supported by fedora
136
137 %description tests
138 Provides some binary unit tests in /usr/share/sfa/tests
139
140 %prep
141 %setup -q
142
143 %build
144 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %{python_sitelib}/sfa/__init__.py*
155 %{python_sitelib}/sfa/trust
156 %{python_sitelib}/sfa/storage
157 %{python_sitelib}/sfa/util
158 %{python_sitelib}/sfa/server
159 %{python_sitelib}/sfa/methods
160 %{python_sitelib}/sfa/generic
161 %{python_sitelib}/sfa/managers
162 %{python_sitelib}/sfa/importer
163 %{python_sitelib}/sfa/rspecs
164 %{python_sitelib}/sfa/client
165 /etc/init.d/sfa
166 %{_bindir}/sfa-start.py*
167 %{_bindir}/sfaadmin.py*
168 %{_bindir}/sfaadmin
169 %{_bindir}/keyconvert.py*
170 %{_bindir}/sfa-config-tty
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 /usr/share/sfa/migrations
175 /usr/share/sfa/examples
176 /var/www/html/wsdl/*.wsdl
177
178 %files flashpolicy
179 %{_bindir}/sfa_flashpolicy.py*
180 /etc/sfa/sfa_flashpolicy_config.xml
181
182 %files client
183 %config (noreplace) /etc/sfa/sfi_config
184 %{_bindir}/sfi*.py*
185 %{_bindir}/sfi
186 %{_bindir}/get*.py*
187 %{_bindir}/setRecord.py*
188 %{_bindir}/sfascan.py*
189 %{_bindir}/sfascan
190 %{_bindir}/sfadump.py*
191
192 %files plc
193 %defattr(-,root,root)
194 %{python_sitelib}/sfa/planetlab
195 %{python_sitelib}/sfa/openstack
196 /etc/sfa/pl.rng
197 /etc/sfa/credential.xsd
198 /etc/sfa/top.xsd
199 /etc/sfa/sig.xsd
200 /etc/sfa/xml.xsd
201 /etc/sfa/protogeni-rspec-common.xsd
202 /etc/sfa/topology
203 %{_bindir}/gen-sfa-cm-config.py*
204
205 %files cm
206 /etc/init.d/sfa-cm
207 %{_bindir}/sfa_component_setup.py*
208 # cron jobs here 
209
210 %files federica
211 %{python_sitelib}/sfa/federica
212
213 %files sfatables
214 /etc/sfatables/*
215 %{_bindir}/sfatables
216 %{python_sitelib}/sfatables
217
218 %files xmlbuilder
219 %{python_sitelib}/xmlbuilder
220
221 %files tests
222 %{_datadir}/sfa/tests
223
224 ### sfa installs the 'sfa' service
225 %post 
226 chkconfig --add sfa
227
228 %preun 
229 if [ "$1" = 0 ] ; then
230   /sbin/service sfa stop || :
231   /sbin/chkconfig --del sfa || :
232 fi
233
234 %postun
235 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
236
237 ### sfa-cm installs the 'sfa-cm' service
238 %post cm
239 chkconfig --add sfa-cm
240
241 %preun cm
242 if [ "$1" = 0 ] ; then
243    /sbin/service sfa-cm stop || :
244    /sbin/chkconfig --del sfa-cm || :
245 fi
246
247 %postun cm
248 [ "$1" -ge "1" ] && service sfa-cm restart || :
249
250 %changelog
251 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
252 - fix bug in sfi update()
253
254 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
255 - fix broken sfa.util.xrn class for lowercase
256
257 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
258 - new 'void' generic_flavour for running in registry-only mode
259 - first shot at refactoring importers - probably needs more work
260 - openstack: various enhancements
261 - sfi interface to registry not based on xml files anymore
262 - sfi show sorts result on record key
263 - bugfix in sfa update on users with a pl-backed registry
264
265 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
266 - renamed sfa/plc into sfa/planetlab
267 - plxrn moved in sfa/planetlab as well
268 - bugfix for sfaadmin reg update --pi <>
269
270 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
271 - native data model now has a authority x user (PI) relationship
272 - no call to 'augment_records_with_testbed_info' for GetCredential
273 - which means, registry can now be used without an underlying testbed
274 - reviewed code about relationships b/w objects and related in pl driver
275 - reviewed PL import wrt roles and pis
276 - removed mentions to is_enabled in driver
277 - small changes in update_relation* in driver interface
278 - sfaadmin: can create authorities and attach pi users to them
279 - sfaadmin: categories can be abbreviated
280 - sfi list and sfaadmin list have a new -r/--recursive option
281 - this means that List now supports an (optional) 'options' argument
282 - sfi config can display config vars
283 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
284
285 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
286 - make sync now supports vserver or lxc.
287 - Added slice expiration and login info to SliverStatus response. 
288 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
289   the 'component_name' attribute.
290 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
291   
292 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
293 - Introduced new administrative command line script, sfaadmin.py. Removed various single
294  purpose scripts and migrated their functionality into sfaadmin.py.
295 - Refactored Registry import scripts.
296 - Removed SQLAlchemy dependency from sfi.py.
297 - Fixed bugs in sfi.py
298 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
299
300 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
301 - slice x researcher rel. in database,
302 - plimporter to maintain that, as well as user.email, and more robust
303 - ongoing draft for sfaadmin tool
304 - support for a federica driver
305 - support for a nova/euca driver
306 - no more sfa-clean-peer-records script
307
308 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
309 - registry database has user's keys and mail (known as v0 for migrate)
310 - pl importer properly maintains user's keys and mail
311 - pl driver now to handle 'role' when adding person record (exp.)
312 - first draft of federica driver with config section
313 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
314 - plus, from master as of tag merged-in-sfa-2.1-2:
315 - disk_image revisited
316 - new nova_shell nova_driver & various tweaks for openstack
317
318 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
319 - uses sqlalchemy and related migrate
320 - thorough migration and upgrade scheme
321 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
322 - trashed dbinfo stuff in auth hierarchy
323 - data model still has little more than plain records
324 - checkpoint tag, not yet intended for release
325
326 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
327 - client: added -R --raw sfi cmdline option that displays raw server response.
328 - client: request GENI RSpec by default. 
329 - server: remove database dependencies from sfa.server.sfaapi.
330 - server: increased default credential lifetime to 31 days.
331 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
332 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
333 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
334  
335 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
336 - bugfix: 'geni_api' should be in the top level struct, not the code struct
337 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
338           output returned by the Aggregate Manager.
339 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
340 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
341 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
342           there is extra whitespace in the schemaLocation field.
343 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
344           advertisement rspecs.
345 - bugfix: <login> RSpec element should contain the 'username' attribute.
346 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
347  
348 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
349 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
350   exit when it encountered a user with an invalid public key.
351 - server: imporved logging in sfa-import-plc.py
352  
353 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
354 - bugfix: Fixed appending public keys in CreateSliver
355 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
356 - client: -c --current option allows users to request the current/uncached rspec.
357 - server: Added 'geni_api_versions' field to GetVersion() output.
358 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
359    
360 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
361 - bugfix: sfi was not sending call_id with ListResources to v2 servers
362 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
363 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
364
365 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
366 - client: sfi -a / -p deprecated (use -s instead)
367 - client: sfi cleaned up
368 - client: sfi has backward support for APIv1 aggregates again
369 - server: only APIv2 is supported and should be rather strict
370 - server: settings for turning on/off caching in sm or am
371 - server: plc-dependant code has moved from aggregate to pldriver
372 - server: driver interface extended accordingly
373
374 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
375 - screwed up previous tag
376
377 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
378 - client side revisited with a bootstrap library
379 - client side has a new source layout
380 - various (nasty) bug fixes wrt options and call_id
381
382 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
383 - various fixes in rspecs for sfav1&slice tags
384 - uses 'geni_rspec_version' and not just 'rspec_version'
385 - example flavour for the max testbed
386 - embryo for an sfa client library
387 - topology.py moved into plc
388 - sql: table is named records; record_types are enforced
389 - sql: table creation cleaned up
390
391 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
392 - cleaned up all references to SFA_*_TYPE in config
393 - enable cache at the aggregate by default
394 - registry now uses the driver in a sensible way (see managers/driver.py)
395 - slice manager supports sfav1/pgv2 neighbours
396 - get_key renamed into get_key_from_incoming_ip
397 - new sfa.storage module for record/table and all db-related stuff
398 - db schema in sfa.storage.sfa.sql
399 - init.d and cron.d move one step up
400 - cleaned up rspec/ directory
401 - add deps to pyopenssl and myplc-config
402 - start support for new API (return value)
403 - plc.remoteshell removed, use plshell instead
404 - plshell uses a 'capability' auth method whenever possible
405 - various tweaks in rspec elements
406 - made dependency on sfatables softer
407
408 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
409 - sfa should now be started *before* the initial import
410 - sfa to use its own database (default sfa) - can run without myplc
411 - server calls support optional 'options'
412 - client sends options in argument when needed
413 - fix infinite getattr recursion in elements/element.py
414 - error codes in line with geni
415
416 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
417 - fixed links and attributes in rspecs
418 - minor cleanup in the API methods, and more consistent names in manager methods
419
420 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
421 - ongoing refoactoring towards more genericity
422 - passes tests again although known issues remain with attributes/tags
423
424 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
425 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
426 - improvements in the pgv2 rspecs
427 - driver separated from api
428 - code starts moving around where it belongs
429 - sfascan caches getversion across invokations
430 - vini topology extracted as a config file
431
432 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
433 - first support for protogeni rspecs is working
434 - vini no longer needs a specific manager
435 - refactoring underway towards more flexible/generic architecture
436
437 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
438 - Unicode-friendliness for user names with accents/special chars.
439 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
440 - CreaetSliver no longer fails for users that have a capital letter in their URN.
441 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
442 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
443 - Fix bugs and missing imports     
444  
445
446 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
447 - new method record.get_field for sface
448
449 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
450 - new option -c to sfa-nuke-plc.py
451 - CreateSliver fixed for admin-only slice tags
452
453 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
454 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
455 - Fixed holes in certificate verification logic.
456 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
457 - Added 'boot_state' as an attribute of the node element in SFA rspec.
458 - Non authority certificates are marked as CA:FALSE.
459
460 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
461 - fix typo in sfa-1.0-31 tag.
462 - added CreateGid() Registry interface method.
463
464 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
465 - fix typo in sfa-1.0-30 tag
466
467 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
468 - Declare namespace and schema location in the credential.
469 - Fix bug that prevetend connections from timing out.
470 - Fix slice delegation.
471 - Add statistics to slicemaanger listresources/createsliver rspec.
472 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
473   of days a user can extend their slice expiration.
474 - CA certs are only issued to objects of type authority
475    
476 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
477 - tag 1.0-28 was broken due to typo in the changelog
478 - new class sfa/util/httpsProtocol.py that supports timeouts
479
480 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
481 - Resolved issue that caused sfa hold onto idle db connections.
482 - Fix bug that caused the registry to use the wrong type of credential.
483 - Support authority+sm type.
484 - Fix rspec merging bugs.
485 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
486 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
487  planetlab hosted initscripts using the <planetlab:initscript> tag  
488 - Can now handle extraneous whitespace in the rspec without failing.   
489  
490 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
491 - ProtoGENI v2 RSpec updates.
492 - Convert expiration timestamps with timezone info in credentials to utc.
493 - Fixed redundant logging issue. 
494 - Improved SliceManager and SFI client logging.
495 - Support aggregates that don't support the optional 'call_id' argument. 
496 - Only call get_trusted_certs() at aggreage interfaces that support the call.
497 - CreateSliver() now handles MyPLC slice attributes/tags.
498 - Cache now supports persistence.
499 - Hide whitelisted nodes.
500
501 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
502 - fixed issues with sup authority signing
503 - fixed bugs in remove_slivers and SliverStatus
504
505 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
506 - fix typo that prevented aggregates from operating properly
507
508 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
509 - load trusted certs into ssl context prior to handshake
510 - client's logfile lives in ~/.sfi/sfi.log
511
512 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
513 - includes a change on passphrases that was intended in 1.0-22
514
515 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
516 - Added support for ProtoGENI RSpec v2
517  
518 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
519 - stable sfascan
520 - fix in initscript, *ENABLED tags in config now taken into account
521
522 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
523 - some commits had not been pushed in tag 19
524
525 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
526 - GetVersion should now report full URLs with path
527 - scansfa has nicer output and new syntax (entry URLs as args and not options)
528 - dos2unix'ed flash policy pill
529
530 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
531 - fix packaging again for f8
532
533 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
534 - fix packaging (apparently broken in 1.0-16)
535 - first working version of sfascan
536 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
537 - deprecated the sfa_geni_aggregate config category
538
539 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
540 - Fix build problem
541 - First version of SFA scanner
542
543 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
544 - Add support for Flash clients using flashpolicy
545 - Fix problems with tag handling in RSpec
546
547 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
548 - Modifications to the Eucalyptus Aggregate Manager
549 - Fixes for VINI RSpec
550 - Fix tag handling for PL RSpec
551 - Fix XML Schema ordering for <urn> element
552
553 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
554 - just set x509 version to 2
555
556 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
557 - added urn to the node area in rspecs
558 - conversion to urn now exports fqdn
559 - sfa-import-plc.py now creates a unique registry record for each SFA interface
560
561 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
562 - undo broken attempt for python-2.7
563
564 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
565 - SMs avoid duplicates for when call graph has dags;
566 - just based on network's name, when a duplicate occurs, one is just dropped
567 - does not try to merge/aggregate 2 networks
568 - also reviewed logging with the hope to fix the sfa startup msg:
569 - TypeError: not all arguments converted during string formatting
570
571 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
572 - verify credentials against xsd schema
573 - Fix SM to SM communication
574 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
575 - new setting session_key_path
576
577 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
578 - fix registry credential regeneration and handle expiration
579 - support for setting slice tags (min_role=user)
580 - client can display its own version: sfi.py version --local
581 - GetVersion to provide urn in addition to hrn
582 - more code uses plxrn vs previous helper functions
583 - import replaces '+' in email addresses with '_'
584
585 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
586 - fix GetVersion code_tag and add code_url
587
588 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
589 - extend GetVersion towards minimum federation introspection, and expose local tag
590
591 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
592 - fixed some legacy issues (list vs List)
593 - deprecated sfa.util.namespace for xrn and plxrn
594 - unit tests ship as the sfa-tests rpm
595
596 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
597 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
598 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
599 - hrn-urn translations tweaked
600 - fixed 'service sfa status'
601 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
602 - started to repair sfadump - although not usable yet
603 - trust objects now have dump_string method that dump() actually prints
604 - unit tests under review
605 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
606 - binaries now support -v or -vv to increase loglevel
607 - trashed obsolete sfa.util.client
608
609 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
610 - various bugfixes and cleanup, improved/harmonized logging
611
612 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
613 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
614   to avoid returning a PLCAPI exception that might confuse users.
615 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
616 - fix build errors.  
617
618 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
619 - (Architecture) Credential format changed to match ProtoGENI xml format
620 - (Architecture) All interfaces export a new set of methods that are compatible
621    with the ProtoGeni Aggregate spec. These new methods are considered a 
622    replacement  for the pervious methods exported by the interfaces. All 
623    previous methods are still exported and work as normal, but they are 
624    considered deprecated and will not be supported in future releases.  
625 - (Architecture) SFI has been updated to use the new interface methods.
626 - (Architecture) Changed keyconvet implementation from c to python.
627 - (Architecture) Slice Manager now attempts looks for a delegated credential
628   provided by the client before using its own server credential.
629 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
630   This cache now exists only in memory and is cleared when service is restarted
631   or cache lifetime is exceeded.  
632 - (Performance) SliceManager sends request to Aggregates in parallel instead 
633   of sequentially.
634 - (Bug fix) SFA tickets now support the new rspec format.
635 - (Bug fix) SFI only uses cahced credential if they aren't expired.
636 - (Bug fix) Cerdential delegation modified to work with new credential format.
637 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
638   Aggregate instead of relaying through the Slice Manager.
639 - (Enhancement) Simplified caching. Accociated a global cache instance with
640   the api handler on every new server request, making it easier to access the 
641   cache and use in more general ways.     
642
643 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
644 - SfaServer now uses a pool of threads to handle requests concurrently
645 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
646 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
647 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
648 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
649 - Component manager does not install gid files if slice already has them  
650 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
651 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
652 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
653      
654 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
655 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
656 - - sfa-config-tty now has the same features like plc-config-tty
657 - - Contains code to support both urn and hrn
658 - - Cleaned up request_hash related stuff
659 - - SM, AM and Registry code is organized under respective managers
660 - - Site and Slice synchronization across federated aggregates
661 - - Script to generate sfa_component_config
662
663 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
664 - sfa-config-tty now has the same features like plc-config-tty
665 - Contains code to support both urn and hrn
666 - Cleaned up request_hash related stuff
667 - SM, AM and Registry code is organized under respective managers
668 - Slice synchronization across federated aggregates
669 - some bugs are fixed
670
671 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
672 - checkpoint with fewer mentions of geni
673
674 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
675 - checkpointing
676 - this is believed to pass the tests; among other things:
677 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
678
679 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
680 - This tag includes:
681 - - Sfatables
682 - - Preliminary version of hash based authentication
683 - - Initial code for Component Manager
684 - - Authority structure is moved to /var/lib/sfa/
685 - - some bug-fixes
686
687 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
688 - Create_slice and get_resources methods are connected to sfatables.
689 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
690
691 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
692 - Bug fix on update and remove_peer_object methods
693 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
694
695 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
696 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
697
698 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
699 - compatibility with RefreshPeer
700 - incremental mechanism for importing PLC records into SFA tables
701 - unified single database (still inside the underlying PLC db postgresql server)
702 - includes/improves call traceability and logging features
703 - several bug fixes
704
705 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
706 - added libxslt-python dependency
707
708 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
709 - unified single SFA database in the PLC-DB
710 - upcalls from  PLCAPI to SFA methods
711 - SFA call traceability and logging features
712 - many bug fixes
713 - includes first/rough version of sfatables for policy implementation
714
715 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
716 - snapshot after the GEC5 demo
717 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
718
719 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
720 - snapshot july 15 - has gone through superficial manual testing
721 - hopefully a good basis for gec5 demo
722 - multi-dir sfi client tested as well
723
724 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
725 - rename geniwrapper.spec into sfa.spec
726
727 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
728 - clean up in xmlrpc/soap, --protocol option to chose between both
729 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
730 - hopefully more helpful context in case of crashes when importing
731 - bugfixes for using only /etc/sfa for site-dep files
732 - bugfixes in wsdl generation
733
734 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
735 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
736 - config variables in sfa_config now start with SFA_ and not GENI_
737 - config.py can be loaded even with no config present
738
739 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
740 - first step for cleanup and reorganization
741 - mass-renaming from geni to sfa (some are still needed)
742 - sfa/trust implements the security architecture
743
744 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
745 - snapshot for reproducible builds
746
747 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
748 - snapshot for the convenience of alpha users
749
750 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
751 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
752
753 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
754 - ongoing work - snapshot for 4.3-rc9
755
756 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
757 - various fixes
758
759 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
760 - bugfixes - still a work in progress
761
762 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
763 - initial package
764
765
766 %define module_current_branch 0.2