Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128 # this gets duplicated
129 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/sfa/storage/sfa.sql
130 # create symlinks
131 (cd $RPM_BUILD_ROOT/%{_bindir}; ln -s sfi.py sfi; ln -s sfascan.py sfascan)
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 # sfa and sfatables depend on each other.
138 %{python_sitelib}/sfa
139 %{python_sitelib}/xmlbuilder
140 /etc/init.d/sfa
141 %{_bindir}/sfa-start.py*
142 %{_bindir}/keyconvert.py*
143 %{_bindir}/sfa-config-tty
144 %config /etc/sfa/default_config.xml
145 %config (noreplace) /etc/sfa/aggregates.xml
146 %config (noreplace) /etc/sfa/registries.xml
147 /usr/share/sfa/sfa.sql
148 /var/www/html/wsdl/*.wsdl
149
150 %files plc
151 %defattr(-,root,root)
152 /etc/sfa/pl.rng
153 /etc/sfa/credential.xsd
154 /etc/sfa/top.xsd
155 /etc/sfa/sig.xsd
156 /etc/sfa/xml.xsd
157 /etc/sfa/protogeni-rspec-common.xsd
158 /etc/sfa/topology
159 %{_bindir}/sfa-import-plc.py*
160 %{_bindir}/sfa-nuke-plc.py*
161 %{_bindir}/sfa-clean-peer-records.py*
162 %{_bindir}/gen-sfa-cm-config.py*
163 %{_bindir}/sfa-ca.py*
164
165 %files client
166 %config (noreplace) /etc/sfa/sfi_config
167 %{_bindir}/sfi*
168 %{_bindir}/sfascan*
169 %{_bindir}/getNodes.py*
170 %{_bindir}/getRecord.py*
171 %{_bindir}/setRecord.py*
172 %{_bindir}/sfadump.py*
173
174 %files sfatables
175 /etc/sfatables/*
176 %{_bindir}/sfatables
177 %{python_sitelib}/sfatables
178
179 %files cm
180 /etc/init.d/sfa-cm
181 %{_bindir}/sfa_component_setup.py*
182 # cron jobs here 
183
184 %files flashpolicy
185 %{_bindir}/sfa_flashpolicy.py*
186 /etc/sfa/sfa_flashpolicy_config.xml
187
188 %files tests
189 %{_datadir}/sfa/tests
190
191 ### sfa-plc installs the 'sfa' service
192 %post plc
193 chkconfig --add sfa
194
195 %preun plc
196 if [ "$1" = 0 ] ; then
197   /sbin/service sfa stop || :
198   /sbin/chkconfig --del sfa || :
199 fi
200
201 %postun plc
202 [ "$1" -ge "1" ] && service sfa restart
203
204 ### sfa-cm installs the 'sfa-cm' service
205 %post cm
206 chkconfig --add sfa-cm
207
208 %preun cm
209 if [ "$1" = 0 ] ; then
210    /sbin/service sfa-cm stop || :
211    /sbin/chkconfig --del sfa-cm || :
212 fi
213
214 %postun cm
215 [ "$1" -ge "1" ] && service sfa-cm restart || :
216
217 %changelog
218 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
219 - various fixes in rspecs for sfav1&slice tags
220 - uses 'geni_rspec_version' and not just 'rspec_version'
221 - example flavour for the max testbed
222 - embryo for an sfa client library
223 - topology.py moved into plc
224 - sql: table is named records; record_types are enforced
225 - sql: table creation cleaned up
226
227 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
228 - cleaned up all references to SFA_*_TYPE in config
229 - enable cache at the aggregate by default
230 - registry now uses the driver in a sensible way (see managers/driver.py)
231 - slice manager supports sfav1/pgv2 neighbours
232 - get_key renamed into get_key_from_incoming_ip
233 - new sfa.storage module for record/table and all db-related stuff
234 - db schema in sfa.storage.sfa.sql
235 - init.d and cron.d move one step up
236 - cleaned up rspec/ directory
237 - add deps to pyopenssl and myplc-config
238 - start support for new API (return value)
239 - plc.remoteshell removed, use plshell instead
240 - plshell uses a 'capability' auth method whenever possible
241 - various tweaks in rspec elements
242 - made dependency on sfatables softer
243
244 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
245 - sfa should now be started *before* the initial import
246 - sfa to use its own database (default sfa) - can run without myplc
247 - server calls support optional 'options'
248 - client sends options in argument when needed
249 - fix infinite getattr recursion in elements/element.py
250 - error codes in line with geni
251
252 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
253 - fixed links and attributes in rspecs
254 - minor cleanup in the API methods, and more consistent names in manager methods
255
256 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
257 - ongoing refoactoring towards more genericity
258 - passes tests again although known issues remain with attributes/tags
259
260 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
261 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
262 - improvements in the pgv2 rspecs
263 - driver separated from api
264 - code starts moving around where it belongs
265 - sfascan caches getversion across invokations
266 - vini topology extracted as a config file
267
268 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
269 - first support for protogeni rspecs is working
270 - vini no longer needs a specific manager
271 - refactoring underway towards more flexible/generic architecture
272
273 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
274 - Unicode-friendliness for user names with accents/special chars.
275 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
276 - CreaetSliver no longer fails for users that have a capital letter in their URN.
277 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
278 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
279 - Fix bugs and missing imports     
280  
281
282 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
283 - new method record.get_field for sface
284
285 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
286 - new option -c to sfa-nuke-plc.py
287 - CreateSliver fixed for admin-only slice tags
288
289 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
290 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
291 - Fixed holes in certificate verification logic.
292 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
293 - Added 'boot_state' as an attribute of the node element in SFA rspec.
294 - Non authority certificates are marked as CA:FALSE.
295
296 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
297 - fix typo in sfa-1.0-31 tag.
298 - added CreateGid() Registry interface method.
299
300 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
301 - fix typo in sfa-1.0-30 tag
302
303 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
304 - Declare namespace and schema location in the credential.
305 - Fix bug that prevetend connections from timing out.
306 - Fix slice delegation.
307 - Add statistics to slicemaanger listresources/createsliver rspec.
308 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
309   of days a user can extend their slice expiration.
310 - CA certs are only issued to objects of type authority
311    
312 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
313 - tag 1.0-28 was broken due to typo in the changelog
314 - new class sfa/util/httpsProtocol.py that supports timeouts
315
316 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
317 - Resolved issue that caused sfa hold onto idle db connections.
318 - Fix bug that caused the registry to use the wrong type of credential.
319 - Support authority+sm type.
320 - Fix rspec merging bugs.
321 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
322 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
323  planetlab hosted initscripts using the <planetlab:initscript> tag  
324 - Can now handle extraneous whitespace in the rspec without failing.   
325  
326 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
327 - ProtoGENI v2 RSpec updates.
328 - Convert expiration timestamps with timezone info in credentials to utc.
329 - Fixed redundant logging issue. 
330 - Improved SliceManager and SFI client logging.
331 - Support aggregates that don't support the optional 'call_id' argument. 
332 - Only call get_trusted_certs() at aggreage interfaces that support the call.
333 - CreateSliver() now handles MyPLC slice attributes/tags.
334 - Cache now supports persistence.
335 - Hide whitelisted nodes.
336
337 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
338 - fixed issues with sup authority signing
339 - fixed bugs in remove_slivers and SliverStatus
340
341 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
342 - fix typo that prevented aggregates from operating properly
343
344 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
345 - load trusted certs into ssl context prior to handshake
346 - client's logfile lives in ~/.sfi/sfi.log
347
348 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
349 - includes a change on passphrases that was intended in 1.0-22
350
351 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
352 - Added support for ProtoGENI RSpec v2
353  
354 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
355 - stable sfascan
356 - fix in initscript, *ENABLED tags in config now taken into account
357
358 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
359 - some commits had not been pushed in tag 19
360
361 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
362 - GetVersion should now report full URLs with path
363 - scansfa has nicer output and new syntax (entry URLs as args and not options)
364 - dos2unix'ed flash policy pill
365
366 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
367 - fix packaging again for f8
368
369 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
370 - fix packaging (apparently broken in 1.0-16)
371 - first working version of sfascan
372 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
373 - deprecated the sfa_geni_aggregate config category
374
375 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
376 - Fix build problem
377 - First version of SFA scanner
378
379 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
380 - Add support for Flash clients using flashpolicy
381 - Fix problems with tag handling in RSpec
382
383 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
384 - Modifications to the Eucalyptus Aggregate Manager
385 - Fixes for VINI RSpec
386 - Fix tag handling for PL RSpec
387 - Fix XML Schema ordering for <urn> element
388
389 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
390 - just set x509 version to 2
391
392 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
393 - added urn to the node area in rspecs
394 - conversion to urn now exports fqdn
395 - sfa-import-plc.py now creates a unique registry record for each SFA interface
396
397 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
398 - undo broken attempt for python-2.7
399
400 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
401 - SMs avoid duplicates for when call graph has dags;
402 - just based on network's name, when a duplicate occurs, one is just dropped
403 - does not try to merge/aggregate 2 networks
404 - also reviewed logging with the hope to fix the sfa startup msg:
405 - TypeError: not all arguments converted during string formatting
406
407 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
408 - verify credentials against xsd schema
409 - Fix SM to SM communication
410 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
411 - new setting session_key_path
412
413 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
414 - fix registry credential regeneration and handle expiration
415 - support for setting slice tags (min_role=user)
416 - client can display its own version: sfi.py version --local
417 - GetVersion to provide urn in addition to hrn
418 - more code uses plxrn vs previous helper functions
419 - import replaces '+' in email addresses with '_'
420
421 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
422 - fix GetVersion code_tag and add code_url
423
424 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
425 - extend GetVersion towards minimum federation introspection, and expose local tag
426
427 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
428 - fixed some legacy issues (list vs List)
429 - deprecated sfa.util.namespace for xrn and plxrn
430 - unit tests ship as the sfa-tests rpm
431
432 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
433 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
434 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
435 - hrn-urn translations tweaked
436 - fixed 'service sfa status'
437 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
438 - started to repair sfadump - although not usable yet
439 - trust objects now have dump_string method that dump() actually prints
440 - unit tests under review
441 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
442 - binaries now support -v or -vv to increase loglevel
443 - trashed obsolete sfa.util.client
444
445 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
446 - various bugfixes and cleanup, improved/harmonized logging
447
448 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
449 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
450   to avoid returning a PLCAPI exception that might confuse users.
451 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
452 - fix build errors.  
453
454 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
455 - (Architecture) Credential format changed to match ProtoGENI xml format
456 - (Architecture) All interfaces export a new set of methods that are compatible
457    with the ProtoGeni Aggregate spec. These new methods are considered a 
458    replacement  for the pervious methods exported by the interfaces. All 
459    previous methods are still exported and work as normal, but they are 
460    considered deprecated and will not be supported in future releases.  
461 - (Architecture) SFI has been updated to use the new interface methods.
462 - (Architecture) Changed keyconvet implementation from c to python.
463 - (Architecture) Slice Manager now attempts looks for a delegated credential
464   provided by the client before using its own server credential.
465 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
466   This cache now exists only in memory and is cleared when service is restarted
467   or cache lifetime is exceeded.  
468 - (Performance) SliceManager sends request to Aggregates in parallel instead 
469   of sequentially.
470 - (Bug fix) SFA tickets now support the new rspec format.
471 - (Bug fix) SFI only uses cahced credential if they aren't expired.
472 - (Bug fix) Cerdential delegation modified to work with new credential format.
473 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
474   Aggregate instead of relaying through the Slice Manager.
475 - (Enhancement) Simplified caching. Accociated a global cache instance with
476   the api handler on every new server request, making it easier to access the 
477   cache and use in more general ways.     
478
479 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
480 - SfaServer now uses a pool of threads to handle requests concurrently
481 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
482 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
483 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
484 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
485 - Component manager does not install gid files if slice already has them  
486 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
487 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
488 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
489      
490 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
491 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
492 - - sfa-config-tty now has the same features like plc-config-tty
493 - - Contains code to support both urn and hrn
494 - - Cleaned up request_hash related stuff
495 - - SM, AM and Registry code is organized under respective managers
496 - - Site and Slice synchronization across federated aggregates
497 - - Script to generate sfa_component_config
498
499 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
500 - sfa-config-tty now has the same features like plc-config-tty
501 - Contains code to support both urn and hrn
502 - Cleaned up request_hash related stuff
503 - SM, AM and Registry code is organized under respective managers
504 - Slice synchronization across federated aggregates
505 - some bugs are fixed
506
507 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
508 - checkpoint with fewer mentions of geni
509
510 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
511 - checkpointing
512 - this is believed to pass the tests; among other things:
513 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
514
515 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
516 - This tag includes:
517 - - Sfatables
518 - - Preliminary version of hash based authentication
519 - - Initial code for Component Manager
520 - - Authority structure is moved to /var/lib/sfa/
521 - - some bug-fixes
522
523 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
524 - Create_slice and get_resources methods are connected to sfatables.
525 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
526
527 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
528 - Bug fix on update and remove_peer_object methods
529 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
530
531 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
532 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
533
534 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
535 - compatibility with RefreshPeer
536 - incremental mechanism for importing PLC records into SFA tables
537 - unified single database (still inside the underlying PLC db postgresql server)
538 - includes/improves call traceability and logging features
539 - several bug fixes
540
541 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
542 - added libxslt-python dependency
543
544 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
545 - unified single SFA database in the PLC-DB
546 - upcalls from  PLCAPI to SFA methods
547 - SFA call traceability and logging features
548 - many bug fixes
549 - includes first/rough version of sfatables for policy implementation
550
551 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
552 - snapshot after the GEC5 demo
553 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
554
555 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
556 - snapshot july 15 - has gone through superficial manual testing
557 - hopefully a good basis for gec5 demo
558 - multi-dir sfi client tested as well
559
560 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
561 - rename geniwrapper.spec into sfa.spec
562
563 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
564 - clean up in xmlrpc/soap, --protocol option to chose between both
565 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
566 - hopefully more helpful context in case of crashes when importing
567 - bugfixes for using only /etc/sfa for site-dep files
568 - bugfixes in wsdl generation
569
570 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
571 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
572 - config variables in sfa_config now start with SFA_ and not GENI_
573 - config.py can be loaded even with no config present
574
575 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
576 - first step for cleanup and reorganization
577 - mass-renaming from geni to sfa (some are still needed)
578 - sfa/trust implements the security architecture
579
580 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
581 - snapshot for reproducible builds
582
583 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
584 - snapshot for the convenience of alpha users
585
586 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
587 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
588
589 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
590 - ongoing work - snapshot for 4.3-rc9
591
592 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
593 - various fixes
594
595 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
596 - bugfixes - still a work in progress
597
598 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
599 - initial package
600
601
602 %define module_current_branch 0.2