remove myplc-config dependency
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package sfatables
92 Summary: sfatables policy tool for SFA
93 Group: Applications/System
94 Requires: sfa
95
96 %package xmlbuilder
97 Summary: third-party xmlbuilder tool
98 Group: Applications/System
99 Provides: python-xmlbuilder
100
101 %package tests
102 Summary: unit tests suite for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %description
107 This package provides the python libraries for the PlanetLab implementation of SFA
108
109 %description flashpolicy
110 This package provides support for adobe flash client applications.  
111
112 %description client
113 This package provides the client side of the SFA API, in particular
114 sfi.py, together with other utilities.
115
116 %description plc
117 This package implements the SFA interface which serves as a layer
118 between the existing PlanetLab interfaces and the SFA API.
119
120 %description cm
121 This package implements the SFA interface which serves as a layer
122 between the existing PlanetLab NodeManager interfaces and the SFA API.
123
124 %description federica
125 The SFA driver for FEDERICA.
126
127 %description sfatables
128 sfatables is a tool for defining access and admission control policies
129 in an SFA network, in much the same way as iptables is for ip
130 networks. This is the command line interface to manage sfatables
131
132 %description xmlbuilder
133 This package contains the xmlbuilder python library, packaged for
134 convenience as it is not supported by fedora
135
136 %description tests
137 Provides some binary unit tests in /usr/share/sfa/tests
138
139 %prep
140 %setup -q
141
142 %build
143 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %{python_sitelib}/sfa/__init__.py*
154 %{python_sitelib}/sfa/trust
155 %{python_sitelib}/sfa/storage
156 %{python_sitelib}/sfa/util
157 %{python_sitelib}/sfa/server
158 %{python_sitelib}/sfa/methods
159 %{python_sitelib}/sfa/generic
160 %{python_sitelib}/sfa/managers
161 %{python_sitelib}/sfa/importer
162 %{python_sitelib}/sfa/rspecs
163 %{python_sitelib}/sfa/client
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %config /etc/sfa/default_config.xml
171 %config (noreplace) /etc/sfa/aggregates.xml
172 %config (noreplace) /etc/sfa/registries.xml
173 /usr/share/sfa/migrations
174 /usr/share/sfa/examples
175 /var/www/html/wsdl/*.wsdl
176
177 %files flashpolicy
178 %{_bindir}/sfa_flashpolicy.py*
179 /etc/sfa/sfa_flashpolicy_config.xml
180
181 %files client
182 %config (noreplace) /etc/sfa/sfi_config
183 %{_bindir}/sfi*.py*
184 %{_bindir}/sfi
185 %{_bindir}/get*.py*
186 %{_bindir}/setRecord.py*
187 %{_bindir}/sfascan.py*
188 %{_bindir}/sfascan
189 %{_bindir}/sfadump.py*
190
191 %files plc
192 %defattr(-,root,root)
193 %{python_sitelib}/sfa/planetlab
194 %{python_sitelib}/sfa/openstack
195 /etc/sfa/pl.rng
196 /etc/sfa/credential.xsd
197 /etc/sfa/top.xsd
198 /etc/sfa/sig.xsd
199 /etc/sfa/xml.xsd
200 /etc/sfa/protogeni-rspec-common.xsd
201 /etc/sfa/topology
202 %{_bindir}/gen-sfa-cm-config.py*
203
204 %files cm
205 /etc/init.d/sfa-cm
206 %{_bindir}/sfa_component_setup.py*
207 # cron jobs here 
208
209 %files federica
210 %{python_sitelib}/sfa/federica
211
212 %files sfatables
213 /etc/sfatables/*
214 %{_bindir}/sfatables
215 %{python_sitelib}/sfatables
216
217 %files xmlbuilder
218 %{python_sitelib}/xmlbuilder
219
220 %files tests
221 %{_datadir}/sfa/tests
222
223 ### sfa installs the 'sfa' service
224 %post 
225 chkconfig --add sfa
226
227 %preun 
228 if [ "$1" = 0 ] ; then
229   /sbin/service sfa stop || :
230   /sbin/chkconfig --del sfa || :
231 fi
232
233 %postun
234 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
235
236 ### sfa-cm installs the 'sfa-cm' service
237 %post cm
238 chkconfig --add sfa-cm
239
240 %preun cm
241 if [ "$1" = 0 ] ; then
242    /sbin/service sfa-cm stop || :
243    /sbin/chkconfig --del sfa-cm || :
244 fi
245
246 %postun cm
247 [ "$1" -ge "1" ] && service sfa-cm restart || :
248
249 %changelog
250 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
251 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
252 - sfi to remove expired credentials
253
254 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
255 - Update Openstack driver to support Essex release/
256 - Fix authority xrn bug.
257   
258
259 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
260 - review packaging - site-packages/planetlab now come with sfa-plc
261 - new package sfa-federica
262 - clientbin moved one step upwards
263
264 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
265 - fix bug in sfi update()
266
267 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
268 - fix broken sfa.util.xrn class for lowercase
269
270 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
271 - new 'void' generic_flavour for running in registry-only mode
272 - first shot at refactoring importers - probably needs more work
273 - openstack: various enhancements
274 - sfi interface to registry not based on xml files anymore
275 - sfi show sorts result on record key
276 - bugfix in sfa update on users with a pl-backed registry
277
278 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
279 - renamed sfa/plc into sfa/planetlab
280 - plxrn moved in sfa/planetlab as well
281 - bugfix for sfaadmin reg update --pi <>
282
283 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
284 - native data model now has a authority x user (PI) relationship
285 - no call to 'augment_records_with_testbed_info' for GetCredential
286 - which means, registry can now be used without an underlying testbed
287 - reviewed code about relationships b/w objects and related in pl driver
288 - reviewed PL import wrt roles and pis
289 - removed mentions to is_enabled in driver
290 - small changes in update_relation* in driver interface
291 - sfaadmin: can create authorities and attach pi users to them
292 - sfaadmin: categories can be abbreviated
293 - sfi list and sfaadmin list have a new -r/--recursive option
294 - this means that List now supports an (optional) 'options' argument
295 - sfi config can display config vars
296 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
297
298 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
299 - make sync now supports vserver or lxc.
300 - Added slice expiration and login info to SliverStatus response. 
301 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
302   the 'component_name' attribute.
303 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
304   
305 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
306 - Introduced new administrative command line script, sfaadmin.py. Removed various single
307  purpose scripts and migrated their functionality into sfaadmin.py.
308 - Refactored Registry import scripts.
309 - Removed SQLAlchemy dependency from sfi.py.
310 - Fixed bugs in sfi.py
311 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
312
313 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
314 - slice x researcher rel. in database,
315 - plimporter to maintain that, as well as user.email, and more robust
316 - ongoing draft for sfaadmin tool
317 - support for a federica driver
318 - support for a nova/euca driver
319 - no more sfa-clean-peer-records script
320
321 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
322 - registry database has user's keys and mail (known as v0 for migrate)
323 - pl importer properly maintains user's keys and mail
324 - pl driver now to handle 'role' when adding person record (exp.)
325 - first draft of federica driver with config section
326 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
327 - plus, from master as of tag merged-in-sfa-2.1-2:
328 - disk_image revisited
329 - new nova_shell nova_driver & various tweaks for openstack
330
331 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
332 - uses sqlalchemy and related migrate
333 - thorough migration and upgrade scheme
334 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
335 - trashed dbinfo stuff in auth hierarchy
336 - data model still has little more than plain records
337 - checkpoint tag, not yet intended for release
338
339 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
340 - client: added -R --raw sfi cmdline option that displays raw server response.
341 - client: request GENI RSpec by default. 
342 - server: remove database dependencies from sfa.server.sfaapi.
343 - server: increased default credential lifetime to 31 days.
344 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
345 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
346 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
347  
348 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
349 - bugfix: 'geni_api' should be in the top level struct, not the code struct
350 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
351           output returned by the Aggregate Manager.
352 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
353 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
354 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
355           there is extra whitespace in the schemaLocation field.
356 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
357           advertisement rspecs.
358 - bugfix: <login> RSpec element should contain the 'username' attribute.
359 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
360  
361 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
362 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
363   exit when it encountered a user with an invalid public key.
364 - server: imporved logging in sfa-import-plc.py
365  
366 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
367 - bugfix: Fixed appending public keys in CreateSliver
368 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
369 - client: -c --current option allows users to request the current/uncached rspec.
370 - server: Added 'geni_api_versions' field to GetVersion() output.
371 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
372    
373 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
374 - bugfix: sfi was not sending call_id with ListResources to v2 servers
375 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
376 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
377
378 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
379 - client: sfi -a / -p deprecated (use -s instead)
380 - client: sfi cleaned up
381 - client: sfi has backward support for APIv1 aggregates again
382 - server: only APIv2 is supported and should be rather strict
383 - server: settings for turning on/off caching in sm or am
384 - server: plc-dependant code has moved from aggregate to pldriver
385 - server: driver interface extended accordingly
386
387 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
388 - screwed up previous tag
389
390 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
391 - client side revisited with a bootstrap library
392 - client side has a new source layout
393 - various (nasty) bug fixes wrt options and call_id
394
395 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
396 - various fixes in rspecs for sfav1&slice tags
397 - uses 'geni_rspec_version' and not just 'rspec_version'
398 - example flavour for the max testbed
399 - embryo for an sfa client library
400 - topology.py moved into plc
401 - sql: table is named records; record_types are enforced
402 - sql: table creation cleaned up
403
404 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
405 - cleaned up all references to SFA_*_TYPE in config
406 - enable cache at the aggregate by default
407 - registry now uses the driver in a sensible way (see managers/driver.py)
408 - slice manager supports sfav1/pgv2 neighbours
409 - get_key renamed into get_key_from_incoming_ip
410 - new sfa.storage module for record/table and all db-related stuff
411 - db schema in sfa.storage.sfa.sql
412 - init.d and cron.d move one step up
413 - cleaned up rspec/ directory
414 - add deps to pyopenssl and myplc-config
415 - start support for new API (return value)
416 - plc.remoteshell removed, use plshell instead
417 - plshell uses a 'capability' auth method whenever possible
418 - various tweaks in rspec elements
419 - made dependency on sfatables softer
420
421 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
422 - sfa should now be started *before* the initial import
423 - sfa to use its own database (default sfa) - can run without myplc
424 - server calls support optional 'options'
425 - client sends options in argument when needed
426 - fix infinite getattr recursion in elements/element.py
427 - error codes in line with geni
428
429 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
430 - fixed links and attributes in rspecs
431 - minor cleanup in the API methods, and more consistent names in manager methods
432
433 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
434 - ongoing refoactoring towards more genericity
435 - passes tests again although known issues remain with attributes/tags
436
437 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
438 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
439 - improvements in the pgv2 rspecs
440 - driver separated from api
441 - code starts moving around where it belongs
442 - sfascan caches getversion across invokations
443 - vini topology extracted as a config file
444
445 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
446 - first support for protogeni rspecs is working
447 - vini no longer needs a specific manager
448 - refactoring underway towards more flexible/generic architecture
449
450 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
451 - Unicode-friendliness for user names with accents/special chars.
452 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
453 - CreaetSliver no longer fails for users that have a capital letter in their URN.
454 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
455 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
456 - Fix bugs and missing imports     
457  
458
459 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
460 - new method record.get_field for sface
461
462 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
463 - new option -c to sfa-nuke-plc.py
464 - CreateSliver fixed for admin-only slice tags
465
466 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
467 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
468 - Fixed holes in certificate verification logic.
469 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
470 - Added 'boot_state' as an attribute of the node element in SFA rspec.
471 - Non authority certificates are marked as CA:FALSE.
472
473 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
474 - fix typo in sfa-1.0-31 tag.
475 - added CreateGid() Registry interface method.
476
477 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
478 - fix typo in sfa-1.0-30 tag
479
480 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
481 - Declare namespace and schema location in the credential.
482 - Fix bug that prevetend connections from timing out.
483 - Fix slice delegation.
484 - Add statistics to slicemaanger listresources/createsliver rspec.
485 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
486   of days a user can extend their slice expiration.
487 - CA certs are only issued to objects of type authority
488    
489 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
490 - tag 1.0-28 was broken due to typo in the changelog
491 - new class sfa/util/httpsProtocol.py that supports timeouts
492
493 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
494 - Resolved issue that caused sfa hold onto idle db connections.
495 - Fix bug that caused the registry to use the wrong type of credential.
496 - Support authority+sm type.
497 - Fix rspec merging bugs.
498 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
499 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
500  planetlab hosted initscripts using the <planetlab:initscript> tag  
501 - Can now handle extraneous whitespace in the rspec without failing.   
502  
503 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
504 - ProtoGENI v2 RSpec updates.
505 - Convert expiration timestamps with timezone info in credentials to utc.
506 - Fixed redundant logging issue. 
507 - Improved SliceManager and SFI client logging.
508 - Support aggregates that don't support the optional 'call_id' argument. 
509 - Only call get_trusted_certs() at aggreage interfaces that support the call.
510 - CreateSliver() now handles MyPLC slice attributes/tags.
511 - Cache now supports persistence.
512 - Hide whitelisted nodes.
513
514 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
515 - fixed issues with sup authority signing
516 - fixed bugs in remove_slivers and SliverStatus
517
518 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
519 - fix typo that prevented aggregates from operating properly
520
521 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
522 - load trusted certs into ssl context prior to handshake
523 - client's logfile lives in ~/.sfi/sfi.log
524
525 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
526 - includes a change on passphrases that was intended in 1.0-22
527
528 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
529 - Added support for ProtoGENI RSpec v2
530  
531 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
532 - stable sfascan
533 - fix in initscript, *ENABLED tags in config now taken into account
534
535 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
536 - some commits had not been pushed in tag 19
537
538 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
539 - GetVersion should now report full URLs with path
540 - scansfa has nicer output and new syntax (entry URLs as args and not options)
541 - dos2unix'ed flash policy pill
542
543 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
544 - fix packaging again for f8
545
546 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
547 - fix packaging (apparently broken in 1.0-16)
548 - first working version of sfascan
549 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
550 - deprecated the sfa_geni_aggregate config category
551
552 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
553 - Fix build problem
554 - First version of SFA scanner
555
556 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
557 - Add support for Flash clients using flashpolicy
558 - Fix problems with tag handling in RSpec
559
560 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
561 - Modifications to the Eucalyptus Aggregate Manager
562 - Fixes for VINI RSpec
563 - Fix tag handling for PL RSpec
564 - Fix XML Schema ordering for <urn> element
565
566 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
567 - just set x509 version to 2
568
569 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
570 - added urn to the node area in rspecs
571 - conversion to urn now exports fqdn
572 - sfa-import-plc.py now creates a unique registry record for each SFA interface
573
574 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
575 - undo broken attempt for python-2.7
576
577 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
578 - SMs avoid duplicates for when call graph has dags;
579 - just based on network's name, when a duplicate occurs, one is just dropped
580 - does not try to merge/aggregate 2 networks
581 - also reviewed logging with the hope to fix the sfa startup msg:
582 - TypeError: not all arguments converted during string formatting
583
584 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
585 - verify credentials against xsd schema
586 - Fix SM to SM communication
587 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
588 - new setting session_key_path
589
590 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
591 - fix registry credential regeneration and handle expiration
592 - support for setting slice tags (min_role=user)
593 - client can display its own version: sfi.py version --local
594 - GetVersion to provide urn in addition to hrn
595 - more code uses plxrn vs previous helper functions
596 - import replaces '+' in email addresses with '_'
597
598 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
599 - fix GetVersion code_tag and add code_url
600
601 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
602 - extend GetVersion towards minimum federation introspection, and expose local tag
603
604 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
605 - fixed some legacy issues (list vs List)
606 - deprecated sfa.util.namespace for xrn and plxrn
607 - unit tests ship as the sfa-tests rpm
608
609 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
610 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
611 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
612 - hrn-urn translations tweaked
613 - fixed 'service sfa status'
614 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
615 - started to repair sfadump - although not usable yet
616 - trust objects now have dump_string method that dump() actually prints
617 - unit tests under review
618 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
619 - binaries now support -v or -vv to increase loglevel
620 - trashed obsolete sfa.util.client
621
622 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
623 - various bugfixes and cleanup, improved/harmonized logging
624
625 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
626 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
627   to avoid returning a PLCAPI exception that might confuse users.
628 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
629 - fix build errors.  
630
631 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
632 - (Architecture) Credential format changed to match ProtoGENI xml format
633 - (Architecture) All interfaces export a new set of methods that are compatible
634    with the ProtoGeni Aggregate spec. These new methods are considered a 
635    replacement  for the pervious methods exported by the interfaces. All 
636    previous methods are still exported and work as normal, but they are 
637    considered deprecated and will not be supported in future releases.  
638 - (Architecture) SFI has been updated to use the new interface methods.
639 - (Architecture) Changed keyconvet implementation from c to python.
640 - (Architecture) Slice Manager now attempts looks for a delegated credential
641   provided by the client before using its own server credential.
642 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
643   This cache now exists only in memory and is cleared when service is restarted
644   or cache lifetime is exceeded.  
645 - (Performance) SliceManager sends request to Aggregates in parallel instead 
646   of sequentially.
647 - (Bug fix) SFA tickets now support the new rspec format.
648 - (Bug fix) SFI only uses cahced credential if they aren't expired.
649 - (Bug fix) Cerdential delegation modified to work with new credential format.
650 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
651   Aggregate instead of relaying through the Slice Manager.
652 - (Enhancement) Simplified caching. Accociated a global cache instance with
653   the api handler on every new server request, making it easier to access the 
654   cache and use in more general ways.     
655
656 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
657 - SfaServer now uses a pool of threads to handle requests concurrently
658 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
659 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
660 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
661 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
662 - Component manager does not install gid files if slice already has them  
663 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
664 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
665 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
666      
667 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
668 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
669 - - sfa-config-tty now has the same features like plc-config-tty
670 - - Contains code to support both urn and hrn
671 - - Cleaned up request_hash related stuff
672 - - SM, AM and Registry code is organized under respective managers
673 - - Site and Slice synchronization across federated aggregates
674 - - Script to generate sfa_component_config
675
676 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
677 - sfa-config-tty now has the same features like plc-config-tty
678 - Contains code to support both urn and hrn
679 - Cleaned up request_hash related stuff
680 - SM, AM and Registry code is organized under respective managers
681 - Slice synchronization across federated aggregates
682 - some bugs are fixed
683
684 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
685 - checkpoint with fewer mentions of geni
686
687 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
688 - checkpointing
689 - this is believed to pass the tests; among other things:
690 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
691
692 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
693 - This tag includes:
694 - - Sfatables
695 - - Preliminary version of hash based authentication
696 - - Initial code for Component Manager
697 - - Authority structure is moved to /var/lib/sfa/
698 - - some bug-fixes
699
700 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
701 - Create_slice and get_resources methods are connected to sfatables.
702 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
703
704 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
705 - Bug fix on update and remove_peer_object methods
706 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
707
708 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
709 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
710
711 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
712 - compatibility with RefreshPeer
713 - incremental mechanism for importing PLC records into SFA tables
714 - unified single database (still inside the underlying PLC db postgresql server)
715 - includes/improves call traceability and logging features
716 - several bug fixes
717
718 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
719 - added libxslt-python dependency
720
721 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
722 - unified single SFA database in the PLC-DB
723 - upcalls from  PLCAPI to SFA methods
724 - SFA call traceability and logging features
725 - many bug fixes
726 - includes first/rough version of sfatables for policy implementation
727
728 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
729 - snapshot after the GEC5 demo
730 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
731
732 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
733 - snapshot july 15 - has gone through superficial manual testing
734 - hopefully a good basis for gec5 demo
735 - multi-dir sfi client tested as well
736
737 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
738 - rename geniwrapper.spec into sfa.spec
739
740 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
741 - clean up in xmlrpc/soap, --protocol option to chose between both
742 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
743 - hopefully more helpful context in case of crashes when importing
744 - bugfixes for using only /etc/sfa for site-dep files
745 - bugfixes in wsdl generation
746
747 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
748 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
749 - config variables in sfa_config now start with SFA_ and not GENI_
750 - config.py can be loaded even with no config present
751
752 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
753 - first step for cleanup and reorganization
754 - mass-renaming from geni to sfa (some are still needed)
755 - sfa/trust implements the security architecture
756
757 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
758 - snapshot for reproducible builds
759
760 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
761 - snapshot for the convenience of alpha users
762
763 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
764 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
765
766 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
767 - ongoing work - snapshot for 4.3-rc9
768
769 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
770 - various fixes
771
772 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
773 - bugfixes - still a work in progress
774
775 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
776 - initial package
777
778
779 %define module_current_branch 0.2