Setting tag sfa-0.9-13
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 13
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38
39 # python 2.5 has uuid module added, for python 2.4 we still need it.
40 # we can't really check for if we can load uuid as a python module,
41 # it'll be installed by "devel.pkgs". we have the epel repository so
42 # python-uuid will be provided. but we can test for the python
43 # version.
44 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
45 # %if %has_py24
46 #
47 # this also didn't work very well. I'll just check for distroname - baris
48 %if %{distroname} == "centos5"
49 Requires: python-uuid
50 %endif
51
52 %package cm
53 Summary: the SFA wrapper around MyPLC's NodeManager
54 Group: Applications/System
55 Requires: sfa
56 Requires: pyOpenSSL >= 0.6
57
58 %package plc
59 Summary: the SFA wrapper arounf MyPLC
60 Group: Applications/System
61 Requires: sfa
62 Requires: python-psycopg2
63 Requires: myplc-config
64 Requires: pyOpenSSL >= 0.7
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %description
78 This package provides the python libraries that the SFA implementation requires
79
80 %description cm
81 This package implements the SFA interface which serves as a layer
82 between the existing PlanetLab NodeManager interfaces and the SFA API.
83  
84 %description plc
85 This package implements the SFA interface which serves as a layer
86 between the existing PlanetLab interfaces and the SFA API.
87
88 %description client
89 This package provides the client side of the SFA API, in particular
90 sfi.py, together with other utilities.
91
92 %description sfatables
93 sfatables is a tool for defining access and admission control policies
94 in an SFA network, in much the same way as iptables is for ip
95 networks. This is the command line interface to manage sfatables
96
97 %prep
98 %setup -q
99
100 %build
101 make
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 make install DESTDIR="$RPM_BUILD_ROOT"
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 # sfa and sfatables depend each other.
112 %{_bindir}/sfa-server.py*
113 /etc/sfatables/*
114 %{python_sitelib}/*
115 /usr/bin/keyconvert
116 /var/www/html/wsdl/*.wsdl
117
118 %files cm
119 /etc/init.d/sfa-cm
120 %{_bindir}/sfa_component_setup.py*
121 # cron jobs here 
122
123 %files plc
124 %defattr(-,root,root)
125 %config /etc/sfa/default_config.xml
126 %config (noreplace) /etc/sfa/aggregates.xml
127 %config (noreplace) /etc/sfa/registries.xml
128 /etc/init.d/sfa
129 /etc/sfa/pl.rng
130 %{_bindir}/sfa-config-tty
131 %{_bindir}/sfa-import-plc.py*
132 %{_bindir}/sfa-clean-peer-records.py*
133 %{_bindir}/sfa-nuke-plc.py*
134 %{_bindir}/gen-sfa-cm-config.py*
135 %{_bindir}/sfa-ca.py*
136
137 %files client
138 %config (noreplace) /etc/sfa/sfi_config
139 %{_bindir}/sfi.py*
140 %{_bindir}/getNodes.py*
141 %{_bindir}/getRecord.py*
142 %{_bindir}/setRecord.py*
143 %{_bindir}/sfadump.py*
144
145 %files sfatables
146 %{_bindir}/sfatables
147
148 %pre plc
149 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
150
151 %pre cm
152 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
153
154 %post plc
155 chkconfig --add sfa
156
157 %post cm
158 chkconfig --add sfa-cm
159 %changelog
160 * Mon Jun 07 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-0.9-13
161 - fix spec
162
163 * Mon Jun 07 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-0.9-12
164 - fix parameter type
165
166 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
167 - SfaServer now uses a pool of threads to handle requests concurrently
168 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
169 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
170 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
171 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
172 - Component manager does not install gid files if slice already has them  
173 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
174 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
175 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
176      
177 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
178 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
179 - - sfa-config-tty now has the same features like plc-config-tty
180 - - Contains code to support both urn and hrn
181 - - Cleaned up request_hash related stuff
182 - - SM, AM and Registry code is organized under respective managers
183 - - Site and Slice synchronization across federated aggregates
184 - - Script to generate sfa_component_config
185
186 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
187 - sfa-config-tty now has the same features like plc-config-tty
188 - Contains code to support both urn and hrn
189 - Cleaned up request_hash related stuff
190 - SM, AM and Registry code is organized under respective managers
191 - Slice synchronization across federated aggregates
192 - some bugs are fixed
193
194 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
195 - checkpoint with fewer mentions of geni
196
197 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
198 - checkpointing
199 - this is believed to pass the tests; among other things:
200 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
201
202 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
203 - This tag includes:
204 - - Sfatables
205 - - Preliminary version of hash based authentication
206 - - Initial code for Component Manager
207 - - Authority structure is moved to /var/lib/sfa/
208 - - some bug-fixes
209
210 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
211 - Create_slice and get_resources methods are connected to sfatables.
212 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
213
214 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
215 - Bug fix on update and remove_peer_object methods
216 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
217
218 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
219 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
220
221 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
222 - compatibility with RefreshPeer
223 - incremental mechanism for importing PLC records into SFA tables
224 - unified single database (still inside the underlying PLC db postgresql server)
225 - includes/improves call traceability and logging features
226 - several bug fixes
227
228 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
229 - added libxslt-python dependency
230
231 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
232 - unified single SFA database in the PLC-DB
233 - upcalls from  PLCAPI to SFA methods
234 - SFA call traceability and logging features
235 - many bug fixes
236 - includes first/rough version of sfatables for policy implementation
237
238 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
239 - snapshot after the GEC5 demo
240 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
241
242 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
243 - snapshot july 15 - has gone through superficial manual testing
244 - hopefully a good basis for gec5 demo
245 - multi-dir sfi client tested as well
246
247 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
248 - rename geniwrapper.spec into sfa.spec
249
250 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
251 - clean up in xmlrpc/soap, --protocol option to chose between both
252 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
253 - hopefully more helpful context in case of crashes when importing
254 - bugfixes for using only /etc/sfa for site-dep files
255 - bugfixes in wsdl generation
256
257 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
258 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
259 - config variables in sfa_config now start with SFA_ and not GENI_
260 - config.py can be loaded even with no config present
261
262 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
263 - first step for cleanup and reorganization
264 - mass-renaming from geni to sfa (some are still needed)
265 - sfa/trust implements the security architecture
266
267 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
268 - snapshot for reproducible builds
269
270 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
271 - snapshot for the convenience of alpha users
272
273 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
274 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
275
276 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
277 - ongoing work - snapshot for 4.3-rc9
278
279 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
280 - various fixes
281
282 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
283 - bugfixes - still a work in progress
284
285 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
286 - initial package
287
288
289 %define module_current_branch 0.2