merged master onto senslab2, manually solved conflicts in setup.py
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA layer around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA layer around MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-start.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 /etc/sfa/topology
148 %{_bindir}/sfa-config-tty
149 %{_bindir}/sfa-import-plc.py*
150 %{_bindir}/sfa-clean-peer-records.py*
151 %{_bindir}/sfa-nuke-plc.py*
152 %{_bindir}/gen-sfa-cm-config.py*
153 %{_bindir}/sfa-ca.py*
154
155 %files client
156 %config (noreplace) /etc/sfa/sfi_config
157 %{_bindir}/sfi*
158 %{_bindir}/getNodes.py*
159 %{_bindir}/getRecord.py*
160 %{_bindir}/setRecord.py*
161 %{_bindir}/sfadump.py*
162
163 %files sfatables
164 %{_bindir}/sfatables
165
166 %files flashpolicy
167 %{_bindir}/sfa_flashpolicy.py*
168 /etc/sfa/sfa_flashpolicy_config.xml
169
170 %files tests
171 %{_datadir}/sfa/tests
172
173 ### sfa-plc installs the 'sfa' service
174 %post plc
175 chkconfig --add sfa
176
177 %preun plc
178 if [ "$1" = 0 ] ; then
179   /sbin/service sfa stop || :
180   /sbin/chkconfig --del sfa || :
181 fi
182
183 %postun plc
184 [ "$1" -ge "1" ] && service sfa restart
185
186 ### sfa-cm installs the 'sfa-cm' service
187 %post cm
188 chkconfig --add sfa-cm
189
190 %preun cm
191 if [ "$1" = 0 ] ; then
192    /sbin/service sfa-cm stop || :
193    /sbin/chkconfig --del sfa-cm || :
194 fi
195
196 %postun cm
197 [ "$1" -ge "1" ] && service sfa-cm restart || :
198
199 %changelog
200 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
201 - first support for protogeni rspecs is working
202 - vini no longer needs a specific manager
203 - refactoring underway towards more flexible/generic architecture
204
205 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
206 - Unicode-friendliness for user names with accents/special chars.
207 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
208 - CreaetSliver no longer fails for users that have a capital letter in their URN.
209 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
210 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
211 - Fix bugs and missing imports     
212  
213
214 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
215 - new method record.get_field for sface
216
217 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
218 - new option -c to sfa-nuke-plc.py
219 - CreateSliver fixed for admin-only slice tags
220
221 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
222 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
223 - Fixed holes in certificate verification logic.
224 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
225 - Added 'boot_state' as an attribute of the node element in SFA rspec.
226 - Non authority certificates are marked as CA:FALSE.
227
228 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
229 - fix typo in sfa-1.0-31 tag.
230 - added CreateGid() Registry interface method.
231
232 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
233 - fix typo in sfa-1.0-30 tag
234
235 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
236 - Declare namespace and schema location in the credential.
237 - Fix bug that prevetend connections from timing out.
238 - Fix slice delegation.
239 - Add statistics to slicemaanger listresources/createsliver rspec.
240 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
241   of days a user can extend their slice expiration.
242 - CA certs are only issued to objects of type authority
243    
244 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
245 - tag 1.0-28 was broken due to typo in the changelog
246 - new class sfa/util/httpsProtocol.py that supports timeouts
247
248 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
249 - Resolved issue that caused sfa hold onto idle db connections.
250 - Fix bug that caused the registry to use the wrong type of credential.
251 - Support authority+sm type.
252 - Fix rspec merging bugs.
253 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
254 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
255  planetlab hosted initscripts using the <planetlab:initscript> tag  
256 - Can now handle extraneous whitespace in the rspec without failing.   
257  
258 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
259 - ProtoGENI v2 RSpec updates.
260 - Convert expiration timestamps with timezone info in credentials to utc.
261 - Fixed redundant logging issue. 
262 - Improved SliceManager and SFI client logging.
263 - Support aggregates that don't support the optional 'call_id' argument. 
264 - Only call get_trusted_certs() at aggreage interfaces that support the call.
265 - CreateSliver() now handles MyPLC slice attributes/tags.
266 - Cache now supports persistence.
267 - Hide whitelisted nodes.
268
269 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
270 - fixed issues with sup authority signing
271 - fixed bugs in remove_slivers and SliverStatus
272
273 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
274 - fix typo that prevented aggregates from operating properly
275
276 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
277 - load trusted certs into ssl context prior to handshake
278 - client's logfile lives in ~/.sfi/sfi.log
279
280 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
281 - includes a change on passphrases that was intended in 1.0-22
282
283 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
284 - Added support for ProtoGENI RSpec v2
285  
286 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
287 - stable sfascan
288 - fix in initscript, *ENABLED tags in config now taken into account
289
290 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
291 - some commits had not been pushed in tag 19
292
293 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
294 - GetVersion should now report full URLs with path
295 - scansfa has nicer output and new syntax (entry URLs as args and not options)
296 - dos2unix'ed flash policy pill
297
298 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
299 - fix packaging again for f8
300
301 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
302 - fix packaging (apparently broken in 1.0-16)
303 - first working version of sfascan
304 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
305 - deprecated the sfa_geni_aggregate config category
306
307 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
308 - Fix build problem
309 - First version of SFA scanner
310
311 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
312 - Add support for Flash clients using flashpolicy
313 - Fix problems with tag handling in RSpec
314
315 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
316 - Modifications to the Eucalyptus Aggregate Manager
317 - Fixes for VINI RSpec
318 - Fix tag handling for PL RSpec
319 - Fix XML Schema ordering for <urn> element
320
321 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
322 - just set x509 version to 2
323
324 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
325 - added urn to the node area in rspecs
326 - conversion to urn now exports fqdn
327 - sfa-import-plc.py now creates a unique registry record for each SFA interface
328
329 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
330 - undo broken attempt for python-2.7
331
332 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
333 - SMs avoid duplicates for when call graph has dags;
334 - just based on network's name, when a duplicate occurs, one is just dropped
335 - does not try to merge/aggregate 2 networks
336 - also reviewed logging with the hope to fix the sfa startup msg:
337 - TypeError: not all arguments converted during string formatting
338
339 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
340 - verify credentials against xsd schema
341 - Fix SM to SM communication
342 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
343 - new setting session_key_path
344
345 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
346 - fix registry credential regeneration and handle expiration
347 - support for setting slice tags (min_role=user)
348 - client can display its own version: sfi.py version --local
349 - GetVersion to provide urn in addition to hrn
350 - more code uses plxrn vs previous helper functions
351 - import replaces '+' in email addresses with '_'
352
353 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
354 - fix GetVersion code_tag and add code_url
355
356 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
357 - extend GetVersion towards minimum federation introspection, and expose local tag
358
359 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
360 - fixed some legacy issues (list vs List)
361 - deprecated sfa.util.namespace for xrn and plxrn
362 - unit tests ship as the sfa-tests rpm
363
364 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
365 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
366 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
367 - hrn-urn translations tweaked
368 - fixed 'service sfa status'
369 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
370 - started to repair sfadump - although not usable yet
371 - trust objects now have dump_string method that dump() actually prints
372 - unit tests under review
373 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
374 - binaries now support -v or -vv to increase loglevel
375 - trashed obsolete sfa.util.client
376
377 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
378 - various bugfixes and cleanup, improved/harmonized logging
379
380 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
381 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
382   to avoid returning a PLCAPI exception that might confuse users.
383 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
384 - fix build errors.  
385
386 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
387 - (Architecture) Credential format changed to match ProtoGENI xml format
388 - (Architecture) All interfaces export a new set of methods that are compatible
389    with the ProtoGeni Aggregate spec. These new methods are considered a 
390    replacement  for the pervious methods exported by the interfaces. All 
391    previous methods are still exported and work as normal, but they are 
392    considered deprecated and will not be supported in future releases.  
393 - (Architecture) SFI has been updated to use the new interface methods.
394 - (Architecture) Changed keyconvet implementation from c to python.
395 - (Architecture) Slice Manager now attempts looks for a delegated credential
396   provided by the client before using its own server credential.
397 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
398   This cache now exists only in memory and is cleared when service is restarted
399   or cache lifetime is exceeded.  
400 - (Performance) SliceManager sends request to Aggregates in parallel instead 
401   of sequentially.
402 - (Bug fix) SFA tickets now support the new rspec format.
403 - (Bug fix) SFI only uses cahced credential if they aren't expired.
404 - (Bug fix) Cerdential delegation modified to work with new credential format.
405 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
406   Aggregate instead of relaying through the Slice Manager.
407 - (Enhancement) Simplified caching. Accociated a global cache instance with
408   the api handler on every new server request, making it easier to access the 
409   cache and use in more general ways.     
410
411 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
412 - SfaServer now uses a pool of threads to handle requests concurrently
413 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
414 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
415 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
416 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
417 - Component manager does not install gid files if slice already has them  
418 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
419 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
420 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
421      
422 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
423 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
424 - - sfa-config-tty now has the same features like plc-config-tty
425 - - Contains code to support both urn and hrn
426 - - Cleaned up request_hash related stuff
427 - - SM, AM and Registry code is organized under respective managers
428 - - Site and Slice synchronization across federated aggregates
429 - - Script to generate sfa_component_config
430
431 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
432 - sfa-config-tty now has the same features like plc-config-tty
433 - Contains code to support both urn and hrn
434 - Cleaned up request_hash related stuff
435 - SM, AM and Registry code is organized under respective managers
436 - Slice synchronization across federated aggregates
437 - some bugs are fixed
438
439 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
440 - checkpoint with fewer mentions of geni
441
442 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
443 - checkpointing
444 - this is believed to pass the tests; among other things:
445 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
446
447 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
448 - This tag includes:
449 - - Sfatables
450 - - Preliminary version of hash based authentication
451 - - Initial code for Component Manager
452 - - Authority structure is moved to /var/lib/sfa/
453 - - some bug-fixes
454
455 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
456 - Create_slice and get_resources methods are connected to sfatables.
457 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
458
459 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
460 - Bug fix on update and remove_peer_object methods
461 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
462
463 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
464 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
465
466 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
467 - compatibility with RefreshPeer
468 - incremental mechanism for importing PLC records into SFA tables
469 - unified single database (still inside the underlying PLC db postgresql server)
470 - includes/improves call traceability and logging features
471 - several bug fixes
472
473 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
474 - added libxslt-python dependency
475
476 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
477 - unified single SFA database in the PLC-DB
478 - upcalls from  PLCAPI to SFA methods
479 - SFA call traceability and logging features
480 - many bug fixes
481 - includes first/rough version of sfatables for policy implementation
482
483 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
484 - snapshot after the GEC5 demo
485 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
486
487 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
488 - snapshot july 15 - has gone through superficial manual testing
489 - hopefully a good basis for gec5 demo
490 - multi-dir sfi client tested as well
491
492 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
493 - rename geniwrapper.spec into sfa.spec
494
495 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
496 - clean up in xmlrpc/soap, --protocol option to chose between both
497 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
498 - hopefully more helpful context in case of crashes when importing
499 - bugfixes for using only /etc/sfa for site-dep files
500 - bugfixes in wsdl generation
501
502 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
503 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
504 - config variables in sfa_config now start with SFA_ and not GENI_
505 - config.py can be loaded even with no config present
506
507 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
508 - first step for cleanup and reorganization
509 - mass-renaming from geni to sfa (some are still needed)
510 - sfa/trust implements the security architecture
511
512 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
513 - snapshot for reproducible builds
514
515 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
516 - snapshot for the convenience of alpha users
517
518 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
519 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
520
521 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
522 - ongoing work - snapshot for 4.3-rc9
523
524 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
525 - various fixes
526
527 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
528 - bugfixes - still a work in progress
529
530 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
531 - initial package
532
533
534 %define module_current_branch 0.2