Setting tag sfa-0.9-14
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 14
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38
39 # python 2.5 has uuid module added, for python 2.4 we still need it.
40 # we can't really check for if we can load uuid as a python module,
41 # it'll be installed by "devel.pkgs". we have the epel repository so
42 # python-uuid will be provided. but we can test for the python
43 # version.
44 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
45 # %if %has_py24
46 #
47 # this also didn't work very well. I'll just check for distroname - baris
48 %if %{distroname} == "centos5"
49 Requires: python-uuid
50 %endif
51
52 %package cm
53 Summary: the SFA wrapper around MyPLC's NodeManager
54 Group: Applications/System
55 Requires: sfa
56 Requires: pyOpenSSL >= 0.6
57
58 %package plc
59 Summary: the SFA wrapper arounf MyPLC
60 Group: Applications/System
61 Requires: sfa
62 Requires: python-psycopg2
63 Requires: myplc-config
64 Requires: pyOpenSSL >= 0.7
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %description
78 This package provides the python libraries that the SFA implementation requires
79
80 %description cm
81 This package implements the SFA interface which serves as a layer
82 between the existing PlanetLab NodeManager interfaces and the SFA API.
83  
84 %description plc
85 This package implements the SFA interface which serves as a layer
86 between the existing PlanetLab interfaces and the SFA API.
87
88 %description client
89 This package provides the client side of the SFA API, in particular
90 sfi.py, together with other utilities.
91
92 %description sfatables
93 sfatables is a tool for defining access and admission control policies
94 in an SFA network, in much the same way as iptables is for ip
95 networks. This is the command line interface to manage sfatables
96
97 %prep
98 %setup -q
99
100 %build
101 make
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 make install DESTDIR="$RPM_BUILD_ROOT"
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 # sfa and sfatables depend each other.
112 %{_bindir}/sfa-server.py*
113 /etc/sfatables/*
114 %{python_sitelib}/*
115 /usr/bin/keyconvert
116 /var/www/html/wsdl/*.wsdl
117
118 %files cm
119 /etc/init.d/sfa-cm
120 %{_bindir}/sfa_component_setup.py*
121 # cron jobs here 
122
123 %files plc
124 %defattr(-,root,root)
125 %config /etc/sfa/default_config.xml
126 %config (noreplace) /etc/sfa/aggregates.xml
127 %config (noreplace) /etc/sfa/registries.xml
128 /etc/init.d/sfa
129 /etc/sfa/pl.rng
130 %{_bindir}/sfa-config-tty
131 %{_bindir}/sfa-import-plc.py*
132 %{_bindir}/sfa-clean-peer-records.py*
133 %{_bindir}/sfa-nuke-plc.py*
134 %{_bindir}/gen-sfa-cm-config.py*
135 %{_bindir}/sfa-ca.py*
136
137 %files client
138 %config (noreplace) /etc/sfa/sfi_config
139 %{_bindir}/sfi*
140 %{_bindir}/getNodes.py*
141 %{_bindir}/getRecord.py*
142 %{_bindir}/setRecord.py*
143 %{_bindir}/sfadump.py*
144
145 %files sfatables
146 %{_bindir}/sfatables
147
148 %pre plc
149 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
150
151 %pre cm
152 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
153
154 %post plc
155 chkconfig --add sfa
156
157 %post cm
158 chkconfig --add sfa-cm
159 %changelog
160 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-0.9-14
161 - aff sfi* commands to client package
162
163 * Mon Jun 07 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-0.9-13
164 - fix spec
165
166 * Mon Jun 07 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sfa-0.9-12
167 - fix parameter type
168
169 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
170 - SfaServer now uses a pool of threads to handle requests concurrently
171 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
172 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
173 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
174 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
175 - Component manager does not install gid files if slice already has them  
176 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
177 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
178 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
179      
180 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
181 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
182 - - sfa-config-tty now has the same features like plc-config-tty
183 - - Contains code to support both urn and hrn
184 - - Cleaned up request_hash related stuff
185 - - SM, AM and Registry code is organized under respective managers
186 - - Site and Slice synchronization across federated aggregates
187 - - Script to generate sfa_component_config
188
189 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
190 - sfa-config-tty now has the same features like plc-config-tty
191 - Contains code to support both urn and hrn
192 - Cleaned up request_hash related stuff
193 - SM, AM and Registry code is organized under respective managers
194 - Slice synchronization across federated aggregates
195 - some bugs are fixed
196
197 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
198 - checkpoint with fewer mentions of geni
199
200 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
201 - checkpointing
202 - this is believed to pass the tests; among other things:
203 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
204
205 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
206 - This tag includes:
207 - - Sfatables
208 - - Preliminary version of hash based authentication
209 - - Initial code for Component Manager
210 - - Authority structure is moved to /var/lib/sfa/
211 - - some bug-fixes
212
213 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
214 - Create_slice and get_resources methods are connected to sfatables.
215 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
216
217 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
218 - Bug fix on update and remove_peer_object methods
219 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
220
221 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
222 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
223
224 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
225 - compatibility with RefreshPeer
226 - incremental mechanism for importing PLC records into SFA tables
227 - unified single database (still inside the underlying PLC db postgresql server)
228 - includes/improves call traceability and logging features
229 - several bug fixes
230
231 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
232 - added libxslt-python dependency
233
234 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
235 - unified single SFA database in the PLC-DB
236 - upcalls from  PLCAPI to SFA methods
237 - SFA call traceability and logging features
238 - many bug fixes
239 - includes first/rough version of sfatables for policy implementation
240
241 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
242 - snapshot after the GEC5 demo
243 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
244
245 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
246 - snapshot july 15 - has gone through superficial manual testing
247 - hopefully a good basis for gec5 demo
248 - multi-dir sfi client tested as well
249
250 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
251 - rename geniwrapper.spec into sfa.spec
252
253 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
254 - clean up in xmlrpc/soap, --protocol option to chose between both
255 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
256 - hopefully more helpful context in case of crashes when importing
257 - bugfixes for using only /etc/sfa for site-dep files
258 - bugfixes in wsdl generation
259
260 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
261 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
262 - config variables in sfa_config now start with SFA_ and not GENI_
263 - config.py can be loaded even with no config present
264
265 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
266 - first step for cleanup and reorganization
267 - mass-renaming from geni to sfa (some are still needed)
268 - sfa/trust implements the security architecture
269
270 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
271 - snapshot for reproducible builds
272
273 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
274 - snapshot for the convenience of alpha users
275
276 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
277 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
278
279 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
280 - ongoing work - snapshot for 4.3-rc9
281
282 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
283 - various fixes
284
285 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
286 - bugfixes - still a work in progress
287
288 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
289 - initial package
290
291
292 %define module_current_branch 0.2