minor improvement to packaging
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
228 - various fixes in rspecs for sfav1&slice tags
229 - uses 'geni_rspec_version' and not just 'rspec_version'
230 - example flavour for the max testbed
231 - embryo for an sfa client library
232 - topology.py moved into plc
233 - sql: table is named records; record_types are enforced
234 - sql: table creation cleaned up
235
236 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
237 - cleaned up all references to SFA_*_TYPE in config
238 - enable cache at the aggregate by default
239 - registry now uses the driver in a sensible way (see managers/driver.py)
240 - slice manager supports sfav1/pgv2 neighbours
241 - get_key renamed into get_key_from_incoming_ip
242 - new sfa.storage module for record/table and all db-related stuff
243 - db schema in sfa.storage.sfa.sql
244 - init.d and cron.d move one step up
245 - cleaned up rspec/ directory
246 - add deps to pyopenssl and myplc-config
247 - start support for new API (return value)
248 - plc.remoteshell removed, use plshell instead
249 - plshell uses a 'capability' auth method whenever possible
250 - various tweaks in rspec elements
251 - made dependency on sfatables softer
252
253 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
254 - sfa should now be started *before* the initial import
255 - sfa to use its own database (default sfa) - can run without myplc
256 - server calls support optional 'options'
257 - client sends options in argument when needed
258 - fix infinite getattr recursion in elements/element.py
259 - error codes in line with geni
260
261 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
262 - fixed links and attributes in rspecs
263 - minor cleanup in the API methods, and more consistent names in manager methods
264
265 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
266 - ongoing refoactoring towards more genericity
267 - passes tests again although known issues remain with attributes/tags
268
269 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
270 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
271 - improvements in the pgv2 rspecs
272 - driver separated from api
273 - code starts moving around where it belongs
274 - sfascan caches getversion across invokations
275 - vini topology extracted as a config file
276
277 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
278 - first support for protogeni rspecs is working
279 - vini no longer needs a specific manager
280 - refactoring underway towards more flexible/generic architecture
281
282 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
283 - Unicode-friendliness for user names with accents/special chars.
284 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
285 - CreaetSliver no longer fails for users that have a capital letter in their URN.
286 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
287 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
288 - Fix bugs and missing imports     
289  
290
291 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
292 - new method record.get_field for sface
293
294 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
295 - new option -c to sfa-nuke-plc.py
296 - CreateSliver fixed for admin-only slice tags
297
298 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
299 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
300 - Fixed holes in certificate verification logic.
301 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
302 - Added 'boot_state' as an attribute of the node element in SFA rspec.
303 - Non authority certificates are marked as CA:FALSE.
304
305 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
306 - fix typo in sfa-1.0-31 tag.
307 - added CreateGid() Registry interface method.
308
309 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
310 - fix typo in sfa-1.0-30 tag
311
312 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
313 - Declare namespace and schema location in the credential.
314 - Fix bug that prevetend connections from timing out.
315 - Fix slice delegation.
316 - Add statistics to slicemaanger listresources/createsliver rspec.
317 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
318   of days a user can extend their slice expiration.
319 - CA certs are only issued to objects of type authority
320    
321 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
322 - tag 1.0-28 was broken due to typo in the changelog
323 - new class sfa/util/httpsProtocol.py that supports timeouts
324
325 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
326 - Resolved issue that caused sfa hold onto idle db connections.
327 - Fix bug that caused the registry to use the wrong type of credential.
328 - Support authority+sm type.
329 - Fix rspec merging bugs.
330 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
331 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
332  planetlab hosted initscripts using the <planetlab:initscript> tag  
333 - Can now handle extraneous whitespace in the rspec without failing.   
334  
335 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
336 - ProtoGENI v2 RSpec updates.
337 - Convert expiration timestamps with timezone info in credentials to utc.
338 - Fixed redundant logging issue. 
339 - Improved SliceManager and SFI client logging.
340 - Support aggregates that don't support the optional 'call_id' argument. 
341 - Only call get_trusted_certs() at aggreage interfaces that support the call.
342 - CreateSliver() now handles MyPLC slice attributes/tags.
343 - Cache now supports persistence.
344 - Hide whitelisted nodes.
345
346 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
347 - fixed issues with sup authority signing
348 - fixed bugs in remove_slivers and SliverStatus
349
350 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
351 - fix typo that prevented aggregates from operating properly
352
353 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
354 - load trusted certs into ssl context prior to handshake
355 - client's logfile lives in ~/.sfi/sfi.log
356
357 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
358 - includes a change on passphrases that was intended in 1.0-22
359
360 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
361 - Added support for ProtoGENI RSpec v2
362  
363 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
364 - stable sfascan
365 - fix in initscript, *ENABLED tags in config now taken into account
366
367 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
368 - some commits had not been pushed in tag 19
369
370 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
371 - GetVersion should now report full URLs with path
372 - scansfa has nicer output and new syntax (entry URLs as args and not options)
373 - dos2unix'ed flash policy pill
374
375 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
376 - fix packaging again for f8
377
378 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
379 - fix packaging (apparently broken in 1.0-16)
380 - first working version of sfascan
381 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
382 - deprecated the sfa_geni_aggregate config category
383
384 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
385 - Fix build problem
386 - First version of SFA scanner
387
388 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
389 - Add support for Flash clients using flashpolicy
390 - Fix problems with tag handling in RSpec
391
392 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
393 - Modifications to the Eucalyptus Aggregate Manager
394 - Fixes for VINI RSpec
395 - Fix tag handling for PL RSpec
396 - Fix XML Schema ordering for <urn> element
397
398 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
399 - just set x509 version to 2
400
401 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
402 - added urn to the node area in rspecs
403 - conversion to urn now exports fqdn
404 - sfa-import-plc.py now creates a unique registry record for each SFA interface
405
406 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
407 - undo broken attempt for python-2.7
408
409 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
410 - SMs avoid duplicates for when call graph has dags;
411 - just based on network's name, when a duplicate occurs, one is just dropped
412 - does not try to merge/aggregate 2 networks
413 - also reviewed logging with the hope to fix the sfa startup msg:
414 - TypeError: not all arguments converted during string formatting
415
416 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
417 - verify credentials against xsd schema
418 - Fix SM to SM communication
419 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
420 - new setting session_key_path
421
422 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
423 - fix registry credential regeneration and handle expiration
424 - support for setting slice tags (min_role=user)
425 - client can display its own version: sfi.py version --local
426 - GetVersion to provide urn in addition to hrn
427 - more code uses plxrn vs previous helper functions
428 - import replaces '+' in email addresses with '_'
429
430 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
431 - fix GetVersion code_tag and add code_url
432
433 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
434 - extend GetVersion towards minimum federation introspection, and expose local tag
435
436 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
437 - fixed some legacy issues (list vs List)
438 - deprecated sfa.util.namespace for xrn and plxrn
439 - unit tests ship as the sfa-tests rpm
440
441 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
442 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
443 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
444 - hrn-urn translations tweaked
445 - fixed 'service sfa status'
446 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
447 - started to repair sfadump - although not usable yet
448 - trust objects now have dump_string method that dump() actually prints
449 - unit tests under review
450 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
451 - binaries now support -v or -vv to increase loglevel
452 - trashed obsolete sfa.util.client
453
454 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
455 - various bugfixes and cleanup, improved/harmonized logging
456
457 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
458 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
459   to avoid returning a PLCAPI exception that might confuse users.
460 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
461 - fix build errors.  
462
463 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
464 - (Architecture) Credential format changed to match ProtoGENI xml format
465 - (Architecture) All interfaces export a new set of methods that are compatible
466    with the ProtoGeni Aggregate spec. These new methods are considered a 
467    replacement  for the pervious methods exported by the interfaces. All 
468    previous methods are still exported and work as normal, but they are 
469    considered deprecated and will not be supported in future releases.  
470 - (Architecture) SFI has been updated to use the new interface methods.
471 - (Architecture) Changed keyconvet implementation from c to python.
472 - (Architecture) Slice Manager now attempts looks for a delegated credential
473   provided by the client before using its own server credential.
474 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
475   This cache now exists only in memory and is cleared when service is restarted
476   or cache lifetime is exceeded.  
477 - (Performance) SliceManager sends request to Aggregates in parallel instead 
478   of sequentially.
479 - (Bug fix) SFA tickets now support the new rspec format.
480 - (Bug fix) SFI only uses cahced credential if they aren't expired.
481 - (Bug fix) Cerdential delegation modified to work with new credential format.
482 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
483   Aggregate instead of relaying through the Slice Manager.
484 - (Enhancement) Simplified caching. Accociated a global cache instance with
485   the api handler on every new server request, making it easier to access the 
486   cache and use in more general ways.     
487
488 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
489 - SfaServer now uses a pool of threads to handle requests concurrently
490 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
491 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
492 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
493 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
494 - Component manager does not install gid files if slice already has them  
495 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
496 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
497 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
498      
499 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
500 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
501 - - sfa-config-tty now has the same features like plc-config-tty
502 - - Contains code to support both urn and hrn
503 - - Cleaned up request_hash related stuff
504 - - SM, AM and Registry code is organized under respective managers
505 - - Site and Slice synchronization across federated aggregates
506 - - Script to generate sfa_component_config
507
508 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
509 - sfa-config-tty now has the same features like plc-config-tty
510 - Contains code to support both urn and hrn
511 - Cleaned up request_hash related stuff
512 - SM, AM and Registry code is organized under respective managers
513 - Slice synchronization across federated aggregates
514 - some bugs are fixed
515
516 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
517 - checkpoint with fewer mentions of geni
518
519 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
520 - checkpointing
521 - this is believed to pass the tests; among other things:
522 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
523
524 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
525 - This tag includes:
526 - - Sfatables
527 - - Preliminary version of hash based authentication
528 - - Initial code for Component Manager
529 - - Authority structure is moved to /var/lib/sfa/
530 - - some bug-fixes
531
532 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
533 - Create_slice and get_resources methods are connected to sfatables.
534 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
535
536 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
537 - Bug fix on update and remove_peer_object methods
538 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
539
540 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
541 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
542
543 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
544 - compatibility with RefreshPeer
545 - incremental mechanism for importing PLC records into SFA tables
546 - unified single database (still inside the underlying PLC db postgresql server)
547 - includes/improves call traceability and logging features
548 - several bug fixes
549
550 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
551 - added libxslt-python dependency
552
553 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
554 - unified single SFA database in the PLC-DB
555 - upcalls from  PLCAPI to SFA methods
556 - SFA call traceability and logging features
557 - many bug fixes
558 - includes first/rough version of sfatables for policy implementation
559
560 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
561 - snapshot after the GEC5 demo
562 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
563
564 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
565 - snapshot july 15 - has gone through superficial manual testing
566 - hopefully a good basis for gec5 demo
567 - multi-dir sfi client tested as well
568
569 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
570 - rename geniwrapper.spec into sfa.spec
571
572 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
573 - clean up in xmlrpc/soap, --protocol option to chose between both
574 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
575 - hopefully more helpful context in case of crashes when importing
576 - bugfixes for using only /etc/sfa for site-dep files
577 - bugfixes in wsdl generation
578
579 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
580 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
581 - config variables in sfa_config now start with SFA_ and not GENI_
582 - config.py can be loaded even with no config present
583
584 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
585 - first step for cleanup and reorganization
586 - mass-renaming from geni to sfa (some are still needed)
587 - sfa/trust implements the security architecture
588
589 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
590 - snapshot for reproducible builds
591
592 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
593 - snapshot for the convenience of alpha users
594
595 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
596 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
597
598 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
599 - ongoing work - snapshot for 4.3-rc9
600
601 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
602 - various fixes
603
604 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
605 - bugfixes - still a work in progress
606
607 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
608 - initial package
609
610
611 %define module_current_branch 0.2