rename sfa-server.py into sfa-start.py
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 36
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA layer around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA layer around MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-start.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart || :
197
198 %changelog
199 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
200 - Unicode-friendliness for user names with accents/special chars.
201 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
202 - CreaetSliver no longer fails for users that have a capital letter in their URN.
203 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
204 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
205 - Fix bugs and missing imports     
206  
207
208 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
209 - new method record.get_field for sface
210
211 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
212 - new option -c to sfa-nuke-plc.py
213 - CreateSliver fixed for admin-only slice tags
214
215 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
216 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
217 - Fixed holes in certificate verification logic.
218 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
219 - Added 'boot_state' as an attribute of the node element in SFA rspec.
220 - Non authority certificates are marked as CA:FALSE.
221
222 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
223 - fix typo in sfa-1.0-31 tag.
224 - added CreateGid() Registry interface method.
225
226 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
227 - fix typo in sfa-1.0-30 tag
228
229 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
230 - Declare namespace and schema location in the credential.
231 - Fix bug that prevetend connections from timing out.
232 - Fix slice delegation.
233 - Add statistics to slicemaanger listresources/createsliver rspec.
234 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
235   of days a user can extend their slice expiration.
236 - CA certs are only issued to objects of type authority
237    
238 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
239 - tag 1.0-28 was broken due to typo in the changelog
240 - new class sfa/util/httpsProtocol.py that supports timeouts
241
242 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
243 - Resolved issue that caused sfa hold onto idle db connections.
244 - Fix bug that caused the registry to use the wrong type of credential.
245 - Support authority+sm type.
246 - Fix rspec merging bugs.
247 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
248 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
249  planetlab hosted initscripts using the <planetlab:initscript> tag  
250 - Can now handle extraneous whitespace in the rspec without failing.   
251  
252 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
253 - ProtoGENI v2 RSpec updates.
254 - Convert expiration timestamps with timezone info in credentials to utc.
255 - Fixed redundant logging issue. 
256 - Improved SliceManager and SFI client logging.
257 - Support aggregates that don't support the optional 'call_id' argument. 
258 - Only call get_trusted_certs() at aggreage interfaces that support the call.
259 - CreateSliver() now handles MyPLC slice attributes/tags.
260 - Cache now supports persistence.
261 - Hide whitelisted nodes.
262
263 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
264 - fixed issues with sup authority signing
265 - fixed bugs in remove_slivers and SliverStatus
266
267 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
268 - fix typo that prevented aggregates from operating properly
269
270 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
271 - load trusted certs into ssl context prior to handshake
272 - client's logfile lives in ~/.sfi/sfi.log
273
274 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
275 - includes a change on passphrases that was intended in 1.0-22
276
277 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
278 - Added support for ProtoGENI RSpec v2
279  
280 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
281 - stable sfascan
282 - fix in initscript, *ENABLED tags in config now taken into account
283
284 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
285 - some commits had not been pushed in tag 19
286
287 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
288 - GetVersion should now report full URLs with path
289 - scansfa has nicer output and new syntax (entry URLs as args and not options)
290 - dos2unix'ed flash policy pill
291
292 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
293 - fix packaging again for f8
294
295 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
296 - fix packaging (apparently broken in 1.0-16)
297 - first working version of sfascan
298 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
299 - deprecated the sfa_geni_aggregate config category
300
301 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
302 - Fix build problem
303 - First version of SFA scanner
304
305 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
306 - Add support for Flash clients using flashpolicy
307 - Fix problems with tag handling in RSpec
308
309 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
310 - Modifications to the Eucalyptus Aggregate Manager
311 - Fixes for VINI RSpec
312 - Fix tag handling for PL RSpec
313 - Fix XML Schema ordering for <urn> element
314
315 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
316 - just set x509 version to 2
317
318 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
319 - added urn to the node area in rspecs
320 - conversion to urn now exports fqdn
321 - sfa-import-plc.py now creates a unique registry record for each SFA interface
322
323 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
324 - undo broken attempt for python-2.7
325
326 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
327 - SMs avoid duplicates for when call graph has dags;
328 - just based on network's name, when a duplicate occurs, one is just dropped
329 - does not try to merge/aggregate 2 networks
330 - also reviewed logging with the hope to fix the sfa startup msg:
331 - TypeError: not all arguments converted during string formatting
332
333 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
334 - verify credentials against xsd schema
335 - Fix SM to SM communication
336 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
337 - new setting session_key_path
338
339 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
340 - fix registry credential regeneration and handle expiration
341 - support for setting slice tags (min_role=user)
342 - client can display its own version: sfi.py version --local
343 - GetVersion to provide urn in addition to hrn
344 - more code uses plxrn vs previous helper functions
345 - import replaces '+' in email addresses with '_'
346
347 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
348 - fix GetVersion code_tag and add code_url
349
350 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
351 - extend GetVersion towards minimum federation introspection, and expose local tag
352
353 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
354 - fixed some legacy issues (list vs List)
355 - deprecated sfa.util.namespace for xrn and plxrn
356 - unit tests ship as the sfa-tests rpm
357
358 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
359 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
360 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
361 - hrn-urn translations tweaked
362 - fixed 'service sfa status'
363 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
364 - started to repair sfadump - although not usable yet
365 - trust objects now have dump_string method that dump() actually prints
366 - unit tests under review
367 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
368 - binaries now support -v or -vv to increase loglevel
369 - trashed obsolete sfa.util.client
370
371 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
372 - various bugfixes and cleanup, improved/harmonized logging
373
374 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
375 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
376   to avoid returning a PLCAPI exception that might confuse users.
377 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
378 - fix build errors.  
379
380 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
381 - (Architecture) Credential format changed to match ProtoGENI xml format
382 - (Architecture) All interfaces export a new set of methods that are compatible
383    with the ProtoGeni Aggregate spec. These new methods are considered a 
384    replacement  for the pervious methods exported by the interfaces. All 
385    previous methods are still exported and work as normal, but they are 
386    considered deprecated and will not be supported in future releases.  
387 - (Architecture) SFI has been updated to use the new interface methods.
388 - (Architecture) Changed keyconvet implementation from c to python.
389 - (Architecture) Slice Manager now attempts looks for a delegated credential
390   provided by the client before using its own server credential.
391 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
392   This cache now exists only in memory and is cleared when service is restarted
393   or cache lifetime is exceeded.  
394 - (Performance) SliceManager sends request to Aggregates in parallel instead 
395   of sequentially.
396 - (Bug fix) SFA tickets now support the new rspec format.
397 - (Bug fix) SFI only uses cahced credential if they aren't expired.
398 - (Bug fix) Cerdential delegation modified to work with new credential format.
399 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
400   Aggregate instead of relaying through the Slice Manager.
401 - (Enhancement) Simplified caching. Accociated a global cache instance with
402   the api handler on every new server request, making it easier to access the 
403   cache and use in more general ways.     
404
405 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
406 - SfaServer now uses a pool of threads to handle requests concurrently
407 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
408 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
409 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
410 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
411 - Component manager does not install gid files if slice already has them  
412 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
413 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
414 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
415      
416 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
417 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
418 - - sfa-config-tty now has the same features like plc-config-tty
419 - - Contains code to support both urn and hrn
420 - - Cleaned up request_hash related stuff
421 - - SM, AM and Registry code is organized under respective managers
422 - - Site and Slice synchronization across federated aggregates
423 - - Script to generate sfa_component_config
424
425 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
426 - sfa-config-tty now has the same features like plc-config-tty
427 - Contains code to support both urn and hrn
428 - Cleaned up request_hash related stuff
429 - SM, AM and Registry code is organized under respective managers
430 - Slice synchronization across federated aggregates
431 - some bugs are fixed
432
433 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
434 - checkpoint with fewer mentions of geni
435
436 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
437 - checkpointing
438 - this is believed to pass the tests; among other things:
439 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
440
441 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
442 - This tag includes:
443 - - Sfatables
444 - - Preliminary version of hash based authentication
445 - - Initial code for Component Manager
446 - - Authority structure is moved to /var/lib/sfa/
447 - - some bug-fixes
448
449 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
450 - Create_slice and get_resources methods are connected to sfatables.
451 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
452
453 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
454 - Bug fix on update and remove_peer_object methods
455 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
456
457 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
458 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
459
460 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
461 - compatibility with RefreshPeer
462 - incremental mechanism for importing PLC records into SFA tables
463 - unified single database (still inside the underlying PLC db postgresql server)
464 - includes/improves call traceability and logging features
465 - several bug fixes
466
467 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
468 - added libxslt-python dependency
469
470 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
471 - unified single SFA database in the PLC-DB
472 - upcalls from  PLCAPI to SFA methods
473 - SFA call traceability and logging features
474 - many bug fixes
475 - includes first/rough version of sfatables for policy implementation
476
477 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
478 - snapshot after the GEC5 demo
479 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
480
481 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
482 - snapshot july 15 - has gone through superficial manual testing
483 - hopefully a good basis for gec5 demo
484 - multi-dir sfi client tested as well
485
486 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
487 - rename geniwrapper.spec into sfa.spec
488
489 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
490 - clean up in xmlrpc/soap, --protocol option to chose between both
491 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
492 - hopefully more helpful context in case of crashes when importing
493 - bugfixes for using only /etc/sfa for site-dep files
494 - bugfixes in wsdl generation
495
496 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
497 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
498 - config variables in sfa_config now start with SFA_ and not GENI_
499 - config.py can be loaded even with no config present
500
501 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
502 - first step for cleanup and reorganization
503 - mass-renaming from geni to sfa (some are still needed)
504 - sfa/trust implements the security architecture
505
506 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
507 - snapshot for reproducible builds
508
509 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
510 - snapshot for the convenience of alpha users
511
512 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
513 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
514
515 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
516 - ongoing work - snapshot for 4.3-rc9
517
518 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
519 - various fixes
520
521 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
522 - bugfixes - still a work in progress
523
524 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
525 - initial package
526
527
528 %define module_current_branch 0.2