initscript knows how to initialize db
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # for uuidgen - used in db password generation
31 # on f8 this actually comes with e2fsprogs, go figure
32 Requires: util-linux-ng
33 # xmlbuilder depends on  lxml
34 Requires: python-lxml
35 Requires: python-setuptools
36 Requires: python-dateutil
37 # for the registry
38 Requires: postgresql >= 8.2, postgresql-server >= 8.2
39 Requires: postgresql-python
40 Requires: python-psycopg2
41  
42 # python 2.5 has uuid module added, for python 2.4 we still need it.
43 # we can't really check for if we can load uuid as a python module,
44 # it'll be installed by "devel.pkgs". we have the epel repository so
45 # python-uuid will be provided. but we can test for the python
46 # version.
47 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
48 # %if %has_py24
49 #
50 # this also didn't work very well. I'll just check for distroname - baris
51 #%if %{distroname} == "centos5"
52 #Requires: python-uuid
53 #%endif
54
55 %package cm
56 Summary: the SFA layer around MyPLC NodeManager
57 Group: Applications/System
58 Requires: sfa
59 Requires: pyOpenSSL >= 0.6
60
61 %package plc
62 Summary: the SFA layer around MyPLC
63 Group: Applications/System
64 Requires: sfa
65 Requires: python-psycopg2
66 Requires: myplc-config
67 Requires: pyOpenSSL >= 0.7
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package sfatables
76 Summary: sfatables policy tool for SFA
77 Group: Applications/System
78 Requires: sfa
79
80 %package flashpolicy
81 Summary: SFA support for flash clients
82 Group: Applications/System
83 Requires: sfa
84
85 %package tests
86 Summary: unit tests suite for SFA
87 Group: Applications/System
88 Requires: sfa
89
90 %description
91 This package provides the python libraries for the PlanetLab implementation of SFA
92
93 %description cm
94 This package implements the SFA interface which serves as a layer
95 between the existing PlanetLab NodeManager interfaces and the SFA API.
96  
97 %description plc
98 This package implements the SFA interface which serves as a layer
99 between the existing PlanetLab interfaces and the SFA API.
100
101 %description client
102 This package provides the client side of the SFA API, in particular
103 sfi.py, together with other utilities.
104
105 %description sfatables
106 sfatables is a tool for defining access and admission control policies
107 in an SFA network, in much the same way as iptables is for ip
108 networks. This is the command line interface to manage sfatables
109
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112  
113 %description tests
114 Provides some binary unit tests in /usr/share/sfa/tests
115
116 %prep
117 %setup -q
118
119 %build
120 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 # sfa and sfatables depend each other.
131 %{_bindir}/sfa-start.py*
132 /etc/sfatables/*
133 %{python_sitelib}/*
134 %{_bindir}/keyconvert.py*
135 /var/www/html/wsdl/*.wsdl
136
137 %files cm
138 /etc/init.d/sfa-cm
139 %{_bindir}/sfa_component_setup.py*
140 # cron jobs here 
141
142 %files plc
143 %defattr(-,root,root)
144 %config /etc/sfa/default_config.xml
145 %config (noreplace) /etc/sfa/aggregates.xml
146 %config (noreplace) /etc/sfa/registries.xml
147 /etc/init.d/sfa
148 /etc/sfa/pl.rng
149 /etc/sfa/credential.xsd
150 /etc/sfa/top.xsd
151 /etc/sfa/sig.xsd
152 /etc/sfa/xml.xsd
153 /etc/sfa/protogeni-rspec-common.xsd
154 /etc/sfa/topology
155 %{_bindir}/sfa-config-tty
156 %{_bindir}/sfa-import-plc.py*
157 %{_bindir}/sfa-clean-peer-records.py*
158 %{_bindir}/sfa-nuke-plc.py*
159 %{_bindir}/gen-sfa-cm-config.py*
160 %{_bindir}/sfa-ca.py*
161
162 %files client
163 %config (noreplace) /etc/sfa/sfi_config
164 %{_bindir}/sfi*
165 %{_bindir}/getNodes.py*
166 %{_bindir}/getRecord.py*
167 %{_bindir}/setRecord.py*
168 %{_bindir}/sfadump.py*
169
170 %files sfatables
171 %{_bindir}/sfatables
172
173 %files flashpolicy
174 %{_bindir}/sfa_flashpolicy.py*
175 /etc/sfa/sfa_flashpolicy_config.xml
176
177 %files tests
178 %{_datadir}/sfa/tests
179
180 ### sfa-plc installs the 'sfa' service
181 %post plc
182 chkconfig --add sfa
183
184 %preun plc
185 if [ "$1" = 0 ] ; then
186   /sbin/service sfa stop || :
187   /sbin/chkconfig --del sfa || :
188 fi
189
190 %postun plc
191 [ "$1" -ge "1" ] && service sfa restart
192
193 ### sfa-cm installs the 'sfa-cm' service
194 %post cm
195 chkconfig --add sfa-cm
196
197 %preun cm
198 if [ "$1" = 0 ] ; then
199    /sbin/service sfa-cm stop || :
200    /sbin/chkconfig --del sfa-cm || :
201 fi
202
203 %postun cm
204 [ "$1" -ge "1" ] && service sfa-cm restart || :
205
206 %changelog
207 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
208 - fixed links and attributes in rspecs
209 - minor cleanup in the API methods, and more consistent names in manager methods
210
211 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
212 - ongoing refoactoring towards more genericity
213 - passes tests again although known issues remain with attributes/tags
214
215 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
216 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
217 - improvements in the pgv2 rspecs
218 - driver separated from api
219 - code starts moving around where it belongs
220 - sfascan caches getversion across invokations
221 - vini topology extracted as a config file
222
223 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
224 - first support for protogeni rspecs is working
225 - vini no longer needs a specific manager
226 - refactoring underway towards more flexible/generic architecture
227
228 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
229 - Unicode-friendliness for user names with accents/special chars.
230 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
231 - CreaetSliver no longer fails for users that have a capital letter in their URN.
232 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
233 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
234 - Fix bugs and missing imports     
235  
236
237 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
238 - new method record.get_field for sface
239
240 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
241 - new option -c to sfa-nuke-plc.py
242 - CreateSliver fixed for admin-only slice tags
243
244 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
245 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
246 - Fixed holes in certificate verification logic.
247 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
248 - Added 'boot_state' as an attribute of the node element in SFA rspec.
249 - Non authority certificates are marked as CA:FALSE.
250
251 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
252 - fix typo in sfa-1.0-31 tag.
253 - added CreateGid() Registry interface method.
254
255 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
256 - fix typo in sfa-1.0-30 tag
257
258 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
259 - Declare namespace and schema location in the credential.
260 - Fix bug that prevetend connections from timing out.
261 - Fix slice delegation.
262 - Add statistics to slicemaanger listresources/createsliver rspec.
263 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
264   of days a user can extend their slice expiration.
265 - CA certs are only issued to objects of type authority
266    
267 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
268 - tag 1.0-28 was broken due to typo in the changelog
269 - new class sfa/util/httpsProtocol.py that supports timeouts
270
271 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
272 - Resolved issue that caused sfa hold onto idle db connections.
273 - Fix bug that caused the registry to use the wrong type of credential.
274 - Support authority+sm type.
275 - Fix rspec merging bugs.
276 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
277 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
278  planetlab hosted initscripts using the <planetlab:initscript> tag  
279 - Can now handle extraneous whitespace in the rspec without failing.   
280  
281 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
282 - ProtoGENI v2 RSpec updates.
283 - Convert expiration timestamps with timezone info in credentials to utc.
284 - Fixed redundant logging issue. 
285 - Improved SliceManager and SFI client logging.
286 - Support aggregates that don't support the optional 'call_id' argument. 
287 - Only call get_trusted_certs() at aggreage interfaces that support the call.
288 - CreateSliver() now handles MyPLC slice attributes/tags.
289 - Cache now supports persistence.
290 - Hide whitelisted nodes.
291
292 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
293 - fixed issues with sup authority signing
294 - fixed bugs in remove_slivers and SliverStatus
295
296 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
297 - fix typo that prevented aggregates from operating properly
298
299 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
300 - load trusted certs into ssl context prior to handshake
301 - client's logfile lives in ~/.sfi/sfi.log
302
303 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
304 - includes a change on passphrases that was intended in 1.0-22
305
306 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
307 - Added support for ProtoGENI RSpec v2
308  
309 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
310 - stable sfascan
311 - fix in initscript, *ENABLED tags in config now taken into account
312
313 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
314 - some commits had not been pushed in tag 19
315
316 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
317 - GetVersion should now report full URLs with path
318 - scansfa has nicer output and new syntax (entry URLs as args and not options)
319 - dos2unix'ed flash policy pill
320
321 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
322 - fix packaging again for f8
323
324 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
325 - fix packaging (apparently broken in 1.0-16)
326 - first working version of sfascan
327 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
328 - deprecated the sfa_geni_aggregate config category
329
330 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
331 - Fix build problem
332 - First version of SFA scanner
333
334 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
335 - Add support for Flash clients using flashpolicy
336 - Fix problems with tag handling in RSpec
337
338 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
339 - Modifications to the Eucalyptus Aggregate Manager
340 - Fixes for VINI RSpec
341 - Fix tag handling for PL RSpec
342 - Fix XML Schema ordering for <urn> element
343
344 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
345 - just set x509 version to 2
346
347 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
348 - added urn to the node area in rspecs
349 - conversion to urn now exports fqdn
350 - sfa-import-plc.py now creates a unique registry record for each SFA interface
351
352 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
353 - undo broken attempt for python-2.7
354
355 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
356 - SMs avoid duplicates for when call graph has dags;
357 - just based on network's name, when a duplicate occurs, one is just dropped
358 - does not try to merge/aggregate 2 networks
359 - also reviewed logging with the hope to fix the sfa startup msg:
360 - TypeError: not all arguments converted during string formatting
361
362 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
363 - verify credentials against xsd schema
364 - Fix SM to SM communication
365 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
366 - new setting session_key_path
367
368 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
369 - fix registry credential regeneration and handle expiration
370 - support for setting slice tags (min_role=user)
371 - client can display its own version: sfi.py version --local
372 - GetVersion to provide urn in addition to hrn
373 - more code uses plxrn vs previous helper functions
374 - import replaces '+' in email addresses with '_'
375
376 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
377 - fix GetVersion code_tag and add code_url
378
379 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
380 - extend GetVersion towards minimum federation introspection, and expose local tag
381
382 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
383 - fixed some legacy issues (list vs List)
384 - deprecated sfa.util.namespace for xrn and plxrn
385 - unit tests ship as the sfa-tests rpm
386
387 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
388 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
389 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
390 - hrn-urn translations tweaked
391 - fixed 'service sfa status'
392 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
393 - started to repair sfadump - although not usable yet
394 - trust objects now have dump_string method that dump() actually prints
395 - unit tests under review
396 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
397 - binaries now support -v or -vv to increase loglevel
398 - trashed obsolete sfa.util.client
399
400 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
401 - various bugfixes and cleanup, improved/harmonized logging
402
403 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
404 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
405   to avoid returning a PLCAPI exception that might confuse users.
406 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
407 - fix build errors.  
408
409 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
410 - (Architecture) Credential format changed to match ProtoGENI xml format
411 - (Architecture) All interfaces export a new set of methods that are compatible
412    with the ProtoGeni Aggregate spec. These new methods are considered a 
413    replacement  for the pervious methods exported by the interfaces. All 
414    previous methods are still exported and work as normal, but they are 
415    considered deprecated and will not be supported in future releases.  
416 - (Architecture) SFI has been updated to use the new interface methods.
417 - (Architecture) Changed keyconvet implementation from c to python.
418 - (Architecture) Slice Manager now attempts looks for a delegated credential
419   provided by the client before using its own server credential.
420 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
421   This cache now exists only in memory and is cleared when service is restarted
422   or cache lifetime is exceeded.  
423 - (Performance) SliceManager sends request to Aggregates in parallel instead 
424   of sequentially.
425 - (Bug fix) SFA tickets now support the new rspec format.
426 - (Bug fix) SFI only uses cahced credential if they aren't expired.
427 - (Bug fix) Cerdential delegation modified to work with new credential format.
428 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
429   Aggregate instead of relaying through the Slice Manager.
430 - (Enhancement) Simplified caching. Accociated a global cache instance with
431   the api handler on every new server request, making it easier to access the 
432   cache and use in more general ways.     
433
434 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
435 - SfaServer now uses a pool of threads to handle requests concurrently
436 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
437 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
438 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
439 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
440 - Component manager does not install gid files if slice already has them  
441 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
442 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
443 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
444      
445 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
446 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
447 - - sfa-config-tty now has the same features like plc-config-tty
448 - - Contains code to support both urn and hrn
449 - - Cleaned up request_hash related stuff
450 - - SM, AM and Registry code is organized under respective managers
451 - - Site and Slice synchronization across federated aggregates
452 - - Script to generate sfa_component_config
453
454 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
455 - sfa-config-tty now has the same features like plc-config-tty
456 - Contains code to support both urn and hrn
457 - Cleaned up request_hash related stuff
458 - SM, AM and Registry code is organized under respective managers
459 - Slice synchronization across federated aggregates
460 - some bugs are fixed
461
462 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
463 - checkpoint with fewer mentions of geni
464
465 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
466 - checkpointing
467 - this is believed to pass the tests; among other things:
468 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
469
470 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
471 - This tag includes:
472 - - Sfatables
473 - - Preliminary version of hash based authentication
474 - - Initial code for Component Manager
475 - - Authority structure is moved to /var/lib/sfa/
476 - - some bug-fixes
477
478 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
479 - Create_slice and get_resources methods are connected to sfatables.
480 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
481
482 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
483 - Bug fix on update and remove_peer_object methods
484 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
485
486 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
487 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
488
489 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
490 - compatibility with RefreshPeer
491 - incremental mechanism for importing PLC records into SFA tables
492 - unified single database (still inside the underlying PLC db postgresql server)
493 - includes/improves call traceability and logging features
494 - several bug fixes
495
496 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
497 - added libxslt-python dependency
498
499 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
500 - unified single SFA database in the PLC-DB
501 - upcalls from  PLCAPI to SFA methods
502 - SFA call traceability and logging features
503 - many bug fixes
504 - includes first/rough version of sfatables for policy implementation
505
506 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
507 - snapshot after the GEC5 demo
508 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
509
510 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
511 - snapshot july 15 - has gone through superficial manual testing
512 - hopefully a good basis for gec5 demo
513 - multi-dir sfi client tested as well
514
515 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
516 - rename geniwrapper.spec into sfa.spec
517
518 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
519 - clean up in xmlrpc/soap, --protocol option to chose between both
520 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
521 - hopefully more helpful context in case of crashes when importing
522 - bugfixes for using only /etc/sfa for site-dep files
523 - bugfixes in wsdl generation
524
525 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
526 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
527 - config variables in sfa_config now start with SFA_ and not GENI_
528 - config.py can be loaded even with no config present
529
530 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
531 - first step for cleanup and reorganization
532 - mass-renaming from geni to sfa (some are still needed)
533 - sfa/trust implements the security architecture
534
535 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
536 - snapshot for reproducible builds
537
538 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
539 - snapshot for the convenience of alpha users
540
541 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
542 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
543
544 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
545 - ongoing work - snapshot for 4.3-rc9
546
547 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
548 - various fixes
549
550 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
551 - bugfixes - still a work in progress
552
553 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
554 - initial package
555
556
557 %define module_current_branch 0.2