proper fault string to user whose account is disabled, but attempts to extract user...
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 10
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35
36 # python 2.5 has uuid module added, for python 2.4 we still need it.
37 # we can't really check for if we can load uuid as a python module,
38 # it'll be installed by "devel.pkgs". we have the epel repository so
39 # python-uuid will be provided. but we can test for the python
40 # version.
41 %define has_py24 %(`python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $?`)
42 %if has_py24
43 Requires: python-uuid
44 %endif
45
46 %package cm
47 Summary: the SFA wrapper around MyPLC's NodeManager
48 Group: Applications/System
49 Requires: sfa
50 Requires: pyOpenSSL >= 0.6
51
52 %package plc
53 Summary: the SFA wrapper arounf MyPLC
54 Group: Applications/System
55 Requires: sfa
56 Requires: python-psycopg2
57 Requires: myplc-config
58 Requires: pyOpenSSL >= 0.7
59
60 %package client
61 Summary: the SFA experimenter-side CLI
62 Group: Applications/System
63 Requires: sfa
64 Requires: pyOpenSSL >= 0.7
65
66 %package sfatables
67 Summary: sfatables policy tool for SFA
68 Group: Applications/System
69 Requires: sfa
70
71 %description
72 This package provides the python libraries that the SFA implementation requires
73
74 %description cm
75 This package implements the SFA interface which serves as a layer
76 between the existing PlanetLab NodeManager interfaces and the SFA API.
77  
78 %description plc
79 This package implements the SFA interface which serves as a layer
80 between the existing PlanetLab interfaces and the SFA API.
81
82 %description client
83 This package provides the client side of the SFA API, in particular
84 sfi.py, together with other utilities.
85
86 %description sfatables
87 sfatables is a tool for defining access and admission control policies
88 in an SFA network, in much the same way as iptables is for ip
89 networks. This is the command line interface to manage sfatables
90
91 %prep
92 %setup -q
93
94 %build
95 make
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 make install DESTDIR="$RPM_BUILD_ROOT"
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 # sfa and sfatables depend each other.
106 /etc/sfatables/*
107 %{python_sitelib}/*
108 /usr/bin/keyconvert
109 /var/www/html/wsdl/*.wsdl
110
111 %files cm
112 /etc/init.d/sfa_cm
113 # cron jobs here 
114
115 %files plc
116 %defattr(-,root,root)
117 %config /etc/sfa/default_config.xml
118 %config (noreplace) /etc/sfa/aggregates.xml
119 %config (noreplace) /etc/sfa/registries.xml
120 /etc/init.d/sfa
121 %{_bindir}/sfa-config-tty
122 %{_bindir}/sfa-import-plc.py*
123 %{_bindir}/sfa-clean-peer-records.py*
124 %{_bindir}/sfa-nuke-plc.py*
125 %{_bindir}/sfa-server.py*
126 %{_bindir}/gen-sfa-cm-config.py*
127
128 %files client
129 %config (noreplace) /etc/sfa/sfi_config
130 %{_bindir}/sfi.py*
131 %{_bindir}/getNodes.py*
132 %{_bindir}/getRecord.py*
133 %{_bindir}/setRecord.py*
134 %{_bindir}/sfadump.py*
135
136 %files sfatables
137 %{_bindir}/sfatables
138
139 %pre plc
140 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
141
142 %pre cm
143 [ -f %{_sysconfdir}/init.d/sfacm ] && service sfacm stop ||:
144
145 %post plc
146 chkconfig --add sfa
147
148 %post cm
149 chkconfig --add sfacm
150 %changelog
151 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
152 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
153 - - sfa-config-tty now has the same features like plc-config-tty
154 - - Contains code to support both urn and hrn
155 - - Cleaned up request_hash related stuff
156 - - SM, AM and Registry code is organized under respective managers
157 - - Site and Slice synchronization across federated aggregates
158 - - Script to generate sfa_component_config
159
160 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
161 - sfa-config-tty now has the same features like plc-config-tty
162 - Contains code to support both urn and hrn
163 - Cleaned up request_hash related stuff
164 - SM, AM and Registry code is organized under respective managers
165 - Slice synchronization across federated aggregates
166 - some bugs are fixed
167
168 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
169 - checkpoint with fewer mentions of geni
170
171 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
172 - checkpointing
173 - this is believed to pass the tests; among other things:
174 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
175
176 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
177 - This tag includes:
178 - - Sfatables
179 - - Preliminary version of hash based authentication
180 - - Initial code for Component Manager
181 - - Authority structure is moved to /var/lib/sfa/
182 - - some bug-fixes
183
184 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
185 - Create_slice and get_resources methods are connected to sfatables.
186 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
187
188 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
189 - Bug fix on update and remove_peer_object methods
190 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
191
192 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
193 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
194
195 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
196 - compatibility with RefreshPeer
197 - incremental mechanism for importing PLC records into SFA tables
198 - unified single database (still inside the underlying PLC db postgresql server)
199 - includes/improves call traceability and logging features
200 - several bug fixes
201
202 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
203 - added libxslt-python dependency
204
205 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
206 - unified single SFA database in the PLC-DB
207 - upcalls from  PLCAPI to SFA methods
208 - SFA call traceability and logging features
209 - many bug fixes
210 - includes first/rough version of sfatables for policy implementation
211
212 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
213 - snapshot after the GEC5 demo
214 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
215
216 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
217 - snapshot july 15 - has gone through superficial manual testing
218 - hopefully a good basis for gec5 demo
219 - multi-dir sfi client tested as well
220
221 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
222 - rename geniwrapper.spec into sfa.spec
223
224 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
225 - clean up in xmlrpc/soap, --protocol option to chose between both
226 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
227 - hopefully more helpful context in case of crashes when importing
228 - bugfixes for using only /etc/sfa for site-dep files
229 - bugfixes in wsdl generation
230
231 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
232 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
233 - config variables in sfa_config now start with SFA_ and not GENI_
234 - config.py can be loaded even with no config present
235
236 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
237 - first step for cleanup and reorganization
238 - mass-renaming from geni to sfa (some are still needed)
239 - sfa/trust implements the security architecture
240
241 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
242 - snapshot for reproducible builds
243
244 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
245 - snapshot for the convenience of alpha users
246
247 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
248 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
249
250 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
251 - ongoing work - snapshot for 4.3-rc9
252
253 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
254 - various fixes
255
256 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
257 - bugfixes - still a work in progress
258
259 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
260 - initial package
261
262
263 %define module_current_branch 0.2