Setting tag sfa-1.0-6
[sfa.git] / sfa.spec
1
2 %define url $URL$
3
4 %define name sfa
5 %define version 1.0
6 %define taglevel 6
7
8 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
9 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
10 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
11
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 Source0: %{name}-%{version}.tar.bz2
16 License: GPL
17 Group: Applications/System
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %(echo %{url} | cut -d ' ' -f 2)
24 Summary: the SFA python libraries
25 Group: Applications/System
26
27 BuildRequires: make
28 Requires: python >= 2.5
29 Requires: m2crypto
30 Requires: xmlsec1-openssl-devel
31 Requires: libxslt-python
32 Requires: python-ZSI
33 # xmlbuilder depends on  lxml
34 Requires: python-lxml
35 Requires: python-setuptools
36 Requires: python-dateutil
37  
38 # python 2.5 has uuid module added, for python 2.4 we still need it.
39 # we can't really check for if we can load uuid as a python module,
40 # it'll be installed by "devel.pkgs". we have the epel repository so
41 # python-uuid will be provided. but we can test for the python
42 # version.
43 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
44 # %if %has_py24
45 #
46 # this also didn't work very well. I'll just check for distroname - baris
47 #%if %{distroname} == "centos5"
48 #Requires: python-uuid
49 #%endif
50
51 %package cm
52 Summary: the SFA wrapper around MyPLC NodeManager
53 Group: Applications/System
54 Requires: sfa
55 Requires: pyOpenSSL >= 0.6
56
57 %package plc
58 Summary: the SFA wrapper arounf MyPLC
59 Group: Applications/System
60 Requires: sfa
61 Requires: python-psycopg2
62 Requires: myplc-config
63 Requires: pyOpenSSL >= 0.7
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %Package tests
77 Summary: unit tests suite for SFA
78 Group: Applications/System
79 Requires: sfa
80
81 %description
82 This package provides the python libraries for the PlanetLab implementation of SFA
83
84 %description cm
85 This package implements the SFA interface which serves as a layer
86 between the existing PlanetLab NodeManager interfaces and the SFA API.
87  
88 %description plc
89 This package implements the SFA interface which serves as a layer
90 between the existing PlanetLab interfaces and the SFA API.
91
92 %description client
93 This package provides the client side of the SFA API, in particular
94 sfi.py, together with other utilities.
95
96 %description sfatables
97 sfatables is a tool for defining access and admission control policies
98 in an SFA network, in much the same way as iptables is for ip
99 networks. This is the command line interface to manage sfatables
100
101 %description tests
102 Provides some binary unit tests in /usr/share/sfa/tests
103
104 %prep
105 %setup -q
106
107 %build
108 make VERSION=%{version}-%{taglevel}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 make install VERSION=%{version}-%{taglevel} DESTDIR="$RPM_BUILD_ROOT"
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 # sfa and sfatables depend each other.
119 %{_bindir}/sfa-server.py*
120 /etc/sfatables/*
121 %{python_sitelib}/*
122 %{_bindir}/keyconvert.py*
123 /var/www/html/wsdl/*.wsdl
124
125 %files cm
126 /etc/init.d/sfa-cm
127 %{_bindir}/sfa_component_setup.py*
128 # cron jobs here 
129
130 %files plc
131 %defattr(-,root,root)
132 %config /etc/sfa/default_config.xml
133 %config (noreplace) /etc/sfa/aggregates.xml
134 %config (noreplace) /etc/sfa/registries.xml
135 /etc/init.d/sfa
136 /etc/sfa/pl.rng
137 %{_bindir}/sfa-config-tty
138 %{_bindir}/sfa-import-plc.py*
139 %{_bindir}/sfa-clean-peer-records.py*
140 %{_bindir}/sfa-nuke-plc.py*
141 %{_bindir}/gen-sfa-cm-config.py*
142 %{_bindir}/sfa-ca.py*
143
144 %files client
145 %config (noreplace) /etc/sfa/sfi_config
146 %{_bindir}/sfi*
147 %{_bindir}/getNodes.py*
148 %{_bindir}/getRecord.py*
149 %{_bindir}/setRecord.py*
150 %{_bindir}/sfadump.py*
151
152 %files sfatables
153 %{_bindir}/sfatables
154
155 %files tests
156 %{_datadir}/sfa/tests
157
158 ### sfa-plc installs the 'sfa' service
159 %post plc
160 chkconfig --add sfa
161
162 %preun plc
163 if [ "$1" = 0 ] ; then
164   /sbin/service sfa stop || :
165   /sbin/chkconfig --del sfa || :
166 fi
167
168 %postun plc
169 [ "$1" -ge "1" ] && service sfa restart
170
171 ### sfa-cm installs the 'sfa-cm' service
172 %post cm
173 chkconfig --add sfa-cm
174
175 %preun cm
176 if [ "$1" = 0 ] ; then
177    /sbin/service sfa-cm stop || :
178    /sbin/chkconfig --del sfa-cm || :
179 fi
180
181 %postun cm
182 [ "$1" -ge "1" ] && service sfa-cm restart
183
184
185 %changelog
186 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
187 - extend GetVersion towards minimum federation introspection, and expose local tag
188
189 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
190 - fixed some legacy issues (list vs List)
191 - deprecated sfa.util.namespace for xrn and plxrn
192 - unit tests ship as the sfa-tests rpm
193
194 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
195 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
196 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
197 - hrn-urn translations tweaked
198 - fixed 'service sfa status'
199 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
200 - started to repair sfadump - although not usable yet
201 - trust objects now have dump_string method that dump() actually prints
202 - unit tests under review
203 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
204 - binaries now support -v or -vv to increase loglevel
205 - trashed obsolete sfa.util.client
206
207 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
208 - various bugfixes and cleanup, improved/harmonized logging
209
210 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
211 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
212   to avoid returning a PLCAPI exception that might confuse users.
213 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
214 - fix build errors.  
215
216 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
217 - (Architecture) Credential format changed to match ProtoGENI xml format
218 - (Architecture) All interfaces export a new set of methods that are compatible
219    with the ProtoGeni Aggregate spec. These new methods are considered a 
220    replacement  for the pervious methods exported by the interfaces. All 
221    previous methods are still exported and work as normal, but they are 
222    considered deprecated and will not be supported in future releases.  
223 - (Architecture) SFI has been updated to use the new interface methods.
224 - (Architecture) Changed keyconvet implementation from c to python.
225 - (Architecture) Slice Manager now attempts looks for a delegated credential
226   provided by the client before using its own server credential.
227 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
228   This cache now exists only in memory and is cleared when service is restarted
229   or cache lifetime is exceeded.  
230 - (Performance) SliceManager sends request to Aggregates in parallel instead 
231   of sequentially.
232 - (Bug fix) SFA tickets now support the new rspec format.
233 - (Bug fix) SFI only uses cahced credential if they aren't expired.
234 - (Bug fix) Cerdential delegation modified to work with new credential format.
235 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
236   Aggregate instead of relaying through the Slice Manager.
237 - (Enhancement) Simplified caching. Accociated a global cache instance with
238   the api handler on every new server request, making it easier to access the 
239   cache and use in more general ways.     
240
241 %changelog
242 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
243 - extend GetVersion towards minimum federation introspection, and expose local tag
244
245 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
246 - fixed some legacy issues (list vs List)
247 - deprecated sfa.util.namespace for xrn and plxrn
248 - unit tests ship as the sfa-tests rpm
249
250 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
251 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
252 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
253 - hrn-urn translations tweaked
254 - fixed 'service sfa status'
255 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
256 - started to repair sfadump - although not usable yet
257 - trust objects now have dump_string method that dump() actually prints
258 - unit tests under review
259 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
260 - binaries now support -v or -vv to increase loglevel
261 - trashed obsolete sfa.util.client
262
263 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
264 - various bugfixes and cleanup, improved/harmonized logging
265
266 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
267 - SfaServer now uses a pool of threads to handle requests concurrently
268 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
269 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
270 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
271 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
272 - Component manager does not install gid files if slice already has them  
273 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
274 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
275 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
276      
277 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
278 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
279 - - sfa-config-tty now has the same features like plc-config-tty
280 - - Contains code to support both urn and hrn
281 - - Cleaned up request_hash related stuff
282 - - SM, AM and Registry code is organized under respective managers
283 - - Site and Slice synchronization across federated aggregates
284 - - Script to generate sfa_component_config
285
286 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
287 - sfa-config-tty now has the same features like plc-config-tty
288 - Contains code to support both urn and hrn
289 - Cleaned up request_hash related stuff
290 - SM, AM and Registry code is organized under respective managers
291 - Slice synchronization across federated aggregates
292 - some bugs are fixed
293
294 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
295 - checkpoint with fewer mentions of geni
296
297 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
298 - checkpointing
299 - this is believed to pass the tests; among other things:
300 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
301
302 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
303 - This tag includes:
304 - - Sfatables
305 - - Preliminary version of hash based authentication
306 - - Initial code for Component Manager
307 - - Authority structure is moved to /var/lib/sfa/
308 - - some bug-fixes
309
310 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
311 - Create_slice and get_resources methods are connected to sfatables.
312 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
313
314 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
315 - Bug fix on update and remove_peer_object methods
316 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
317
318 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
319 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
320
321 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
322 - compatibility with RefreshPeer
323 - incremental mechanism for importing PLC records into SFA tables
324 - unified single database (still inside the underlying PLC db postgresql server)
325 - includes/improves call traceability and logging features
326 - several bug fixes
327
328 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
329 - added libxslt-python dependency
330
331 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
332 - unified single SFA database in the PLC-DB
333 - upcalls from  PLCAPI to SFA methods
334 - SFA call traceability and logging features
335 - many bug fixes
336 - includes first/rough version of sfatables for policy implementation
337
338 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
339 - snapshot after the GEC5 demo
340 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
341
342 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
343 - snapshot july 15 - has gone through superficial manual testing
344 - hopefully a good basis for gec5 demo
345 - multi-dir sfi client tested as well
346
347 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
348 - rename geniwrapper.spec into sfa.spec
349
350 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
351 - clean up in xmlrpc/soap, --protocol option to chose between both
352 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
353 - hopefully more helpful context in case of crashes when importing
354 - bugfixes for using only /etc/sfa for site-dep files
355 - bugfixes in wsdl generation
356
357 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
358 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
359 - config variables in sfa_config now start with SFA_ and not GENI_
360 - config.py can be loaded even with no config present
361
362 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
363 - first step for cleanup and reorganization
364 - mass-renaming from geni to sfa (some are still needed)
365 - sfa/trust implements the security architecture
366
367 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
368 - snapshot for reproducible builds
369
370 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
371 - snapshot for the convenience of alpha users
372
373 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
374 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
375
376 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
377 - ongoing work - snapshot for 4.3-rc9
378
379 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
380 - various fixes
381
382 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
383 - bugfixes - still a work in progress
384
385 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
386 - initial package
387
388
389 %define module_current_branch 0.2