typo in changelog -g prevents from building
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 28
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart || :
197
198 %changelog
199 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
200 - Resolved issue that caused sfa hold onto idle db connections.
201 - Fix bug that caused the registry to use the wrong type of credential.
202 - Support authority+sm type.
203 - Fix rspec merging bugs.
204 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
205 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
206  planetlab hosted initscripts using the <planetlab:initscript> tag  
207 - Can now handle extraneous whitespace in the rspec without failing.   
208  
209 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
210 - ProtoGENI v2 RSpec updates.
211 - Convert expiration timestamps with timezone info in credentials to utc.
212 - Fixed redundant logging issue. 
213 - Improved SliceManager and SFI client logging.
214 - Support aggregates that don't support the optional 'call_id' argument. 
215 - Only call get_trusted_certs() at aggreage interfaces that support the call.
216 - CreateSliver() now handles MyPLC slice attributes/tags.
217 - Cache now supports persistence.
218 - Hide whitelisted nodes.
219
220 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
221 - fixed issues with sup authority signing
222 - fixed bugs in remove_slivers and SliverStatus
223
224 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
225 - fix typo that prevented aggregates from operating properly
226
227 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
228 - load trusted certs into ssl context prior to handshake
229 - client's logfile lives in ~/.sfi/sfi.log
230
231 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
232 - includes a change on passphrases that was intended in 1.0-22
233
234 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
235 - Added support for ProtoGENI RSpec v2
236  
237 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
238 - stable sfascan
239 - fix in initscript, *ENABLED tags in config now taken into account
240
241 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
242 - some commits had not been pushed in tag 19
243
244 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
245 - GetVersion should now report full URLs with path
246 - scansfa has nicer output and new syntax (entry URLs as args and not options)
247 - dos2unix'ed flash policy pill
248
249 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
250 - fix packaging again for f8
251
252 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
253 - fix packaging (apparently broken in 1.0-16)
254 - first working version of sfascan
255 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
256 - deprecated the sfa_geni_aggregate config category
257
258 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
259 - Fix build problem
260 - First version of SFA scanner
261
262 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
263 - Add support for Flash clients using flashpolicy
264 - Fix problems with tag handling in RSpec
265
266 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
267 - Modifications to the Eucalyptus Aggregate Manager
268 - Fixes for VINI RSpec
269 - Fix tag handling for PL RSpec
270 - Fix XML Schema ordering for <urn> element
271
272 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
273 - just set x509 version to 2
274
275 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
276 - added urn to the node area in rspecs
277 - conversion to urn now exports fqdn
278 - sfa-import-plc.py now creates a unique registry record for each SFA interface
279
280 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
281 - undo broken attempt for python-2.7
282
283 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
284 - SMs avoid duplicates for when call graph has dags;
285 - just based on network's name, when a duplicate occurs, one is just dropped
286 - does not try to merge/aggregate 2 networks
287 - also reviewed logging with the hope to fix the sfa startup msg:
288 - TypeError: not all arguments converted during string formatting
289
290 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
291 - verify credentials against xsd schema
292 - Fix SM to SM communication
293 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
294 - new setting session_key_path
295
296 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
297 - fix registry credential regeneration and handle expiration
298 - support for setting slice tags (min_role=user)
299 - client can display its own version: sfi.py version --local
300 - GetVersion to provide urn in addition to hrn
301 - more code uses plxrn vs previous helper functions
302 - import replaces '+' in email addresses with '_'
303
304 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
305 - fix GetVersion code_tag and add code_url
306
307 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
308 - extend GetVersion towards minimum federation introspection, and expose local tag
309
310 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
311 - fixed some legacy issues (list vs List)
312 - deprecated sfa.util.namespace for xrn and plxrn
313 - unit tests ship as the sfa-tests rpm
314
315 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
316 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
317 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
318 - hrn-urn translations tweaked
319 - fixed 'service sfa status'
320 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
321 - started to repair sfadump - although not usable yet
322 - trust objects now have dump_string method that dump() actually prints
323 - unit tests under review
324 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
325 - binaries now support -v or -vv to increase loglevel
326 - trashed obsolete sfa.util.client
327
328 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
329 - various bugfixes and cleanup, improved/harmonized logging
330
331 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
332 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
333   to avoid returning a PLCAPI exception that might confuse users.
334 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
335 - fix build errors.  
336
337 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
338 - (Architecture) Credential format changed to match ProtoGENI xml format
339 - (Architecture) All interfaces export a new set of methods that are compatible
340    with the ProtoGeni Aggregate spec. These new methods are considered a 
341    replacement  for the pervious methods exported by the interfaces. All 
342    previous methods are still exported and work as normal, but they are 
343    considered deprecated and will not be supported in future releases.  
344 - (Architecture) SFI has been updated to use the new interface methods.
345 - (Architecture) Changed keyconvet implementation from c to python.
346 - (Architecture) Slice Manager now attempts looks for a delegated credential
347   provided by the client before using its own server credential.
348 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
349   This cache now exists only in memory and is cleared when service is restarted
350   or cache lifetime is exceeded.  
351 - (Performance) SliceManager sends request to Aggregates in parallel instead 
352   of sequentially.
353 - (Bug fix) SFA tickets now support the new rspec format.
354 - (Bug fix) SFI only uses cahced credential if they aren't expired.
355 - (Bug fix) Cerdential delegation modified to work with new credential format.
356 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
357   Aggregate instead of relaying through the Slice Manager.
358 - (Enhancement) Simplified caching. Accociated a global cache instance with
359   the api handler on every new server request, making it easier to access the 
360   cache and use in more general ways.     
361
362 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
363 - SfaServer now uses a pool of threads to handle requests concurrently
364 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
365 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
366 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
367 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
368 - Component manager does not install gid files if slice already has them  
369 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
370 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
371 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
372      
373 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
374 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
375 - - sfa-config-tty now has the same features like plc-config-tty
376 - - Contains code to support both urn and hrn
377 - - Cleaned up request_hash related stuff
378 - - SM, AM and Registry code is organized under respective managers
379 - - Site and Slice synchronization across federated aggregates
380 - - Script to generate sfa_component_config
381
382 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
383 - sfa-config-tty now has the same features like plc-config-tty
384 - Contains code to support both urn and hrn
385 - Cleaned up request_hash related stuff
386 - SM, AM and Registry code is organized under respective managers
387 - Slice synchronization across federated aggregates
388 - some bugs are fixed
389
390 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
391 - checkpoint with fewer mentions of geni
392
393 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
394 - checkpointing
395 - this is believed to pass the tests; among other things:
396 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
397
398 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
399 - This tag includes:
400 - - Sfatables
401 - - Preliminary version of hash based authentication
402 - - Initial code for Component Manager
403 - - Authority structure is moved to /var/lib/sfa/
404 - - some bug-fixes
405
406 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
407 - Create_slice and get_resources methods are connected to sfatables.
408 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
409
410 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
411 - Bug fix on update and remove_peer_object methods
412 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
413
414 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
415 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
416
417 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
418 - compatibility with RefreshPeer
419 - incremental mechanism for importing PLC records into SFA tables
420 - unified single database (still inside the underlying PLC db postgresql server)
421 - includes/improves call traceability and logging features
422 - several bug fixes
423
424 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
425 - added libxslt-python dependency
426
427 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
428 - unified single SFA database in the PLC-DB
429 - upcalls from  PLCAPI to SFA methods
430 - SFA call traceability and logging features
431 - many bug fixes
432 - includes first/rough version of sfatables for policy implementation
433
434 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
435 - snapshot after the GEC5 demo
436 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
437
438 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
439 - snapshot july 15 - has gone through superficial manual testing
440 - hopefully a good basis for gec5 demo
441 - multi-dir sfi client tested as well
442
443 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
444 - rename geniwrapper.spec into sfa.spec
445
446 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
447 - clean up in xmlrpc/soap, --protocol option to chose between both
448 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
449 - hopefully more helpful context in case of crashes when importing
450 - bugfixes for using only /etc/sfa for site-dep files
451 - bugfixes in wsdl generation
452
453 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
454 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
455 - config variables in sfa_config now start with SFA_ and not GENI_
456 - config.py can be loaded even with no config present
457
458 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
459 - first step for cleanup and reorganization
460 - mass-renaming from geni to sfa (some are still needed)
461 - sfa/trust implements the security architecture
462
463 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
464 - snapshot for reproducible builds
465
466 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
467 - snapshot for the convenience of alpha users
468
469 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
470 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
471
472 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
473 - ongoing work - snapshot for 4.3-rc9
474
475 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
476 - various fixes
477
478 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
479 - bugfixes - still a work in progress
480
481 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
482 - initial package
483
484
485 %define module_current_branch 0.2