Merge branch 'master' into senslab2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
228 - bugfix: 'geni_api' should be in the top level struct, not the code struct
229 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
230           output returned by the Aggregate Manager.
231 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
232 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
233 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
234           there is extra whitespace in the schemaLocation field.
235 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
236           advertisement rspecs.
237 - bugfix: <login> RSpec element should contain the 'username' attribute.
238 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
239  
240 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
241 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
242   exit when it encountered a user with an invalid public key.
243 - server: imporved logging in sfa-import-plc.py
244  
245 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
246 - bugfix: Fixed appending public keys in CreateSliver
247 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
248 - client: -c --current option allows users to request the current/uncached rspec.
249 - server: Added 'geni_api_versions' field to GetVersion() output.
250 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
251    
252 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
253 - bugfix: sfi was not sending call_id with ListResources to v2 servers
254 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
255 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
256
257 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
258 - client: sfi -a / -p deprecated (use -s instead)
259 - client: sfi cleaned up
260 - client: sfi has backward support for APIv1 aggregates again
261 - server: only APIv2 is supported and should be rather strict
262 - server: settings for turning on/off caching in sm or am
263 - server: plc-dependant code has moved from aggregate to pldriver
264 - server: driver interface extended accordingly
265
266 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
267 - screwed up previous tag
268
269 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
270 - client side revisited with a bootstrap library
271 - client side has a new source layout
272 - various (nasty) bug fixes wrt options and call_id
273
274 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
275 - various fixes in rspecs for sfav1&slice tags
276 - uses 'geni_rspec_version' and not just 'rspec_version'
277 - example flavour for the max testbed
278 - embryo for an sfa client library
279 - topology.py moved into plc
280 - sql: table is named records; record_types are enforced
281 - sql: table creation cleaned up
282
283 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
284 - cleaned up all references to SFA_*_TYPE in config
285 - enable cache at the aggregate by default
286 - registry now uses the driver in a sensible way (see managers/driver.py)
287 - slice manager supports sfav1/pgv2 neighbours
288 - get_key renamed into get_key_from_incoming_ip
289 - new sfa.storage module for record/table and all db-related stuff
290 - db schema in sfa.storage.sfa.sql
291 - init.d and cron.d move one step up
292 - cleaned up rspec/ directory
293 - add deps to pyopenssl and myplc-config
294 - start support for new API (return value)
295 - plc.remoteshell removed, use plshell instead
296 - plshell uses a 'capability' auth method whenever possible
297 - various tweaks in rspec elements
298 - made dependency on sfatables softer
299
300 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
301 - sfa should now be started *before* the initial import
302 - sfa to use its own database (default sfa) - can run without myplc
303 - server calls support optional 'options'
304 - client sends options in argument when needed
305 - fix infinite getattr recursion in elements/element.py
306 - error codes in line with geni
307
308 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
309 - fixed links and attributes in rspecs
310 - minor cleanup in the API methods, and more consistent names in manager methods
311
312 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
313 - ongoing refoactoring towards more genericity
314 - passes tests again although known issues remain with attributes/tags
315
316 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
317 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
318 - improvements in the pgv2 rspecs
319 - driver separated from api
320 - code starts moving around where it belongs
321 - sfascan caches getversion across invokations
322 - vini topology extracted as a config file
323
324 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
325 - first support for protogeni rspecs is working
326 - vini no longer needs a specific manager
327 - refactoring underway towards more flexible/generic architecture
328
329 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
330 - Unicode-friendliness for user names with accents/special chars.
331 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
332 - CreaetSliver no longer fails for users that have a capital letter in their URN.
333 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
334 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
335 - Fix bugs and missing imports     
336  
337
338 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
339 - new method record.get_field for sface
340
341 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
342 - new option -c to sfa-nuke-plc.py
343 - CreateSliver fixed for admin-only slice tags
344
345 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
346 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
347 - Fixed holes in certificate verification logic.
348 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
349 - Added 'boot_state' as an attribute of the node element in SFA rspec.
350 - Non authority certificates are marked as CA:FALSE.
351
352 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
353 - fix typo in sfa-1.0-31 tag.
354 - added CreateGid() Registry interface method.
355
356 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
357 - fix typo in sfa-1.0-30 tag
358
359 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
360 - Declare namespace and schema location in the credential.
361 - Fix bug that prevetend connections from timing out.
362 - Fix slice delegation.
363 - Add statistics to slicemaanger listresources/createsliver rspec.
364 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
365   of days a user can extend their slice expiration.
366 - CA certs are only issued to objects of type authority
367    
368 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
369 - tag 1.0-28 was broken due to typo in the changelog
370 - new class sfa/util/httpsProtocol.py that supports timeouts
371
372 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
373 - Resolved issue that caused sfa hold onto idle db connections.
374 - Fix bug that caused the registry to use the wrong type of credential.
375 - Support authority+sm type.
376 - Fix rspec merging bugs.
377 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
378 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
379  planetlab hosted initscripts using the <planetlab:initscript> tag  
380 - Can now handle extraneous whitespace in the rspec without failing.   
381  
382 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
383 - ProtoGENI v2 RSpec updates.
384 - Convert expiration timestamps with timezone info in credentials to utc.
385 - Fixed redundant logging issue. 
386 - Improved SliceManager and SFI client logging.
387 - Support aggregates that don't support the optional 'call_id' argument. 
388 - Only call get_trusted_certs() at aggreage interfaces that support the call.
389 - CreateSliver() now handles MyPLC slice attributes/tags.
390 - Cache now supports persistence.
391 - Hide whitelisted nodes.
392
393 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
394 - fixed issues with sup authority signing
395 - fixed bugs in remove_slivers and SliverStatus
396
397 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
398 - fix typo that prevented aggregates from operating properly
399
400 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
401 - load trusted certs into ssl context prior to handshake
402 - client's logfile lives in ~/.sfi/sfi.log
403
404 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
405 - includes a change on passphrases that was intended in 1.0-22
406
407 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
408 - Added support for ProtoGENI RSpec v2
409  
410 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
411 - stable sfascan
412 - fix in initscript, *ENABLED tags in config now taken into account
413
414 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
415 - some commits had not been pushed in tag 19
416
417 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
418 - GetVersion should now report full URLs with path
419 - scansfa has nicer output and new syntax (entry URLs as args and not options)
420 - dos2unix'ed flash policy pill
421
422 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
423 - fix packaging again for f8
424
425 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
426 - fix packaging (apparently broken in 1.0-16)
427 - first working version of sfascan
428 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
429 - deprecated the sfa_geni_aggregate config category
430
431 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
432 - Fix build problem
433 - First version of SFA scanner
434
435 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
436 - Add support for Flash clients using flashpolicy
437 - Fix problems with tag handling in RSpec
438
439 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
440 - Modifications to the Eucalyptus Aggregate Manager
441 - Fixes for VINI RSpec
442 - Fix tag handling for PL RSpec
443 - Fix XML Schema ordering for <urn> element
444
445 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
446 - just set x509 version to 2
447
448 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
449 - added urn to the node area in rspecs
450 - conversion to urn now exports fqdn
451 - sfa-import-plc.py now creates a unique registry record for each SFA interface
452
453 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
454 - undo broken attempt for python-2.7
455
456 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
457 - SMs avoid duplicates for when call graph has dags;
458 - just based on network's name, when a duplicate occurs, one is just dropped
459 - does not try to merge/aggregate 2 networks
460 - also reviewed logging with the hope to fix the sfa startup msg:
461 - TypeError: not all arguments converted during string formatting
462
463 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
464 - verify credentials against xsd schema
465 - Fix SM to SM communication
466 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
467 - new setting session_key_path
468
469 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
470 - fix registry credential regeneration and handle expiration
471 - support for setting slice tags (min_role=user)
472 - client can display its own version: sfi.py version --local
473 - GetVersion to provide urn in addition to hrn
474 - more code uses plxrn vs previous helper functions
475 - import replaces '+' in email addresses with '_'
476
477 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
478 - fix GetVersion code_tag and add code_url
479
480 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
481 - extend GetVersion towards minimum federation introspection, and expose local tag
482
483 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
484 - fixed some legacy issues (list vs List)
485 - deprecated sfa.util.namespace for xrn and plxrn
486 - unit tests ship as the sfa-tests rpm
487
488 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
489 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
490 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
491 - hrn-urn translations tweaked
492 - fixed 'service sfa status'
493 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
494 - started to repair sfadump - although not usable yet
495 - trust objects now have dump_string method that dump() actually prints
496 - unit tests under review
497 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
498 - binaries now support -v or -vv to increase loglevel
499 - trashed obsolete sfa.util.client
500
501 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
502 - various bugfixes and cleanup, improved/harmonized logging
503
504 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
505 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
506   to avoid returning a PLCAPI exception that might confuse users.
507 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
508 - fix build errors.  
509
510 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
511 - (Architecture) Credential format changed to match ProtoGENI xml format
512 - (Architecture) All interfaces export a new set of methods that are compatible
513    with the ProtoGeni Aggregate spec. These new methods are considered a 
514    replacement  for the pervious methods exported by the interfaces. All 
515    previous methods are still exported and work as normal, but they are 
516    considered deprecated and will not be supported in future releases.  
517 - (Architecture) SFI has been updated to use the new interface methods.
518 - (Architecture) Changed keyconvet implementation from c to python.
519 - (Architecture) Slice Manager now attempts looks for a delegated credential
520   provided by the client before using its own server credential.
521 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
522   This cache now exists only in memory and is cleared when service is restarted
523   or cache lifetime is exceeded.  
524 - (Performance) SliceManager sends request to Aggregates in parallel instead 
525   of sequentially.
526 - (Bug fix) SFA tickets now support the new rspec format.
527 - (Bug fix) SFI only uses cahced credential if they aren't expired.
528 - (Bug fix) Cerdential delegation modified to work with new credential format.
529 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
530   Aggregate instead of relaying through the Slice Manager.
531 - (Enhancement) Simplified caching. Accociated a global cache instance with
532   the api handler on every new server request, making it easier to access the 
533   cache and use in more general ways.     
534
535 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
536 - SfaServer now uses a pool of threads to handle requests concurrently
537 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
538 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
539 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
540 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
541 - Component manager does not install gid files if slice already has them  
542 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
543 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
544 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
545      
546 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
547 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
548 - - sfa-config-tty now has the same features like plc-config-tty
549 - - Contains code to support both urn and hrn
550 - - Cleaned up request_hash related stuff
551 - - SM, AM and Registry code is organized under respective managers
552 - - Site and Slice synchronization across federated aggregates
553 - - Script to generate sfa_component_config
554
555 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
556 - sfa-config-tty now has the same features like plc-config-tty
557 - Contains code to support both urn and hrn
558 - Cleaned up request_hash related stuff
559 - SM, AM and Registry code is organized under respective managers
560 - Slice synchronization across federated aggregates
561 - some bugs are fixed
562
563 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
564 - checkpoint with fewer mentions of geni
565
566 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
567 - checkpointing
568 - this is believed to pass the tests; among other things:
569 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
570
571 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
572 - This tag includes:
573 - - Sfatables
574 - - Preliminary version of hash based authentication
575 - - Initial code for Component Manager
576 - - Authority structure is moved to /var/lib/sfa/
577 - - some bug-fixes
578
579 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
580 - Create_slice and get_resources methods are connected to sfatables.
581 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
582
583 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
584 - Bug fix on update and remove_peer_object methods
585 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
586
587 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
588 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
589
590 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
591 - compatibility with RefreshPeer
592 - incremental mechanism for importing PLC records into SFA tables
593 - unified single database (still inside the underlying PLC db postgresql server)
594 - includes/improves call traceability and logging features
595 - several bug fixes
596
597 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
598 - added libxslt-python dependency
599
600 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
601 - unified single SFA database in the PLC-DB
602 - upcalls from  PLCAPI to SFA methods
603 - SFA call traceability and logging features
604 - many bug fixes
605 - includes first/rough version of sfatables for policy implementation
606
607 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
608 - snapshot after the GEC5 demo
609 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
610
611 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
612 - snapshot july 15 - has gone through superficial manual testing
613 - hopefully a good basis for gec5 demo
614 - multi-dir sfi client tested as well
615
616 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
617 - rename geniwrapper.spec into sfa.spec
618
619 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
620 - clean up in xmlrpc/soap, --protocol option to chose between both
621 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
622 - hopefully more helpful context in case of crashes when importing
623 - bugfixes for using only /etc/sfa for site-dep files
624 - bugfixes in wsdl generation
625
626 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
627 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
628 - config variables in sfa_config now start with SFA_ and not GENI_
629 - config.py can be loaded even with no config present
630
631 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
632 - first step for cleanup and reorganization
633 - mass-renaming from geni to sfa (some are still needed)
634 - sfa/trust implements the security architecture
635
636 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
637 - snapshot for reproducible builds
638
639 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
640 - snapshot for the convenience of alpha users
641
642 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
643 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
644
645 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
646 - ongoing work - snapshot for 4.3-rc9
647
648 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
649 - various fixes
650
651 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
652 - bugfixes - still a work in progress
653
654 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
655 - initial package
656
657
658 %define module_current_branch 0.2