Merge branch 'upstreammaster'
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/keyconvert.py*
152 %{_bindir}/sfa-config-tty
153 %config /etc/sfa/default_config.xml
154 %config (noreplace) /etc/sfa/aggregates.xml
155 %config (noreplace) /etc/sfa/registries.xml
156 /usr/share/sfa/migrations
157 /usr/share/sfa/examples
158 /var/www/html/wsdl/*.wsdl
159
160 %files plc
161 %defattr(-,root,root)
162 /etc/sfa/pl.rng
163 /etc/sfa/credential.xsd
164 /etc/sfa/top.xsd
165 /etc/sfa/sig.xsd
166 /etc/sfa/xml.xsd
167 /etc/sfa/protogeni-rspec-common.xsd
168 /etc/sfa/topology
169 %{_bindir}/sfa-import.py*
170 %{_bindir}/sfa-nuke.py*
171 %{_bindir}/gen-sfa-cm-config.py*
172 %{_bindir}/sfa-ca.py*
173
174 %files client
175 %config (noreplace) /etc/sfa/sfi_config
176 %{_bindir}/sfi*.py*
177 %{_bindir}/sfi
178 %{_bindir}/get*.py*
179 %{_bindir}/setRecord.py*
180 %{_bindir}/sfascan.py*
181 %{_bindir}/sfascan
182 %{_bindir}/sfadump.py*
183
184 %files sfatables
185 /etc/sfatables/*
186 %{_bindir}/sfatables
187 %{python_sitelib}/sfatables
188
189 %files cm
190 /etc/init.d/sfa-cm
191 %{_bindir}/sfa_component_setup.py*
192 # cron jobs here 
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files xmlbuilder
199 %{python_sitelib}/xmlbuilder
200
201 %files tests
202 %{_datadir}/sfa/tests
203
204 ### sfa installs the 'sfa' service
205 %post 
206 chkconfig --add sfa
207
208 %preun 
209 if [ "$1" = 0 ] ; then
210   /sbin/service sfa stop || :
211   /sbin/chkconfig --del sfa || :
212 fi
213
214 %postun
215 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
216
217 ### sfa-cm installs the 'sfa-cm' service
218 %post cm
219 chkconfig --add sfa-cm
220
221 %preun cm
222 if [ "$1" = 0 ] ; then
223    /sbin/service sfa-cm stop || :
224    /sbin/chkconfig --del sfa-cm || :
225 fi
226
227 %postun cm
228 [ "$1" -ge "1" ] && service sfa-cm restart || :
229
230 %changelog
231 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
232 - slice x researcher rel. in database,
233 - plimporter to maintain that, as well as user.email, and more robust
234 - ongoing draft for sfaadmin tool
235 - support for a federica driver
236 - support for a nova/euca driver
237 - no more sfa-clean-peer-records script
238
239 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
240 - registry database has user's keys and mail (known as v0 for migrate)
241 - pl importer properly maintains user's keys and mail
242 - pl driver now to handle 'role' when adding person record (exp.)
243 - first draft of federica driver with config section
244 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
245 - plus, from master as of tag merged-in-sfa-2.1-2:
246 - disk_image revisited
247 - new nova_shell nova_driver & various tweaks for openstack
248
249 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
250 - uses sqlalchemy and related migrate
251 - thorough migration and upgrade scheme
252 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
253 - trashed dbinfo stuff in auth hierarchy
254 - data model still has little more than plain records
255 - checkpoint tag, not yet intended for release
256
257 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
258 - client: added -R --raw sfi cmdline option that displays raw server response.
259 - client: request GENI RSpec by default. 
260 - server: remove database dependencies from sfa.server.sfaapi.
261 - server: increased default credential lifetime to 31 days.
262 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
263 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
264 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
265  
266 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
267 - bugfix: 'geni_api' should be in the top level struct, not the code struct
268 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
269           output returned by the Aggregate Manager.
270 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
271 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
272 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
273           there is extra whitespace in the schemaLocation field.
274 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
275           advertisement rspecs.
276 - bugfix: <login> RSpec element should contain the 'username' attribute.
277 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
278  
279 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
280 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
281   exit when it encountered a user with an invalid public key.
282 - server: imporved logging in sfa-import-plc.py
283  
284 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
285 - bugfix: Fixed appending public keys in CreateSliver
286 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
287 - client: -c --current option allows users to request the current/uncached rspec.
288 - server: Added 'geni_api_versions' field to GetVersion() output.
289 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
290    
291 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
292 - bugfix: sfi was not sending call_id with ListResources to v2 servers
293 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
294 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
295
296 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
297 - client: sfi -a / -p deprecated (use -s instead)
298 - client: sfi cleaned up
299 - client: sfi has backward support for APIv1 aggregates again
300 - server: only APIv2 is supported and should be rather strict
301 - server: settings for turning on/off caching in sm or am
302 - server: plc-dependant code has moved from aggregate to pldriver
303 - server: driver interface extended accordingly
304
305 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
306 - screwed up previous tag
307
308 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
309 - client side revisited with a bootstrap library
310 - client side has a new source layout
311 - various (nasty) bug fixes wrt options and call_id
312
313 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
314 - various fixes in rspecs for sfav1&slice tags
315 - uses 'geni_rspec_version' and not just 'rspec_version'
316 - example flavour for the max testbed
317 - embryo for an sfa client library
318 - topology.py moved into plc
319 - sql: table is named records; record_types are enforced
320 - sql: table creation cleaned up
321
322 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
323 - cleaned up all references to SFA_*_TYPE in config
324 - enable cache at the aggregate by default
325 - registry now uses the driver in a sensible way (see managers/driver.py)
326 - slice manager supports sfav1/pgv2 neighbours
327 - get_key renamed into get_key_from_incoming_ip
328 - new sfa.storage module for record/table and all db-related stuff
329 - db schema in sfa.storage.sfa.sql
330 - init.d and cron.d move one step up
331 - cleaned up rspec/ directory
332 - add deps to pyopenssl and myplc-config
333 - start support for new API (return value)
334 - plc.remoteshell removed, use plshell instead
335 - plshell uses a 'capability' auth method whenever possible
336 - various tweaks in rspec elements
337 - made dependency on sfatables softer
338
339 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
340 - sfa should now be started *before* the initial import
341 - sfa to use its own database (default sfa) - can run without myplc
342 - server calls support optional 'options'
343 - client sends options in argument when needed
344 - fix infinite getattr recursion in elements/element.py
345 - error codes in line with geni
346
347 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
348 - fixed links and attributes in rspecs
349 - minor cleanup in the API methods, and more consistent names in manager methods
350
351 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
352 - ongoing refoactoring towards more genericity
353 - passes tests again although known issues remain with attributes/tags
354
355 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
356 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
357 - improvements in the pgv2 rspecs
358 - driver separated from api
359 - code starts moving around where it belongs
360 - sfascan caches getversion across invokations
361 - vini topology extracted as a config file
362
363 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
364 - first support for protogeni rspecs is working
365 - vini no longer needs a specific manager
366 - refactoring underway towards more flexible/generic architecture
367
368 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
369 - Unicode-friendliness for user names with accents/special chars.
370 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
371 - CreaetSliver no longer fails for users that have a capital letter in their URN.
372 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
373 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
374 - Fix bugs and missing imports     
375  
376
377 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
378 - new method record.get_field for sface
379
380 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
381 - new option -c to sfa-nuke-plc.py
382 - CreateSliver fixed for admin-only slice tags
383
384 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
385 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
386 - Fixed holes in certificate verification logic.
387 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
388 - Added 'boot_state' as an attribute of the node element in SFA rspec.
389 - Non authority certificates are marked as CA:FALSE.
390
391 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
392 - fix typo in sfa-1.0-31 tag.
393 - added CreateGid() Registry interface method.
394
395 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
396 - fix typo in sfa-1.0-30 tag
397
398 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
399 - Declare namespace and schema location in the credential.
400 - Fix bug that prevetend connections from timing out.
401 - Fix slice delegation.
402 - Add statistics to slicemaanger listresources/createsliver rspec.
403 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
404   of days a user can extend their slice expiration.
405 - CA certs are only issued to objects of type authority
406    
407 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
408 - tag 1.0-28 was broken due to typo in the changelog
409 - new class sfa/util/httpsProtocol.py that supports timeouts
410
411 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
412 - Resolved issue that caused sfa hold onto idle db connections.
413 - Fix bug that caused the registry to use the wrong type of credential.
414 - Support authority+sm type.
415 - Fix rspec merging bugs.
416 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
417 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
418  planetlab hosted initscripts using the <planetlab:initscript> tag  
419 - Can now handle extraneous whitespace in the rspec without failing.   
420  
421 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
422 - ProtoGENI v2 RSpec updates.
423 - Convert expiration timestamps with timezone info in credentials to utc.
424 - Fixed redundant logging issue. 
425 - Improved SliceManager and SFI client logging.
426 - Support aggregates that don't support the optional 'call_id' argument. 
427 - Only call get_trusted_certs() at aggreage interfaces that support the call.
428 - CreateSliver() now handles MyPLC slice attributes/tags.
429 - Cache now supports persistence.
430 - Hide whitelisted nodes.
431
432 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
433 - fixed issues with sup authority signing
434 - fixed bugs in remove_slivers and SliverStatus
435
436 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
437 - fix typo that prevented aggregates from operating properly
438
439 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
440 - load trusted certs into ssl context prior to handshake
441 - client's logfile lives in ~/.sfi/sfi.log
442
443 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
444 - includes a change on passphrases that was intended in 1.0-22
445
446 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
447 - Added support for ProtoGENI RSpec v2
448  
449 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
450 - stable sfascan
451 - fix in initscript, *ENABLED tags in config now taken into account
452
453 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
454 - some commits had not been pushed in tag 19
455
456 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
457 - GetVersion should now report full URLs with path
458 - scansfa has nicer output and new syntax (entry URLs as args and not options)
459 - dos2unix'ed flash policy pill
460
461 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
462 - fix packaging again for f8
463
464 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
465 - fix packaging (apparently broken in 1.0-16)
466 - first working version of sfascan
467 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
468 - deprecated the sfa_geni_aggregate config category
469
470 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
471 - Fix build problem
472 - First version of SFA scanner
473
474 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
475 - Add support for Flash clients using flashpolicy
476 - Fix problems with tag handling in RSpec
477
478 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
479 - Modifications to the Eucalyptus Aggregate Manager
480 - Fixes for VINI RSpec
481 - Fix tag handling for PL RSpec
482 - Fix XML Schema ordering for <urn> element
483
484 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
485 - just set x509 version to 2
486
487 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
488 - added urn to the node area in rspecs
489 - conversion to urn now exports fqdn
490 - sfa-import-plc.py now creates a unique registry record for each SFA interface
491
492 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
493 - undo broken attempt for python-2.7
494
495 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
496 - SMs avoid duplicates for when call graph has dags;
497 - just based on network's name, when a duplicate occurs, one is just dropped
498 - does not try to merge/aggregate 2 networks
499 - also reviewed logging with the hope to fix the sfa startup msg:
500 - TypeError: not all arguments converted during string formatting
501
502 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
503 - verify credentials against xsd schema
504 - Fix SM to SM communication
505 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
506 - new setting session_key_path
507
508 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
509 - fix registry credential regeneration and handle expiration
510 - support for setting slice tags (min_role=user)
511 - client can display its own version: sfi.py version --local
512 - GetVersion to provide urn in addition to hrn
513 - more code uses plxrn vs previous helper functions
514 - import replaces '+' in email addresses with '_'
515
516 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
517 - fix GetVersion code_tag and add code_url
518
519 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
520 - extend GetVersion towards minimum federation introspection, and expose local tag
521
522 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
523 - fixed some legacy issues (list vs List)
524 - deprecated sfa.util.namespace for xrn and plxrn
525 - unit tests ship as the sfa-tests rpm
526
527 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
528 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
529 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
530 - hrn-urn translations tweaked
531 - fixed 'service sfa status'
532 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
533 - started to repair sfadump - although not usable yet
534 - trust objects now have dump_string method that dump() actually prints
535 - unit tests under review
536 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
537 - binaries now support -v or -vv to increase loglevel
538 - trashed obsolete sfa.util.client
539
540 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
541 - various bugfixes and cleanup, improved/harmonized logging
542
543 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
544 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
545   to avoid returning a PLCAPI exception that might confuse users.
546 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
547 - fix build errors.  
548
549 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
550 - (Architecture) Credential format changed to match ProtoGENI xml format
551 - (Architecture) All interfaces export a new set of methods that are compatible
552    with the ProtoGeni Aggregate spec. These new methods are considered a 
553    replacement  for the pervious methods exported by the interfaces. All 
554    previous methods are still exported and work as normal, but they are 
555    considered deprecated and will not be supported in future releases.  
556 - (Architecture) SFI has been updated to use the new interface methods.
557 - (Architecture) Changed keyconvet implementation from c to python.
558 - (Architecture) Slice Manager now attempts looks for a delegated credential
559   provided by the client before using its own server credential.
560 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
561   This cache now exists only in memory and is cleared when service is restarted
562   or cache lifetime is exceeded.  
563 - (Performance) SliceManager sends request to Aggregates in parallel instead 
564   of sequentially.
565 - (Bug fix) SFA tickets now support the new rspec format.
566 - (Bug fix) SFI only uses cahced credential if they aren't expired.
567 - (Bug fix) Cerdential delegation modified to work with new credential format.
568 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
569   Aggregate instead of relaying through the Slice Manager.
570 - (Enhancement) Simplified caching. Accociated a global cache instance with
571   the api handler on every new server request, making it easier to access the 
572   cache and use in more general ways.     
573
574 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
575 - SfaServer now uses a pool of threads to handle requests concurrently
576 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
577 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
578 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
579 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
580 - Component manager does not install gid files if slice already has them  
581 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
582 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
583 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
584      
585 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
586 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
587 - - sfa-config-tty now has the same features like plc-config-tty
588 - - Contains code to support both urn and hrn
589 - - Cleaned up request_hash related stuff
590 - - SM, AM and Registry code is organized under respective managers
591 - - Site and Slice synchronization across federated aggregates
592 - - Script to generate sfa_component_config
593
594 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
595 - sfa-config-tty now has the same features like plc-config-tty
596 - Contains code to support both urn and hrn
597 - Cleaned up request_hash related stuff
598 - SM, AM and Registry code is organized under respective managers
599 - Slice synchronization across federated aggregates
600 - some bugs are fixed
601
602 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
603 - checkpoint with fewer mentions of geni
604
605 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
606 - checkpointing
607 - this is believed to pass the tests; among other things:
608 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
609
610 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
611 - This tag includes:
612 - - Sfatables
613 - - Preliminary version of hash based authentication
614 - - Initial code for Component Manager
615 - - Authority structure is moved to /var/lib/sfa/
616 - - some bug-fixes
617
618 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
619 - Create_slice and get_resources methods are connected to sfatables.
620 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
621
622 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
623 - Bug fix on update and remove_peer_object methods
624 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
625
626 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
627 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
628
629 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
630 - compatibility with RefreshPeer
631 - incremental mechanism for importing PLC records into SFA tables
632 - unified single database (still inside the underlying PLC db postgresql server)
633 - includes/improves call traceability and logging features
634 - several bug fixes
635
636 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
637 - added libxslt-python dependency
638
639 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
640 - unified single SFA database in the PLC-DB
641 - upcalls from  PLCAPI to SFA methods
642 - SFA call traceability and logging features
643 - many bug fixes
644 - includes first/rough version of sfatables for policy implementation
645
646 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
647 - snapshot after the GEC5 demo
648 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
649
650 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
651 - snapshot july 15 - has gone through superficial manual testing
652 - hopefully a good basis for gec5 demo
653 - multi-dir sfi client tested as well
654
655 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
656 - rename geniwrapper.spec into sfa.spec
657
658 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
659 - clean up in xmlrpc/soap, --protocol option to chose between both
660 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
661 - hopefully more helpful context in case of crashes when importing
662 - bugfixes for using only /etc/sfa for site-dep files
663 - bugfixes in wsdl generation
664
665 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
666 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
667 - config variables in sfa_config now start with SFA_ and not GENI_
668 - config.py can be loaded even with no config present
669
670 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
671 - first step for cleanup and reorganization
672 - mass-renaming from geni to sfa (some are still needed)
673 - sfa/trust implements the security architecture
674
675 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
676 - snapshot for reproducible builds
677
678 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
679 - snapshot for the convenience of alpha users
680
681 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
682 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
683
684 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
685 - ongoing work - snapshot for 4.3-rc9
686
687 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
688 - various fixes
689
690 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
691 - bugfixes - still a work in progress
692
693 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
694 - initial package
695
696
697 %define module_current_branch 0.2