reviwed packaging
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 Summary: the SFA python libraries
23 Group: Applications/System
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # for uuidgen - used in db password generation
31 # on f8 this actually comes with e2fsprogs, go figure
32 Requires: util-linux-ng
33 # xmlbuilder depends on  lxml
34 Requires: python-lxml
35 Requires: python-setuptools
36 Requires: python-dateutil
37 # for the registry
38 Requires: postgresql >= 8.2, postgresql-server >= 8.2
39 Requires: postgresql-python
40 Requires: python-psycopg2
41  
42 # python 2.5 has uuid module added, for python 2.4 we still need it.
43 # we can't really check for if we can load uuid as a python module,
44 # it'll be installed by "devel.pkgs". we have the epel repository so
45 # python-uuid will be provided. but we can test for the python
46 # version.
47 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
48 # %if %has_py24
49 #
50 # this also didn't work very well. I'll just check for distroname - baris
51 #%if %{distroname} == "centos5"
52 #Requires: python-uuid
53 #%endif
54
55 %package plc
56 Summary: the SFA layer around MyPLC
57 Group: Applications/System
58 Requires: sfa
59 Requires: python-psycopg2
60 Requires: myplc-config
61 Requires: pyOpenSSL >= 0.7
62
63 %package client
64 Summary: the SFA experimenter-side CLI
65 Group: Applications/System
66 Requires: sfa
67 Requires: pyOpenSSL >= 0.7
68
69 %package sfatables
70 Summary: sfatables policy tool for SFA
71 Group: Applications/System
72 Requires: sfa
73
74 %package cm
75 Summary: the SFA layer around MyPLC NodeManager
76 Group: Applications/System
77 Requires: sfa
78 Requires: pyOpenSSL >= 0.6
79
80 %package flashpolicy
81 Summary: SFA support for flash clients
82 Group: Applications/System
83 Requires: sfa
84
85 %package tests
86 Summary: unit tests suite for SFA
87 Group: Applications/System
88 Requires: sfa
89
90 %description
91 This package provides the python libraries for the PlanetLab implementation of SFA
92
93 %description plc
94 This package implements the SFA interface which serves as a layer
95 between the existing PlanetLab interfaces and the SFA API.
96
97 %description client
98 This package provides the client side of the SFA API, in particular
99 sfi.py, together with other utilities.
100
101 %description sfatables
102 sfatables is a tool for defining access and admission control policies
103 in an SFA network, in much the same way as iptables is for ip
104 networks. This is the command line interface to manage sfatables
105
106 %description cm
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab NodeManager interfaces and the SFA API.
109  
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112  
113 %description tests
114 Provides some binary unit tests in /usr/share/sfa/tests
115
116 %prep
117 %setup -q
118
119 %build
120 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 # sfa and sfatables depend on each other.
131 %{python_sitelib}/sfa
132 %{python_sitelib}/sfa*egg-info
133 %{python_sitelib}/xmlbuilder
134 %{python_sitelib}/xmlbuilder*egg-info
135 /etc/init.d/sfa
136 %{_bindir}/sfa-start.py*
137 %{_bindir}/keyconvert.py*
138 %{_bindir}/sfa-config-tty
139 %config /etc/sfa/default_config.xml
140 %config (noreplace) /etc/sfa/aggregates.xml
141 %config (noreplace) /etc/sfa/registries.xml
142 /var/www/html/wsdl/*.wsdl
143
144 %files plc
145 %defattr(-,root,root)
146 /etc/sfa/pl.rng
147 /etc/sfa/credential.xsd
148 /etc/sfa/top.xsd
149 /etc/sfa/sig.xsd
150 /etc/sfa/xml.xsd
151 /etc/sfa/protogeni-rspec-common.xsd
152 /etc/sfa/topology
153 %{_bindir}/sfa-import-plc.py*
154 %{_bindir}/sfa-nuke-plc.py*
155 %{_bindir}/sfa-clean-peer-records.py*
156 %{_bindir}/gen-sfa-cm-config.py*
157 %{_bindir}/sfa-ca.py*
158
159 %files client
160 %config (noreplace) /etc/sfa/sfi_config
161 %{_bindir}/sfi*
162 %{_bindir}/getNodes.py*
163 %{_bindir}/getRecord.py*
164 %{_bindir}/setRecord.py*
165 %{_bindir}/sfadump.py*
166
167 %files sfatables
168 /etc/sfatables/*
169 %{_bindir}/sfatables
170 %{python_sitelib}/sfatables
171
172 %files cm
173 /etc/init.d/sfa-cm
174 %{_bindir}/sfa_component_setup.py*
175 # cron jobs here 
176
177 %files flashpolicy
178 %{_bindir}/sfa_flashpolicy.py*
179 /etc/sfa/sfa_flashpolicy_config.xml
180
181 %files tests
182 %{_datadir}/sfa/tests
183
184 ### sfa-plc installs the 'sfa' service
185 %post plc
186 chkconfig --add sfa
187
188 %preun plc
189 if [ "$1" = 0 ] ; then
190   /sbin/service sfa stop || :
191   /sbin/chkconfig --del sfa || :
192 fi
193
194 %postun plc
195 [ "$1" -ge "1" ] && service sfa restart
196
197 ### sfa-cm installs the 'sfa-cm' service
198 %post cm
199 chkconfig --add sfa-cm
200
201 %preun cm
202 if [ "$1" = 0 ] ; then
203    /sbin/service sfa-cm stop || :
204    /sbin/chkconfig --del sfa-cm || :
205 fi
206
207 %postun cm
208 [ "$1" -ge "1" ] && service sfa-cm restart || :
209
210 %changelog
211 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
212 - fixed links and attributes in rspecs
213 - minor cleanup in the API methods, and more consistent names in manager methods
214
215 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
216 - ongoing refoactoring towards more genericity
217 - passes tests again although known issues remain with attributes/tags
218
219 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
220 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
221 - improvements in the pgv2 rspecs
222 - driver separated from api
223 - code starts moving around where it belongs
224 - sfascan caches getversion across invokations
225 - vini topology extracted as a config file
226
227 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
228 - first support for protogeni rspecs is working
229 - vini no longer needs a specific manager
230 - refactoring underway towards more flexible/generic architecture
231
232 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
233 - Unicode-friendliness for user names with accents/special chars.
234 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
235 - CreaetSliver no longer fails for users that have a capital letter in their URN.
236 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
237 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
238 - Fix bugs and missing imports     
239  
240
241 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
242 - new method record.get_field for sface
243
244 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
245 - new option -c to sfa-nuke-plc.py
246 - CreateSliver fixed for admin-only slice tags
247
248 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
249 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
250 - Fixed holes in certificate verification logic.
251 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
252 - Added 'boot_state' as an attribute of the node element in SFA rspec.
253 - Non authority certificates are marked as CA:FALSE.
254
255 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
256 - fix typo in sfa-1.0-31 tag.
257 - added CreateGid() Registry interface method.
258
259 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
260 - fix typo in sfa-1.0-30 tag
261
262 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
263 - Declare namespace and schema location in the credential.
264 - Fix bug that prevetend connections from timing out.
265 - Fix slice delegation.
266 - Add statistics to slicemaanger listresources/createsliver rspec.
267 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
268   of days a user can extend their slice expiration.
269 - CA certs are only issued to objects of type authority
270    
271 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
272 - tag 1.0-28 was broken due to typo in the changelog
273 - new class sfa/util/httpsProtocol.py that supports timeouts
274
275 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
276 - Resolved issue that caused sfa hold onto idle db connections.
277 - Fix bug that caused the registry to use the wrong type of credential.
278 - Support authority+sm type.
279 - Fix rspec merging bugs.
280 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
281 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
282  planetlab hosted initscripts using the <planetlab:initscript> tag  
283 - Can now handle extraneous whitespace in the rspec without failing.   
284  
285 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
286 - ProtoGENI v2 RSpec updates.
287 - Convert expiration timestamps with timezone info in credentials to utc.
288 - Fixed redundant logging issue. 
289 - Improved SliceManager and SFI client logging.
290 - Support aggregates that don't support the optional 'call_id' argument. 
291 - Only call get_trusted_certs() at aggreage interfaces that support the call.
292 - CreateSliver() now handles MyPLC slice attributes/tags.
293 - Cache now supports persistence.
294 - Hide whitelisted nodes.
295
296 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
297 - fixed issues with sup authority signing
298 - fixed bugs in remove_slivers and SliverStatus
299
300 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
301 - fix typo that prevented aggregates from operating properly
302
303 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
304 - load trusted certs into ssl context prior to handshake
305 - client's logfile lives in ~/.sfi/sfi.log
306
307 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
308 - includes a change on passphrases that was intended in 1.0-22
309
310 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
311 - Added support for ProtoGENI RSpec v2
312  
313 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
314 - stable sfascan
315 - fix in initscript, *ENABLED tags in config now taken into account
316
317 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
318 - some commits had not been pushed in tag 19
319
320 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
321 - GetVersion should now report full URLs with path
322 - scansfa has nicer output and new syntax (entry URLs as args and not options)
323 - dos2unix'ed flash policy pill
324
325 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
326 - fix packaging again for f8
327
328 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
329 - fix packaging (apparently broken in 1.0-16)
330 - first working version of sfascan
331 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
332 - deprecated the sfa_geni_aggregate config category
333
334 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
335 - Fix build problem
336 - First version of SFA scanner
337
338 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
339 - Add support for Flash clients using flashpolicy
340 - Fix problems with tag handling in RSpec
341
342 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
343 - Modifications to the Eucalyptus Aggregate Manager
344 - Fixes for VINI RSpec
345 - Fix tag handling for PL RSpec
346 - Fix XML Schema ordering for <urn> element
347
348 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
349 - just set x509 version to 2
350
351 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
352 - added urn to the node area in rspecs
353 - conversion to urn now exports fqdn
354 - sfa-import-plc.py now creates a unique registry record for each SFA interface
355
356 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
357 - undo broken attempt for python-2.7
358
359 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
360 - SMs avoid duplicates for when call graph has dags;
361 - just based on network's name, when a duplicate occurs, one is just dropped
362 - does not try to merge/aggregate 2 networks
363 - also reviewed logging with the hope to fix the sfa startup msg:
364 - TypeError: not all arguments converted during string formatting
365
366 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
367 - verify credentials against xsd schema
368 - Fix SM to SM communication
369 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
370 - new setting session_key_path
371
372 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
373 - fix registry credential regeneration and handle expiration
374 - support for setting slice tags (min_role=user)
375 - client can display its own version: sfi.py version --local
376 - GetVersion to provide urn in addition to hrn
377 - more code uses plxrn vs previous helper functions
378 - import replaces '+' in email addresses with '_'
379
380 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
381 - fix GetVersion code_tag and add code_url
382
383 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
384 - extend GetVersion towards minimum federation introspection, and expose local tag
385
386 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
387 - fixed some legacy issues (list vs List)
388 - deprecated sfa.util.namespace for xrn and plxrn
389 - unit tests ship as the sfa-tests rpm
390
391 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
392 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
393 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
394 - hrn-urn translations tweaked
395 - fixed 'service sfa status'
396 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
397 - started to repair sfadump - although not usable yet
398 - trust objects now have dump_string method that dump() actually prints
399 - unit tests under review
400 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
401 - binaries now support -v or -vv to increase loglevel
402 - trashed obsolete sfa.util.client
403
404 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
405 - various bugfixes and cleanup, improved/harmonized logging
406
407 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
408 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
409   to avoid returning a PLCAPI exception that might confuse users.
410 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
411 - fix build errors.  
412
413 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
414 - (Architecture) Credential format changed to match ProtoGENI xml format
415 - (Architecture) All interfaces export a new set of methods that are compatible
416    with the ProtoGeni Aggregate spec. These new methods are considered a 
417    replacement  for the pervious methods exported by the interfaces. All 
418    previous methods are still exported and work as normal, but they are 
419    considered deprecated and will not be supported in future releases.  
420 - (Architecture) SFI has been updated to use the new interface methods.
421 - (Architecture) Changed keyconvet implementation from c to python.
422 - (Architecture) Slice Manager now attempts looks for a delegated credential
423   provided by the client before using its own server credential.
424 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
425   This cache now exists only in memory and is cleared when service is restarted
426   or cache lifetime is exceeded.  
427 - (Performance) SliceManager sends request to Aggregates in parallel instead 
428   of sequentially.
429 - (Bug fix) SFA tickets now support the new rspec format.
430 - (Bug fix) SFI only uses cahced credential if they aren't expired.
431 - (Bug fix) Cerdential delegation modified to work with new credential format.
432 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
433   Aggregate instead of relaying through the Slice Manager.
434 - (Enhancement) Simplified caching. Accociated a global cache instance with
435   the api handler on every new server request, making it easier to access the 
436   cache and use in more general ways.     
437
438 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
439 - SfaServer now uses a pool of threads to handle requests concurrently
440 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
441 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
442 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
443 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
444 - Component manager does not install gid files if slice already has them  
445 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
446 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
447 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
448      
449 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
450 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
451 - - sfa-config-tty now has the same features like plc-config-tty
452 - - Contains code to support both urn and hrn
453 - - Cleaned up request_hash related stuff
454 - - SM, AM and Registry code is organized under respective managers
455 - - Site and Slice synchronization across federated aggregates
456 - - Script to generate sfa_component_config
457
458 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
459 - sfa-config-tty now has the same features like plc-config-tty
460 - Contains code to support both urn and hrn
461 - Cleaned up request_hash related stuff
462 - SM, AM and Registry code is organized under respective managers
463 - Slice synchronization across federated aggregates
464 - some bugs are fixed
465
466 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
467 - checkpoint with fewer mentions of geni
468
469 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
470 - checkpointing
471 - this is believed to pass the tests; among other things:
472 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
473
474 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
475 - This tag includes:
476 - - Sfatables
477 - - Preliminary version of hash based authentication
478 - - Initial code for Component Manager
479 - - Authority structure is moved to /var/lib/sfa/
480 - - some bug-fixes
481
482 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
483 - Create_slice and get_resources methods are connected to sfatables.
484 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
485
486 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
487 - Bug fix on update and remove_peer_object methods
488 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
489
490 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
491 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
492
493 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
494 - compatibility with RefreshPeer
495 - incremental mechanism for importing PLC records into SFA tables
496 - unified single database (still inside the underlying PLC db postgresql server)
497 - includes/improves call traceability and logging features
498 - several bug fixes
499
500 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
501 - added libxslt-python dependency
502
503 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
504 - unified single SFA database in the PLC-DB
505 - upcalls from  PLCAPI to SFA methods
506 - SFA call traceability and logging features
507 - many bug fixes
508 - includes first/rough version of sfatables for policy implementation
509
510 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
511 - snapshot after the GEC5 demo
512 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
513
514 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
515 - snapshot july 15 - has gone through superficial manual testing
516 - hopefully a good basis for gec5 demo
517 - multi-dir sfi client tested as well
518
519 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
520 - rename geniwrapper.spec into sfa.spec
521
522 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
523 - clean up in xmlrpc/soap, --protocol option to chose between both
524 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
525 - hopefully more helpful context in case of crashes when importing
526 - bugfixes for using only /etc/sfa for site-dep files
527 - bugfixes in wsdl generation
528
529 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
530 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
531 - config variables in sfa_config now start with SFA_ and not GENI_
532 - config.py can be loaded even with no config present
533
534 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
535 - first step for cleanup and reorganization
536 - mass-renaming from geni to sfa (some are still needed)
537 - sfa/trust implements the security architecture
538
539 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
540 - snapshot for reproducible builds
541
542 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
543 - snapshot for the convenience of alpha users
544
545 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
546 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
547
548 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
549 - ongoing work - snapshot for 4.3-rc9
550
551 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
552 - various fixes
553
554 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
555 - bugfixes - still a work in progress
556
557 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
558 - initial package
559
560
561 %define module_current_branch 0.2