moved requires: clauses from sfa-plc to sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 Summary: the SFA python libraries
23 Group: Applications/System
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # for uuidgen - used in db password generation
31 # on f8 this actually comes with e2fsprogs, go figure
32 Requires: util-linux-ng
33 # xmlbuilder depends on  lxml
34 Requires: python-lxml
35 Requires: python-setuptools
36 Requires: python-dateutil
37 # for the registry
38 Requires: postgresql >= 8.2, postgresql-server >= 8.2
39 Requires: postgresql-python
40 Requires: python-psycopg2
41 Requires: pyOpenSSL >= 0.7
42 Requires: myplc-config
43  
44 # python 2.5 has uuid module added, for python 2.4 we still need it.
45 # we can't really check for if we can load uuid as a python module,
46 # it'll be installed by "devel.pkgs". we have the epel repository so
47 # python-uuid will be provided. but we can test for the python
48 # version.
49 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
50 # %if %has_py24
51 #
52 # this also didn't work very well. I'll just check for distroname - baris
53 #%if %{distroname} == "centos5"
54 #Requires: python-uuid
55 #%endif
56
57 %package plc
58 Summary: the SFA layer around MyPLC
59 Group: Applications/System
60 Requires: sfa
61 Requires: python-psycopg2
62
63 %package client
64 Summary: the SFA experimenter-side CLI
65 Group: Applications/System
66 Requires: sfa
67 Requires: pyOpenSSL >= 0.7
68
69 %package sfatables
70 Summary: sfatables policy tool for SFA
71 Group: Applications/System
72 Requires: sfa
73
74 %package cm
75 Summary: the SFA layer around MyPLC NodeManager
76 Group: Applications/System
77 Requires: sfa
78 Requires: pyOpenSSL >= 0.6
79
80 %package flashpolicy
81 Summary: SFA support for flash clients
82 Group: Applications/System
83 Requires: sfa
84
85 %package tests
86 Summary: unit tests suite for SFA
87 Group: Applications/System
88 Requires: sfa
89
90 %description
91 This package provides the python libraries for the PlanetLab implementation of SFA
92
93 %description plc
94 This package implements the SFA interface which serves as a layer
95 between the existing PlanetLab interfaces and the SFA API.
96
97 %description client
98 This package provides the client side of the SFA API, in particular
99 sfi.py, together with other utilities.
100
101 %description sfatables
102 sfatables is a tool for defining access and admission control policies
103 in an SFA network, in much the same way as iptables is for ip
104 networks. This is the command line interface to manage sfatables
105
106 %description cm
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab NodeManager interfaces and the SFA API.
109  
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112  
113 %description tests
114 Provides some binary unit tests in /usr/share/sfa/tests
115
116 %prep
117 %setup -q
118
119 %build
120 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 # sfa and sfatables depend on each other.
131 %{python_sitelib}/sfa
132 %{python_sitelib}/sfa*egg-info
133 %{python_sitelib}/xmlbuilder
134 %{python_sitelib}/xmlbuilder*egg-info
135 /etc/init.d/sfa
136 %{_bindir}/sfa-start.py*
137 %{_bindir}/keyconvert.py*
138 %{_bindir}/sfa-config-tty
139 %config /etc/sfa/default_config.xml
140 %config (noreplace) /etc/sfa/aggregates.xml
141 %config (noreplace) /etc/sfa/registries.xml
142 /var/www/html/wsdl/*.wsdl
143
144 %files plc
145 %defattr(-,root,root)
146 /etc/sfa/pl.rng
147 /etc/sfa/credential.xsd
148 /etc/sfa/top.xsd
149 /etc/sfa/sig.xsd
150 /etc/sfa/xml.xsd
151 /etc/sfa/protogeni-rspec-common.xsd
152 /etc/sfa/topology
153 %{_bindir}/sfa-import-plc.py*
154 %{_bindir}/sfa-nuke-plc.py*
155 %{_bindir}/sfa-clean-peer-records.py*
156 %{_bindir}/gen-sfa-cm-config.py*
157 %{_bindir}/sfa-ca.py*
158
159 %files client
160 %config (noreplace) /etc/sfa/sfi_config
161 %{_bindir}/sfi*
162 %{_bindir}/getNodes.py*
163 %{_bindir}/getRecord.py*
164 %{_bindir}/setRecord.py*
165 %{_bindir}/sfadump.py*
166
167 %files sfatables
168 /etc/sfatables/*
169 %{_bindir}/sfatables
170 %{python_sitelib}/sfatables
171
172 %files cm
173 /etc/init.d/sfa-cm
174 %{_bindir}/sfa_component_setup.py*
175 # cron jobs here 
176
177 %files flashpolicy
178 %{_bindir}/sfa_flashpolicy.py*
179 /etc/sfa/sfa_flashpolicy_config.xml
180
181 %files tests
182 %{_datadir}/sfa/tests
183
184 ### sfa-plc installs the 'sfa' service
185 %post plc
186 chkconfig --add sfa
187
188 %preun plc
189 if [ "$1" = 0 ] ; then
190   /sbin/service sfa stop || :
191   /sbin/chkconfig --del sfa || :
192 fi
193
194 %postun plc
195 [ "$1" -ge "1" ] && service sfa restart
196
197 ### sfa-cm installs the 'sfa-cm' service
198 %post cm
199 chkconfig --add sfa-cm
200
201 %preun cm
202 if [ "$1" = 0 ] ; then
203    /sbin/service sfa-cm stop || :
204    /sbin/chkconfig --del sfa-cm || :
205 fi
206
207 %postun cm
208 [ "$1" -ge "1" ] && service sfa-cm restart || :
209
210 %changelog
211 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
212 - sfa should now be started *before* the initial import
213 - sfa to use its own database (default sfa) - can run without myplc
214 - server calls support optional 'options'
215 - client sends options in argument when needed
216 - fix infinite getattr recursion in elements/element.py
217 - error codes in line with geni
218
219 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
220 - fixed links and attributes in rspecs
221 - minor cleanup in the API methods, and more consistent names in manager methods
222
223 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
224 - ongoing refoactoring towards more genericity
225 - passes tests again although known issues remain with attributes/tags
226
227 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
228 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
229 - improvements in the pgv2 rspecs
230 - driver separated from api
231 - code starts moving around where it belongs
232 - sfascan caches getversion across invokations
233 - vini topology extracted as a config file
234
235 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
236 - first support for protogeni rspecs is working
237 - vini no longer needs a specific manager
238 - refactoring underway towards more flexible/generic architecture
239
240 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
241 - Unicode-friendliness for user names with accents/special chars.
242 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
243 - CreaetSliver no longer fails for users that have a capital letter in their URN.
244 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
245 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
246 - Fix bugs and missing imports     
247  
248
249 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
250 - new method record.get_field for sface
251
252 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
253 - new option -c to sfa-nuke-plc.py
254 - CreateSliver fixed for admin-only slice tags
255
256 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
257 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
258 - Fixed holes in certificate verification logic.
259 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
260 - Added 'boot_state' as an attribute of the node element in SFA rspec.
261 - Non authority certificates are marked as CA:FALSE.
262
263 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
264 - fix typo in sfa-1.0-31 tag.
265 - added CreateGid() Registry interface method.
266
267 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
268 - fix typo in sfa-1.0-30 tag
269
270 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
271 - Declare namespace and schema location in the credential.
272 - Fix bug that prevetend connections from timing out.
273 - Fix slice delegation.
274 - Add statistics to slicemaanger listresources/createsliver rspec.
275 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
276   of days a user can extend their slice expiration.
277 - CA certs are only issued to objects of type authority
278    
279 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
280 - tag 1.0-28 was broken due to typo in the changelog
281 - new class sfa/util/httpsProtocol.py that supports timeouts
282
283 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
284 - Resolved issue that caused sfa hold onto idle db connections.
285 - Fix bug that caused the registry to use the wrong type of credential.
286 - Support authority+sm type.
287 - Fix rspec merging bugs.
288 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
289 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
290  planetlab hosted initscripts using the <planetlab:initscript> tag  
291 - Can now handle extraneous whitespace in the rspec without failing.   
292  
293 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
294 - ProtoGENI v2 RSpec updates.
295 - Convert expiration timestamps with timezone info in credentials to utc.
296 - Fixed redundant logging issue. 
297 - Improved SliceManager and SFI client logging.
298 - Support aggregates that don't support the optional 'call_id' argument. 
299 - Only call get_trusted_certs() at aggreage interfaces that support the call.
300 - CreateSliver() now handles MyPLC slice attributes/tags.
301 - Cache now supports persistence.
302 - Hide whitelisted nodes.
303
304 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
305 - fixed issues with sup authority signing
306 - fixed bugs in remove_slivers and SliverStatus
307
308 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
309 - fix typo that prevented aggregates from operating properly
310
311 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
312 - load trusted certs into ssl context prior to handshake
313 - client's logfile lives in ~/.sfi/sfi.log
314
315 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
316 - includes a change on passphrases that was intended in 1.0-22
317
318 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
319 - Added support for ProtoGENI RSpec v2
320  
321 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
322 - stable sfascan
323 - fix in initscript, *ENABLED tags in config now taken into account
324
325 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
326 - some commits had not been pushed in tag 19
327
328 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
329 - GetVersion should now report full URLs with path
330 - scansfa has nicer output and new syntax (entry URLs as args and not options)
331 - dos2unix'ed flash policy pill
332
333 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
334 - fix packaging again for f8
335
336 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
337 - fix packaging (apparently broken in 1.0-16)
338 - first working version of sfascan
339 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
340 - deprecated the sfa_geni_aggregate config category
341
342 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
343 - Fix build problem
344 - First version of SFA scanner
345
346 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
347 - Add support for Flash clients using flashpolicy
348 - Fix problems with tag handling in RSpec
349
350 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
351 - Modifications to the Eucalyptus Aggregate Manager
352 - Fixes for VINI RSpec
353 - Fix tag handling for PL RSpec
354 - Fix XML Schema ordering for <urn> element
355
356 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
357 - just set x509 version to 2
358
359 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
360 - added urn to the node area in rspecs
361 - conversion to urn now exports fqdn
362 - sfa-import-plc.py now creates a unique registry record for each SFA interface
363
364 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
365 - undo broken attempt for python-2.7
366
367 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
368 - SMs avoid duplicates for when call graph has dags;
369 - just based on network's name, when a duplicate occurs, one is just dropped
370 - does not try to merge/aggregate 2 networks
371 - also reviewed logging with the hope to fix the sfa startup msg:
372 - TypeError: not all arguments converted during string formatting
373
374 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
375 - verify credentials against xsd schema
376 - Fix SM to SM communication
377 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
378 - new setting session_key_path
379
380 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
381 - fix registry credential regeneration and handle expiration
382 - support for setting slice tags (min_role=user)
383 - client can display its own version: sfi.py version --local
384 - GetVersion to provide urn in addition to hrn
385 - more code uses plxrn vs previous helper functions
386 - import replaces '+' in email addresses with '_'
387
388 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
389 - fix GetVersion code_tag and add code_url
390
391 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
392 - extend GetVersion towards minimum federation introspection, and expose local tag
393
394 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
395 - fixed some legacy issues (list vs List)
396 - deprecated sfa.util.namespace for xrn and plxrn
397 - unit tests ship as the sfa-tests rpm
398
399 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
400 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
401 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
402 - hrn-urn translations tweaked
403 - fixed 'service sfa status'
404 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
405 - started to repair sfadump - although not usable yet
406 - trust objects now have dump_string method that dump() actually prints
407 - unit tests under review
408 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
409 - binaries now support -v or -vv to increase loglevel
410 - trashed obsolete sfa.util.client
411
412 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
413 - various bugfixes and cleanup, improved/harmonized logging
414
415 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
416 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
417   to avoid returning a PLCAPI exception that might confuse users.
418 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
419 - fix build errors.  
420
421 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
422 - (Architecture) Credential format changed to match ProtoGENI xml format
423 - (Architecture) All interfaces export a new set of methods that are compatible
424    with the ProtoGeni Aggregate spec. These new methods are considered a 
425    replacement  for the pervious methods exported by the interfaces. All 
426    previous methods are still exported and work as normal, but they are 
427    considered deprecated and will not be supported in future releases.  
428 - (Architecture) SFI has been updated to use the new interface methods.
429 - (Architecture) Changed keyconvet implementation from c to python.
430 - (Architecture) Slice Manager now attempts looks for a delegated credential
431   provided by the client before using its own server credential.
432 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
433   This cache now exists only in memory and is cleared when service is restarted
434   or cache lifetime is exceeded.  
435 - (Performance) SliceManager sends request to Aggregates in parallel instead 
436   of sequentially.
437 - (Bug fix) SFA tickets now support the new rspec format.
438 - (Bug fix) SFI only uses cahced credential if they aren't expired.
439 - (Bug fix) Cerdential delegation modified to work with new credential format.
440 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
441   Aggregate instead of relaying through the Slice Manager.
442 - (Enhancement) Simplified caching. Accociated a global cache instance with
443   the api handler on every new server request, making it easier to access the 
444   cache and use in more general ways.     
445
446 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
447 - SfaServer now uses a pool of threads to handle requests concurrently
448 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
449 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
450 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
451 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
452 - Component manager does not install gid files if slice already has them  
453 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
454 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
455 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
456      
457 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
458 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
459 - - sfa-config-tty now has the same features like plc-config-tty
460 - - Contains code to support both urn and hrn
461 - - Cleaned up request_hash related stuff
462 - - SM, AM and Registry code is organized under respective managers
463 - - Site and Slice synchronization across federated aggregates
464 - - Script to generate sfa_component_config
465
466 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
467 - sfa-config-tty now has the same features like plc-config-tty
468 - Contains code to support both urn and hrn
469 - Cleaned up request_hash related stuff
470 - SM, AM and Registry code is organized under respective managers
471 - Slice synchronization across federated aggregates
472 - some bugs are fixed
473
474 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
475 - checkpoint with fewer mentions of geni
476
477 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
478 - checkpointing
479 - this is believed to pass the tests; among other things:
480 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
481
482 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
483 - This tag includes:
484 - - Sfatables
485 - - Preliminary version of hash based authentication
486 - - Initial code for Component Manager
487 - - Authority structure is moved to /var/lib/sfa/
488 - - some bug-fixes
489
490 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
491 - Create_slice and get_resources methods are connected to sfatables.
492 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
493
494 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
495 - Bug fix on update and remove_peer_object methods
496 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
497
498 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
499 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
500
501 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
502 - compatibility with RefreshPeer
503 - incremental mechanism for importing PLC records into SFA tables
504 - unified single database (still inside the underlying PLC db postgresql server)
505 - includes/improves call traceability and logging features
506 - several bug fixes
507
508 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
509 - added libxslt-python dependency
510
511 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
512 - unified single SFA database in the PLC-DB
513 - upcalls from  PLCAPI to SFA methods
514 - SFA call traceability and logging features
515 - many bug fixes
516 - includes first/rough version of sfatables for policy implementation
517
518 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
519 - snapshot after the GEC5 demo
520 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
521
522 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
523 - snapshot july 15 - has gone through superficial manual testing
524 - hopefully a good basis for gec5 demo
525 - multi-dir sfi client tested as well
526
527 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
528 - rename geniwrapper.spec into sfa.spec
529
530 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
531 - clean up in xmlrpc/soap, --protocol option to chose between both
532 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
533 - hopefully more helpful context in case of crashes when importing
534 - bugfixes for using only /etc/sfa for site-dep files
535 - bugfixes in wsdl generation
536
537 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
538 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
539 - config variables in sfa_config now start with SFA_ and not GENI_
540 - config.py can be loaded even with no config present
541
542 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
543 - first step for cleanup and reorganization
544 - mass-renaming from geni to sfa (some are still needed)
545 - sfa/trust implements the security architecture
546
547 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
548 - snapshot for reproducible builds
549
550 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
551 - snapshot for the convenience of alpha users
552
553 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
554 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
555
556 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
557 - ongoing work - snapshot for 4.3-rc9
558
559 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
560 - various fixes
561
562 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
563 - bugfixes - still a work in progress
564
565 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
566 - initial package
567
568
569 %define module_current_branch 0.2