Setting tag sfa-2.0-3
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
228 - client side revisited with a bootstrap library
229 - client side has a new source layout
230 - various (nasty) bug fixes wrt options and call_id
231
232 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
233 - various fixes in rspecs for sfav1&slice tags
234 - uses 'geni_rspec_version' and not just 'rspec_version'
235 - example flavour for the max testbed
236 - embryo for an sfa client library
237 - topology.py moved into plc
238 - sql: table is named records; record_types are enforced
239 - sql: table creation cleaned up
240
241 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
242 - cleaned up all references to SFA_*_TYPE in config
243 - enable cache at the aggregate by default
244 - registry now uses the driver in a sensible way (see managers/driver.py)
245 - slice manager supports sfav1/pgv2 neighbours
246 - get_key renamed into get_key_from_incoming_ip
247 - new sfa.storage module for record/table and all db-related stuff
248 - db schema in sfa.storage.sfa.sql
249 - init.d and cron.d move one step up
250 - cleaned up rspec/ directory
251 - add deps to pyopenssl and myplc-config
252 - start support for new API (return value)
253 - plc.remoteshell removed, use plshell instead
254 - plshell uses a 'capability' auth method whenever possible
255 - various tweaks in rspec elements
256 - made dependency on sfatables softer
257
258 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
259 - sfa should now be started *before* the initial import
260 - sfa to use its own database (default sfa) - can run without myplc
261 - server calls support optional 'options'
262 - client sends options in argument when needed
263 - fix infinite getattr recursion in elements/element.py
264 - error codes in line with geni
265
266 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
267 - fixed links and attributes in rspecs
268 - minor cleanup in the API methods, and more consistent names in manager methods
269
270 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
271 - ongoing refoactoring towards more genericity
272 - passes tests again although known issues remain with attributes/tags
273
274 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
275 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
276 - improvements in the pgv2 rspecs
277 - driver separated from api
278 - code starts moving around where it belongs
279 - sfascan caches getversion across invokations
280 - vini topology extracted as a config file
281
282 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
283 - first support for protogeni rspecs is working
284 - vini no longer needs a specific manager
285 - refactoring underway towards more flexible/generic architecture
286
287 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
288 - Unicode-friendliness for user names with accents/special chars.
289 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
290 - CreaetSliver no longer fails for users that have a capital letter in their URN.
291 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
292 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
293 - Fix bugs and missing imports     
294  
295
296 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
297 - new method record.get_field for sface
298
299 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
300 - new option -c to sfa-nuke-plc.py
301 - CreateSliver fixed for admin-only slice tags
302
303 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
304 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
305 - Fixed holes in certificate verification logic.
306 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
307 - Added 'boot_state' as an attribute of the node element in SFA rspec.
308 - Non authority certificates are marked as CA:FALSE.
309
310 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
311 - fix typo in sfa-1.0-31 tag.
312 - added CreateGid() Registry interface method.
313
314 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
315 - fix typo in sfa-1.0-30 tag
316
317 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
318 - Declare namespace and schema location in the credential.
319 - Fix bug that prevetend connections from timing out.
320 - Fix slice delegation.
321 - Add statistics to slicemaanger listresources/createsliver rspec.
322 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
323   of days a user can extend their slice expiration.
324 - CA certs are only issued to objects of type authority
325    
326 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
327 - tag 1.0-28 was broken due to typo in the changelog
328 - new class sfa/util/httpsProtocol.py that supports timeouts
329
330 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
331 - Resolved issue that caused sfa hold onto idle db connections.
332 - Fix bug that caused the registry to use the wrong type of credential.
333 - Support authority+sm type.
334 - Fix rspec merging bugs.
335 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
336 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
337  planetlab hosted initscripts using the <planetlab:initscript> tag  
338 - Can now handle extraneous whitespace in the rspec without failing.   
339  
340 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
341 - ProtoGENI v2 RSpec updates.
342 - Convert expiration timestamps with timezone info in credentials to utc.
343 - Fixed redundant logging issue. 
344 - Improved SliceManager and SFI client logging.
345 - Support aggregates that don't support the optional 'call_id' argument. 
346 - Only call get_trusted_certs() at aggreage interfaces that support the call.
347 - CreateSliver() now handles MyPLC slice attributes/tags.
348 - Cache now supports persistence.
349 - Hide whitelisted nodes.
350
351 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
352 - fixed issues with sup authority signing
353 - fixed bugs in remove_slivers and SliverStatus
354
355 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
356 - fix typo that prevented aggregates from operating properly
357
358 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
359 - load trusted certs into ssl context prior to handshake
360 - client's logfile lives in ~/.sfi/sfi.log
361
362 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
363 - includes a change on passphrases that was intended in 1.0-22
364
365 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
366 - Added support for ProtoGENI RSpec v2
367  
368 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
369 - stable sfascan
370 - fix in initscript, *ENABLED tags in config now taken into account
371
372 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
373 - some commits had not been pushed in tag 19
374
375 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
376 - GetVersion should now report full URLs with path
377 - scansfa has nicer output and new syntax (entry URLs as args and not options)
378 - dos2unix'ed flash policy pill
379
380 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
381 - fix packaging again for f8
382
383 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
384 - fix packaging (apparently broken in 1.0-16)
385 - first working version of sfascan
386 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
387 - deprecated the sfa_geni_aggregate config category
388
389 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
390 - Fix build problem
391 - First version of SFA scanner
392
393 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
394 - Add support for Flash clients using flashpolicy
395 - Fix problems with tag handling in RSpec
396
397 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
398 - Modifications to the Eucalyptus Aggregate Manager
399 - Fixes for VINI RSpec
400 - Fix tag handling for PL RSpec
401 - Fix XML Schema ordering for <urn> element
402
403 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
404 - just set x509 version to 2
405
406 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
407 - added urn to the node area in rspecs
408 - conversion to urn now exports fqdn
409 - sfa-import-plc.py now creates a unique registry record for each SFA interface
410
411 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
412 - undo broken attempt for python-2.7
413
414 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
415 - SMs avoid duplicates for when call graph has dags;
416 - just based on network's name, when a duplicate occurs, one is just dropped
417 - does not try to merge/aggregate 2 networks
418 - also reviewed logging with the hope to fix the sfa startup msg:
419 - TypeError: not all arguments converted during string formatting
420
421 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
422 - verify credentials against xsd schema
423 - Fix SM to SM communication
424 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
425 - new setting session_key_path
426
427 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
428 - fix registry credential regeneration and handle expiration
429 - support for setting slice tags (min_role=user)
430 - client can display its own version: sfi.py version --local
431 - GetVersion to provide urn in addition to hrn
432 - more code uses plxrn vs previous helper functions
433 - import replaces '+' in email addresses with '_'
434
435 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
436 - fix GetVersion code_tag and add code_url
437
438 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
439 - extend GetVersion towards minimum federation introspection, and expose local tag
440
441 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
442 - fixed some legacy issues (list vs List)
443 - deprecated sfa.util.namespace for xrn and plxrn
444 - unit tests ship as the sfa-tests rpm
445
446 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
447 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
448 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
449 - hrn-urn translations tweaked
450 - fixed 'service sfa status'
451 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
452 - started to repair sfadump - although not usable yet
453 - trust objects now have dump_string method that dump() actually prints
454 - unit tests under review
455 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
456 - binaries now support -v or -vv to increase loglevel
457 - trashed obsolete sfa.util.client
458
459 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
460 - various bugfixes and cleanup, improved/harmonized logging
461
462 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
463 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
464   to avoid returning a PLCAPI exception that might confuse users.
465 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
466 - fix build errors.  
467
468 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
469 - (Architecture) Credential format changed to match ProtoGENI xml format
470 - (Architecture) All interfaces export a new set of methods that are compatible
471    with the ProtoGeni Aggregate spec. These new methods are considered a 
472    replacement  for the pervious methods exported by the interfaces. All 
473    previous methods are still exported and work as normal, but they are 
474    considered deprecated and will not be supported in future releases.  
475 - (Architecture) SFI has been updated to use the new interface methods.
476 - (Architecture) Changed keyconvet implementation from c to python.
477 - (Architecture) Slice Manager now attempts looks for a delegated credential
478   provided by the client before using its own server credential.
479 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
480   This cache now exists only in memory and is cleared when service is restarted
481   or cache lifetime is exceeded.  
482 - (Performance) SliceManager sends request to Aggregates in parallel instead 
483   of sequentially.
484 - (Bug fix) SFA tickets now support the new rspec format.
485 - (Bug fix) SFI only uses cahced credential if they aren't expired.
486 - (Bug fix) Cerdential delegation modified to work with new credential format.
487 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
488   Aggregate instead of relaying through the Slice Manager.
489 - (Enhancement) Simplified caching. Accociated a global cache instance with
490   the api handler on every new server request, making it easier to access the 
491   cache and use in more general ways.     
492
493 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
494 - SfaServer now uses a pool of threads to handle requests concurrently
495 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
496 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
497 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
498 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
499 - Component manager does not install gid files if slice already has them  
500 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
501 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
502 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
503      
504 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
505 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
506 - - sfa-config-tty now has the same features like plc-config-tty
507 - - Contains code to support both urn and hrn
508 - - Cleaned up request_hash related stuff
509 - - SM, AM and Registry code is organized under respective managers
510 - - Site and Slice synchronization across federated aggregates
511 - - Script to generate sfa_component_config
512
513 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
514 - sfa-config-tty now has the same features like plc-config-tty
515 - Contains code to support both urn and hrn
516 - Cleaned up request_hash related stuff
517 - SM, AM and Registry code is organized under respective managers
518 - Slice synchronization across federated aggregates
519 - some bugs are fixed
520
521 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
522 - checkpoint with fewer mentions of geni
523
524 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
525 - checkpointing
526 - this is believed to pass the tests; among other things:
527 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
528
529 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
530 - This tag includes:
531 - - Sfatables
532 - - Preliminary version of hash based authentication
533 - - Initial code for Component Manager
534 - - Authority structure is moved to /var/lib/sfa/
535 - - some bug-fixes
536
537 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
538 - Create_slice and get_resources methods are connected to sfatables.
539 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
540
541 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
542 - Bug fix on update and remove_peer_object methods
543 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
544
545 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
546 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
547
548 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
549 - compatibility with RefreshPeer
550 - incremental mechanism for importing PLC records into SFA tables
551 - unified single database (still inside the underlying PLC db postgresql server)
552 - includes/improves call traceability and logging features
553 - several bug fixes
554
555 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
556 - added libxslt-python dependency
557
558 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
559 - unified single SFA database in the PLC-DB
560 - upcalls from  PLCAPI to SFA methods
561 - SFA call traceability and logging features
562 - many bug fixes
563 - includes first/rough version of sfatables for policy implementation
564
565 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
566 - snapshot after the GEC5 demo
567 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
568
569 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
570 - snapshot july 15 - has gone through superficial manual testing
571 - hopefully a good basis for gec5 demo
572 - multi-dir sfi client tested as well
573
574 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
575 - rename geniwrapper.spec into sfa.spec
576
577 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
578 - clean up in xmlrpc/soap, --protocol option to chose between both
579 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
580 - hopefully more helpful context in case of crashes when importing
581 - bugfixes for using only /etc/sfa for site-dep files
582 - bugfixes in wsdl generation
583
584 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
585 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
586 - config variables in sfa_config now start with SFA_ and not GENI_
587 - config.py can be loaded even with no config present
588
589 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
590 - first step for cleanup and reorganization
591 - mass-renaming from geni to sfa (some are still needed)
592 - sfa/trust implements the security architecture
593
594 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
595 - snapshot for reproducible builds
596
597 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
598 - snapshot for the convenience of alpha users
599
600 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
601 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
602
603 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
604 - ongoing work - snapshot for 4.3-rc9
605
606 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
607 - various fixes
608
609 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
610 - bugfixes - still a work in progress
611
612 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
613 - initial package
614
615
616 %define module_current_branch 0.2