Setting tag sfa-2.1-8
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 8
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/sfaadmin
153 %{_bindir}/keyconvert.py*
154 %{_bindir}/sfa-config-tty
155 %config /etc/sfa/default_config.xml
156 %config (noreplace) /etc/sfa/aggregates.xml
157 %config (noreplace) /etc/sfa/registries.xml
158 /usr/share/sfa/migrations
159 /usr/share/sfa/examples
160 /var/www/html/wsdl/*.wsdl
161
162 %files plc
163 %defattr(-,root,root)
164 /etc/sfa/pl.rng
165 /etc/sfa/credential.xsd
166 /etc/sfa/top.xsd
167 /etc/sfa/sig.xsd
168 /etc/sfa/xml.xsd
169 /etc/sfa/protogeni-rspec-common.xsd
170 /etc/sfa/topology
171 %{_bindir}/gen-sfa-cm-config.py*
172
173 %files client
174 %config (noreplace) /etc/sfa/sfi_config
175 %{_bindir}/sfi*.py*
176 %{_bindir}/sfi
177 %{_bindir}/get*.py*
178 %{_bindir}/setRecord.py*
179 %{_bindir}/sfascan.py*
180 %{_bindir}/sfascan
181 %{_bindir}/sfadump.py*
182
183 %files sfatables
184 /etc/sfatables/*
185 %{_bindir}/sfatables
186 %{python_sitelib}/sfatables
187
188 %files cm
189 /etc/init.d/sfa-cm
190 %{_bindir}/sfa_component_setup.py*
191 # cron jobs here 
192
193 %files flashpolicy
194 %{_bindir}/sfa_flashpolicy.py*
195 /etc/sfa/sfa_flashpolicy_config.xml
196
197 %files xmlbuilder
198 %{python_sitelib}/xmlbuilder
199
200 %files tests
201 %{_datadir}/sfa/tests
202
203 ### sfa installs the 'sfa' service
204 %post 
205 chkconfig --add sfa
206
207 %preun 
208 if [ "$1" = 0 ] ; then
209   /sbin/service sfa stop || :
210   /sbin/chkconfig --del sfa || :
211 fi
212
213 %postun
214 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
215
216 ### sfa-cm installs the 'sfa-cm' service
217 %post cm
218 chkconfig --add sfa-cm
219
220 %preun cm
221 if [ "$1" = 0 ] ; then
222    /sbin/service sfa-cm stop || :
223    /sbin/chkconfig --del sfa-cm || :
224 fi
225
226 %postun cm
227 [ "$1" -ge "1" ] && service sfa-cm restart || :
228
229 %changelog
230 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
231 - new 'void' generic_flavour for running in registry-only mode
232 - first shot at refactoring importers - probably needs more work
233 - openstack: various enhancements
234 - sfi interface to registry not based on xml files anymore
235 - sfi show sorts result on record key
236 - bugfix in sfa update on users with a pl-backed registry
237
238 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
239 - renamed sfa/plc into sfa/planetlab
240 - plxrn moved in sfa/planetlab as well
241 - bugfix for sfaadmin reg update --pi <>
242
243 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
244 - native data model now has a authority x user (PI) relationship
245 - no call to 'augment_records_with_testbed_info' for GetCredential
246 - which means, registry can now be used without an underlying testbed
247 - reviewed code about relationships b/w objects and related in pl driver
248 - reviewed PL import wrt roles and pis
249 - removed mentions to is_enabled in driver
250 - small changes in update_relation* in driver interface
251 - sfaadmin: can create authorities and attach pi users to them
252 - sfaadmin: categories can be abbreviated
253 - sfi list and sfaadmin list have a new -r/--recursive option
254 - this means that List now supports an (optional) 'options' argument
255 - sfi config can display config vars
256 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
257
258 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
259 - make sync now supports vserver or lxc.
260 - Added slice expiration and login info to SliverStatus response. 
261 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
262   the 'component_name' attribute.
263 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
264   
265 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
266 - Introduced new administrative command line script, sfaadmin.py. Removed various single
267  purpose scripts and migrated their functionality into sfaadmin.py.
268 - Refactored Registry import scripts.
269 - Removed SQLAlchemy dependency from sfi.py.
270 - Fixed bugs in sfi.py
271 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
272
273 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
274 - slice x researcher rel. in database,
275 - plimporter to maintain that, as well as user.email, and more robust
276 - ongoing draft for sfaadmin tool
277 - support for a federica driver
278 - support for a nova/euca driver
279 - no more sfa-clean-peer-records script
280
281 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
282 - registry database has user's keys and mail (known as v0 for migrate)
283 - pl importer properly maintains user's keys and mail
284 - pl driver now to handle 'role' when adding person record (exp.)
285 - first draft of federica driver with config section
286 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
287 - plus, from master as of tag merged-in-sfa-2.1-2:
288 - disk_image revisited
289 - new nova_shell nova_driver & various tweaks for openstack
290
291 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
292 - uses sqlalchemy and related migrate
293 - thorough migration and upgrade scheme
294 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
295 - trashed dbinfo stuff in auth hierarchy
296 - data model still has little more than plain records
297 - checkpoint tag, not yet intended for release
298
299 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
300 - client: added -R --raw sfi cmdline option that displays raw server response.
301 - client: request GENI RSpec by default. 
302 - server: remove database dependencies from sfa.server.sfaapi.
303 - server: increased default credential lifetime to 31 days.
304 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
305 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
306 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
307  
308 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
309 - bugfix: 'geni_api' should be in the top level struct, not the code struct
310 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
311           output returned by the Aggregate Manager.
312 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
313 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
314 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
315           there is extra whitespace in the schemaLocation field.
316 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
317           advertisement rspecs.
318 - bugfix: <login> RSpec element should contain the 'username' attribute.
319 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
320  
321 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
322 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
323   exit when it encountered a user with an invalid public key.
324 - server: imporved logging in sfa-import-plc.py
325  
326 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
327 - bugfix: Fixed appending public keys in CreateSliver
328 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
329 - client: -c --current option allows users to request the current/uncached rspec.
330 - server: Added 'geni_api_versions' field to GetVersion() output.
331 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
332    
333 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
334 - bugfix: sfi was not sending call_id with ListResources to v2 servers
335 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
336 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
337
338 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
339 - client: sfi -a / -p deprecated (use -s instead)
340 - client: sfi cleaned up
341 - client: sfi has backward support for APIv1 aggregates again
342 - server: only APIv2 is supported and should be rather strict
343 - server: settings for turning on/off caching in sm or am
344 - server: plc-dependant code has moved from aggregate to pldriver
345 - server: driver interface extended accordingly
346
347 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
348 - screwed up previous tag
349
350 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
351 - client side revisited with a bootstrap library
352 - client side has a new source layout
353 - various (nasty) bug fixes wrt options and call_id
354
355 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
356 - various fixes in rspecs for sfav1&slice tags
357 - uses 'geni_rspec_version' and not just 'rspec_version'
358 - example flavour for the max testbed
359 - embryo for an sfa client library
360 - topology.py moved into plc
361 - sql: table is named records; record_types are enforced
362 - sql: table creation cleaned up
363
364 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
365 - cleaned up all references to SFA_*_TYPE in config
366 - enable cache at the aggregate by default
367 - registry now uses the driver in a sensible way (see managers/driver.py)
368 - slice manager supports sfav1/pgv2 neighbours
369 - get_key renamed into get_key_from_incoming_ip
370 - new sfa.storage module for record/table and all db-related stuff
371 - db schema in sfa.storage.sfa.sql
372 - init.d and cron.d move one step up
373 - cleaned up rspec/ directory
374 - add deps to pyopenssl and myplc-config
375 - start support for new API (return value)
376 - plc.remoteshell removed, use plshell instead
377 - plshell uses a 'capability' auth method whenever possible
378 - various tweaks in rspec elements
379 - made dependency on sfatables softer
380
381 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
382 - sfa should now be started *before* the initial import
383 - sfa to use its own database (default sfa) - can run without myplc
384 - server calls support optional 'options'
385 - client sends options in argument when needed
386 - fix infinite getattr recursion in elements/element.py
387 - error codes in line with geni
388
389 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
390 - fixed links and attributes in rspecs
391 - minor cleanup in the API methods, and more consistent names in manager methods
392
393 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
394 - ongoing refoactoring towards more genericity
395 - passes tests again although known issues remain with attributes/tags
396
397 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
398 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
399 - improvements in the pgv2 rspecs
400 - driver separated from api
401 - code starts moving around where it belongs
402 - sfascan caches getversion across invokations
403 - vini topology extracted as a config file
404
405 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
406 - first support for protogeni rspecs is working
407 - vini no longer needs a specific manager
408 - refactoring underway towards more flexible/generic architecture
409
410 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
411 - Unicode-friendliness for user names with accents/special chars.
412 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
413 - CreaetSliver no longer fails for users that have a capital letter in their URN.
414 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
415 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
416 - Fix bugs and missing imports     
417  
418
419 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
420 - new method record.get_field for sface
421
422 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
423 - new option -c to sfa-nuke-plc.py
424 - CreateSliver fixed for admin-only slice tags
425
426 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
427 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
428 - Fixed holes in certificate verification logic.
429 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
430 - Added 'boot_state' as an attribute of the node element in SFA rspec.
431 - Non authority certificates are marked as CA:FALSE.
432
433 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
434 - fix typo in sfa-1.0-31 tag.
435 - added CreateGid() Registry interface method.
436
437 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
438 - fix typo in sfa-1.0-30 tag
439
440 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
441 - Declare namespace and schema location in the credential.
442 - Fix bug that prevetend connections from timing out.
443 - Fix slice delegation.
444 - Add statistics to slicemaanger listresources/createsliver rspec.
445 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
446   of days a user can extend their slice expiration.
447 - CA certs are only issued to objects of type authority
448    
449 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
450 - tag 1.0-28 was broken due to typo in the changelog
451 - new class sfa/util/httpsProtocol.py that supports timeouts
452
453 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
454 - Resolved issue that caused sfa hold onto idle db connections.
455 - Fix bug that caused the registry to use the wrong type of credential.
456 - Support authority+sm type.
457 - Fix rspec merging bugs.
458 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
459 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
460  planetlab hosted initscripts using the <planetlab:initscript> tag  
461 - Can now handle extraneous whitespace in the rspec without failing.   
462  
463 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
464 - ProtoGENI v2 RSpec updates.
465 - Convert expiration timestamps with timezone info in credentials to utc.
466 - Fixed redundant logging issue. 
467 - Improved SliceManager and SFI client logging.
468 - Support aggregates that don't support the optional 'call_id' argument. 
469 - Only call get_trusted_certs() at aggreage interfaces that support the call.
470 - CreateSliver() now handles MyPLC slice attributes/tags.
471 - Cache now supports persistence.
472 - Hide whitelisted nodes.
473
474 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
475 - fixed issues with sup authority signing
476 - fixed bugs in remove_slivers and SliverStatus
477
478 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
479 - fix typo that prevented aggregates from operating properly
480
481 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
482 - load trusted certs into ssl context prior to handshake
483 - client's logfile lives in ~/.sfi/sfi.log
484
485 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
486 - includes a change on passphrases that was intended in 1.0-22
487
488 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
489 - Added support for ProtoGENI RSpec v2
490  
491 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
492 - stable sfascan
493 - fix in initscript, *ENABLED tags in config now taken into account
494
495 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
496 - some commits had not been pushed in tag 19
497
498 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
499 - GetVersion should now report full URLs with path
500 - scansfa has nicer output and new syntax (entry URLs as args and not options)
501 - dos2unix'ed flash policy pill
502
503 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
504 - fix packaging again for f8
505
506 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
507 - fix packaging (apparently broken in 1.0-16)
508 - first working version of sfascan
509 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
510 - deprecated the sfa_geni_aggregate config category
511
512 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
513 - Fix build problem
514 - First version of SFA scanner
515
516 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
517 - Add support for Flash clients using flashpolicy
518 - Fix problems with tag handling in RSpec
519
520 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
521 - Modifications to the Eucalyptus Aggregate Manager
522 - Fixes for VINI RSpec
523 - Fix tag handling for PL RSpec
524 - Fix XML Schema ordering for <urn> element
525
526 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
527 - just set x509 version to 2
528
529 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
530 - added urn to the node area in rspecs
531 - conversion to urn now exports fqdn
532 - sfa-import-plc.py now creates a unique registry record for each SFA interface
533
534 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
535 - undo broken attempt for python-2.7
536
537 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
538 - SMs avoid duplicates for when call graph has dags;
539 - just based on network's name, when a duplicate occurs, one is just dropped
540 - does not try to merge/aggregate 2 networks
541 - also reviewed logging with the hope to fix the sfa startup msg:
542 - TypeError: not all arguments converted during string formatting
543
544 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
545 - verify credentials against xsd schema
546 - Fix SM to SM communication
547 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
548 - new setting session_key_path
549
550 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
551 - fix registry credential regeneration and handle expiration
552 - support for setting slice tags (min_role=user)
553 - client can display its own version: sfi.py version --local
554 - GetVersion to provide urn in addition to hrn
555 - more code uses plxrn vs previous helper functions
556 - import replaces '+' in email addresses with '_'
557
558 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
559 - fix GetVersion code_tag and add code_url
560
561 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
562 - extend GetVersion towards minimum federation introspection, and expose local tag
563
564 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
565 - fixed some legacy issues (list vs List)
566 - deprecated sfa.util.namespace for xrn and plxrn
567 - unit tests ship as the sfa-tests rpm
568
569 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
570 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
571 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
572 - hrn-urn translations tweaked
573 - fixed 'service sfa status'
574 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
575 - started to repair sfadump - although not usable yet
576 - trust objects now have dump_string method that dump() actually prints
577 - unit tests under review
578 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
579 - binaries now support -v or -vv to increase loglevel
580 - trashed obsolete sfa.util.client
581
582 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
583 - various bugfixes and cleanup, improved/harmonized logging
584
585 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
586 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
587   to avoid returning a PLCAPI exception that might confuse users.
588 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
589 - fix build errors.  
590
591 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
592 - (Architecture) Credential format changed to match ProtoGENI xml format
593 - (Architecture) All interfaces export a new set of methods that are compatible
594    with the ProtoGeni Aggregate spec. These new methods are considered a 
595    replacement  for the pervious methods exported by the interfaces. All 
596    previous methods are still exported and work as normal, but they are 
597    considered deprecated and will not be supported in future releases.  
598 - (Architecture) SFI has been updated to use the new interface methods.
599 - (Architecture) Changed keyconvet implementation from c to python.
600 - (Architecture) Slice Manager now attempts looks for a delegated credential
601   provided by the client before using its own server credential.
602 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
603   This cache now exists only in memory and is cleared when service is restarted
604   or cache lifetime is exceeded.  
605 - (Performance) SliceManager sends request to Aggregates in parallel instead 
606   of sequentially.
607 - (Bug fix) SFA tickets now support the new rspec format.
608 - (Bug fix) SFI only uses cahced credential if they aren't expired.
609 - (Bug fix) Cerdential delegation modified to work with new credential format.
610 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
611   Aggregate instead of relaying through the Slice Manager.
612 - (Enhancement) Simplified caching. Accociated a global cache instance with
613   the api handler on every new server request, making it easier to access the 
614   cache and use in more general ways.     
615
616 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
617 - SfaServer now uses a pool of threads to handle requests concurrently
618 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
619 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
620 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
621 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
622 - Component manager does not install gid files if slice already has them  
623 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
624 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
625 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
626      
627 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
628 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
629 - - sfa-config-tty now has the same features like plc-config-tty
630 - - Contains code to support both urn and hrn
631 - - Cleaned up request_hash related stuff
632 - - SM, AM and Registry code is organized under respective managers
633 - - Site and Slice synchronization across federated aggregates
634 - - Script to generate sfa_component_config
635
636 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
637 - sfa-config-tty now has the same features like plc-config-tty
638 - Contains code to support both urn and hrn
639 - Cleaned up request_hash related stuff
640 - SM, AM and Registry code is organized under respective managers
641 - Slice synchronization across federated aggregates
642 - some bugs are fixed
643
644 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
645 - checkpoint with fewer mentions of geni
646
647 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
648 - checkpointing
649 - this is believed to pass the tests; among other things:
650 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
651
652 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
653 - This tag includes:
654 - - Sfatables
655 - - Preliminary version of hash based authentication
656 - - Initial code for Component Manager
657 - - Authority structure is moved to /var/lib/sfa/
658 - - some bug-fixes
659
660 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
661 - Create_slice and get_resources methods are connected to sfatables.
662 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
663
664 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
665 - Bug fix on update and remove_peer_object methods
666 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
667
668 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
669 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
670
671 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
672 - compatibility with RefreshPeer
673 - incremental mechanism for importing PLC records into SFA tables
674 - unified single database (still inside the underlying PLC db postgresql server)
675 - includes/improves call traceability and logging features
676 - several bug fixes
677
678 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
679 - added libxslt-python dependency
680
681 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
682 - unified single SFA database in the PLC-DB
683 - upcalls from  PLCAPI to SFA methods
684 - SFA call traceability and logging features
685 - many bug fixes
686 - includes first/rough version of sfatables for policy implementation
687
688 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
689 - snapshot after the GEC5 demo
690 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
691
692 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
693 - snapshot july 15 - has gone through superficial manual testing
694 - hopefully a good basis for gec5 demo
695 - multi-dir sfi client tested as well
696
697 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
698 - rename geniwrapper.spec into sfa.spec
699
700 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
701 - clean up in xmlrpc/soap, --protocol option to chose between both
702 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
703 - hopefully more helpful context in case of crashes when importing
704 - bugfixes for using only /etc/sfa for site-dep files
705 - bugfixes in wsdl generation
706
707 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
708 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
709 - config variables in sfa_config now start with SFA_ and not GENI_
710 - config.py can be loaded even with no config present
711
712 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
713 - first step for cleanup and reorganization
714 - mass-renaming from geni to sfa (some are still needed)
715 - sfa/trust implements the security architecture
716
717 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
718 - snapshot for reproducible builds
719
720 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
721 - snapshot for the convenience of alpha users
722
723 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
724 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
725
726 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
727 - ongoing work - snapshot for 4.3-rc9
728
729 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
730 - various fixes
731
732 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
733 - bugfixes - still a work in progress
734
735 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
736 - initial package
737
738
739 %define module_current_branch 0.2