removed sfa-clean-peer-records.py
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/gen-sfa-cm-config.py*
167 %{_bindir}/sfa-ca.py*
168
169 %files client
170 %config (noreplace) /etc/sfa/sfi_config
171 %{_bindir}/sfi*.py*
172 %{_bindir}/sfi
173 %{_bindir}/get*.py*
174 %{_bindir}/setRecord.py*
175 %{_bindir}/sfascan.py*
176 %{_bindir}/sfascan
177 %{_bindir}/sfadump.py*
178
179 %files sfatables
180 /etc/sfatables/*
181 %{_bindir}/sfatables
182 %{python_sitelib}/sfatables
183
184 %files cm
185 /etc/init.d/sfa-cm
186 %{_bindir}/sfa_component_setup.py*
187 # cron jobs here 
188
189 %files flashpolicy
190 %{_bindir}/sfa_flashpolicy.py*
191 /etc/sfa/sfa_flashpolicy_config.xml
192
193 %files xmlbuilder
194 %{python_sitelib}/xmlbuilder
195
196 %files tests
197 %{_datadir}/sfa/tests
198
199 ### sfa-plc installs the 'sfa' service
200 %post plc
201 chkconfig --add sfa
202
203 %preun plc
204 if [ "$1" = 0 ] ; then
205   /sbin/service sfa stop || :
206   /sbin/chkconfig --del sfa || :
207 fi
208
209 %postun plc
210 [ "$1" -ge "1" ] && service sfa restart
211
212 ### sfa-cm installs the 'sfa-cm' service
213 %post cm
214 chkconfig --add sfa-cm
215
216 %preun cm
217 if [ "$1" = 0 ] ; then
218    /sbin/service sfa-cm stop || :
219    /sbin/chkconfig --del sfa-cm || :
220 fi
221
222 %postun cm
223 [ "$1" -ge "1" ] && service sfa-cm restart || :
224
225 %changelog
226 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
227 - client: added -R --raw sfi cmdline option that displays raw server response.
228 - client: request GENI RSpec by default. 
229 - server: remove database dependencies from sfa.server.sfaapi.
230 - server: increased default credential lifetime to 31 days.
231 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
232 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
233 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
234  
235 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
236 - bugfix: 'geni_api' should be in the top level struct, not the code struct
237 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
238           output returned by the Aggregate Manager.
239 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
240 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
241 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
242           there is extra whitespace in the schemaLocation field.
243 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
244           advertisement rspecs.
245 - bugfix: <login> RSpec element should contain the 'username' attribute.
246 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
247  
248 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
249 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
250   exit when it encountered a user with an invalid public key.
251 - server: imporved logging in sfa-import-plc.py
252  
253 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
254 - bugfix: Fixed appending public keys in CreateSliver
255 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
256 - client: -c --current option allows users to request the current/uncached rspec.
257 - server: Added 'geni_api_versions' field to GetVersion() output.
258 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
259    
260 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
261 - bugfix: sfi was not sending call_id with ListResources to v2 servers
262 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
263 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
264
265 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
266 - client: sfi -a / -p deprecated (use -s instead)
267 - client: sfi cleaned up
268 - client: sfi has backward support for APIv1 aggregates again
269 - server: only APIv2 is supported and should be rather strict
270 - server: settings for turning on/off caching in sm or am
271 - server: plc-dependant code has moved from aggregate to pldriver
272 - server: driver interface extended accordingly
273
274 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
275 - screwed up previous tag
276
277 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
278 - client side revisited with a bootstrap library
279 - client side has a new source layout
280 - various (nasty) bug fixes wrt options and call_id
281
282 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
283 - various fixes in rspecs for sfav1&slice tags
284 - uses 'geni_rspec_version' and not just 'rspec_version'
285 - example flavour for the max testbed
286 - embryo for an sfa client library
287 - topology.py moved into plc
288 - sql: table is named records; record_types are enforced
289 - sql: table creation cleaned up
290
291 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
292 - cleaned up all references to SFA_*_TYPE in config
293 - enable cache at the aggregate by default
294 - registry now uses the driver in a sensible way (see managers/driver.py)
295 - slice manager supports sfav1/pgv2 neighbours
296 - get_key renamed into get_key_from_incoming_ip
297 - new sfa.storage module for record/table and all db-related stuff
298 - db schema in sfa.storage.sfa.sql
299 - init.d and cron.d move one step up
300 - cleaned up rspec/ directory
301 - add deps to pyopenssl and myplc-config
302 - start support for new API (return value)
303 - plc.remoteshell removed, use plshell instead
304 - plshell uses a 'capability' auth method whenever possible
305 - various tweaks in rspec elements
306 - made dependency on sfatables softer
307
308 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
309 - sfa should now be started *before* the initial import
310 - sfa to use its own database (default sfa) - can run without myplc
311 - server calls support optional 'options'
312 - client sends options in argument when needed
313 - fix infinite getattr recursion in elements/element.py
314 - error codes in line with geni
315
316 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
317 - fixed links and attributes in rspecs
318 - minor cleanup in the API methods, and more consistent names in manager methods
319
320 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
321 - ongoing refoactoring towards more genericity
322 - passes tests again although known issues remain with attributes/tags
323
324 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
325 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
326 - improvements in the pgv2 rspecs
327 - driver separated from api
328 - code starts moving around where it belongs
329 - sfascan caches getversion across invokations
330 - vini topology extracted as a config file
331
332 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
333 - first support for protogeni rspecs is working
334 - vini no longer needs a specific manager
335 - refactoring underway towards more flexible/generic architecture
336
337 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
338 - Unicode-friendliness for user names with accents/special chars.
339 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
340 - CreaetSliver no longer fails for users that have a capital letter in their URN.
341 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
342 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
343 - Fix bugs and missing imports     
344  
345
346 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
347 - new method record.get_field for sface
348
349 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
350 - new option -c to sfa-nuke-plc.py
351 - CreateSliver fixed for admin-only slice tags
352
353 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
354 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
355 - Fixed holes in certificate verification logic.
356 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
357 - Added 'boot_state' as an attribute of the node element in SFA rspec.
358 - Non authority certificates are marked as CA:FALSE.
359
360 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
361 - fix typo in sfa-1.0-31 tag.
362 - added CreateGid() Registry interface method.
363
364 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
365 - fix typo in sfa-1.0-30 tag
366
367 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
368 - Declare namespace and schema location in the credential.
369 - Fix bug that prevetend connections from timing out.
370 - Fix slice delegation.
371 - Add statistics to slicemaanger listresources/createsliver rspec.
372 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
373   of days a user can extend their slice expiration.
374 - CA certs are only issued to objects of type authority
375    
376 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
377 - tag 1.0-28 was broken due to typo in the changelog
378 - new class sfa/util/httpsProtocol.py that supports timeouts
379
380 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
381 - Resolved issue that caused sfa hold onto idle db connections.
382 - Fix bug that caused the registry to use the wrong type of credential.
383 - Support authority+sm type.
384 - Fix rspec merging bugs.
385 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
386 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
387  planetlab hosted initscripts using the <planetlab:initscript> tag  
388 - Can now handle extraneous whitespace in the rspec without failing.   
389  
390 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
391 - ProtoGENI v2 RSpec updates.
392 - Convert expiration timestamps with timezone info in credentials to utc.
393 - Fixed redundant logging issue. 
394 - Improved SliceManager and SFI client logging.
395 - Support aggregates that don't support the optional 'call_id' argument. 
396 - Only call get_trusted_certs() at aggreage interfaces that support the call.
397 - CreateSliver() now handles MyPLC slice attributes/tags.
398 - Cache now supports persistence.
399 - Hide whitelisted nodes.
400
401 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
402 - fixed issues with sup authority signing
403 - fixed bugs in remove_slivers and SliverStatus
404
405 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
406 - fix typo that prevented aggregates from operating properly
407
408 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
409 - load trusted certs into ssl context prior to handshake
410 - client's logfile lives in ~/.sfi/sfi.log
411
412 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
413 - includes a change on passphrases that was intended in 1.0-22
414
415 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
416 - Added support for ProtoGENI RSpec v2
417  
418 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
419 - stable sfascan
420 - fix in initscript, *ENABLED tags in config now taken into account
421
422 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
423 - some commits had not been pushed in tag 19
424
425 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
426 - GetVersion should now report full URLs with path
427 - scansfa has nicer output and new syntax (entry URLs as args and not options)
428 - dos2unix'ed flash policy pill
429
430 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
431 - fix packaging again for f8
432
433 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
434 - fix packaging (apparently broken in 1.0-16)
435 - first working version of sfascan
436 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
437 - deprecated the sfa_geni_aggregate config category
438
439 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
440 - Fix build problem
441 - First version of SFA scanner
442
443 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
444 - Add support for Flash clients using flashpolicy
445 - Fix problems with tag handling in RSpec
446
447 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
448 - Modifications to the Eucalyptus Aggregate Manager
449 - Fixes for VINI RSpec
450 - Fix tag handling for PL RSpec
451 - Fix XML Schema ordering for <urn> element
452
453 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
454 - just set x509 version to 2
455
456 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
457 - added urn to the node area in rspecs
458 - conversion to urn now exports fqdn
459 - sfa-import-plc.py now creates a unique registry record for each SFA interface
460
461 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
462 - undo broken attempt for python-2.7
463
464 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
465 - SMs avoid duplicates for when call graph has dags;
466 - just based on network's name, when a duplicate occurs, one is just dropped
467 - does not try to merge/aggregate 2 networks
468 - also reviewed logging with the hope to fix the sfa startup msg:
469 - TypeError: not all arguments converted during string formatting
470
471 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
472 - verify credentials against xsd schema
473 - Fix SM to SM communication
474 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
475 - new setting session_key_path
476
477 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
478 - fix registry credential regeneration and handle expiration
479 - support for setting slice tags (min_role=user)
480 - client can display its own version: sfi.py version --local
481 - GetVersion to provide urn in addition to hrn
482 - more code uses plxrn vs previous helper functions
483 - import replaces '+' in email addresses with '_'
484
485 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
486 - fix GetVersion code_tag and add code_url
487
488 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
489 - extend GetVersion towards minimum federation introspection, and expose local tag
490
491 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
492 - fixed some legacy issues (list vs List)
493 - deprecated sfa.util.namespace for xrn and plxrn
494 - unit tests ship as the sfa-tests rpm
495
496 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
497 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
498 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
499 - hrn-urn translations tweaked
500 - fixed 'service sfa status'
501 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
502 - started to repair sfadump - although not usable yet
503 - trust objects now have dump_string method that dump() actually prints
504 - unit tests under review
505 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
506 - binaries now support -v or -vv to increase loglevel
507 - trashed obsolete sfa.util.client
508
509 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
510 - various bugfixes and cleanup, improved/harmonized logging
511
512 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
513 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
514   to avoid returning a PLCAPI exception that might confuse users.
515 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
516 - fix build errors.  
517
518 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
519 - (Architecture) Credential format changed to match ProtoGENI xml format
520 - (Architecture) All interfaces export a new set of methods that are compatible
521    with the ProtoGeni Aggregate spec. These new methods are considered a 
522    replacement  for the pervious methods exported by the interfaces. All 
523    previous methods are still exported and work as normal, but they are 
524    considered deprecated and will not be supported in future releases.  
525 - (Architecture) SFI has been updated to use the new interface methods.
526 - (Architecture) Changed keyconvet implementation from c to python.
527 - (Architecture) Slice Manager now attempts looks for a delegated credential
528   provided by the client before using its own server credential.
529 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
530   This cache now exists only in memory and is cleared when service is restarted
531   or cache lifetime is exceeded.  
532 - (Performance) SliceManager sends request to Aggregates in parallel instead 
533   of sequentially.
534 - (Bug fix) SFA tickets now support the new rspec format.
535 - (Bug fix) SFI only uses cahced credential if they aren't expired.
536 - (Bug fix) Cerdential delegation modified to work with new credential format.
537 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
538   Aggregate instead of relaying through the Slice Manager.
539 - (Enhancement) Simplified caching. Accociated a global cache instance with
540   the api handler on every new server request, making it easier to access the 
541   cache and use in more general ways.     
542
543 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
544 - SfaServer now uses a pool of threads to handle requests concurrently
545 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
546 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
547 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
548 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
549 - Component manager does not install gid files if slice already has them  
550 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
551 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
552 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
553      
554 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
555 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
556 - - sfa-config-tty now has the same features like plc-config-tty
557 - - Contains code to support both urn and hrn
558 - - Cleaned up request_hash related stuff
559 - - SM, AM and Registry code is organized under respective managers
560 - - Site and Slice synchronization across federated aggregates
561 - - Script to generate sfa_component_config
562
563 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
564 - sfa-config-tty now has the same features like plc-config-tty
565 - Contains code to support both urn and hrn
566 - Cleaned up request_hash related stuff
567 - SM, AM and Registry code is organized under respective managers
568 - Slice synchronization across federated aggregates
569 - some bugs are fixed
570
571 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
572 - checkpoint with fewer mentions of geni
573
574 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
575 - checkpointing
576 - this is believed to pass the tests; among other things:
577 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
578
579 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
580 - This tag includes:
581 - - Sfatables
582 - - Preliminary version of hash based authentication
583 - - Initial code for Component Manager
584 - - Authority structure is moved to /var/lib/sfa/
585 - - some bug-fixes
586
587 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
588 - Create_slice and get_resources methods are connected to sfatables.
589 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
590
591 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
592 - Bug fix on update and remove_peer_object methods
593 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
594
595 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
596 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
597
598 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
599 - compatibility with RefreshPeer
600 - incremental mechanism for importing PLC records into SFA tables
601 - unified single database (still inside the underlying PLC db postgresql server)
602 - includes/improves call traceability and logging features
603 - several bug fixes
604
605 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
606 - added libxslt-python dependency
607
608 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
609 - unified single SFA database in the PLC-DB
610 - upcalls from  PLCAPI to SFA methods
611 - SFA call traceability and logging features
612 - many bug fixes
613 - includes first/rough version of sfatables for policy implementation
614
615 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
616 - snapshot after the GEC5 demo
617 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
618
619 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
620 - snapshot july 15 - has gone through superficial manual testing
621 - hopefully a good basis for gec5 demo
622 - multi-dir sfi client tested as well
623
624 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
625 - rename geniwrapper.spec into sfa.spec
626
627 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
628 - clean up in xmlrpc/soap, --protocol option to chose between both
629 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
630 - hopefully more helpful context in case of crashes when importing
631 - bugfixes for using only /etc/sfa for site-dep files
632 - bugfixes in wsdl generation
633
634 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
635 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
636 - config variables in sfa_config now start with SFA_ and not GENI_
637 - config.py can be loaded even with no config present
638
639 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
640 - first step for cleanup and reorganization
641 - mass-renaming from geni to sfa (some are still needed)
642 - sfa/trust implements the security architecture
643
644 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
645 - snapshot for reproducible builds
646
647 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
648 - snapshot for the convenience of alpha users
649
650 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
651 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
652
653 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
654 - ongoing work - snapshot for 4.3-rc9
655
656 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
657 - various fixes
658
659 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
660 - bugfixes - still a work in progress
661
662 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
663 - initial package
664
665
666 %define module_current_branch 0.2