Setting tag sfa-2.1-5
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/keyconvert.py*
153 %{_bindir}/sfa-config-tty
154 %config /etc/sfa/default_config.xml
155 %config (noreplace) /etc/sfa/aggregates.xml
156 %config (noreplace) /etc/sfa/registries.xml
157 /usr/share/sfa/migrations
158 /usr/share/sfa/examples
159 /var/www/html/wsdl/*.wsdl
160
161 %files plc
162 %defattr(-,root,root)
163 /etc/sfa/pl.rng
164 /etc/sfa/credential.xsd
165 /etc/sfa/top.xsd
166 /etc/sfa/sig.xsd
167 /etc/sfa/xml.xsd
168 /etc/sfa/protogeni-rspec-common.xsd
169 /etc/sfa/topology
170 %{_bindir}/gen-sfa-cm-config.py*
171
172 %files client
173 %config (noreplace) /etc/sfa/sfi_config
174 %{_bindir}/sfi*.py*
175 %{_bindir}/sfi
176 %{_bindir}/get*.py*
177 %{_bindir}/setRecord.py*
178 %{_bindir}/sfascan.py*
179 %{_bindir}/sfascan
180 %{_bindir}/sfadump.py*
181
182 %files sfatables
183 /etc/sfatables/*
184 %{_bindir}/sfatables
185 %{python_sitelib}/sfatables
186
187 %files cm
188 /etc/init.d/sfa-cm
189 %{_bindir}/sfa_component_setup.py*
190 # cron jobs here 
191
192 %files flashpolicy
193 %{_bindir}/sfa_flashpolicy.py*
194 /etc/sfa/sfa_flashpolicy_config.xml
195
196 %files xmlbuilder
197 %{python_sitelib}/xmlbuilder
198
199 %files tests
200 %{_datadir}/sfa/tests
201
202 ### sfa installs the 'sfa' service
203 %post 
204 chkconfig --add sfa
205
206 %preun 
207 if [ "$1" = 0 ] ; then
208   /sbin/service sfa stop || :
209   /sbin/chkconfig --del sfa || :
210 fi
211
212 %postun
213 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
214
215 ### sfa-cm installs the 'sfa-cm' service
216 %post cm
217 chkconfig --add sfa-cm
218
219 %preun cm
220 if [ "$1" = 0 ] ; then
221    /sbin/service sfa-cm stop || :
222    /sbin/chkconfig --del sfa-cm || :
223 fi
224
225 %postun cm
226 [ "$1" -ge "1" ] && service sfa-cm restart || :
227
228 %changelog
229 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
230 - make sync now supports vserver or lxc.
231 - Added slice expiration and login info to SliverStatus response. 
232 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
233   the 'component_name' attribute.
234 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
235   
236 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
237 - Introduced new administrative command line script, sfaadmin.py. Removed various single
238  purpose scripts and migrated their functionality into sfaadmin.py.
239 - Refactored Registry import scripts.
240 - Removed SQLAlchemy dependency from sfi.py.
241 - Fixed bugs in sfi.py
242 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
243
244 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
245 - slice x researcher rel. in database,
246 - plimporter to maintain that, as well as user.email, and more robust
247 - ongoing draft for sfaadmin tool
248 - support for a federica driver
249 - support for a nova/euca driver
250 - no more sfa-clean-peer-records script
251
252 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
253 - registry database has user's keys and mail (known as v0 for migrate)
254 - pl importer properly maintains user's keys and mail
255 - pl driver now to handle 'role' when adding person record (exp.)
256 - first draft of federica driver with config section
257 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
258 - plus, from master as of tag merged-in-sfa-2.1-2:
259 - disk_image revisited
260 - new nova_shell nova_driver & various tweaks for openstack
261
262 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
263 - uses sqlalchemy and related migrate
264 - thorough migration and upgrade scheme
265 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
266 - trashed dbinfo stuff in auth hierarchy
267 - data model still has little more than plain records
268 - checkpoint tag, not yet intended for release
269
270 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
271 - client: added -R --raw sfi cmdline option that displays raw server response.
272 - client: request GENI RSpec by default. 
273 - server: remove database dependencies from sfa.server.sfaapi.
274 - server: increased default credential lifetime to 31 days.
275 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
276 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
277 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
278  
279 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
280 - bugfix: 'geni_api' should be in the top level struct, not the code struct
281 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
282           output returned by the Aggregate Manager.
283 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
284 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
285 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
286           there is extra whitespace in the schemaLocation field.
287 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
288           advertisement rspecs.
289 - bugfix: <login> RSpec element should contain the 'username' attribute.
290 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
291  
292 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
293 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
294   exit when it encountered a user with an invalid public key.
295 - server: imporved logging in sfa-import-plc.py
296  
297 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
298 - bugfix: Fixed appending public keys in CreateSliver
299 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
300 - client: -c --current option allows users to request the current/uncached rspec.
301 - server: Added 'geni_api_versions' field to GetVersion() output.
302 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
303    
304 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
305 - bugfix: sfi was not sending call_id with ListResources to v2 servers
306 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
307 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
308
309 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
310 - client: sfi -a / -p deprecated (use -s instead)
311 - client: sfi cleaned up
312 - client: sfi has backward support for APIv1 aggregates again
313 - server: only APIv2 is supported and should be rather strict
314 - server: settings for turning on/off caching in sm or am
315 - server: plc-dependant code has moved from aggregate to pldriver
316 - server: driver interface extended accordingly
317
318 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
319 - screwed up previous tag
320
321 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
322 - client side revisited with a bootstrap library
323 - client side has a new source layout
324 - various (nasty) bug fixes wrt options and call_id
325
326 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
327 - various fixes in rspecs for sfav1&slice tags
328 - uses 'geni_rspec_version' and not just 'rspec_version'
329 - example flavour for the max testbed
330 - embryo for an sfa client library
331 - topology.py moved into plc
332 - sql: table is named records; record_types are enforced
333 - sql: table creation cleaned up
334
335 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
336 - cleaned up all references to SFA_*_TYPE in config
337 - enable cache at the aggregate by default
338 - registry now uses the driver in a sensible way (see managers/driver.py)
339 - slice manager supports sfav1/pgv2 neighbours
340 - get_key renamed into get_key_from_incoming_ip
341 - new sfa.storage module for record/table and all db-related stuff
342 - db schema in sfa.storage.sfa.sql
343 - init.d and cron.d move one step up
344 - cleaned up rspec/ directory
345 - add deps to pyopenssl and myplc-config
346 - start support for new API (return value)
347 - plc.remoteshell removed, use plshell instead
348 - plshell uses a 'capability' auth method whenever possible
349 - various tweaks in rspec elements
350 - made dependency on sfatables softer
351
352 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
353 - sfa should now be started *before* the initial import
354 - sfa to use its own database (default sfa) - can run without myplc
355 - server calls support optional 'options'
356 - client sends options in argument when needed
357 - fix infinite getattr recursion in elements/element.py
358 - error codes in line with geni
359
360 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
361 - fixed links and attributes in rspecs
362 - minor cleanup in the API methods, and more consistent names in manager methods
363
364 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
365 - ongoing refoactoring towards more genericity
366 - passes tests again although known issues remain with attributes/tags
367
368 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
369 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
370 - improvements in the pgv2 rspecs
371 - driver separated from api
372 - code starts moving around where it belongs
373 - sfascan caches getversion across invokations
374 - vini topology extracted as a config file
375
376 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
377 - first support for protogeni rspecs is working
378 - vini no longer needs a specific manager
379 - refactoring underway towards more flexible/generic architecture
380
381 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
382 - Unicode-friendliness for user names with accents/special chars.
383 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
384 - CreaetSliver no longer fails for users that have a capital letter in their URN.
385 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
386 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
387 - Fix bugs and missing imports     
388  
389
390 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
391 - new method record.get_field for sface
392
393 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
394 - new option -c to sfa-nuke-plc.py
395 - CreateSliver fixed for admin-only slice tags
396
397 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
398 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
399 - Fixed holes in certificate verification logic.
400 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
401 - Added 'boot_state' as an attribute of the node element in SFA rspec.
402 - Non authority certificates are marked as CA:FALSE.
403
404 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
405 - fix typo in sfa-1.0-31 tag.
406 - added CreateGid() Registry interface method.
407
408 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
409 - fix typo in sfa-1.0-30 tag
410
411 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
412 - Declare namespace and schema location in the credential.
413 - Fix bug that prevetend connections from timing out.
414 - Fix slice delegation.
415 - Add statistics to slicemaanger listresources/createsliver rspec.
416 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
417   of days a user can extend their slice expiration.
418 - CA certs are only issued to objects of type authority
419    
420 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
421 - tag 1.0-28 was broken due to typo in the changelog
422 - new class sfa/util/httpsProtocol.py that supports timeouts
423
424 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
425 - Resolved issue that caused sfa hold onto idle db connections.
426 - Fix bug that caused the registry to use the wrong type of credential.
427 - Support authority+sm type.
428 - Fix rspec merging bugs.
429 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
430 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
431  planetlab hosted initscripts using the <planetlab:initscript> tag  
432 - Can now handle extraneous whitespace in the rspec without failing.   
433  
434 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
435 - ProtoGENI v2 RSpec updates.
436 - Convert expiration timestamps with timezone info in credentials to utc.
437 - Fixed redundant logging issue. 
438 - Improved SliceManager and SFI client logging.
439 - Support aggregates that don't support the optional 'call_id' argument. 
440 - Only call get_trusted_certs() at aggreage interfaces that support the call.
441 - CreateSliver() now handles MyPLC slice attributes/tags.
442 - Cache now supports persistence.
443 - Hide whitelisted nodes.
444
445 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
446 - fixed issues with sup authority signing
447 - fixed bugs in remove_slivers and SliverStatus
448
449 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
450 - fix typo that prevented aggregates from operating properly
451
452 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
453 - load trusted certs into ssl context prior to handshake
454 - client's logfile lives in ~/.sfi/sfi.log
455
456 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
457 - includes a change on passphrases that was intended in 1.0-22
458
459 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
460 - Added support for ProtoGENI RSpec v2
461  
462 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
463 - stable sfascan
464 - fix in initscript, *ENABLED tags in config now taken into account
465
466 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
467 - some commits had not been pushed in tag 19
468
469 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
470 - GetVersion should now report full URLs with path
471 - scansfa has nicer output and new syntax (entry URLs as args and not options)
472 - dos2unix'ed flash policy pill
473
474 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
475 - fix packaging again for f8
476
477 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
478 - fix packaging (apparently broken in 1.0-16)
479 - first working version of sfascan
480 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
481 - deprecated the sfa_geni_aggregate config category
482
483 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
484 - Fix build problem
485 - First version of SFA scanner
486
487 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
488 - Add support for Flash clients using flashpolicy
489 - Fix problems with tag handling in RSpec
490
491 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
492 - Modifications to the Eucalyptus Aggregate Manager
493 - Fixes for VINI RSpec
494 - Fix tag handling for PL RSpec
495 - Fix XML Schema ordering for <urn> element
496
497 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
498 - just set x509 version to 2
499
500 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
501 - added urn to the node area in rspecs
502 - conversion to urn now exports fqdn
503 - sfa-import-plc.py now creates a unique registry record for each SFA interface
504
505 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
506 - undo broken attempt for python-2.7
507
508 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
509 - SMs avoid duplicates for when call graph has dags;
510 - just based on network's name, when a duplicate occurs, one is just dropped
511 - does not try to merge/aggregate 2 networks
512 - also reviewed logging with the hope to fix the sfa startup msg:
513 - TypeError: not all arguments converted during string formatting
514
515 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
516 - verify credentials against xsd schema
517 - Fix SM to SM communication
518 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
519 - new setting session_key_path
520
521 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
522 - fix registry credential regeneration and handle expiration
523 - support for setting slice tags (min_role=user)
524 - client can display its own version: sfi.py version --local
525 - GetVersion to provide urn in addition to hrn
526 - more code uses plxrn vs previous helper functions
527 - import replaces '+' in email addresses with '_'
528
529 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
530 - fix GetVersion code_tag and add code_url
531
532 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
533 - extend GetVersion towards minimum federation introspection, and expose local tag
534
535 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
536 - fixed some legacy issues (list vs List)
537 - deprecated sfa.util.namespace for xrn and plxrn
538 - unit tests ship as the sfa-tests rpm
539
540 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
541 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
542 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
543 - hrn-urn translations tweaked
544 - fixed 'service sfa status'
545 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
546 - started to repair sfadump - although not usable yet
547 - trust objects now have dump_string method that dump() actually prints
548 - unit tests under review
549 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
550 - binaries now support -v or -vv to increase loglevel
551 - trashed obsolete sfa.util.client
552
553 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
554 - various bugfixes and cleanup, improved/harmonized logging
555
556 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
557 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
558   to avoid returning a PLCAPI exception that might confuse users.
559 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
560 - fix build errors.  
561
562 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
563 - (Architecture) Credential format changed to match ProtoGENI xml format
564 - (Architecture) All interfaces export a new set of methods that are compatible
565    with the ProtoGeni Aggregate spec. These new methods are considered a 
566    replacement  for the pervious methods exported by the interfaces. All 
567    previous methods are still exported and work as normal, but they are 
568    considered deprecated and will not be supported in future releases.  
569 - (Architecture) SFI has been updated to use the new interface methods.
570 - (Architecture) Changed keyconvet implementation from c to python.
571 - (Architecture) Slice Manager now attempts looks for a delegated credential
572   provided by the client before using its own server credential.
573 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
574   This cache now exists only in memory and is cleared when service is restarted
575   or cache lifetime is exceeded.  
576 - (Performance) SliceManager sends request to Aggregates in parallel instead 
577   of sequentially.
578 - (Bug fix) SFA tickets now support the new rspec format.
579 - (Bug fix) SFI only uses cahced credential if they aren't expired.
580 - (Bug fix) Cerdential delegation modified to work with new credential format.
581 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
582   Aggregate instead of relaying through the Slice Manager.
583 - (Enhancement) Simplified caching. Accociated a global cache instance with
584   the api handler on every new server request, making it easier to access the 
585   cache and use in more general ways.     
586
587 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
588 - SfaServer now uses a pool of threads to handle requests concurrently
589 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
590 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
591 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
592 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
593 - Component manager does not install gid files if slice already has them  
594 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
595 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
596 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
597      
598 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
599 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
600 - - sfa-config-tty now has the same features like plc-config-tty
601 - - Contains code to support both urn and hrn
602 - - Cleaned up request_hash related stuff
603 - - SM, AM and Registry code is organized under respective managers
604 - - Site and Slice synchronization across federated aggregates
605 - - Script to generate sfa_component_config
606
607 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
608 - sfa-config-tty now has the same features like plc-config-tty
609 - Contains code to support both urn and hrn
610 - Cleaned up request_hash related stuff
611 - SM, AM and Registry code is organized under respective managers
612 - Slice synchronization across federated aggregates
613 - some bugs are fixed
614
615 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
616 - checkpoint with fewer mentions of geni
617
618 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
619 - checkpointing
620 - this is believed to pass the tests; among other things:
621 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
622
623 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
624 - This tag includes:
625 - - Sfatables
626 - - Preliminary version of hash based authentication
627 - - Initial code for Component Manager
628 - - Authority structure is moved to /var/lib/sfa/
629 - - some bug-fixes
630
631 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
632 - Create_slice and get_resources methods are connected to sfatables.
633 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
634
635 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
636 - Bug fix on update and remove_peer_object methods
637 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
638
639 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
640 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
641
642 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
643 - compatibility with RefreshPeer
644 - incremental mechanism for importing PLC records into SFA tables
645 - unified single database (still inside the underlying PLC db postgresql server)
646 - includes/improves call traceability and logging features
647 - several bug fixes
648
649 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
650 - added libxslt-python dependency
651
652 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
653 - unified single SFA database in the PLC-DB
654 - upcalls from  PLCAPI to SFA methods
655 - SFA call traceability and logging features
656 - many bug fixes
657 - includes first/rough version of sfatables for policy implementation
658
659 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
660 - snapshot after the GEC5 demo
661 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
662
663 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
664 - snapshot july 15 - has gone through superficial manual testing
665 - hopefully a good basis for gec5 demo
666 - multi-dir sfi client tested as well
667
668 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
669 - rename geniwrapper.spec into sfa.spec
670
671 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
672 - clean up in xmlrpc/soap, --protocol option to chose between both
673 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
674 - hopefully more helpful context in case of crashes when importing
675 - bugfixes for using only /etc/sfa for site-dep files
676 - bugfixes in wsdl generation
677
678 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
679 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
680 - config variables in sfa_config now start with SFA_ and not GENI_
681 - config.py can be loaded even with no config present
682
683 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
684 - first step for cleanup and reorganization
685 - mass-renaming from geni to sfa (some are still needed)
686 - sfa/trust implements the security architecture
687
688 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
689 - snapshot for reproducible builds
690
691 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
692 - snapshot for the convenience of alpha users
693
694 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
695 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
696
697 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
698 - ongoing work - snapshot for 4.3-rc9
699
700 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
701 - various fixes
702
703 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
704 - bugfixes - still a work in progress
705
706 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
707 - initial package
708
709
710 %define module_current_branch 0.2